Sunday, 2019-06-02

Mister_Magisterspiiroin: also mcetool --set-ps-on-demand=enabled doesn't have that parameter05:42
Mister_Magisteri don't know if that https://github.com/mer-hybris/droid-config-sony-nile/commit/c1d0896e2cbcd69a1bc0194a4010e3b41791b1a3 took effect cause it's still reacting everywhere05:52
Mister_Magistermal: if you could confirm or something05:52
vknechtMister_Magister, --set-ps-on-demand=<enabled|disabled> is there, since 3.0.3.907:56
vknechtneeds mce & mce-tools >= 1.100 I think07:58
spiiroinMister_Magister: if you have the log somewhere accessible, I will take a peek08:49
spiiroinMister_Magister: also that droid config patch = just makes the default to be the same as if "mcetool --set-ps-on-demand=enabled" -> if mce is old enough not to support the mcetool option, having such settings file does not do anything either08:53
*** OhYash1 is now known as ohyash09:13
T4<jamesisaweeb> vknecht: so i gave that fix a go, and it worked pretty09:29
T4<jamesisaweeb> [Edit] vknecht: so i gave that fix a go, and it worked pretty well09:29
T4<jamesisaweeb> mal: could you reupload the paste here: http://www.merproject.org/logs/%23sailfishos-porters/%23sailfishos-porters.2017-10-23.log.html#t2017-10-23T21:40:53 the link is broken :(09:33
vknecht@jamesisaweeb: good news :-)09:49
T4<jamesisaweeb> it's just the ui isn't working quite yet 🤔09:49
vknechtif droid-hal-init is ok now, time to try "EGL_PLATFORM=hwcomposer test_hwcomposer" (see faq too)09:51
T4<jamesisaweeb> I've tried that and it just freezes09:52
vknechtsince there was progress, show fresh logs (dmesg, journalctl, logcat)09:53
T4<jamesisaweeb> will do09:54
T4<jamesisaweeb> journalctl: https://pastebin.com/XUWrnYSg09:56
T4<jamesisaweeb> dmesg: https://pastebin.com/Fgh8Vwhy09:56
vknecht@jamesisaweeb: the dmesg from your host machine is not really useful, need run the command on the phone ;-) (not too late after a reboot)10:37
T4<jamesisaweeb> ahhhh10:38
T4<jamesisaweeb> that makes more sense10:38
T4<jamesisaweeb> https://pastebin.com/3nZeXgF5 here's the one on the phone10:41
vknechta link to your droid-config git repo would help, so we can see what you have done10:42
T4<jamesisaweeb> https://github.com/benclarkk/droid-config-scale10:43
vknechtespecially wrt. the symlinks to firmware directories, etc.10:43
T4<elros34> droid-hal-init: property_set *  failed all over the place doesn't look good10:44
vknechtsee faq line 607, don't see those symlinks in your sparse10:44
T4<jamesisaweeb> they're there, i just haven't pushed them yet10:46
T4<jamesisaweeb> i've done that now10:49
vknecht@jamesisaweeb: based on 2017-10-24 log, it seems you'd need a sparse/etc/firmware/ symlink to /system/etc/firmware11:01
vknechtthe tmp/ and installroot/ you have in sparse are unintended, right ?11:01
T4<jamesisaweeb> yes?11:02
T4<jamesisaweeb> i think so11:02
mal@jamesisaweeb is this the droid-hal spec you use https://github.com/benclarkk/droid-hal-scale/blob/master/droid-hal-scale.spec11:33
malhave you added all changes to that11:33
T4<jamesisaweeb> Yeah that's the one13:05
T4<jamesisaweeb> And no not quite yet13:05
mal@jamesisaweeb just odd that the channel log you linked talked about straggler files but you said you didn't need those in droid-hal spec13:09
mal@jamesisaweeb did you try the ugly fix for droid-hal-init13:16
T4<jamesisaweeb> yea13:57
T4<jamesisaweeb> it worked13:57
T4<elros34> not really, it fails at property_set13:59
T4<jamesisaweeb> well, at least it fixed the droid-hal-init problem14:00
vknecht about OBS/osc comparison... would have been to easy if that had worked directly :-/  https://pastebin.com/4ynkN5cT14:33
vknecht*too easy14:33
vknechtpackage revisions are not quite useful...14:34
vknechtonly able to get version if rpm package is directly in package dir, like droid-hal-$DEVICE14:36
vknechtfrom what I read, if there was a _history file or if version was written in package meta that may work, but Mer OBS doesn't have this14:36
vknecht*SailfishOS OBS ;-)14:37
Mister_Magistervknecht: so i need to update to 3.0.3.9 got it15:47
malMister_Magister: or build your own mce like I did for fp2 in 3.0.215:50
Mister_Magistermal: updating sdk it should be like that? https://paste.opensuse.org/view//652044616:35
malprobably16:37
malthe downgraded packages are not always downgraded, just the build number is smaller in the new target16:38
Mister_Magistermal: i'm going to do some busy porting in following days/months as i have  2 devices on hybris16 to port16:47
Mister_Magisteryay i'm overworking myself again16:47
malMister_Magister: I need to setup my new hard disks before I can do any neew porting, my build machine is out of space16:55
Mister_Magistermal: lol same i sent all hadks to my cloud in order to make some space16:55
Mister_Magisteri have to buy HDDs and setup my array but nomoney™16:55
Mister_MagisterTheKit: ported patches so we r fine16:56
malMister_Magister: I just got 2 x 10 TB disks for that, won't be running out of space any time soon16:57
Mister_Magisterlool nice16:57
malthose will be setup as raid116:57
Mister_Magisteri have raid controller in my router and backplane from supermicro server already but waiting for HDDs16:58
Mister_Magisteri'm gonna setup them in ZRAID616:58
* Mister_Magister overdoing everything16:58
Mister_Magisteronly 20TB with 12x2TB16:58
Mister_Magisterwhich i can upgrade to 100TB lel but don't need this much16:59
Mister_Magisterthis or that much can't remember16:59
T4<meierrom> mal: Nas and gigabit?17:16
mal@meierrom I have NAS but it's also out of space17:17
maland broken at the moment17:17
Mister_Magisterlol17:18
Mister_Magistermal's adventures with running out of sapce17:19
Mister_Magisterspace*17:19
Mister_Magistermal: what repos from sfos are needed in order to build sfos?17:44
malMister_Magister: what do you mean? git repos or package repos?17:46
Mister_Magistergit repos17:46
malMister_Magister: if you mean for a port then check build_packages.sh17:47
Mister_Magisteri mean in order to build hybris kernel and stuff17:48
Mister_Magisterto make hybris-hal17:48
malI don't understand17:48
Mister_Magisterwhat repos do i need in order to build hybris bootimage17:50
malandroid repos, I'm confused17:50
Mister_Magisterhm but i can't build sailfishos ramdisk with only android repos17:52
malwhat is the error17:53
maldo you have habuild_sdk installed?17:53
Mister_Magistererm17:53
malof course you can build it also without that like I sometimes do17:53
Mister_Magisterbut how?17:54
malyou just need to check android build instructions for the packages you need to install to for example ubuntu so you can build android17:54
Mister_Magistermal: wait wait lemme try to explain. I have android repo (not from hybris-15 manifest, clear android repo) and want to build sailfish on that but i need some sailfish/hybris repos right?17:55
maloh, you meant which android repos need patches?17:55
malthe hybris manifests will tell that, check what repos come from mer-hybris17:56
Mister_Magisteryeah17:57
Mister_Magistermal: so add repos from hybris-15 manifest?17:57
malbetter cherry-pick the patches to your base17:58
malwhich base are you using?17:58
Mister_Magisterandroid9 if that's what you mean17:59
Mister_Magisteraosp17:59
Mister_Magisterstock rom in addition17:59
malok18:01
malI really should push the hybris-16.0 repos but I need to test those first and for that I need to have more disk space18:02
Mister_Magister;-;18:03
Mister_Magisterwait18:03
Mister_Magistercherry pick patches? that's already done18:03
Mister_Magisterso you mean that will build hybris alredy18:03
malmight build18:04
Mister_Magisterk18:04
Mister_Magistermal: i got ninja: error: 'out/target/product/t5/utilities/busybox', needed by 'out/target/product/t5/obj/ROOT/hybris-recovery_intermediates/recovery-initramfs.gz', missing and no known rule to make it. any idea what am i missing?19:50
TheKitMister_Magister, external/busybox probably19:54
Mister_Magisterdank19:54
TheKithttps://github.com/mer-hybris/android_external_busybox_prebuilt19:56

Generated by irclog2html.py 2.17.1 by Marius Gedminas - find it at https://mg.pov.lt/irclog2html/!