#mer-meeting: Mer release management/planning 10/1/2012
Meeting started by Stskeeps at 12:02:42 UTC
(full logs).
Meeting summary
- 
  - kickstarter templates for vendors to derive
    from (task) (Stskeeps,
    12:05:18)
 
  - http://meego.gitorious.org/meego-developer-tools/kickstarter/blobs/master/configurations.yaml
    (Stskeeps,
    12:06:24)
 
  - Mer IMG setup (task) (Stskeeps,
    12:06:39)
 
  - Use
    https://bugs.merproject.org/show_bug.cgi?id=88 for IMG setup
    (lbt,
    12:07:43)
 
  - tar.gz releases of core per release
    (Stskeeps,
    12:13:34)
 
  - rootfs builds in integration testing/gerrit
    changes (Stskeeps,
    12:14:28)
 
  - build logs in release (already a bug for
    this) (Stskeeps,
    12:15:58)
 
  - SB2-OBS integration - within two weeks, we'll
    likely be switching to be using SB2-OBS for cross compilation
    (Stskeeps,
    12:18:51)
 
  - requires OBS package builds working,
    ScriptRipper has done git trees for mer OBS integration as
    wel (Stskeeps,
    12:19:16)
 
  - we need Mer package signing (lbt,
    12:19:26)
 
  - requires community OBS to support this as
    well (Stskeeps,
    12:19:27)
 
  - http://wiki.merproject.org/wiki/SB2
    (Stskeeps,
    12:20:34)
 
  - Mer Handbook: Make your own Mer image with
    'mic' (Stskeeps,
    12:23:28)
 
  - http://pastie.org/3159898
    ? (Sage,
    12:23:49)
 
  - get rid of dependancy on meego.com repositories
    for bootstrapping/tools (Stskeeps,
    12:24:12)
 
  - MINT is (now) Mer Intergration Tools
    (lbt,
    12:24:15)
 
  - Establish plan for Mer:Tools (seperate from
    Core) (Stskeeps,
    12:28:37)
 
  - Mer a host target - mer tools on mer, or do we
    build for debian/opensuse too? (Stskeeps,
    12:28:54)
 
  - Perhaps osc etc in "platform SDK"? (Stskeeps,
    12:31:47)
 
  - Note BR for Tools is not enough to warrant
    inclusion in Core (lbt,
    12:33:00)
 
  - need a Mer build/versioning policy/guide
    (lbt,
    12:34:08)
 
  - (migrate Packaging/Guidelines to mer
    wiki?) (Stskeeps,
    12:34:23)
 
  - https://bugs.merproject.org/show_bug.cgi?id=91
    (lbt,
    12:35:03)
 
  - 'make' approach for entire Mer core
    (Stskeeps,
    12:53:55)
 
  - "osc mv" (Stskeeps,
    12:54:56)
 
  - osc mv to support preservation of CI and
    B (lbt,
    12:55:19)
 
  - osc remote link to support preservation of CI
    and B (lbt,
    12:55:36)
 
  - simplify development process by allowing
    sortable vcs revision based version ( like sha1sum for git cf.
    https://bugs.merproject.org/show_bug.cgi?id=91) (phaeron,
    13:00:04)
 
 
- Versioning discussion (Stskeeps, 13:18:21)
  - Requirement: we want to relate a built RPM
    package to a certain change (commit) in Mer (Stskeeps,
    13:18:33)
 
  - Requirement: we want to make it possible for a
    vendor to maintain branched change in Mer and still relate back to a
    certain change in Mer, and in vendor system (Stskeeps,
    13:18:43)
 
  - Requirement: no 2 changelog entries have the
    same version identifier (lbt,
    13:32:52)
 
  - http://www.mail-archive.com/meego-packaging@meego.com/msg00415.html
    (lbt,
    13:52:15)
 
  - http://pkgs.fedoraproject.org/gitweb/?p=polkit.git;a=tree
    (Sage,
    14:05:55)
 
  - Mer will move to using Release: values which
    come from .changes file (lbt,
    14:45:22)
 
  - AGREED: merX.nemoY
    and grabbing it automatically from .changes with RPM scripts,
    eventually dist.sh in rpm configs %{dist} (Stskeeps,
    14:45:52)
 
 
Meeting ended at 14:46:51 UTC
(full logs).
Action items
  - (none)
 
People present (lines said)
  - lbt (283)
 
  - Stskeeps (225)
 
  - Sage (90)
 
  - phaeron (64)
 
  - MerBot (2)
 
  - jukkaeklund (1)
 
  - X-Fade (1)
 
Generated by MeetBot 0.1.4.