11:00:56 <Stskeeps> #startmeeting Nemo steering group meeting 14/2/2012
11:00:57 <MerBot> Meeting started Tue Feb 14 11:00:56 2012 UTC.  The chair is Stskeeps. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
11:00:57 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
11:01:41 <Stskeeps> i think we have two items today, deciding if jukkaeklund should be representative of nemo project within the Mer advisory board, and what to do with steering group/governance
11:01:48 <Stskeeps> any objections to that agenda?
11:02:09 <Sage_> sounds good
11:02:10 <Stskeeps> and status, of course
11:02:35 <veskuh> Maybe short report from FOSDEM for those who were not present?
11:02:55 <vgrade> too much beer :)
11:02:58 <Stskeeps> i think we can cover that under status as that's status for the project in general
11:03:02 <Sage_> vgrade: ;)
11:03:37 <Stskeeps> #topic jukkaeklund as representative of nemo project within the Mer advisory board
11:03:43 <jukkaeklund> hi
11:04:13 <Stskeeps> we have a advisory board meeting in Mer on friday and i have nominated Jukka to be our representative -- any objections to this?
11:04:52 <Sage_> I second that nomination.
11:04:56 <veskuh> +1
11:05:17 <Stskeeps> and jukka agrees too? ;)
11:05:25 <jukkaeklund> well, yes
11:05:29 <Stskeeps> alright then
11:05:38 <iekku> +1
11:05:44 <Stskeeps> #agreed jukkaeklund is our representative towards Mer project in the advisory board
11:06:00 <jukkaeklund> thanks for the trust, I hope I'm worth it
11:06:11 <Stskeeps> please approach him if there's any issues you want to raise on behalf of nemo project, i guess :)
11:06:30 <Stskeeps> #topic Governance
11:07:16 <Stskeeps> we haven't gotten terribly many nominations for steering group and i'd like to suggest that instead we run contributor meetings every 7/14 days for sync and when those have grown big enough, to select a steering group?
11:07:34 <jukkaeklund> sounds sensible
11:07:36 <Stskeeps> as there's not terribly a lot of governing that can't be done with a proper discussion
11:07:42 <xruxa> +1
11:08:11 <w00t> sounds sane
11:08:14 <Sage_> :nod:
11:09:06 <veskuh> +1
11:09:28 <Stskeeps> so, sync meeting every week at this time to hear what has happened since last and plan?
11:09:41 <Stskeeps> then we have bug triages and sync meetings
11:10:25 <Sage_> sounds good to me
11:10:41 <jukkaeklund> yep
11:10:42 <lbt> I'd like to re-raise the "Nemo as vendor" role too
11:11:23 <lbt> most of Nemo's efforts are about making a great device platform (which is cool)
11:11:25 <Stskeeps> lbt: elaborate? (i wasn't in last meeting)
11:12:04 <lbt> I just want us to check if "being a reference vendor" is still part of our goals
11:12:46 <Sage_> lbt: IMO it should be still one of our goals as well.
11:12:48 <Stskeeps> i think in every way we still are
11:12:56 <lbt> and what deliverables we have that demonstrate or support that role
11:13:08 <lbt> other than "watch what we do" :)
11:13:10 <Stskeeps> nemo helps validate mer a lot
11:13:23 <lbt> I totally agree
11:13:30 <Stskeeps> as well as contributing effort, etc
11:13:42 <lbt> I'm just asking if it should be more explicit in what Nemo delivers
11:14:12 <Stskeeps> lbt: well, a good place to start is defining what a vendor is optimally doing
11:14:15 <Stskeeps> #agreed Sync meetings every week at 11:00 tuesdays
11:14:20 <Stskeeps> #agreed (UTC)
11:14:37 <lbt> Stskeeps: yes - is that a Nemo deliverable?
11:14:40 <veskuh> Stskeeps: I propose that you keep chairing these
11:14:46 <Stskeeps> veskuh: yes, that's my idea
11:15:04 <veskuh> great.
11:15:13 <Stskeeps> we could probably replace me with a handy written python script ;)
11:15:27 <Stskeeps> lbt: well, we show best practices
11:15:35 <lbt> do we?
11:15:36 <Stskeeps> lbt: do you mind if we take this discussion after status?
11:15:40 <lbt> sure
11:15:43 <Stskeeps> alright
11:15:53 <Stskeeps> #topic Status since last
11:16:48 <Stskeeps> #info my effort into Mer: SB2-OBS now running in Mer production, patches sent upstream, qtwebkit 2.2.1, soon to come to a OBS near Nemo
11:17:42 <Stskeeps> #info Great reception of open mobile linux devroom in FOSDEM, very well attended, we need a bigger devroom next year
11:18:53 <Stskeeps> #info did talk on Beyond Traditional Mobile Linux, http://fosdem.org/2012/schedule/event/mobile_beyond , slides available on page, video to come
11:19:03 <Stskeeps> (that's it from me, i think)
11:19:10 <jukkaeklund> apps client is there and working, which is great
11:19:49 <veskuh> #info we changed from upstream Helium to own fork HeliumReborn, since upstream does not seem to be moving anymore.
11:20:43 <Sage_> #info Nemo Mobile FOSDEM presentation slides available at http://sage.kapsi.fi/Nemo/fosdem2012-nemo-presentation.pdf
11:20:46 <Sage_> #info New weekly release 0.20120120.1.NEMO.2012-02-09.1 is out http://www.mail-archive.com/mer-general@lists.merproject.org/msg00237.html
11:23:20 <xruxa> Since we have silence, lemme ask. Can we (at some point) open the can of worms of packaging, rpm vs deb? Since Tizen went Debian (?)
11:23:39 <lbt> xruxa: nah, they didn't :)
11:23:45 <Stskeeps> xruxa: even tizen is a confusing mess
11:23:47 <lbt> they're still fighting apparently
11:23:53 <Stskeeps> xruxa: intel says it's rpm, samsung says it's deb
11:24:06 <lbt> meanwhile we deliver...
11:24:19 <Stskeeps> xruxa: i'd like to sync on packaging with the qtonpi project ideally, at least
11:24:37 <xruxa> sounds like answer to me :)
11:24:44 * Sage_ doesn't want to talk about rpm vs deb anymore.
11:24:48 <Stskeeps> i wouldn't mind supporting '.wgt'
11:24:55 <Stskeeps> ie, the html5 wac stuff
11:24:59 <Stskeeps> but that's another story :)
11:25:20 <Sage_> the selection is done could we just live with it? :)
11:25:31 <lbt> yes <---- debian guy
11:26:06 <lbt> so... shall I pipe up on vendor thing?
11:26:13 <lbt> or are we too tired :)
11:26:14 <Stskeeps> any other status first?
11:26:32 <veskuh> I heard that new pics app is making good progress
11:26:39 <veskuh> also calendar apparently
11:26:44 <Stskeeps> on a sidenote, anyone interested in trying to package phonegap-qt4 in nemo?
11:26:51 <Stskeeps> it should be a slam dunk qmake project
11:27:21 <veskuh> I'm curious also to hear how that works
11:28:02 <lbt> also ... what's happening on roadmap for MTF and Qt5 and things. Is there a page?
11:28:13 <Stskeeps> qt5 requires mer support
11:28:24 <lbt> sure
11:28:32 <lbt> but planning and thinking
11:28:36 <Stskeeps> and we are slowly working on rewrites but our hands are few
11:28:53 <Sage_> does phonegap contain demo application to test all features?
11:28:57 <Stskeeps> Sage_: it does
11:29:06 <lbt> I would like to see a page saying where we are on some of these big frameworks and where we are going (and why)
11:29:09 <Sage_> hmmp..
11:29:11 <veskuh> lbt: actually having that kind of high-level roadmap on wiki would be a good idea.
11:29:21 <lbt> veskuh: yes
11:29:23 <veskuh> I think so far its been on our heads but not in paper
11:29:40 <Stskeeps> veskuh: we can start with our glorious nemo plan, that pretty much lists it
11:29:48 <Stskeeps> on things that happened and what didn't
11:30:03 <veskuh> Yes, I think I can write up something about that.
11:30:06 <Stskeeps> :nod:
11:30:38 <Stskeeps> regarding qt5 they're finally in feature freeze so maybe it will be possible to have package that works on the next morning's snapshot
11:32:20 <lbt> bye bye
11:32:34 <Stskeeps> ah, netsplit
11:32:39 <Stskeeps> let's give them a second to come back
11:32:49 <lbt> w
11:32:49 <lbt> b
11:33:13 <Stskeeps> think we lost jukka in the turn
11:33:22 <faenil> yep he said he had to go
11:33:26 <Stskeeps> ah
11:33:46 <Stskeeps> okay, anything else before we discuss the vendor relationship?
11:34:00 <faenil> what was the last message you guys read?
11:34:28 <lbt> Stskeeps's qt5 feature freeze
11:35:10 <faenil> :O I didn't read that....did you read jukka's message about app's client?
11:35:28 <Stskeeps> [12:19] <jukkaeklund> apps client is there and working, which is great
11:35:38 <Stskeeps> we can see it in meeting log afterwards
11:35:40 * Stskeeps points to merbot
11:36:12 <faenil> ok good, then I said I'll push qmlgallery v0.0.0.1 before the evening comes, so that you can give some feedback and drive the development
11:36:16 <Stskeeps> cool
11:36:18 <Stskeeps> okay, i guess we can switch to reference vendor relations
11:36:25 <Stskeeps> #topic reference vendor definition
11:36:40 <faenil> and jukka said
11:36:41 <faenil> <jukkaeklund> overall I think Nemo is looking very good now and many issues have bugs already waiting to be taken
11:36:55 <Stskeeps> as a start, we can't really commit to anything, except in how we generally work as a project
11:36:58 <lbt> hehe ... so this was just meant to be a gentle reminder about that role
11:37:03 <lbt> so when I said "do we" ... I was meaning "do we *show* best practice?" or do we just follow it?  Where are our day-to-day tasks? The wiki page saying how do we react to a Mer release? Is the best way to learn Nemo is to hang out in irc, read backlogs or mailing list archives...?  So I'm *asking* if others want to help deliver these things. I clearly think we should and I'm going to be working on it but I'd rather it was a Nemo goal/
11:37:05 <lbt> deliverable :)
11:37:18 <Stskeeps> :nod:
11:37:34 <Sage_> lbt: cut after goal/
11:37:40 <lbt> so basically a plea to write more stuff down
11:37:41 <Stskeeps> i think it indirectly is, we help with driving documentation as well, interaction problems/etc
11:37:44 <Stskeeps> :nod:
11:38:09 <lbt> Sage_: just " ...goal/deliverable :) "
11:38:29 <Stskeeps> i guess part of the difficulty is that new mer releases get handed to us on cobs ;)
11:38:35 <Stskeeps> so it's transparent to us
11:38:42 <lbt> Sage_: in particular I want to do a "day/week/cycle in the life of a vendor"
11:38:46 <lbt> Stskeeps: yes indeed
11:39:37 <Sage_> lbt: so in the end you are after more documentation between the interaction of Nemo and Mer?
11:39:37 <veskuh> I think Sage's release routine for taking mer release and making nemo release would be worth documenting
11:39:42 <Stskeeps> :nod:
11:39:49 <lbt> Sage_: yes
11:40:05 <lbt> so ... one solution I use is to try to follow my own instructions when i do stuff - also see if others can do it for me
11:40:09 <Sage_> veskuh: true
11:40:42 <Sage_> veskuh: I can do that.
11:40:52 * Sage_ writes note about that
11:41:03 <lbt> so ... what I wanted was a "yes this is still in scope" and "yes we'll try and be more explicit about having deliverables for it"
11:41:16 <lbt> maybe even bugs for missing docs/processes
11:41:24 <Stskeeps> :nod:
11:41:34 <veskuh> yes, I'm all for task bugs.
11:41:44 <lbt> thanks ... and sorry for being boring :)
11:42:09 * Sage_ thinks lbt just inspired him to do some documentation
11:42:11 <Stskeeps> i think it's a responsibility of every vendor to provide a better experience for themselves
11:43:02 * lbt offers to buy sage a cider at the next FOSDEM :D
11:43:44 * Sage_ smiles
11:44:35 <lbt> cool, well, I have SDK and OBS stuff to do....
11:44:44 <Stskeeps> alright, thank you all for coming
11:45:03 <veskuh> thanks. It's been good to see a lot of activity in IRC today :)
11:46:10 <Stskeeps> think most people are either on or over their fosdem flu :P
11:46:11 <Stskeeps> #endmeeting