12:00:54 <Stskeeps> #startmeeting Mer release management meeting
12:00:54 <MerBot> Meeting started Tue Feb 28 12:00:54 2012 UTC.  The chair is Stskeeps. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
12:00:54 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:02:05 <Stskeeps> we have a release out!
12:02:10 <lbt> \o/
12:02:43 <Stskeeps> and of course we botched a couple of things along the way :) it turned out that MDS did not send updates about prjconf / meta changes
12:02:44 * lbt wonders what an audio pickup near Stskeeps would have heard as he walked lbt through the process...
12:02:57 <Stskeeps> #link http://www.mail-archive.com/mer-general@lists.merproject.org/msg00304.html
12:04:32 <Stskeeps> what other experiences did we have?
12:04:33 <lbt> I'll be documenting that sometime soon
12:04:36 <Stskeeps> MDS needs to be more intelligent
12:05:11 <lbt> One issue was hacking on the live box is more problematic when >1 person is administering
12:05:27 <lbt> "no, that hack is OK, I meant to revert the other one" :D
12:05:45 <lbt> (just as a lesson learned)
12:05:47 <Stskeeps> yes, someone managed to wipe out the MDS mappings.xml for community obs, as well
12:05:53 <lbt> moi?
12:05:56 <Stskeeps> hence the MDS needs to be more intelligent, as we're too stupid
12:06:24 <lbt> This fits into the MDS rewrite/upgrade anyway
12:06:28 <Stskeeps> :nod:
12:06:43 <Stskeeps> i was planning to work on MDS more but this will come soon
12:06:48 <lbt> anyhow - teaching and therefore mission acomplished ...
12:06:58 <Stskeeps> the upstreaming of SB2-OBS is taking a different patch direction due to two-three concurrent cross proposals
12:07:09 <Stskeeps> so there might be follow up patches to it
12:07:25 <lbt> I saw the sysroot thing but didn't follow through
12:07:45 <Stskeeps> this will also be needed for the toolchain-core split
12:07:55 <lbt> yeah - that was my next question
12:07:55 <Stskeeps> as seen in the B2G devices, there is some merit to this kind of stuff
12:08:09 <lbt> does it affect that design we worked up ?
12:08:12 <lbt> or is it aligned?
12:08:38 <Stskeeps> we might be able to do a saner design, without aggregates
12:08:46 <Stskeeps> it remains to be seen
12:08:49 <lbt> OK
12:09:15 <lbt> It doesn't feel like it will affect the SB2 SDK work
12:09:19 <lbt> mm
12:09:19 <Sage_> sry I'm late
12:09:34 <Sage_> +1 \o/ for the release
12:09:59 <lbt> I should say, I did a fair bit of rework on the SDK script - not a lot to show but I think it's a saner approach
12:10:24 <lbt> I have had very little feedback which is dissapointing
12:10:32 <Stskeeps> just means people are happy ;)
12:10:33 <lbt> or maybe it works
12:10:55 <Sage_> so they are happy? :)
12:10:57 <Stskeeps> will you do a release matching the new release?
12:11:00 <lbt> so I'll do a new SDK image
12:11:06 <lbt> now we have a new release :)
12:11:18 <Stskeeps> :nod:
12:11:24 <lbt> Then we need an i486 version of cross tools
12:11:26 <lbt> that's a biggy
12:11:28 <Stskeeps> right
12:11:36 <lbt> how intrusive is that?
12:11:37 <Stskeeps> that comes after the next build
12:11:39 <timoph> lbt: ping me when it's ready. I'll try it after I get home (in an hour or so)
12:11:42 <Stskeeps> not very intrusive
12:11:45 <lbt> timoph: OK
12:11:53 <Stskeeps> just not a thing i wanted to do at end of release cylcle
12:11:59 <lbt> of course
12:12:20 <lbt> I'd really like to get the SB2 into the SDK and try to find ways to make it more holistic
12:12:33 <Stskeeps> :nod:
12:12:39 <Stskeeps> that's one of the aims for this week wasn't it
12:12:43 <lbt> yes
12:12:45 <timoph> yes
12:13:08 <lbt> also, I know it's caused some disquiet - but I think lxc may be a better solution than chroot for us
12:13:40 <lbt> it's actually just a spiritual successor to how chroot is used for isolation
12:13:49 <Stskeeps> not totally against, but we have to weigh ease of installation vs idiot-proofing
12:13:51 <lbt> so let me work on it and see how it goes
12:13:58 <Stskeeps> i don't want to end up with sb1 again
12:14:08 <phaeron> back from dr. appointment
12:14:31 <lbt> yep - I am 99% sure it will have a simple dependency against the lxc binary - almost identical to using qemu
12:15:19 <lbt> and in the script I expect to s/chroot <args>/lxc <args>/
12:15:20 <phaeron> jumping in, so my reservation against lxc after trying it a lot before , is that it is missing some separation / virtualization
12:15:32 <Stskeeps> what happens if you run 'halt' in lxc?
12:15:39 <lbt> yeah, it's a replacement for chroot
12:15:43 <lbt> not VM
12:15:51 <lbt> Stskeeps: what happens if you run it in a chroot?
12:16:04 <Stskeeps> well, monster.tspre.org goes down
12:16:06 <Stskeeps> :P
12:16:13 <Stskeeps> true story
12:16:13 <lbt> don't do that then :)
12:16:20 <lbt> haha
12:16:35 <Stskeeps> so, assuming we have a next release in a week, what's realistic goals?
12:16:44 <Stskeeps> i'd like to get llvmpipe in, at least and mesa 8.0
12:17:05 <lbt> not Qt5
12:17:17 <Stskeeps> as well as merging gdb, zip
12:17:21 <lbt> that may go alpha in a week+1 though
12:17:24 <Stskeeps> :nod:
12:17:36 <Stskeeps> python2.7 -- too risky?
12:17:41 * lbt wonders if we should aim low
12:17:45 <Stskeeps> ok
12:17:49 <Stskeeps> so a bog standard release
12:17:57 <lbt> and introduce some new processes
12:18:01 <lbt> or refine existing
12:18:06 <phaeron> lbt: systemd inside lxc can break the host sometimes btw
12:18:07 <Stskeeps> :nod:
12:18:07 <lbt> eg release blocking bugs
12:18:12 <Sage_> Stskeeps: I would hold python 2.7 back one release at least
12:18:20 <Stskeeps> ok
12:18:31 <Sage_> Stskeeps: the pcre is already there so we might have enough problems with that one :)
12:18:32 <phaeron> anyway for another discussion
12:18:40 <lbt> phaeron: as it would inside chroot - but lets take this to #mer post meeting?
12:18:41 <Stskeeps> please review D Wadsworth's patches, they pass DBC/SBC, but i wouldn't mind a deep package review
12:18:56 <lbt> Stskeeps: are they python?
12:19:02 <Sage_> Stskeeps: also I would like to see udev and systemd updates in next release
12:19:08 <Stskeeps> that should be possible
12:19:21 <lbt> so maybe an "upstream sync" release?
12:19:30 <Stskeeps> i think that's enough content, with MDS aligned as well
12:20:07 <lbt> so... thoughts on making some decisions (goals) and making release-blocker bugs?
12:20:24 <lbt> as a way to track progress towards a release
12:20:48 <Sage_> also we should really do zypper update in some of the upcoming releases as well.
12:20:52 <Stskeeps> yes
12:21:07 <Stskeeps> lbt: should be integrated with our BOSS/CI process
12:21:31 <Sage_> question: when the next release is due? This friday?
12:21:33 <lbt> agreed - but it should also be worked through manually before we automate it
12:21:43 <Stskeeps> Sage_: i think from today + week
12:21:58 <Stskeeps> the schedule for releases is foobar at the moment
12:22:20 <Sage_> :nod: also I think release every week is a bit too tight schedule.
12:22:29 <Stskeeps> 14 day schedule maybe?
12:22:35 <Stskeeps> considering we always ship 'stable'
12:22:44 <Sage_> that sounds better IMO
12:22:45 <lbt> seems better to me
12:22:47 <Stskeeps> ok
12:22:51 <Stskeeps> well, less headache for me then
12:22:55 <Stskeeps> #info 14 day release schedule
12:23:06 <lbt> so +1w and +3w ?
12:23:07 <Sage_> so far we have had too much rush with the releases
12:23:19 <Stskeeps> lbt: think so
12:23:25 <Sage_> lbt: ?
12:23:32 <Stskeeps> err..
12:23:44 <Stskeeps> +2w and +4w you mean?
12:23:54 <lbt> Sage_: just checking if this 14 day overrides release in +1w as we just said
12:24:17 <Sage_> +2w, +4w I would say
12:24:33 <Stskeeps> with some prereleases inbetween
12:24:42 <Sage_> :nod:
12:24:48 <lbt> just noting we made all the decisions based on the next release assuming +1w
12:25:15 <lbt> so ... does more go in or do we just have more breathing space?
12:25:26 <lbt> since I said Qt5 alpha goes in in 2w
12:25:39 <Stskeeps> yes, that'd be in next-next
12:25:49 <lbt> in 4w ?
12:25:52 <Sage_> qt5 in +4w
12:26:12 <Stskeeps> yeah, merged into the release that opens in 2w
12:26:17 <Stskeeps> so we can do prereleases, etc
12:26:21 <Sage_> as the packaging isn't ready yet and not submitted even review
12:26:27 <lbt> #info qt5 in +4w release
12:26:45 <lbt> setting a goal == release blocker :)
12:26:50 <Stskeeps> :nod:
12:27:01 <lbt> python2.7 in 4w?
12:27:09 <Stskeeps> make sense
12:27:11 <Sage_> :nod:
12:27:21 <lbt> #info python2.7 in +4w release
12:27:34 * Sage_ is guessing that python 2.7 will cause some work for vendors
12:27:46 * lbt looks at sdk too
12:28:06 <lbt> and mcrypto package name
12:28:08 <lbt> grrr
12:28:10 <Stskeeps> will a sb2 'sdk' in +2w make sense?
12:28:23 <lbt> I would like that
12:28:25 <Stskeeps> if you get prereleases early of _i486 switchover
12:28:26 <lbt> if not sooner
12:28:55 <lbt> yes
12:29:46 <lbt> So phaeron has done some work on IMG and mic
12:30:01 <phaeron> *blush*
12:30:04 <phaeron> :D
12:30:05 <lbt> and we can start to use that once we have this new deployment done
12:30:16 <lbt> which will really help on the BOSS/CI
12:30:20 <Stskeeps> :nod:
12:30:32 <lbt> I'd like to make adding rootfs builds the first delta
12:30:40 <Stskeeps> i'd like to not be too involved in CI implementation, except for stating requirements from architect pov
12:30:43 <Stskeeps> if possible
12:30:54 <Stskeeps> phaeron: can you take action to upload project-copy patches?
12:30:54 <lbt> yes - that's the idea, we de-hack it
12:30:58 * lbt ducks and runs
12:31:22 <phaeron> Stskeeps: yes will do that , wil create a bug to track it
12:31:31 * Sage_ likes the humoristic touch in the conversation ;)
12:31:32 <lbt> (oh, then the MIPS builds once we've gotten some feel for it)
12:31:49 <lbt> Sage_: good, you're still evil.
12:32:07 * lbt has an aspiration to have a review accepted 1st time!
12:32:10 <Stskeeps> instead of having a monolithic Core:i586 / armv7l tree, i'd like to move the idea of copying a previous release and making a new one by copy
12:32:23 <Stskeeps> this will take more space on CI, but make more sense from BOSS/CI proces
12:32:41 <Stskeeps> s
12:32:47 <lbt> I'd like to clean up what we have before moving on to things like that
12:32:51 <phaeron> Stskeeps: /me still doesn't get
12:32:59 <lbt> there's a lot of partially production-ready ideas
12:33:00 <phaeron> but I am sure the patches will help
12:33:05 <Stskeeps> okay
12:33:06 <Stskeeps> well
12:33:17 <Sage_> lbt: hehe :)
12:33:34 <lbt> toolchain split is still ongoing
12:33:49 <lbt> so maybe queue the copyrelease behind that
12:34:26 <lbt> Stskeeps: if you want stuff to do .... removing tspre from all our docs/scripts would also be good
12:34:43 <lbt> (it can get confusing to vendors I think)
12:35:02 <lbt> and I'm not sure exactly what's going on with all the names :)
12:35:26 <lbt> reminder http://airy:5001 is the internal wiki for infra
12:35:38 <Stskeeps> agreed
12:35:47 <Stskeeps> the idea is to not use tspre.org and eventually wiping monster
12:35:53 <lbt> *nod*
12:36:20 <Stskeeps> copyrelease has to be done before toolchain split, we can't ensure a sane CI process at the moment without
12:36:31 <Stskeeps> for various reasons
12:36:34 <lbt> ah - didn't know that dependency
12:36:52 <Stskeeps> i have to do too much manual work atm
12:37:04 <Stskeeps> and we need to be able to do full-repo snapshots with CI, for IMG tests
12:37:05 <Stskeeps> http://wiki.merproject.org/wiki/Process#New_process_2
12:37:11 <lbt> yep
12:37:17 <Stskeeps> dep checks are localdep atm
12:38:04 <lbt> OK - so does i486 cross come first?
12:38:11 <Stskeeps> yes]
12:38:20 <lbt> and you asked about making i586 a target
12:38:22 <lbt> I think yes
12:38:40 <Stskeeps> huh/
12:38:42 <Stskeeps> ?
12:39:05 <lbt> ages ago you asked if i586 should be a cross-target I think
12:39:09 <Stskeeps> ah yes
12:39:20 <Stskeeps> tha's toolchain-core split stuff
12:39:29 <lbt> I don't know - I would like to build Atom code on my AMD desktop
12:39:46 <lbt> OK - I mention it just in case it was cross related
12:41:00 <Stskeeps> (pizza came in the door, oment..)
12:41:26 <lbt> priorites: i486 cross for SB2 for SDK; copy-release for OBS; toolchain split    ??
12:41:52 <Stskeeps> toolchain split needs the sb2 rebase stuff first
12:41:58 <Stskeeps> so design phases first
12:42:17 <lbt> priorites: i486 cross for SB2 for SDK; copy-release for OBS; sb2 rebase; toolchain split    ??
12:42:38 <Stskeeps> copy-release -and- automated BOSS/CI tests/img
12:42:54 <lbt> I have them in a different dependency list :)
12:42:56 <lbt> does the sb2 rebase impact the SDK SB2 work ?
12:43:00 <Stskeeps> no
12:43:02 <lbt> IMG working for rootfs (nested stuff); BOSS CI process
12:43:03 <phaeron> *head spin*
12:43:15 <lbt> Stskeeps: good
12:43:21 <Stskeeps> phaeron: mm?
12:43:39 <phaeron> too many acronyms on one line
12:43:45 <phaeron> never mind me
12:44:43 <phaeron> lbt: one last warning, not fud, I did get a physical host hard freeze with nested kvm on my laptop. did you try it at on some machine on your side ?
12:45:00 <lbt> phaeron: we will
12:45:12 <phaeron> ok
12:46:05 <lbt> OK .. so here are 4 threads of work
12:46:14 <lbt> i486 cross for SB2 for SDK; copy-release for OBS; sb2 rebase; toolchain split
12:46:15 <lbt> IMG working for rootfs (nested stuff); BOSS CI process (rootfs build and MIPS)
12:46:17 <lbt> MDS rewrite and release processes
12:46:18 <lbt> Infra: tspre name, LDAP on IMG, C.OBS https mess
12:47:11 * lbt checks backlog for missing bits
12:47:35 <lbt> SDK SB2
12:48:34 <lbt> anything missed?
12:48:56 <Stskeeps> makes sense for RM work
12:49:07 <Stskeeps> toolchain split is 'design phase and experimentation'
12:49:39 <Stskeeps> sb2 rebase and MDS rewrite (at least basics) is on me
12:49:41 <lbt> any other OBS ?
12:49:58 <Stskeeps> we need guides on how to deploy merproject OBS and tools
12:50:12 <Stskeeps> slaine would be good as he's setting up one now
12:50:14 <lbt> I should work that through with slaine today
12:50:17 <Stskeeps> yes
12:50:18 <lbt> hehe
12:50:25 <lbt> I'll info them for now then
12:50:33 <lbt> #info threads of work
12:50:34 <lbt> #info i486 cross for SB2 for SDK; copy-release for OBS; sb2 rebase; toolchain split design phase and experimentation
12:50:36 <lbt> #info SDK on new release and SB2 integration
12:50:37 <lbt> #info IMG working for rootfs (nested stuff); BOSS CI process (rootfs build and MIPS)
12:50:39 <lbt> #info MDS rewrite and release processes
12:50:40 <lbt> #info Infra: tspre name, LDAP on IMG, C.OBS https mess
12:50:49 <Sage_> o_0
12:50:54 <Stskeeps> mm?
12:50:56 * Sage_ has same feeling phaeron had :)
12:51:02 <Stskeeps> yeah..
12:51:06 <Stskeeps> we need wiki/Dictionary
12:51:08 <lbt> I know...
12:51:22 <Sage_> We do need dictionary to wiki..
12:51:46 <lbt> #info TLA dictionary: http://wiki.merproject.org/wiki/Category:About
12:52:15 <lbt> Sage_ and Stskeeps thanks for volunteering to add some terms in there
12:52:29 <lbt> #action Sage_ and Stskeeps thanks for volunteering to add some terms in there :D
12:52:36 <phaeron> do you have a page on how to add terms to the categories page ?
12:52:38 <phaeron> :D
12:52:43 <Sage_> :P
12:52:44 <Stskeeps> he who invents the TLA writes the page
12:52:46 <lbt> http://wiki.merproject.org/wiki/About_category_guidelines
12:52:53 <phaeron> damn
12:52:53 <lbt> :P :P :P
12:53:19 * lbt enjoyed that so much ... you can ask again
12:53:56 <Stskeeps> lbt: you'll action on documentation for the hordes of people needing new 'osc' and 'build' for ARM SB2 builds?
12:54:03 <Stskeeps> as part of sdk/tools
12:54:07 <lbt> yeah
12:54:09 <Stskeeps> k
12:54:21 <lbt> partly why I'm in  a rush on SB2
12:54:29 <lbt> I don't want to document it twice
12:54:37 <Stskeeps> mmm
12:54:49 <Stskeeps> osc and build are using sb2 transparently, but ok
12:54:49 <lbt> I don't know how things might change
12:54:57 <lbt> osc build is, yes
12:55:01 <Stskeeps> we need to make sure Mer:Tools:Testing has merproject osc and build
12:55:11 <lbt> *nod*
12:55:22 <phaeron> upgrade OBS ?
12:55:28 <phaeron> is that RE or infra ?
12:55:38 <Stskeeps> both, i guess
12:55:50 <lbt> partly BAU
12:55:58 <lbt> I do wonder if we need an infra meeting
12:55:59 <phaeron> I already pushed updated rpms
12:56:06 <lbt> it sometimes feels OT in here
12:56:16 <Sage_> BAU?
12:56:22 <lbt> business as usual
12:56:39 <lbt> maybe we should make infra phase 2 of RE? they are tightly related
12:56:57 * lbt looks at "Sage_ the worker killer"
12:57:36 <lbt> maybe do that next week ?
12:57:44 <Stskeeps> before next week
12:57:48 <Stskeeps> we really need search button to work
12:57:48 * Sage_ ponders where is lbt's next review ;)
12:57:56 <Sage_> Stskeeps: +1
12:58:13 <lbt> oh, that's ASAP
12:58:40 <lbt> I meant shall we have an infra section at the end of next weeks RE meeeting or as a followon
12:58:48 <Stskeeps> ah
12:58:59 <Stskeeps> i think it's just part of RM
12:59:04 <Stskeeps> for now
12:59:13 <lbt> OK - fine by me - I won't be shy about it then
12:59:13 <Stskeeps> it all serves to make a  good release, so
12:59:25 <Stskeeps> though i think we should wrap up now
12:59:35 <Sage_> no need to separate things as long as thing go nicely forward.
12:59:40 <lbt> *nod*
12:59:46 <lbt> I've not done anything about getting a new machine from vgrade
12:59:53 <Sage_> if we things start to mix up then we can think about doing different topics
12:59:57 <lbt> slightly nervous about scaling up the infra
13:00:08 <lbt> we'll need to make some decisions soon
13:00:09 <Stskeeps> any reasons for this?
13:00:18 <Stskeeps> let's take those in #mer ?
13:00:24 <lbt> OK
13:00:28 <Stskeeps> thank you all for coming
13:00:33 <Sage_> cya
13:00:37 <Stskeeps> #endmeeting