12:00:34 <Stskeeps> #startmeeting Release management sync 13/3/2012
12:00:34 <MerBot> Meeting started Tue Mar 13 12:00:34 2012 UTC.  The chair is Stskeeps. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
12:00:34 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:01:11 <lbt> afternoon all
12:01:26 <Stskeeps> afternoon
12:02:07 <Stskeeps> so we have a prerelease out, http://www.mail-archive.com/mer-general@lists.merproject.org/msg00365.html
12:02:38 <Stskeeps> release of this will be thursday
12:04:59 <Stskeeps> so, content for the next release discussion?
12:05:21 <lbt> you mean in +2w ?
12:05:43 <Stskeeps> yeah, 0.20120329.1
12:05:50 <lbt> http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-02-28-12.00.html  said Qt5 and python2.7
12:05:54 <Stskeeps> :nod:
12:06:04 <Stskeeps> and eglibc 2.15 i'd like to add on top
12:06:16 <Stskeeps> as well as a focus on testability
12:06:28 <Stskeeps> ie, decide where we put mer core tests, test tools, etc
12:06:43 <lbt> OK - but not included in the release?
12:07:12 <lbt> we have some outstanding threads of work
12:07:16 <lbt> sb2 rebase
12:07:19 <Stskeeps> :nod:
12:07:27 <lbt> which needs another OBS release/deploy iirc
12:07:38 <Stskeeps> i think we need to provide proof of concept testing at least
12:08:01 <Stskeeps> maybe not part of release, but at least showing end-to-end testing of a release possible
12:08:18 <Stskeeps> makes for a good argument for utilizing mer, see our passed test cases
12:08:25 <lbt> we said in Mer:Tools too I think
12:08:52 <Stskeeps> :nod:
12:09:06 <lbt> just thinking of proj organisation
12:09:32 <Stskeeps> in +2 i'd like to be able to add mer tools to a device and install test cases, and run testrunner from sdk
12:09:57 <Stskeeps> makes sense?
12:10:09 <lbt> yes, just thinking what's involved
12:10:10 <Stskeeps> and then in +4 we can integrate with BOSS process
12:10:22 <lbt> test cases mainly
12:11:13 <Stskeeps> :nod:
12:11:56 <Stskeeps> for +2w i'd also like to make a push for removing meego mentions from mer core
12:12:01 <Stskeeps> think meego-rpm-config, %vendor mer, etc
12:12:09 <lbt> We should seriously think about taking a "new things" pause after that. I want to see how many of these things work out from the vendor side
12:12:13 <Stskeeps> :nod:
12:12:30 <lbt> Nemo is too complex and too important to hack on
12:12:47 <lbt> we need a minimal setup of some sort
12:12:53 <lbt> vendor template
12:13:26 <lbt> Maybe the RasPi or VM
12:13:55 <lbt> eg test cases need to blend core and vendor test cases
12:14:09 <Stskeeps> in most cases, you can do well enough with core + hw adaptation
12:14:13 <lbt> IMG needs to use core kickstarter and add vendor bits
12:14:25 <lbt> that doesn't work well for sdk
12:15:02 <Stskeeps> :nod:
12:15:04 <lbt> so I'd like to discover those areas where it works for Mer but is harder than we thought to overlay on it
12:15:43 <Stskeeps> core content wise i think we're quite close to what i'd like to see for a '1.0'
12:15:49 <Stskeeps> tools wise.. we need a little more
12:15:54 <lbt> yep
12:16:07 <lbt> any problem areas in core?
12:16:14 <lbt> I'm thinking pulseaudio
12:17:00 <lbt> #action identify packages in Mer with high patch weight
12:17:09 <Stskeeps> urgh
12:17:13 <Stskeeps> yeah, PA we need to upgrade..
12:18:19 <Stskeeps> phaeron finally has a obs testbed up
12:18:41 <lbt> yes, that's looking good
12:18:43 <Stskeeps> so we can start with proper boss setup and copy-on-release
12:19:16 <lbt> That has been on my todo list for a while
12:19:35 <lbt> MeeGo c.obs has needed attention this week (and workers are *still* dying)
12:19:39 <Stskeeps> :nod:
12:19:49 <lbt> but we have LDAP on IMG
12:19:56 <lbt> the release process is written up
12:20:06 <lbt> we have /cross sorted properly
12:20:07 <Stskeeps> so i can get run over by a bus yet?
12:20:08 <Stskeeps> :P
12:20:24 <lbt> yeah, feel free to take up rock climbing :)
12:20:39 <lbt> and the SDK has now got basic SB2 capability
12:23:38 <lbt> just thinking of priorities on the tools side
12:23:47 <lbt> SB2 in SDK seems top
12:23:53 <Stskeeps> :nod:
12:24:28 <lbt> my git packaging looks really sane to me so I'll spend time getting that ready for a review
12:25:03 <lbt> phaeron is hacking away at OBS and that's also high prio
12:25:29 <lbt> IMG is production ready and needs some medium prio (but fun to do) tweaks
12:25:38 <lbt> so they're on his list too
12:25:53 <Stskeeps> swerden's box is IMG right?
12:25:56 <lbt> yes
12:25:58 <Stskeeps> ok
12:26:03 <lbt> and mer c.obs
12:28:51 <Stskeeps> we should also plan systematic test cases for sdk and such
12:29:21 <Sage_> hi, sry I'm late
12:29:24 <lbt> agree
12:29:25 <Stskeeps> http://wiki.meego.com/Quality/QA-tools/Testplanner
12:30:10 <lbt> hmm .... use that on SDK releases
12:30:34 <Stskeeps> :nod:
12:30:43 <lbt> kinda scary
12:31:41 <Stskeeps> Sage_: any comments to the above planning?
12:33:13 <Stskeeps> lbt: test cases can be stuff like kickstarter testing, do builds of reference images, etc..
12:34:28 <lbt> yeah - I'm not sure how to do a deployment wrapper and things
12:36:18 <lbt> at the moment what I do is run through the Platform SDK documentation and try all the examples there
12:36:43 <Stskeeps> :nod:
12:37:03 <lbt> the problems arise when I have a non-standard environment - eg I share mic cache with my host - that hides the bindmount problem
12:37:33 <lbt> OTOH w/o it my ADSL takes 40m to download all the packages :)
12:37:36 <Stskeeps> sounds like a good motivation for vm tests
12:38:09 <lbt> yep - and I have a niggle that 2.6.32 != 3.2 for bind mounts
12:38:35 <lbt> but I'll take a look
12:42:26 * lbt notes the TLA dictionary action from 2 weeks ago .... Sage_ Stskeeps ?
12:42:47 <Stskeeps> postponed
12:42:53 <Stskeeps> higher priority actions to be done
12:42:53 <lbt> :)
12:42:53 <Stskeeps> :P
12:45:37 <Stskeeps> right, i have nothing else
12:45:49 <lbt> nothing else here
12:46:03 <lbt> Sage_: anything?
12:50:34 <lbt> guess not
12:51:33 <Stskeeps> thanks all for coming
12:51:36 <Stskeeps> #endmeeting