12:14:53 <lbt> #startmeeting Mer Release Planning
12:14:53 <MerBot> Meeting started Tue Apr  3 12:14:53 2012 UTC.  The chair is lbt. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
12:14:53 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:15:42 <lbt> So Stskeeps isn't able to make this meeting
12:16:10 <Sage> o/
12:16:24 <lbt> hey Sage :)
12:16:29 <lbt> anyone else around?
12:16:57 <Sage> well I have to leave soon as well
12:17:01 <lbt> So Sage, lets just do some quick updates
12:17:40 <lbt> The prerelease is out for the upcoming release
12:17:49 <lbt> The main change is eglibc
12:18:19 <lbt> We had some problems with a boundary condition in a release script which messed up the snapshots for next- on one arch last week
12:18:30 <Sage> python, qt5, nss/nspr changes postponed to next release I guess?
12:18:35 <lbt> that's fixed and the 0.1 release is out
12:19:00 <lbt> Yes. they've been pushed back
12:19:22 <lbt> Bostik has been working on the Qt5 packaging though
12:19:31 <Sage> yes, gave him a review yesterday
12:19:37 <Sage> on the first qt5base package
12:19:47 <lbt> good
12:20:38 <lbt> I'm working on the OBS packaging and then hopefully will be able to look at BOSS/IMG in the CI process
12:22:16 <lbt> we have a number of security driven package upgrades needed  too
12:22:54 <Sage> I have qtorganizer package submissions also on their way and we should push those in for next release as well
12:22:59 <Sage> MER#14
12:23:28 <lbt> OK
12:23:49 <lbt> hmm ... makes me think about our review/accept process
12:23:55 <Sage> Also I have zypper update packaged but there is some linkin problems MER#76
12:24:45 <Sage> Hopefully those can be got in to next release. I'll check also if I can work on some of those CVE updates at some point.
12:24:50 <lbt> BOSS does a build check on package A and then we may accept other packages (B,C,D) in before accepting A
12:25:10 <lbt> at that point A may fail to build... just ... hmm
12:25:50 <Sage> true
12:26:14 <lbt> I should probably note that as a bug
12:26:16 <Sage> also there isn't currently way to submit fixes to multiple packages at the same time as there are some packages that depend on each other.
12:26:29 <lbt> yeah - that's a tad irritating
12:26:44 <Sage> e.g., nss and nspr update isn't currently checked by our review process as either one of those can't build properly
12:27:10 <Sage> also zypper will probably have similar problem
12:27:17 <Sage> when it is time for push those updates
12:27:32 <lbt> #action lbt to setup a CI process review meeting
12:27:38 <lbt> :)
12:27:48 <lbt> then we can focus on it
12:28:53 <lbt> Any other items?
12:29:55 <Sage> I don't have more.
12:30:31 <lbt> OK. I'm happy to wrap up early
12:30:36 <Sage> one thing
12:30:43 <lbt> yep?
12:30:45 <Sage> should we start doing wiki pages about releases?
12:30:54 <Sage> like what is expected to go in next release and what is the status
12:31:12 <lbt> yes
12:31:26 <lbt> We had a chat about roadmaps recently
12:31:27 <Sage> and also prioritize those things
12:31:35 <lbt> so they're closely related
12:31:56 <Sage> e.g., we have been talking about python 2.7 and qt5 for some time. Would be nice if we could actually push those in next.
12:32:23 <Sage> if something comes up that should be moved to next release if it is not CVE fix or something
12:32:33 <Sage> like plan next release before the release CI starts.
12:32:53 <lbt> #action lbt to create Release Plans wiki page  (and update internal release-steps wiki page to ensure it's updated)
12:33:01 <Sage> Would also probably give more time for vendors to prepare for changes
12:33:13 <lbt> yes - I've wanted to have release-blocker bugs but this would be more visible
12:33:49 <Sage> small items can be always accepted on the side but bigger items should be listed somehow
12:34:10 <lbt> Hopefully vendors would comment at these meetings about their priorities too
12:34:55 <lbt> right now I have no idea what Vivaldi consideres to be desireable/important for upcoming Mer releases (maybe Carsten does though)
12:35:53 <Sage> have to go now. Cya.
12:36:04 <lbt> OK thanks for coming :)
12:36:15 <lbt> anything from anyone else ?
12:37:00 <lbt> #endmeeting