16:00:01 <vgrade> #startmeeting MeeGo Community OBS Replacement Meeting 10/4/2012
16:00:01 <MerBot> Meeting started Tue Apr 10 16:00:01 2012 UTC. The chair is vgrade. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
16:00:01 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:10 <Stskeeps> o/
16:00:12 <vgrade> Welcome everyone I have the Agenda at http://www.mail-archive.com/mer-general@lists.merproject.org/msg00413.html
16:00:22 <vgrade> Whos here today I see a few new faces? Could we have a quick intro if you are new to the meeting ?
16:00:24 <lbt> good afternoon
16:00:35 <X-Fade> Hi
16:01:32 <qgil> hi, Nokia is funding apps.formeego.org hosting and I'm the contact for community OBS related things - interested myself in knowing what the community plans to do with it in the future
16:01:57 <vgrade> qgil, X-Fade, welcome
16:02:23 <vgrade> OK then let start.
16:02:32 <vgrade> #topic 1. Current status of Maemo community OBS
16:02:43 <vgrade> X-Fade, could you let us know where we are, then we can pick up the discussion about the future in Item 5?
16:02:52 <X-Fade> Sure
16:03:11 <X-Fade> Let me do some history about it first:
16:03:18 <X-Fade> At the maemo.org hosting facility we have an OBS instance, which was setup about 2 years ago by lbt and me.
16:03:33 <X-Fade> We used it for some experimenting with fremantle and harmattan builds and also for some early MeeGo community building.
16:03:57 <X-Fade> It was the early MeeGo cobs.
16:04:24 <X-Fade> Currently it is only serving as a testing bed.
16:04:31 <X-Fade> There are a few spare servers waiting to be dispatched as workers.
16:04:46 <Stskeeps> sebas: http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-04-10-16.00.log.txt to catch up
16:05:07 <sebas> Stskeeps: thanks
16:05:21 <X-Fade> Not sure what to add more :)
16:05:35 <vgrade> ok thanks X-Fade
16:05:48 <Stskeeps> something about autobuilder and utilizing OBS for it instead, perhaps?
16:05:55 <Stskeeps> as that was discussed at some point
16:05:58 <lbt> what's the funding stateus of them too?
16:06:06 <X-Fade> Stskeeps: I thought that was about the future.
16:06:20 <X-Fade> But I can talk about it.
16:06:31 * dm8tbr wakes up and waves
16:06:47 <X-Fade> I have done some tests in the past with building fremantle apps on OBS..
16:07:10 <X-Fade> I got to a certain point, but then got pulled away for Harmattan/MeeGo at that time.
16:07:16 <dm8tbr> fremantle needed some hackery to work with OBS IIRC?
16:07:28 <lbt> oh yes
16:07:45 <dm8tbr> we had a fremantle test-OBS at work (Tieto)
16:07:56 <dm8tbr> I probably still have the notes
16:07:56 <X-Fade> If we can get some people interested in helping out in this project, we can migrate everything to OBS and eventually get rid of autobuilder.
16:08:22 <X-Fade> Main problem we had was that people used SB-isms in their packaging.
16:08:49 <X-Fade> We might be in a better situation nowadays with SB2 in OBS, but that needs to be studied.
16:08:51 <lbt> and pre-fremantle versions of maemo?
16:09:02 <X-Fade> Same thing.
16:09:12 <X-Fade> They don't differ that much.
16:09:23 <vgrade> What about the funding question ?
16:09:24 <Stskeeps> SB2 has pretty-good emulation of SB-isms, if needed, it's regularly tested against it
16:10:18 <X-Fade> As qgil stated on the lists, Nokia is still funding these servers/services.
16:10:38 <X-Fade> And afaik has no intention in stopping that any time soon.
16:11:02 <vgrade> qgil, anything more to add here?
16:11:17 <qgil> nope, that's the summary
16:11:21 <vgrade> cool
16:11:24 <X-Fade> We at least have funding until the end of the year. More to be discussed about that around the summer.
16:11:42 <qgil> maemo.org has always been budgeted this way
16:11:43 <Sage> o/
16:12:17 <vgrade> ok lets come back to future at 5. if noone has anymore questions about current status
16:12:43 <Stskeeps> Jaffa: http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-04-10-16.00.log.txt to catch up
16:13:05 <vgrade> #topic 2. Mer NFP Status including progress on Donation/Sponsorship Procedures
16:13:15 <vgrade> lbt, Could you give us an update?
16:13:29 <lbt> Waiting on an email from the bank. Spoke to them this morning. Taking a bit longer than I'd hoped but I don't think it's blocking us.
16:13:40 <Jaffa> Stskeeps: Already found it - thanks :)
16:14:27 <vgrade> yea, I don't see a long line of people with cheque books ready. A couple though are waiting
16:14:28 <lbt> I am also (still) talking to osuosl ... but not holding out much hope at this point
16:14:45 <lbt> vgrade: and honestly I don't want to spend any money until we know our direction
16:15:22 <lbt> I have sebas offering me money too (iirc) but I don't want to waste it
16:15:41 * sebas ?
16:15:42 <lbt> swer even :)
16:15:47 <sebas> maybe my boss :)
16:15:48 <sebas> yeah :)
16:16:17 <lbt> I do have a personal task to draft up a donation policy
16:16:42 <lbt> essentially we should only take financial aid, not servers, for security reasons
16:16:45 <vgrade> #action lbt to draft up a donation policy
16:17:03 <lbt> but I will clarify that, get it reviewed by the AB and publish it
16:17:19 <vgrade> ok thanks,
16:17:35 <vgrade> #topic 3, Legal Entity Progress
16:17:37 <Stskeeps> (for those outside Mer, NFP = not-for-profit, AB = Mer's Advisory Board)
16:17:52 <vgrade> lbt, Could you give us an update?
16:17:53 <Stskeeps> as described in http://wiki.merproject.org/wiki/Governance
16:17:57 <lbt> Not had time to progress this directly. I have asked for Mer's advisory board to confirm that this is in scope so I can be clear when talking to people about solutions.
16:18:29 <Stskeeps> http://www.mail-archive.com/mer-general@lists.merproject.org/msg00416.html
16:18:30 <lbt> I have it as a lower priority task, again, the scope of what we do may affect it
16:18:35 <Stskeeps> for the next AB meeting
16:18:36 <vgrade> yes I saw that at the AB meeting and also you posted on the ml
16:18:45 <lbt> thanks Stskeeps
16:19:44 <vgrade> any other input for this topic, sebas did you speak to KDE eV at all on this?
16:19:48 <lbt> So I think we have a good outline of what we'd like to be doing now - details to be filled in
16:21:03 <sebas> vgrade: no, but we can talk about a specific request anytime
16:21:13 <vgrade> ok thanks
16:21:16 <sebas> in general, it's possible, I've confirmed that with a few other people
16:21:52 <vgrade> #topic 4. Plasma Active Update on proposed plans for new Repos
16:22:01 <vgrade> aseigo, Could you give an update on Plasma Active OBS requirements
16:22:32 <aseigo> vgrade: sure ... (he says nursing a rather massive headache)
16:24:48 <aseigo> first, more of us are using the SDK ... bringing that to the point where it is as easy as possible to set up and get running, building PA images (or things on to pof it) is pretty important
16:25:15 <vgrade> great to hear
16:25:29 <Sage> SDK as in Mer SDK?
16:25:34 <aseigo> Sage: yes
16:26:24 <aseigo> people looking to build apps with Plasma Active are nearly universally interested when they hear that instead of having to set up a cross compile system, etc that they could instead use OBS. it's very attractive to such developers as a means to both test and deploy.
16:27:17 <aseigo> OBS already makes it pretty easy to get a package building on it; and we have the PA projects which people can use a base for their own projects as well, this is working reaonsably well
16:27:18 <notmart> yep, i think osc inside the sdkmakes things easy enough even for casual developers
16:27:37 <lbt> good to hear
16:28:10 <aseigo> making it easy and clear (documentation, e.g.) on how to build an application on OBS using libraries etc from PA will be important
16:28:57 <aseigo> eventually, i think we'd like to use OBS as a way to draw finished packages into repositories for people using PA to easily install from ...
16:29:01 <lbt> the SDK should be easy to customise using a Mer base SDK and extending it to provide PA specific things
16:29:27 <lbt> aseigo: are you familiar with apps-for-meego ?
16:29:43 <aseigo> so those are our two sets of needs / desires: making the SDK and OBS application easily accessable to 3rd party devs.
16:29:53 <aseigo> lbt: yes.. have spoken with them previously as well on the phone
16:29:56 <lbt> good
16:31:12 <qgil> aseigo: who is "them"?
16:32:36 <aseigo> qgil: Jukka e.g.
16:33:28 <vgrade> aseigo, what requirements from OBS will be required for the Make Play Live add on app?
16:33:53 <vgrade> any?
16:33:55 <aseigo> having distribution channels for apps is important, but the is preceded by having good ways of building them and feeding those channels.
16:34:31 <aseigo> vgrade: we'd like to be able to pull packages for delivery via the add ons app from the OBS ...
16:34:40 <dm8tbr> I guess a.f.o was brought up because it's fed by COBS :)
16:34:48 <aseigo> we're already federating data from multiple places, as well as hosting content. depends on the content in question.
16:35:48 <aseigo> for packaged applications, people should be able to submit their OBS project and then pending a thumbs up from us (e.g. checking it does indeed work as advertised) then we would add it to the catalog.
16:36:27 <X-Fade> Sounds like a job for BOSS to me :)
16:36:37 <aseigo> we'd like that process to be as painless as possible .. for many 3rd party developers, the best thing would be to build their package on OBS and we would pull it straight from there onto the device.
16:37:01 <aseigo> X-Fade: yes, i keep hearing about boss :) haven't had an opportunity to be educated properly on it, however.
16:38:11 <vgrade> I think there is much synergy (sorry) in this area between afm and mpl add on
16:38:31 <aseigo> from the Mer side, we just need the OBS to work as well as possible .. we'll need to provide documentation to our (shared) audience on how to use it easily, and the shorter build queue wait times are the better obviously
16:38:48 <lbt> aseigo: who's driving the SDK task and the OBS task? (we should #info that)
16:39:49 <aseigo> lbt: right now notmart has been doing most of our forays into the SDK; honestly, we've been kept busy with all the other practicalities involved in this to spend significant time on the SDK.
16:40:53 <vgrade> but we can say there is a task on Plasma Active side to customise SDK
16:41:00 <aseigo> OBS is something many of us have been working with. we don't have a specific OBS-for-add-ons-store lead at the moment, however.
16:41:07 <aseigo> vgrade: yes...
16:41:43 <vgrade> ok, time is moving on
16:41:47 <lbt> OK - well, you know where I am aseigo...
16:41:57 <vgrade> #topic 5. Harmattan/Fremantle Targets
16:42:04 <aseigo> as well as for the Add Ons app.. it can install rpm's, there's an approval process built into the system ... the last loop will be to accept submissions via the mer OBS
16:42:18 <vgrade> Ok, we've had an update on where we are with Maemo OBS so what requirements do people have for a new OBS, what resources are required, on offer, what targets are needed ?
16:42:22 <aseigo> in my bigger dreams, i imagine a button people can push right on the OBS that starts the proces for inclusion
16:42:30 <lbt> aseigo: do-able
16:42:39 <lbt> (fairly easy too)
16:42:41 * aseigo retreats back to the dark and waits for his headache to subside...
16:42:42 <X-Fade> aseigo: That is how afm does it already.
16:43:08 <aseigo> very good; i'm out of country for the rest of the week, i'll try and find some of you on irc next week when i'm back to look into this some more
16:43:10 <X-Fade> vgrade: So about the fremantle targets.
16:43:14 <lbt> From my point of view supporting Fremantle and Harmattan seems to be a reasonable thing to do for the Mer project.
16:43:25 <aseigo> (and perhaps find a way to make it scalable for the user so they don't end up with N different buttons ...)
16:43:25 <lbt> My main concern would be resource demands but I'd frankly expect that $$ contributions would easily outweigh the additional load. I don't see any real problems from the infrastructure side.
16:43:28 <X-Fade> I think it mainly depends on manpower.
16:43:51 <X-Fade> And we have some spare workers on the maemo side.
16:44:12 <X-Fade> So I am not to worried about the hardware, more about the people resource.
16:44:22 <lbt> We'd have to delegate support of the project configs to someone - and note that despite asking, no-one in #harmattan has gotten the council (who, because they exist I consider should be the ones speaking for Maemo) to agree to create an official OBS project.
16:44:51 <X-Fade> lbt: I can load a project, which people can branch and do their testing in their own home.
16:45:05 <X-Fade> And work on project configs there.
16:45:23 <lbt> I guess I'd like to see the maemo council nominate an OBS team :)
16:45:23 <X-Fade> Then the changes can be brought back to a central testing project.
16:45:25 <Stskeeps> it shouldn't be too difficult to teach someone the black arts of obs prjconfigs if there's anyone interested on maemo.org side from community
16:45:41 <X-Fade> And I had a semi working one for fremantle pr1.2 already.
16:45:55 <X-Fade> So that can serve as a base.
16:46:33 <X-Fade> But we need a few people who at least know debian packaging and have time and are interested in experimenting..
16:46:43 <lbt> yep - I mainly want someone(s) I can go to who has authority to make subprojects or grant maintenance rights to widely shared projects
16:46:44 <SD69_> lbt: pycage has offered to help with client software for fremantle target
16:47:17 <X-Fade> lbt: Sure, but I don't think that is too big of a problem.
16:47:48 <X-Fade> I'm willing to pitch in, but can't be pulling the whole effort.
16:48:15 <lbt> X-Fade: agreed - but I'm aware that Maemo has a governing body and I think they need to delegate to someone
16:48:29 <Stskeeps> maemo.org, that is
16:48:34 <lbt> I don't want to randomly hand Maemo:* to the first community bod that asks ...
16:48:43 <lbt> Stskeeps: :P ... it's been a while
16:48:57 <X-Fade> lbt: of course, but at the start that isn't even needed that much.
16:49:06 <lbt> very true
16:49:50 <X-Fade> SD69_: Could you try to see if there are people willing to help with this?
16:49:59 <SD69_> lbt: maemo council can attempt to form an OBS team
16:50:17 <X-Fade> Or ar least we should start the discussion about it.
16:50:19 <vgrade> before getting people to help , is there a real need
16:50:46 <SD69_> X-Fade: we could try...
16:50:50 <Stskeeps> i think there is, considering maemo.org community activities and needs in this area
16:51:03 <X-Fade> It makes maintaining the repos a lot easier.
16:51:13 <X-Fade> And also prevents some of the mess we have now.
16:52:12 <Stskeeps> one priority for that team though, is cross compilation enabling the targets.
16:52:25 <Stskeeps> a given community obs will be dragged down by qemu-only builds
16:52:35 <SD69_> knowing that there will be a fremantle target will help
16:52:43 <X-Fade> Stskeeps: Yes, for sure.
16:52:46 <Stskeeps> it'll be easier with the SB2 work we're doing, but it has to be made a priority
16:53:33 <lbt> agreed - maybe even a blocker to 'production' use?
16:54:13 <vgrade> ok whats the best way to get this discussed on the Maemo side?
16:54:42 <SD69_> oy vey
16:54:50 <Stskeeps> i think representatives here can take it back to their communities?
16:55:19 <vgrade> ok, qgil, SD69?
16:55:32 <Stskeeps> after all, they're (as in their communities) the ones who'll be maintaining their targets
16:55:39 <Stskeeps> like others would maintain PA, others Mer, etc
16:56:05 <vgrade> ok, AOB
16:56:10 <lbt> well
16:56:45 <lbt> Have maemo.org said they'd support/use/migrate-to/something else.... a Mer project managed community OBS ?
16:56:47 <qgil> noted, vgrade
16:56:50 <SD69_> yes
16:57:14 <lbt> OK - I wasn't specially aware - thanks :)
16:57:59 <lbt> Can I refer to some kind of council minutes? Since I'll be talking to others about how we establish the OBS service?
16:58:30 <lbt> happy to take this out of the meeting btq
16:58:32 <lbt> btw
16:58:34 <SD69_> do we have a timeline?
16:58:49 <lbt> <12 months
16:59:00 <lbt> probably ~6 months
16:59:12 <SD69_> OK
16:59:15 <Stskeeps> i presume 'target setup' is a bit of an addon and not a blocker, allowing to perhaps use maemo.org machinery for workers is another question
17:00:35 <lbt> yes, using maemo.org machines as workers for a 'mer-ish' OBS would be sane
17:01:13 <lbt> and qgil... I'd be very interested to talk to the funding people given how cheap the Mer setup is :)
17:01:41 <qgil> lbt: make a proposal
17:01:53 <lbt> OK
17:02:03 <Stskeeps> any other things for this meeting?
17:02:17 <Stskeeps> vgrade: next sync meeting in a 14 days time again?
17:02:34 <vgrade> Yes I think so, thanks for attending
17:02:35 <Jaffa> Damn. Missed last bit due to dinner. Will read scrollback
17:02:36 <qgil> fyi: if you can relate your activity to OSS experimentation around Qt, Nokia platforms or devices then we have a common denominator to discuss funding
17:02:53 <lbt> noted - ty
17:02:59 <Stskeeps> i'm fairly certain we can also accomodate qtonpi if needed, at least
17:03:04 <Stskeeps> very similar baselines
17:03:12 <lbt> for sure - I'm the OBS mentor for them :)
17:03:18 <X-Fade> That makes a lot of sense, yes.
17:03:52 <vgrade> #endmeeting