12:00:53 <iekku> #startmeeting Mer Bug Triage 23/4/2012
12:00:53 <MerBot> Meeting started Mon Apr 23 12:00:53 2012 UTC.  The chair is iekku. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
12:00:53 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:01:09 <iekku> welcome all
12:01:26 <iekku> #info We'll start with the bugs: https://bugs.merproject.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=need-triage&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=bug_id
12:01:51 <lbt> o/
12:01:57 <iekku> any volunteers for updating the bugs?
12:02:05 <lbt> o/
12:02:12 <iekku> thanks lbt :)
12:02:19 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=313 - test-definition files have meego mentioned and urls to meego.com
12:02:55 <iekku> task? normal?
12:03:12 <E-P> yes
12:03:22 <lbt> low? unless it affects functionality?
12:03:31 <lbt> do you need any infra to support qa-reports.merproject.org
12:03:34 <Stskeeps> it does when meego.com shuts down
12:03:35 <lbt> and does it depend?
12:03:42 <Stskeeps> so normal, imho
12:04:06 <E-P> lbt: we will need infra for qa-reports at somepoint
12:04:30 <lbt> does this depend on it ... it seems like?
12:04:40 <Stskeeps> or some asset site for the qa reports
12:04:43 <Stskeeps> like, html ish
12:04:47 <lbt> *nod*
12:05:13 <E-P> lbt: not really depending, it just uses the same stylesheet and we can host it separately
12:05:41 <iekku> #info task, normal
12:06:18 <iekku> next?
12:07:01 <iekku> #info affects functionality when meego.com shuts down
12:07:15 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=314 - offline results xml transformation currently not possible
12:07:26 <Stskeeps> that was fixed wasn't it?
12:07:28 <Stskeeps> with new test-definition
12:07:52 <E-P> timoph knows about that
12:08:09 <iekku> hmm
12:08:28 <E-P> ah, he made a merge request but pull it off
12:08:39 <iekku> task and low, need info?
12:08:53 <E-P> task and low
12:09:09 <iekku> #info task low
12:09:29 <iekku> #info timoph has made merge request but pull it off
12:09:49 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=317 - Desing to identify test constraints (eg which tests run in chroot at build time, on a VM or need a device)
12:10:04 <Stskeeps> can't we do this with boardname / hwid?
12:10:25 <Stskeeps> .. though it might be better to spell it out
12:10:49 <E-P> http://wiki.merproject.org/wiki/Talk:Quality/Test_processes
12:11:39 <E-P> I wouldn't put the information where to execute the test in to the xml
12:11:39 <lbt> mmm the intention is that tests are annotated with requirements
12:12:15 <lbt> so almost "Requires: real-device" or "Requires: > VM"
12:12:28 <E-P> something like that would be possible
12:12:59 <E-P> we have to discuss more about that
12:13:18 <lbt> it was a placeholder bug
12:13:22 <E-P> I don't like the idea that test defines if it can be executed on the vm or not
12:14:11 <E-P> I would say task and normal?
12:14:18 <iekku> #info placeholder to get more discussion about the topic
12:14:36 <Sage> hmmp
12:14:50 <Sage> the systemd already distinguishes the chroot env at least
12:15:11 <lbt> typically a test knows what environment it needs
12:15:24 <iekku> i would like to have this discussion to the qa-meeting?
12:15:37 <lbt> yep
12:15:40 <iekku> let's just decide the importance now
12:15:50 <lbt> rats, I have to go
12:15:56 <Stskeeps> seeya
12:16:08 <iekku> and if E-P could take a action to get this to next meeting?
12:16:13 <iekku> lbt, se you
12:16:16 <lbt> can someone set to not-taken and put the 'triaged, comment' in
12:16:22 <iekku> i can
12:16:28 <E-P> iekku: I will
12:17:41 <iekku> #action E-P to have this discussed in the next qa-meeting
12:17:48 <iekku> normal task?
12:18:17 <iekku> oh, it's already normal task :D
12:18:21 <E-P> :)
12:18:29 <iekku> #info normal-task
12:18:54 <iekku> ok, let's continue
12:19:08 <iekku> #topic Moving on to tasks: https://bugs.merproject.org/buglist.cgi?emailassigned_to1=1&query_format=advanced&bug_severity=task&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=need-triage&emailtype1=substring&order=bug_id
12:19:22 <iekku> zarro bugs found
12:19:34 <iekku> #info Task list is now: https://bugs.merproject.org/buglist.cgi?bug_severity=task&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=not-taken%40&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=priority%2Cbug_id&query_based_on=
12:19:41 <iekku> #info Not taken bugs: https://bugs.merproject.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=not-taken%40&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=priority%2Cbug_id&query_based_on=
12:20:03 <iekku> should we have review or do we skip it this time?
12:20:28 <iekku> we have got plenty of time but i know lbt would like to participate
12:20:39 <l3i> Isn't there actually an <environment> tag available in the test definition already that could also be utilized in some way?
12:20:52 * Stskeeps reviews tasks
12:20:59 <l3i> Hmm, <environments>
12:21:00 <Stskeeps> let's move 26 to low
12:21:05 <iekku> #topic review the task list and adjust according to discussion and plans: https://bugs.merproject.org/buglist.cgi?bug_severity=task&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=not-taken&emailassigned_to1=1&emailtype1=substring&query_format=advanced&query_based_on=&columnlist=bug_severity%2Cpriority%2Cshort_desc%2Ccomponent
12:21:23 <l3i> Meant to say an environments element
12:22:17 <E-P> l3i: let's discuss about that in the qa meeting or in #mer channel after this
12:22:40 <l3i> E-P: Yep.. just happened to notice your earlier discussion now
12:22:52 <iekku> #info https://bugs.merproject.org/show_bug.cgi?id=26 - Evaluate dash as /bin/sh vs /bin/bash, disk/memory footprint/boot time/impact --> low
12:23:26 <iekku> anything else to change?
12:23:41 <Stskeeps> 117 (task) can be moved to normal
12:23:46 <Stskeeps> we have better guides in platform sdk page
12:23:55 <Stskeeps> though not entirely gone, most seem to get by
12:24:31 <Stskeeps> 166 i think we can close and we're happy with OTS/testrunner/eat
12:25:03 <iekku> #info https://bugs.merproject.org/show_bug.cgi?id=117 - Update wiki with new mic installation details --> normal
12:25:29 <iekku> Stskeeps, i agree
12:26:31 <Stskeeps> 141 can be moved to normal
12:26:45 <Stskeeps> 134 to low
12:26:55 <Stskeeps> so can 142,143
12:27:08 <iekku> #info https://bugs.merproject.org/show_bug.cgi?id=166 - Investigate automated testing of images --> resolved: "we're happy with OTS/testrunner/eat"
12:27:11 <Stskeeps> 175 can be a task, "Define retention policy
12:27:29 <iekku> huh, can't follow :)
12:27:39 <Stskeeps> sorry :)
12:27:48 <iekku> too slow :(
12:28:38 <iekku> hmmm, i don't have 141 in my list
12:29:34 <iekku> #info normal: https://bugs.merproject.org/show_bug.cgi?id=141 - Updating connman package over SSH breaks connection
12:30:17 <iekku> #info low: https://bugs.merproject.org/show_bug.cgi?id=134 - rpm test cases require fakechroot
12:31:09 <iekku> #info low: https://bugs.merproject.org/show_bug.cgi?id=142 - giflib contains a timestamp
12:32:08 <iekku> #info low: https://bugs.merproject.org/show_bug.cgi?id=143 - vim contains timestamps
12:33:14 <iekku> Stskeeps, about 175 do i change the summary?
12:33:48 <Stskeeps> yes
12:34:04 <Stskeeps> should be in a manner of a task, ie , Define retention policy for releases
12:34:49 <iekku> #info task: https://bugs.merproject.org/show_bug.cgi?id=175 - Define retention policy for releases
12:35:03 <iekku> ok, next :)
12:35:44 <iekku> or is there anythign else?
12:37:01 <Stskeeps> not anything on my mind
12:38:07 <iekku> thanks for the meeting
12:38:12 <Stskeeps> thank you for hosting :)
12:38:25 <iekku> next monday we will return to 11 UTC
12:38:40 <iekku> Stskeeps, my pleasure :)
12:38:45 <iekku> #endmeeting