11:00:44 <iekku> #startmeeting Mer Bug Triage 9/7/2012
11:00:44 <MerBot> Meeting started Mon Jul  9 11:00:44 2012 UTC.  The chair is iekku. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
11:00:44 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
11:00:57 <iekku> #topic We'll start with the new bugs:
11:00:59 <iekku> #link https://bugs.merproject.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=need-triage&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=bug_id
11:01:12 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=170 contribution_in_detail: [new] git clone / push commands wrong?
11:01:34 <Stskeeps> REMEMBER: if you'd like to take a bug, please just indicate during or after the bug
11:01:40 <iekku> lbt, can you fdo the areed changes?
11:01:49 <lbt> yup
11:01:57 <iekku> agreed and do
11:01:59 <iekku> thanks
11:02:28 <lbt> nb - no-one else should edit these bugs during meeting to avoid in-flight collisions
11:02:56 <iekku> they are so annoying
11:03:38 <iekku> is this still valid?
11:03:57 <lbt> hmm, needs checking against SDK
11:04:00 <Stskeeps> lbt can probably comment
11:04:05 <lbt> it could be a git version issue
11:04:15 <lbt> II'll take it
11:04:42 <iekku> #info needs checking against SDK, lbt taking
11:04:43 <lbt> high as it's a key part of our docs/process
11:04:52 <iekku> #info high
11:05:12 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=407 [META] Very essential #topic https://bugs.merproject.org/show_bug.cgi?id=performance tools needs to be included / packaged
11:05:33 <iekku> wasn't sure how to handle metas (i think this is first) so i brought it here
11:06:06 <lbt> feels like we should have someone manage this kind of bug
11:06:14 <lbt> maybe release mgmt?
11:06:40 <lbt> Stskeeps: ?
11:06:50 <Stskeeps> mm, yeah, assign over to me
11:06:58 <Stskeeps> medium prio
11:07:35 <Stskeeps> next?
11:07:44 <iekku> #info assigned to: Stskeeps , normal
11:07:49 <lbt> hmm
11:07:59 <lbt> actually, I'll take it as SDK maintainer
11:08:13 <iekku> #info lbt taking as SDK maintainer
11:08:18 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=409 uxlaunch leaves X running when it can't start a session; then cycles, causing focus to swap to X from tty
11:08:40 <Stskeeps> normal, it should raelly behave better
11:08:49 <iekku> #info normal
11:08:57 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=410 Do not complain about installing tests to /opt/tests/
11:09:12 <Sage_> low
11:09:19 <Stskeeps> is it in rpmlint-MeeGo component?
11:09:21 <lbt> iekku:  I propose meta bugs are assigned to area maintainers for overseeing during triage - delegated if desired
11:09:36 <Sage_> Stskeeps: yes
11:09:39 <Stskeeps> ok
11:09:53 <iekku> lbt, agreed
11:10:07 <iekku> #info low
11:10:17 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=411 Get rid of verbose info of attached input devices
11:10:55 <Stskeeps> normal, pretty annoying
11:10:58 <Stskeeps> fills up xsession-errors
11:11:21 <iekku> #info normal, pretty annoying fills up xsession-errors
11:11:29 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=412 openssl is not installable on all architectures
11:11:49 <lbt> this is a major pain
11:11:56 <Stskeeps> high
11:11:59 <iekku> +1
11:11:59 <lbt> seems to break SDK updates too
11:12:01 <Stskeeps> and release blocker OK
11:12:06 <iekku> +1
11:12:06 <lbt> yes
11:12:16 <iekku> #info high, release blocker
11:12:34 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=413 Build loops happen
11:13:15 <Stskeeps> build loops will happen, but nss is a bad one
11:13:19 <Stskeeps> there's another bug regarding that
11:13:25 <Stskeeps> low/normal as it affects vendors and QA time
11:13:59 <iekku> normal
11:14:05 <lbt> mmm
11:14:20 <lbt> I think there are higher prio issues
11:14:25 <lbt> so I'd say low
11:14:32 <iekku> :)
11:14:34 <lbt> not many people rebuild mer core a lot
11:14:35 <iekku> #info low
11:14:50 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=415 build-compare needs to check for /usr/lib and not only /lib for nss .chk files
11:14:58 <Stskeeps> connected with 413
11:15:03 <Stskeeps> similar issue
11:15:24 <iekku> #info connected to 413, similar issue. low
11:15:40 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=416 Mer contribution should not require a OBS in order to do so
11:16:21 <lbt> back to 413
11:16:24 <Stskeeps> normal or low, we need to provide 'offline' 'build' capability
11:16:31 <lbt> 415 I mean
11:16:37 <lbt> should 413 block 415 ?
11:16:48 <iekku> lbt, i think so
11:17:25 <lbt> (inverse ... done, moving on)
11:17:52 <lbt> Stskeeps: ah
11:18:03 <lbt> I completely misunderstood
11:18:05 <iekku> maybe even normal
11:18:11 <lbt> you meant no tcp connection
11:18:14 <lbt> not no OBS
11:18:49 <lbt> "Mer contribution should not require an OBS network connection in order to build"  ??
11:18:57 <Stskeeps> 416 is about that it should be possible to do without osc
11:19:02 <Stskeeps> ie, 'build' calls
11:19:18 <iekku> should the summary be changed?
11:19:42 <lbt> sorry, not sure
11:19:51 <lbt> is this "osc should not be needed"
11:20:05 <Stskeeps> yes, ie, obs account/obs and osc should not be needed
11:20:13 <lbt> why?
11:20:16 <Stskeeps> ie, be able to build a package with use of a mer release
11:20:25 <Stskeeps> because, very simple, not everybody has an obs, or obs account
11:20:26 <lbt> I mean sure ... but looking at the load we have
11:20:55 <Stskeeps> ok, low
11:21:01 <Stskeeps> it's one thing that would be good to have, IMHO
11:21:15 <Stskeeps> and is related to good developer workflow
11:21:16 <lbt> so, acceptance criterea?
11:21:32 <Stskeeps> 'i can build a mer package against mer core without involving a OBS"
11:21:36 <Stskeeps> 'on my local machine'
11:21:39 <Stskeeps> in platform sdk
11:22:08 <lbt> MDS ?
11:22:25 <Stskeeps> MDS may or may not be involved, at least a mer release snapshot of some kind
11:22:27 <lbt> or http repos only
11:22:36 <Stskeeps> anyway, it's low, we can discuss more in bug
11:22:56 <iekku> #info low, more discussion in bug
11:23:06 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=417 Remove udev module from repos
11:23:13 <lbt> OK - but I'm doing quickbuild - hence the interest
11:23:28 <Stskeeps> udev will be removed with systemd update
11:23:29 <Stskeeps> assign to me
11:23:32 <Stskeeps> normal prio
11:23:36 <iekku> task?
11:23:50 <Stskeeps> task
11:24:13 <iekku> #info task, Stskeeps takes, will be removed with systemd update. normal
11:24:22 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=418 openssl-1.0.1b-1.1.i586 package is not installable - missing libcrypto.so.10
11:25:18 <lbt> dupe 412?
11:25:55 <iekku> mmmm
11:26:03 <Aard> yes, libcrypto missing is the (misleading) error message during install
11:26:23 <iekku> if we resolve it as duplicate, i think the comments needs to be added to 412
11:26:31 <iekku> good info
11:26:49 <lbt> ok
11:27:06 <Aard> iekku: it does not contain additional useful info
11:27:13 <iekku> Aard, ok then
11:27:30 <iekku> #info duplicate for 412
11:27:40 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=420 rpmlint says /usr/bin/python is not found when building in OBS
11:27:44 <lbt> Aard: agreed
11:27:52 <Stskeeps> low, cosmetic
11:28:00 <iekku> #info low, cosmetic
11:28:06 <iekku> #topic  Moving on to tasks: https://bugs.merproject.org/buglist.cgi?emailassigned_to1=1&query_format=advanced&bug_severity=task&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=need-triage&emailtype1=substring&order=bug_id
11:28:14 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=419 Testrunner results preview should work offline
11:28:31 <lbt> why should it look for python in /opt/testing ?
11:28:41 <Stskeeps> lbt: look at rpmlint-mini at some point
11:28:52 <Stskeeps> and you'd understand
11:29:17 <Stskeeps> it's needed for not insane cycles in base system
11:29:19 <lbt> added to comments :)
11:29:33 <iekku> normal?
11:29:55 <Stskeeps> low, it's simply that when at conferences, or meeting rooms, things don't look good
11:29:59 <Stskeeps> as it fetches resources online
11:30:06 <iekku> ok
11:30:06 <lbt> erm
11:30:09 <Stskeeps> with bad wifi
11:30:12 <lbt> 421 ?
11:30:22 <Stskeeps> 419
11:30:31 <Stskeeps> what about 421? :P
11:30:36 <lbt> I have 421 as an outstanding bug
11:30:49 <iekku> lbt, true
11:31:05 <iekku> #info low
11:31:13 <Stskeeps> let's quickly take 421
11:31:17 <iekku> #info  Task list is now: https://bugs.merproject.org/buglist.cgi?bug_severity=task&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=not-taken%40&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=priority%2Cbug_id&query_based_on=
11:31:22 <iekku> #info   Not taken bugs: https://bugs.merproject.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=not-taken%40&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=priority%2Cbug_id&query_based_on=
11:31:39 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=421 - bluetoothd complains about missing "/etc/bluetooth/input.conf"
11:32:03 <iekku> low?
11:32:06 <lbt> should this depend on some kind of HA?
11:32:12 <alterego> No
11:32:14 <Stskeeps> maybe, needs to be inspected
11:32:22 <alterego> I think it's just a generic config file.
11:32:38 <lbt> bug in packaging then ?
11:32:48 <alterego> Yeah, should probably just be empty.
11:33:03 <alterego> My input.conf in ubuntu is pretty empty.
11:33:26 <lbt> OK ...I'm looking for HA specific interfaces for packages like this
11:33:32 <lbt> (FYI)
11:34:24 <iekku> so?
11:34:34 <lbt> normal?
11:34:43 <iekku> #info normal
11:34:57 <iekku> #topic review the task list and adjust according to discussion and plans:
11:35:02 <iekku> #link https://bugs.merproject.org/buglist.cgi?bug_severity=task&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=not-taken&emailassigned_to1=1&emailtype1=substring&query_format=advanced&query_based_on=&columnlist=bug_severity%2Cpriority%2Cshort_desc%2Ccomponent
11:35:07 <lbt> 422
11:35:31 <lbt> sry ... but it just keeps going by itself :)
11:35:47 <iekku> lbt, there's also 423
11:35:51 <iekku> and 242
11:36:12 <alterego> 422 is dependency issues with ofono-tests packing
11:36:12 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=422 - ofono-test package requires python dbus bindings.
11:36:15 <lbt> OK - so somehow I guess a list got trimmed
11:36:35 <alterego> ofono-test shoudl depend on python-dbus and pygobject2
11:36:42 <iekku> lbt, they have arrived after i sent invitation
11:36:47 <lbt> ah
11:37:26 <iekku> but let's go them through
11:37:51 <lbt> normal?
11:37:56 <iekku> i think so
11:38:02 <iekku> based on alterego's comment
11:38:23 <iekku> #info normal: ofono-test shoudl depend on python-dbus and pygobject2
11:38:44 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=423 - specify uses sys.environ, not os.environ
11:39:02 <lbt> low trivial
11:39:12 <iekku> #info low trivial
11:39:32 <iekku> #topic https://bugs.merproject.org/show_bug.cgi?id=424 - ca-certificates installation problem wthile upgrading SDK
11:39:50 <lbt> release blocker for SDK I think
11:39:55 <Stskeeps> high
11:39:58 <Stskeeps> that's a really annoying one
11:40:01 <iekku> :nod:
11:40:12 <iekku> #info high, release blocker for SDK
11:40:12 <lbt> yep
11:40:38 <iekku> back to agenda
11:40:39 <iekku> #topic review the task list and adjust according to discussion and plans:
11:40:40 <iekku> #link https://bugs.merproject.org/buglist.cgi?bug_severity=task&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&email1=not-taken&emailassigned_to1=1&emailtype1=substring&query_format=advanced&query_based_on=&columnlist=bug_severity%2Cpriority%2Cshort_desc%2Ccomponent
11:41:40 <iekku> anything to change?
11:42:55 <lbt> not here
11:43:05 <Stskeeps> can we sort that by importance?
11:43:05 <iekku> ok
11:43:13 <Stskeeps> from now on
11:43:20 <iekku> sure!
11:43:49 <lbt> iekku: I put some links + scripts on the bugs wiki page ... do you know about them ?
11:44:05 <iekku> lbt, i have seen them
11:44:13 <lbt> :)
11:44:14 <iekku> not sure how to use them
11:44:25 <lbt> lets take it later
11:44:42 <lbt> prod me
11:45:07 <iekku> https://bugs.merproject.org/buglist.cgi?bug_severity=task&bug_status=NEEDINFO&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=TRIAGEDUPSTREAM&bug_status=REOPENED&columnlist=bug_severity%2Cpriority%2Cshort_desc%2Ccomponent&email1=not-taken&emailassigned_to1=1&emailtype1=substring&query_format=advanced&order=priority%2Cbug_id&query_based_on=
11:46:22 <lbt> all done on tasks?
11:46:39 <iekku> i think so
11:46:41 <iekku> #topic search for bugs that are assigned:
11:46:43 <iekku> #link  https://bugs.merproject.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&columnlist=bug_severity%2Cpriority%2Cassigned_to%2Cbug_status%2Cshort_desc%2Ccomponent%2Cchangeddate&field0-0-0=assigned_to&field0-1-0=assigned_to&query_format=advanced&type0-0-0=notequals&type0-1-0=notequals&value0-0-0=need-triage%40merproject.org&value0-1-0=not-taken%40merproject.org&order=changeddate%2Cbug_id&q
11:46:49 <iekku> and that was all
11:47:10 <iekku> if there's nothing else we can close
11:47:19 <lbt> quick bug review
11:47:46 <iekku> going to get my name off the list this week
11:47:48 <iekku> :)
11:48:12 <lbt> I'll check some of the IT ones on an upcoming 'lbt infra day'
11:48:25 <iekku> :nod:
11:49:31 <iekku> are we done with todays meeting?
11:49:38 <Stskeeps> yes think so
11:49:44 <lbt> yeah - that bug list need TLC
11:50:20 <lbt> so...
11:50:34 <lbt> should we arrange a bug squashing session?
11:50:54 <Stskeeps> perhaps a day dedicated to getting some things off the board
11:50:56 <lbt> if we allocate a half day to it and focus
11:50:58 <lbt> hehe
11:51:21 <lbt> yeah - all at the same time so it's more productive
11:51:43 <lbt> how about next wednesday?
11:51:52 <iekku> this week?
11:51:58 <Stskeeps> next wednesday.
11:51:58 <lbt> 18 July
11:52:14 <lbt> gives us some time to tell people and let them free up some time
11:52:43 <iekku> mmm
11:53:09 <iekku> let's have it in 18th then
11:53:16 <iekku> hopefully i'm available
11:54:10 <iekku> #info bug squashing 18th of july
11:54:33 <lbt> can you send out an email too
11:54:50 <iekku> sure i can
11:55:05 <iekku> need to figure out first what to tell
11:55:05 <lbt> I think the focus should be on fixing bugs, not training... thoughts?
11:55:21 <lbt> happy to have another day on handholding
11:55:23 <iekku> and how to organize it
11:55:42 <lbt> *nod*
11:55:42 <iekku> and where
11:55:43 <lbt> thanks
11:55:57 <iekku> let's continue about that on #mer
11:56:33 <iekku> #action iekku to send email info/invitation to bug squashing
11:56:45 <iekku> i think we are donw for today
11:57:11 <lbt> yup - ty
11:57:19 <iekku> thanks!
11:57:22 <iekku> #endmeeting