16:00:20 <vgrade_> #startmeeting MeeGo Community OBS Replacement Meeting 10/07/2012
16:00:20 <MerBot> Meeting started Tue Jul 10 16:00:20 2012 UTC.  The chair is vgrade_. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
16:00:20 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:35 <vgrade_> #info Welcome everyone I have the Agenda at http://www.mail-archive.com/mer-general@lists.merproject.org/msg00596.html
16:00:40 <Sage_> o/
16:00:43 <X-Fade> hi
16:00:45 <vgrade_> #info Last meeting log at http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-05-15-15.59.html
16:00:52 <vgrade_> Who's here today?
16:00:56 <Stskeeps> o/
16:01:01 <vgrade_> hi sage, X-Fade
16:01:06 <vgrade_> Stskeeps:
16:01:15 <lbt> hi
16:01:26 <vgrade_> lbt \o
16:01:34 <vgrade_> hi phaeron
16:02:03 <vgrade_> OK then let start.
16:02:10 <vgrade_> #topic 1. Mer NFP Status including progress on Donation/Sponsorship Procedures
16:02:10 <phaeron> hmm
16:02:14 <phaeron> jit ?
16:02:19 <vgrade_> #info https://wiki.merproject.org/wiki/Donation_Policy
16:02:45 <lbt> yes
16:02:47 <Stskeeps> yep, approved, and http://www.merproject.org/donations.html
16:02:59 <vgrade_> good news
16:03:10 <lbt> and I've had this validated by my accountant (who actually called in a specialist to discuss it)
16:03:24 <Stskeeps> i'd like to inform that during this week, there will be donation coming from Jolla (as you may have seen as Mer users) for the equivalent of 2 EX-4S'es over 6 months for the purpose of Mer community OBS
16:03:27 <vgrade_> #info http://www.merproject.org/donations.html
16:03:30 <lbt> I do have to prepare a diagram to show cash flows
16:04:07 <Stskeeps> or, rather, within the next week to be precise
16:04:28 <vgrade_> Stskeeps: great news
16:04:37 <phaeron> yeah
16:04:37 <Stskeeps> EX-4S'es being http://www.hetzner.de/en/hosting/produkte_rootserver/ex4s
16:04:43 <vgrade_> #info 'd like to inform that during this week, there will be donation coming from Jolla (as you may have seen as Mer users) for the equivalent of 2 EX-4S'es over 6 months for the purpose of Mer community OBS
16:05:20 <Stskeeps> so this should help kickstart the work
16:06:29 <vgrade_> lbt, do you have a plan for receipting these donations
16:07:11 <lbt> for companies I'll be invoicing them
16:07:24 <lbt> nothing specific for individuals
16:07:48 <vgrade_> SD69, \o
16:07:49 <lbt> in terms of accounting the transactions will be made available
16:07:57 <SD69> hello
16:08:06 <Stskeeps> SD69: http://mer.bfst.de/meetings/mer-meeting/2012/mer-meeting.2012-07-10-16.00.log.txt to catch up
16:08:07 <vgrade_> I think all should get a receipt
16:09:55 <lbt> vgrade_: how?
16:10:09 <lbt> I can offer one on demand
16:10:21 <vgrade_> ok
16:10:23 <Stskeeps> certificate for persons, invoice for company?
16:10:26 <lbt> but donations can come with no notice or information
16:10:31 <Stskeeps> community pride is important :)
16:10:36 <lbt> oh, sorry
16:10:38 <lbt> let me be clear
16:10:57 <lbt> I can offer a receipt to anyone for any transaction they make
16:11:15 <lbt> I can't guarantee to Mer that all transactions will be receipted
16:11:32 <lbt> since it's possible to push money at us essentially anonymously
16:11:53 <lbt> I've suggested in the blurb that people contact me first
16:11:57 <Stskeeps> :nod:
16:12:05 <lbt> companies have to contact me as an invoice is needed
16:12:19 <lbt> we discussed anonymity a while back at the AB and it's permitted
16:12:37 <lbt> we have no firm plans to offer "banner" info
16:12:45 <lbt> I'd like to ...
16:13:03 <lbt> then I can say "yay, thanks vgrade \o/"  a lot more
16:14:24 <vgrade_> a receipt would close the loop on the bank transfer, making sure it got to the right account
16:15:15 <vgrade_> so lbt to provide a receipt on demand
16:15:26 <lbt> agreed ... and I should put some more time into the reporting mechanisms
16:15:43 <vgrade_> #topic 2. Legal Entity Progress
16:16:33 <vgrade_> This is a low priority task to track the Legal issues related to operating a new OBS
16:16:42 <lbt> No further movement yet
16:16:47 <vgrade_> ok
16:16:57 <SD69> Will entity be a UK entity?
16:17:52 <Stskeeps> SD69, can you maybe summarize how it's going with hildon foundation as well?
16:18:25 <lbt> SD69: the current one is but I have no pre-conceived limitations for a final solution
16:18:42 <vgrade_> lbt, can you remind us of the timescale we are working on for the shutdown of MeeGo Community OBS?
16:18:56 <SD69> Hildon Foundation has been sent to the Maemo community list for review and comment
16:19:00 <lbt> drop dead is 2013
16:19:19 <lbt> and there has been no sign of anything before that yet
16:19:43 <lbt> Intel are maintaining it still, security updates, HW fixes
16:19:47 <Stskeeps> SD69: alright, got a link for mailing list archives?
16:19:58 <lbt> even moving VMs to more powerful machines
16:21:16 <SD69_> stskeeps: http://lists.maemo.org/pipermail/maemo-community/2012-July/005552.html
16:21:21 <Stskeeps> thank you
16:21:26 <Stskeeps> #link http://lists.maemo.org/pipermail/maemo-community/2012-July/005552.html
16:21:48 <vgrade_> any common things between the two entities?
16:22:04 <vgrade_> to share the work?
16:22:46 <SD69_> there is overlap in purpose between the entities
16:22:56 <Stskeeps> think it's just good to keep track of eachother for now and see where things develop
16:23:27 <SD69_> cOBS is possibility for sharing work
16:24:44 <vgrade_> I was wondering about the legal research, if that could be shared.
16:25:35 <SD69_> For Hildon Foundation, I will recommend the Debian Patent Policy
16:25:48 <vgrade_> #info Mer and Hildon Foundation to track legal entity process
16:26:22 <lbt> I expect they'll sort out legal issues before I do and I'd be happy to track+copy
16:26:34 <vgrade_> ok
16:26:52 <vgrade_> anything else on this?
16:27:06 <SD69_> I'm happy to share with Mer on, e.g., IPR issues
16:27:49 <ZogG_laptop> sorry to interupt, but except name. what can be legal issues? can someone link me to discussion of that?
16:28:04 <lbt> SD69_: maybe we should plan a scoping/issues brainstorming session
16:28:26 <Stskeeps> ZogG_laptop: long story short, you may be responsible for patent or copyright infrigement of your users
16:28:29 <lbt> ZogG_laptop: probably worth checking old logs
16:28:33 <vgrade_> ZogG_laptop: there was much discussion on this in previous meetings, sec for link
16:28:39 <Stskeeps> ZogG_laptop: and we don't want that to happen and take down Mer, for instance
16:29:10 <vgrade_> ZogG_laptop: see this thread, http://www.mail-archive.com/mer-general@lists.merproject.org/msg00413.html
16:29:16 <phaeron> dmca takedowns come thick and fast
16:29:32 <ZogG_laptop> Stskeeps, so it's more about content itslef but not the system. ok i think it's enuf info for me. answers the question. though i'll check logs. sorry again
16:29:40 <vgrade_> #info <lbt> SD69_: maybe we should plan a scoping/issues brainstorming session
16:31:37 <vgrade_> ZogG_laptop: no probs, ask away, don't say sorry
16:32:10 <SD69_> OK
16:32:18 <vgrade_> #action lbt, SD69_ to arrange a scoping/issues brainstorming session RE Mer and Hildon Foundation Legal Entitiy
16:32:38 <vgrade_> I need to move on
16:32:39 <vgrade_> #topic 3. Feedback on Maemo OBS progress, Harmatten, Freemantle targets
16:33:19 <vgrade_> I've not been following this X-Fade whats going on here?
16:33:56 <X-Fade> vgrade_: We've been working on getting fremantle apps to build on OBS. This looked rather promising.
16:34:33 <X-Fade> We then started to look at Stskeeps' new SB2 on OBS approach.
16:35:10 <vgrade_> #info http://wiki.maemo.org/Task:Maemo_OBS:Meeting_Minutes
16:35:14 <X-Fade> Due to the recent news from Nokia, the pace has slowed a bit.
16:36:15 <X-Fade> Still dedicated to get this in a workable state, but I need to do this in my spare time unfortunately.
16:36:59 <ZogG_laptop> X-Fade, are you doing it alone or have help form community
16:37:39 <ZogG_laptop> from*
16:37:45 <X-Fade> ZogG_laptop: It is a community project. Now more than ever ;)
16:39:48 <vgrade_> Thanks X-Fade
16:39:49 <X-Fade> I don't think I have more to add atm.
16:40:04 <vgrade_> #topic 4. Any new topics.
16:40:07 <lbt> X-Fade: how are you doing for resources
16:40:49 <X-Fade> lbt: What kind of resources? :)
16:40:55 <lbt> people mainly
16:41:15 <lbt> but also do you have any info about host availability?
16:41:43 <X-Fade> Had some help from some people from the community. Did some checking with javispedro.
16:41:52 <X-Fade> But haven't seen him around in a while.
16:42:04 * Sage_ has topic to talk about but waits for the previous discussion to end.
16:42:26 <vgrade_> Sage_: nod
16:42:27 <lbt> just wondering if you were in a "call for help" mode or "getting on with it"
16:42:43 <ZogG_laptop> X-Fade, do you have any topic on TMO or on maillist? i don't have too much time now, but i might have from next week. and i might try to help in what i can.
16:43:12 <X-Fade> lbt: It would benefit from a revival. But this one of these, way to many things todo.
16:43:16 <vgrade_> ZogG_laptop: http://wiki.maemo.org/Task:Maemo_OBS:Meeting_Minutes
16:43:28 <lbt> X-Fade: OK
16:43:35 <ZogG_laptop> http://talk.maemo.org/showthread.php?t=85061 - that thread maybe relative to get help from community? i saw some people asking how they can help
16:43:59 <lbt> there's a big learning curve to be productive too
16:44:08 <vgrade_> Sage_:
16:44:09 <lbt> anyhow...  done ... thanks X-Fade
16:44:21 <Sage_> I was contacted by people from Communications Engineering department of Tampere University of Technology, and they asked me to present their idea for the meeting.
16:44:32 <Sage_> The idea is about creating a research project about "distributed hybrid cloud style OBS" and with that provide relatively large amount of build nodes for community OBS usage. Research topics for example security and performance.
16:44:42 <Sage_> This is an initial query that needs improving, but at first they would like to know if the community would be interested of this if they can get such a research project started? They have the resources, networking skills and academic insterest on this, but they are missing the actual use case for the project.
16:45:26 <phaeron> wasn't there a study to implement this mentioned on obs mailing list ?
16:45:27 <lbt> I'm very interested in the security aspect
16:46:15 <Stskeeps> Sage_: personally i feel that fits right in with mer mission as well, as well as exciting possibilities
16:46:16 <Sage_> From the community point of view also the free resources aspect is nice.
16:46:18 <lbt> our main constraint to accepting cpu/build resource and to using generic cloud is security oriented - so if they're looking for solutions,,,, yes, we have use cases
16:46:32 <Stskeeps> we can even help them do random mer qa builds for tests ;)
16:46:50 <Sage_> Stskeeps: actually that would be even better use case.
16:47:04 <phaeron> http://dspace.cc.tut.fi/dpub/bitstream/handle/123456789/20758/seppanen.pdf?sequence=3 <--- also tampere university
16:47:34 <Sage_> phaeron: it is the same department where this query came from :)
16:47:36 <Stskeeps> #link http://dspace.cc.tut.fi/dpub/bitstream/handle/123456789/20758/seppanen.pdf?sequence=3
16:48:05 <dm8tbr> Sage_: sounds like what I was involved in at some point earlier. TTY wanted to do something there but things didn't pan out at that time.
16:48:11 <Stskeeps> i'd like to propose that we welcome this move and welcome them to join the community, participate as part of it and we can help them with interesting new challenges :)
16:48:11 <phaeron> http://opensuse.14.n6.nabble.com/Elastic-Build-Service-provisioning-workers-flexibly-to-Amazon-EC2-td3397200.html
16:48:19 <Sage_> dm8tbr: yes
16:48:48 <phaeron> so they have previous know how , I guess
16:49:02 <dm8tbr> phaeron: heh, I supervised that thesis on the Tieto side
16:49:14 <Stskeeps> they can even independently take mer and use it as a reference set for builds
16:49:18 <Stskeeps> due to our characteristics
16:49:20 <phaeron> it's a small planet .. :)
16:49:54 <Stskeeps> Sage_: i can at least volunteer to pitch in an hour once in a while to help them get started
16:50:19 <lbt> Sage_: me too
16:50:36 <Sage_> ok, so there is definite interest
16:50:51 <vgrade_> Stskeeps, lbt : thanks
16:51:05 <lbt> I'd add a note of caution on using resources as per reasoning from donation policy
16:51:05 <phaeron> me too :)
16:51:36 <Stskeeps> lbt: yeah, but for example for community OBS, demands may be lower
16:51:49 <Stskeeps> and even research into how to make it safe is interesting
16:51:54 <Sage_> also for doing QA stuff lower as well?
16:52:01 <vgrade_> Sage_: can you take an action to contact them and let them know of the discussions here?
16:52:06 <Sage_> e.g. making images and running tests in distributed network?
16:52:14 <lbt> yep, just a note of caution, not an objection :)
16:52:18 <Stskeeps> Sage_: yes, that's also an interesting direction
16:52:36 <Sage_> because QA is something we haven' actually prepared any resources yet
16:52:43 <lbt> I can think of lots of things to do with more HW!
16:52:45 <Stskeeps> there's plenty of interesting research topics in OS development still
16:53:04 <Stskeeps> Mer started out in research, too :)
16:53:08 <Sage_> vgrade_: sure, I'll keep in touch with them and tell that there is interest around the area.
16:53:40 <vgrade_> #action Sage_ contact Communications Engineering department of Tampere University of Technology re OBS research project
16:53:41 <lbt> did you see the solution to the gcc compiler self-modifying/hiding code security problem
16:54:01 <vgrade_> #topic AOB
16:54:10 <vgrade_> #info Stefan Werden from open-slx has asked "Is there is something we may help additionaly (no donation) please come back."
16:54:16 <vgrade_> #info Please reply to mer-general with anything you think open-slx could help with.
16:55:58 <lbt> hnm
16:56:07 <lbt> they do OBS support+deployment
16:56:25 <lbt> wondering if they can do regression testing on Mer vesion of the OBS
16:58:05 <vgrade_> lbt, if you feel like swerden can help he has made the offer on mer-general
16:58:22 <vgrade_> anything else guys
16:59:05 <vgrade_> just made it in the hour, thanks for your participation
16:59:12 <vgrade_> #endmeeting