12:00:21 <E-P> #startmeeting Mer QA meeting 02/08/2012
12:00:21 <MerBot> Meeting started Thu Aug  2 12:00:21 2012 UTC.  The chair is E-P. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
12:00:21 <MerBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:00:28 <E-P> #topic Current status
12:00:56 <phaeron> 
12:01:14 <E-P> #info Smoke test plan draft https://wiki.merproject.org/wiki/Quality/Test_coverage
12:01:56 <E-P> #info Guide how to execute tests https://wiki.merproject.org/wiki/Quality/ExecuteTests
12:02:19 <E-P> #info new test packages added to home:esmietti:QA:Tests
12:02:51 <E-P> I will update the smoke test plan soon, I am adding new tests to that
12:03:01 <E-P> that's all from me
12:03:17 <E-P> currently testing the prerelease
12:04:25 <phaeron> I've done similar automated smoke testing on the prerelease using those packages from your home
12:04:38 <phaeron> and uploaded results to our qareports
12:05:19 <phaeron> test asset packaging is very broken
12:05:26 <phaeron> missing deps etc ..
12:05:48 <E-P> please file bugs about those
12:05:52 <phaeron> but I did get through 3 test runs and got consistent results
12:06:19 <E-P> that is very good
12:06:29 <phaeron> E-P: I'd rather publish the results on a mer qareports instance and let someone else do it :)
12:06:45 <phaeron> I used zypper in *-tests
12:06:49 <phaeron> :)
12:07:09 <E-P> ok, I have fixed some packages while doing the smoke plan
12:07:37 <phaeron> also test definitions seem to be missing requirements like : needs hardware , needs root ( and doing su ? )
12:07:39 <E-P> phaeron: what is the status of the mer qa-reports?
12:07:47 <phaeron> E-P: I need a vm :)
12:08:11 * Stskeeps points to lbt
12:08:51 <lbt> *nod*
12:08:53 <phaeron> Stskeeps: has seen the results
12:08:57 <phaeron> lbt: have you?
12:09:07 <phaeron> E-P: when did you fix the test suite ?
12:09:08 <lbt> don't think so
12:09:16 <phaeron> hmm ok will send you links
12:09:20 <E-P> yes, the test definition is pretty limited in that area
12:09:43 <E-P> I will file tasks about those
12:10:01 <phaeron> the report uploading is done automatically with a boss participant. simple for now. the code I lifted from the ots plugin was helpful , but had to do some fixing there
12:10:06 <phaeron> specially unicode handling
12:10:09 <E-P> #action E-P File tasks about extending test definition
12:10:41 <phaeron> E-P: also Stskeeps had action point from last time  about test requirement marking
12:11:00 <Stskeeps> right, i haven't actioned on that
12:11:05 <Stskeeps> systemd took too much time and other issues
12:11:09 <Stskeeps> carry on to next meeting
12:11:15 <E-P> ok
12:12:02 <E-P> phaeron: so you have an automation that creates a image, uses that image in vm, executes tests and uploads results to qa-reports?
12:12:27 <phaeron> E-P: yes triggered by incoming new snapshot
12:13:01 <E-P> that is pretty awesome
12:13:05 <kyyberi> yeah
12:14:13 <E-P> great work
12:14:20 <phaeron> http://pastebin.com/5AD6LrZy
12:16:09 <lbt> it's good that it's quite simple to do these things
12:16:42 <phaeron> :)
12:17:00 <E-P> looks good
12:17:26 <phaeron> some json conf for parameters associated
12:18:41 <E-P> #info Current smoke test plan has 26 test cases
12:19:39 <E-P> phaeron: what is the next step in automation?
12:20:27 <phaeron> hmm
12:20:40 <phaeron> haven't thought about it :)
12:21:41 <E-P> ok :)
12:21:51 <Stskeeps> deployment into mer?
12:21:51 <Stskeeps> :P
12:21:55 <E-P> maybe trying to get n900 or n9 to automation?
12:22:07 <phaeron> yunta: updates on device testing ?
12:22:15 <yunta> damn
12:22:30 <yunta> well, no :D
12:22:34 <phaeron> Stskeeps: I thought he meant automate something more
12:22:57 <Stskeeps> ah
12:24:01 <E-P> does someone else have something to update?
12:24:52 <yunta> (I'm sorry, I forgot about this meeting) I'm currently working on using phaeron's awesome stuff with physical devices (in place of vms).
12:25:32 <phaeron> yunta: I setup the process for your project btw , forgot to tell you :)
12:25:38 <yunta> thx :)
12:25:54 <E-P> #info phaeron has created an automation that creates a image, uses that image in vm, executes tests and uploads results to qa-reports
12:26:02 <Stskeeps> and it looks beautiful
12:26:07 <Stskeeps> i could sell mer on that alone ;)
12:26:17 <yunta> I've also finally found my n900, so I'm ready for flashing "fun"
12:26:55 <E-P> yunta: you can take a look to meego-ai-flasher-n900
12:27:03 <phaeron> Stskeeps: :)
12:27:13 <yunta> ok
12:27:15 <Stskeeps> E-P: timoph did this, right?
12:27:26 <Stskeeps> from memory
12:27:44 <E-P> timoph and another timo
12:28:25 <Stskeeps> ok
12:29:09 <E-P> https://meego.gitorious.org/meego-quality-assurance/meego-ai-flasher
12:29:53 <E-P> it works pretty well, and it has support for multiple device flashing
12:30:15 <yunta> can it do n9?
12:30:38 <Stskeeps> it could probably
12:30:40 <E-P> I think yes, if you change the kernel image
12:30:44 <Stskeeps> n9 moslo is similar to meego-ai-flasher initrd
12:31:00 <yunta> ok, I'll take a look
12:32:42 <E-P> kyyberi: ping
12:32:49 <kyyberi> here
12:32:52 <E-P> great
12:32:57 <E-P> so moving to next topic
12:33:15 <E-P> #topic Mer dashboard
12:33:24 <E-P> https://bugs.merproject.org/show_bug.cgi?id=429
12:33:48 <E-P> kyyberi: you could tell what you have done
12:33:57 <kyyberi> ok, here's something
12:34:10 <kyyberi> I've started breaking the MeetMer (dashboardish Rails app) features into gems. Eventually there will be plain core in which gems are installed.
12:34:33 <kyyberi> All features such as listing/viewing meetings are 'gemified' and managed in own repo in github.
12:34:59 <kyyberi> First gem, meetings, is somewhat ready to be tested. It builds and so forth.
12:35:14 <kyyberi> I need to clean up the main app first and then try it.
12:35:37 <kyyberi> Started also https://wiki.merproject.org/wiki/Meet_Mer where I will put details about MeetMer (out of date already)
12:35:52 <kyyberi> that's about it.
12:36:18 <E-P> thanks
12:36:41 <kyyberi> currently my time is though limited due to work related stuff
12:36:56 <E-P> you have done great work
12:36:59 <kyyberi> but I should have more time after a while
12:37:53 <E-P> we could talk about what we want to have into the dashboard
12:38:01 <kyyberi> yes, please
12:38:44 <E-P> the bug has some ideas, but those are mine ideas :)
12:38:59 <kyyberi> not too bad ideas :)
12:40:56 <E-P> so one feature could be the qa summary
12:41:06 <kyyberi> those qa reports should definetily be there imo. Just need url to retrieve data
12:41:25 <phaeron> unfortunately the qareports rest api is very limited.
12:41:52 <E-P> it should be pretty easy to extend that
12:41:59 <phaeron> I need to look at qa-dashboard which does some kind of aggregation of data from qa-reports
12:42:15 <phaeron> and then maybe we can plugin qa-dashboard into kyyberi-dashboard
12:42:25 <phaeron> or maybe just strip it down to a module
12:43:39 <E-P> we need to somehow to store/list mer releases
12:43:47 <E-P> and link tests against them
12:46:47 <kyyberi> I have implemented tasks listing and also bugs listing and some grouping features in those
12:47:13 <kyyberi> I know those were not requested, but was good excercise :)
12:47:48 <E-P> I think those are nice to have
12:48:11 <E-P> real-time bug metrics
12:48:20 <kyyberi> and update processes for the above
12:48:25 <kyyberi> are implemented
12:48:44 <E-P> https://wiki.merproject.org/wiki/Quality/Metrics
12:49:26 <kyyberi> minor clarification: my solution takes only 'not taken' tasks
12:49:54 <kyyberi> could include all, but started with that
12:50:11 <E-P> ok
12:50:32 <E-P> when do we see that in live? :)
12:50:39 <kyyberi> that view could function as 'lure in more developers' if there is clear view to tasks not taken and low hanging fruits would be identifiable
12:51:04 <kyyberi> as soon as I get gem stuff working :)
12:51:15 <kyyberi> it has been initially installed in mer server
12:51:28 <E-P> was there a plan to have a tag for easy bugs?
12:51:46 <kyyberi> dunno, some plans have been I've heard
12:51:53 <Stskeeps> that'd be good, probably
12:53:19 <E-P> kyyberi: do you have any problems or issues that we should discuss or solve?
12:54:01 <kyyberi> hmmm...not at the moment. Found out (I think) how those gems are made
12:54:38 <E-P> I think there will be more request when we see the dashboard in action :)
12:54:43 <kyyberi> yeah :)
12:55:00 <E-P> #info There will be plain core in which gems are installed
12:55:00 <E-P> #info All features such as listing/viewing meetings are 'gemified' and managed in own repo in github
12:55:03 <E-P> #info First gem, meetings, is somewhat ready to be tested. It builds and so forth.
12:55:10 <E-P> #info non-taken tasks listing and also bugs listing and some grouping features in those are implemented
12:55:13 <E-P> #info https://wiki.merproject.org/wiki/Meet_Mer
12:55:15 <E-P> #info QA summary could be another feature, similar to qa-dashboard, might require api changes to qa-reports
12:55:35 <E-P> anything to add?
12:55:57 <kyyberi> nope
12:56:00 <phaeron> no
12:56:22 <phaeron> E-P: I'll try to export the results for you to see
12:56:47 <E-P> phaeron: ok
12:56:58 <E-P> kyyberi: thank you very much
12:57:13 <kyyberi> np, my pleasure
12:57:35 <E-P> we are done for today
12:57:43 <E-P> #endmeeting