07:03:49 <iekku> #startmeeting Nemo Bug Triage 13/8/2012
07:03:49 <MerBot`> Meeting started Mon Aug 13 07:03:49 2012 UTC.  The chair is iekku. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
07:03:49 <MerBot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:03:57 <iekku> #topic We'll start with the new bugs:
07:04:00 <iekku> #link https://bugs.nemomobile.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEW&bug_status=NEEDINFO&bug_status=ASSIGNED&bug_status=REOPENED&email1=need-triage&emailassigned_to1=1&emailtype1=substring&query_format=advanced&query_based_on=&columnlist=bug_severity%2Cpriority%2Cassigned_to%2Cbug_status%2Cshort_desc%2Ccomponent
07:04:24 <iekku> huge amount...
07:05:42 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=157 ��� no phone calls possible, no provider ��� Dialer ���
07:07:28 <Sage> Stskeeps: op the bot
07:08:15 <Sage> valid bug, high I would say
07:08:47 <iekku> high-major? high-critical?
07:10:52 <w00t> makes sense
07:11:05 <Sage> major I would say
07:11:18 <Sage> it isn't always the case
07:11:18 <iekku> #info high-major, valid bug
07:11:49 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=196 ��� Opening photo from file muncher doesn't start gallery ��� Photos/G ���
07:12:30 <Sage> quite annoying bug, but not critical. Normal
07:12:47 <iekku> #info normal
07:13:14 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=227 ��� CP wifi plugin: data in advanced view doesn't get updated upon changes ��� Settings ���
07:13:51 <iekku> have you seen this?
07:14:26 <Sage> I haven't tested, but normal.
07:14:39 <Sage> also if fix is in comman 1.3 we should have that in latest mer now
07:15:29 <Sage> so needs testing
07:16:01 <Sage> with latest release with zypper ref; zypper up that is
07:16:04 <iekku> #info normal
07:16:32 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=239 ��� smshistory is in wrong project
07:16:49 <Sage> I'm going to do new snapshot this week of Nemo on top of new Mer.
07:17:12 <Sage> Low, I'll fix this one.
07:17:30 <Sage> I can comment and change it
07:17:44 <w00t> Sage: it probably won't be needed anymore
07:17:46 <iekku> ok thanks.
07:17:48 <w00t> worth talking to alterego
07:17:52 <w00t> \ special
07:17:58 <iekku> #info low, Sage taking
07:18:01 <w00t> but I think commhistoryd will be taking care of that stuff
07:18:04 <Sage> w00t: yes, it is going to be removed
07:18:15 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=240 ��� voicecallhistory is in wrong project ���
07:18:21 <Sage> same thing. I'll change
07:18:26 <iekku> :nod:
07:18:34 <iekku> #info low, Sage taking
07:18:44 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=246 ��� Phone call button does not work.
07:19:08 <Sage> I think that was just fixed in latest contacts?
07:19:15 <w00t> not really
07:19:23 <w00t> there is code integrated for it, but the dialer doesn't seem to do anything
07:19:29 <w00t> need to talk to alterego
07:19:33 <Sage> oh, ok.
07:19:37 <Sage> normal
07:19:51 <iekku> #info normal
07:20:18 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=247 ��� Dialer needs to offer API for other applications to use.
07:20:48 <Sage> related to previous, alterego working on this?
07:20:59 <w00t> need to ask him whether he needs it open for anything else I guess
07:21:22 <iekku> i think this is high
07:21:36 <Sage> sure
07:21:43 <iekku> major?
07:21:45 <w00t> there is stuff in place (per previous bug), but don't know if he wants to add more
07:22:29 <iekku> hope he comments on those
07:22:40 <iekku> #info high-major
07:23:02 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=250 ��� Messaging button does not work.
07:23:06 <iekku> normal?
07:23:18 <w00t> seems ok
07:23:45 <iekku> #info normal
07:23:59 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=252 ��� Not possible to determine position in the gallery when scrolling.
07:24:24 <Sage> normal
07:24:28 <iekku> :nod:
07:24:33 <iekku> #info normal
07:24:42 <Sage> also task?
07:24:50 <Sage> it is a feature request
07:24:54 <iekku> true
07:24:57 <iekku> #info task
07:25:14 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=253 ��� Avatar picker should not default-select an image unless the contact already has one
07:26:44 <iekku> low - trivial?
07:27:19 <w00t> sounds about right
07:27:27 <Sage> yes
07:28:09 <iekku> #info low- trivial
07:28:25 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=255 ��� Rotating the avatar picker page is slow
07:28:46 <w00t> low
07:28:58 <iekku> low - enhancement
07:29:10 <iekku> ?
07:29:45 <Sage> yes
07:29:56 <w00t> yes
07:30:41 <iekku> #info low - enhancement
07:30:50 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=256 ��� When setting an avatar, the image on the editor sheet is stretched.
07:31:26 <w00t> low
07:31:35 <iekku> encanhement?
07:31:49 <w00t> it's a bug, but not very important/visible
07:31:52 <iekku> or trivial maybe
07:31:55 <w00t> yeah
07:31:57 <w00t> trivial i'd say
07:32:20 <iekku> #info low - trivial
07:32:34 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=257 ��� OHM: fix errors reported by ohmd
07:33:12 <Sage> normal or low, not sure what are the effects of these errors.
07:33:25 <iekku> Sage, camera won't work?
07:33:33 <iekku> (comment 2)
07:33:57 <Sage> we sure if it is related? If yes then I would say High
07:34:09 <iekku> it seems so...
07:34:17 <iekku> #link https://bugs.nemomobile.org/show_bug.cgi?id=214
07:34:39 <iekku> (comment 2 there also)
07:34:51 <Sage> ok, well then high
07:34:57 <iekku> and critical
07:35:24 <Sage> sure
07:35:44 <iekku> #info high - critical, camera doesn't work because of this
07:35:54 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=258 ��� Allow sorting of photos based on date, filename, etc.
07:36:15 <iekku> normal - task?
07:36:24 <Sage> normal and task yes
07:37:01 <iekku> #info normal-task
07:37:03 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=259 ��� Add possiblity to favorite/tag photos
07:37:19 <iekku> low-task
07:37:21 <iekku> ?
07:37:43 <Sage> yes
07:38:00 <iekku> #info low-task
07:38:23 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=260 ��� Feature: videos to the gallery ���
07:38:45 <iekku> normal-task?
07:41:42 <Sage> Well, this is something we would like to see quite fast actually. Just so that we could test basic video playback
07:41:51 <iekku> :nod:
07:41:52 <Sage> how audio works, and video in general.
07:42:09 <iekku> high?
07:42:20 <timoph> a bit off topic but we need a video player?
07:42:29 <Sage> I would say high.
07:42:32 <timoph> and hi
07:42:42 <iekku> timoph, yes, we need :D
07:42:44 <Sage> timoph: well, we don't need separate video player, this is about adding video playback to gallery
07:43:18 <Sage> and then just having filter that show only videos and you pretty much have videoplayer :)
07:43:20 <iekku> #info high-task
07:43:41 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=264 ��� SectionScroller does not have a correct overlay mode
07:44:25 <Sage> w00t: ?
07:44:27 <w00t> task, low, would be fixed (somewhat) with a qt components upgrade
07:44:34 * w00t notes the last part
07:44:38 <Sage> ok
07:45:00 <iekku> #info low-task
07:45:25 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=267 ��� On edit page "save" button is enabled even when nothing has changed
07:46:02 <w00t> that isn't exactly trivial
07:46:12 <w00t> qt components provides no way to change the enabled state of the buttons
07:47:57 <iekku> is there anything we can do?
07:48:06 <w00t> it can probably be done
07:48:08 <iekku> or is this wontfix?
07:48:36 <w00t> I'd mark it low I guess, it is an annoyance, but there's other things that are probably more important
07:48:42 <w00t> Sage: ^?
07:49:02 <Sage> yes,  very low ;)
07:49:10 <Sage> Just a thing that annoyed me a bit ;)
07:50:05 <iekku> #info low
07:50:15 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=268 ��� [FEA] Search contacts ���
07:50:33 <iekku> high - task
07:50:35 <iekku> ?
07:50:44 <w00t> normal/high, task sounds good
07:51:15 <iekku> i would like to set this high, i see this feature very important
07:51:25 <w00t> fine
07:51:38 <Sage> sure
07:51:57 <iekku> #info high-task
07:52:08 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=269 ��� qtcontacts-tracker should also install libqtsparql-tracker-direct ���
07:52:50 <w00t> high
07:53:07 <iekku> bug?
07:53:08 <w00t> that has a very big performance impact, and some stuff also won't even work without -direct installed
07:53:21 <w00t> (I think commhistory may be affected there, I forget)
07:53:27 <iekku> so critical?
07:53:27 <Sage> also easy fix
07:53:42 <w00t> critical's fine with me
07:54:24 <iekku> #info high-critical (easy fix)
07:54:35 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=272 ��� SelectionDialog & others don't work with C++ models
07:55:22 <w00t> normal
07:55:27 <w00t> it's an annoyance, but there is a workaround
07:56:12 <iekku> ok
07:56:17 <iekku> #info normal
07:56:36 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=273 ��� Not able to initiate a cellular call ���
07:57:12 <w00t> high?
07:57:17 <Sage> yes
07:57:30 <iekku> duplicate for 157?
07:57:58 <Sage> iekku: different device so maybe/maybe not
07:58:11 <iekku> noticed that too
07:58:17 <iekku> adding comment to see also 157
07:58:28 <iekku> high - critical
07:59:10 <iekku> #info high-critical
07:59:19 <iekku> ok, we are running out of thiime
07:59:21 <iekku> time
07:59:32 <Sage> I'm ok to continue ;)
07:59:40 <w00t> me also
07:59:48 <iekku> i have other meeting
07:59:56 <Sage> ok, well next time then
08:00:02 <iekku> :nod:
08:00:10 <w00t> should we schedule one a bit earlier to deal with more of the backlog?
08:00:13 <iekku> i will organize bigger timeslot on next mon
08:00:19 <w00t> ok
08:00:27 <iekku> w00t, i have time on fri next time...
08:00:33 <Sage> this week is quite booked for me as well
08:00:44 <Sage> except today and maybe friday ;)
08:00:55 <w00t> me too also i guess, i won't be here tomorrow even due to driving exam..
08:01:07 <iekku> #action iekku to organize longer triage next time
08:01:18 <iekku> #info  Task list is now: https://bugs.nemomobile.org/buglist.cgi?emailassigned_to1=1&query_format=advanced&bug_severity=task&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=NEEDINFO&bug_status=ASSIGNED&bug_status=REOPENED&email1=not-taken%40&emailtype1=substring
08:01:26 <iekku> #info   Not taken bugs: https://bugs.nemomobile.org/buglist.cgi?emailassigned_to1=1&query_format=advanced&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=NEEDINFO&bug_status=ASSIGNED&bug_status=REOPENED&email1=not-taken%40&emailtype1=substring
08:01:33 <iekku> #topic search for bugs that are assigned:
08:01:34 <iekku> #link  https://bugs.nemomobile.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&field0-0-0=assigned_to&field0-1-0=assigned_to&query_format=advanced&type0-0-0=notequals&type0-1-0=notequals&value0-0-0=need-triage%40nemomobile.org&value0-1-0=not-taken%40nemomobile.org&query_based_on=&columnlist=bug_severity%2Cpriority%2Cassigned_to%2Cbug_status%2Cshort_desc%2Ccomponent%2Cchangeddate
08:01:40 <iekku> thanks for meeting
08:01:42 <iekku> #endmeeting