07:01:48 <iekku> #startmeeting Nemo Bug Triage 20/8/2012
07:01:48 <Merbot> Meeting started Mon Aug 20 07:01:48 2012 UTC.  The chair is iekku. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
07:01:48 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:01:56 <iekku> #topic We'll start with the new bugs:
07:01:58 <iekku> #link https://bugs.nemomobile.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEW&bug_status=NEEDINFO&bug_status=ASSIGNED&bug_status=REOPENED&email1=need-triage&emailassigned_to1=1&emailtype1=substring&query_format=advanced&query_based_on=&columnlist=bug_severity%2Cpriority%2Cassigned_to%2Cbug_status%2Cshort_desc%2Ccomponent
07:02:15 <Sage> o/
07:02:17 <iekku> still lot's of new ones...
07:02:30 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=227 - CP wifi plugin: data in advanced view doesn't get updated upon changes
07:02:30 <Merbot> 04Bug 227: normal, Normal, ---, need-triage, NEEDINFO, CP wifi plugin: data in advanced view doesn't get updated upon changes
07:02:30 <Sage> I have time so we could just go all through if you have time
07:03:06 <Sage> triaged already
07:03:08 <iekku> Sage, i'm having visitor at 11:00 :/
07:03:12 <Sage> :/
07:03:19 <sasikala_> hello
07:03:23 * w00t is here
07:03:39 <iekku> #info triaged already, needs retesting
07:03:53 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=274 - Receiving or answering an incoming call is not possible
07:03:53 <Merbot> 04Bug 274: major, Undecided, ---, need-triage, NEW, Receiving or answering an incoming call is not possible
07:04:25 <Sage> I would say high
07:04:35 <w00t> wow, my internet is so slow that i can't load bugs..
07:04:42 <Sage> :P
07:04:50 <iekku> i say high-critical
07:04:57 <w00t> from the description i'd agree
07:05:05 <Sage> agreed, next
07:05:11 <Sage> iekku: want me to do changes?
07:05:26 <iekku> Sage, i can handle
07:05:29 <Sage> ok
07:05:36 <iekku> #info high-critical
07:05:48 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=275 - Opening of people or contact application from dialer application is not working
07:05:48 <Merbot> 04Bug 275: major, Undecided, ---, need-triage, NEW, Opening of people or contact application from dialer application is not working
07:06:30 <w00t> needs feedback from alterego, because i don't think the new dialer has such a button, does it?
07:07:21 <Sage> normal, needinfo from alterego. next ;)
07:07:25 <iekku> :D
07:07:40 <iekku> #info normal, needinfo from alterego
07:07:49 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=276 - Deleting service provider SMS using CSM menu is not working
07:07:49 <Merbot> 04Bug 276: major, Undecided, ---, need-triage, NEW, Deleting service provider SMS using CSM menu is not working
07:08:10 <special> obsolete once we have qml messages, no?
07:08:16 <w00t> sounds like it
07:09:14 <Sage> would be nice to get the obsolete for qmlmessages in and telepaty-ring there as well. so we would not have the old app installed anymore
07:09:36 <iekku> should we have new task for that?
07:09:42 <Sage> iekku: there is
07:09:59 <iekku> oh, ok
07:10:01 <Sage> bug 134
07:10:02 <Merbot> 04Bug https://bugs.merproject.org/show_bug.cgi?id=134 normal, Low, ---, not-taken, NEW, rpm test cases require fakechroot
07:10:03 <special> https://bugs.nemomobile.org/show_bug.cgi?id=134
07:10:03 <Merbot> 04Bug 134: task, High, ---, john.brooks, NEW, SMS should be replaced with QML SMS
07:10:20 * Sage was faster in a way ;)
07:10:33 <iekku> so, can we ignore 276 because of 134?
07:10:41 <iekku> ignore = wontfix
07:10:47 <special> I would say so
07:10:50 <Sage> :nod:
07:11:25 <w00t> yep
07:11:27 <iekku> #info wontfix, see reason from bug 134
07:11:39 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=277 - When no backend is available the dialer doesn't show that
07:11:39 <Merbot> 04Bug 277: normal, Undecided, ---, need-triage, NEW, When no backend is available the dialer doesn't show that
07:12:07 <Sage> low, happens very rarely
07:12:42 <iekku> :nod:
07:13:08 <iekku> #info low, happens very rarely
07:13:18 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=278 - HW keypad doesn't work with calculator
07:13:18 <Merbot> 04Bug 278: normal, Undecided, ---, need-triage, NEW, HW keypad doesn't work with calculator
07:13:36 <w00t> normal, task?
07:13:41 <Sage> This I would say normal as I really was surpriced that it didn't work :)
07:13:44 <Sage> yes, normal task
07:13:51 <iekku> :nod:
07:14:00 <iekku> #info normal, task
07:14:08 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=279 - can not call to a contact 's phone number from the people application
07:14:08 <Merbot> 04Bug 279: major, Undecided, ---, need-triage, NEW, can not call to a contact 's phone number from the people application
07:14:26 <w00t> should in theory be fixed now actually, but i lack a SIM to test it
07:15:05 <iekku> NEEDINFO?
07:15:13 <iekku> and retest..
07:15:23 <Sage> High major and RESOLVED-FIXED probably
07:15:36 <iekku> can someone test it?
07:16:22 <w00t> +1 Sage
07:16:26 <w00t> can always reopen if it's still broken
07:17:06 <Sage> :nod:
07:17:11 <iekku> #info high-major resolved-fixed
07:17:20 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=280 - TO field not shown in SMS composer window when initiated from people application
07:17:20 <Merbot> 04Bug 280: major, Undecided, ---, need-triage, NEW, TO field not shown in SMS composer window when initiated from people application
07:17:39 <w00t> also wontfix on 134?
07:17:43 <Sage> wontfix see 134
07:17:58 <special> mhm
07:18:12 <iekku> :nod:
07:18:22 <iekku> #info wontfix, see bug 134
07:18:22 <Merbot> 04Bug https://bugs.merproject.org/show_bug.cgi?id=134 normal, Low, ---, not-taken, NEW, rpm test cases require fakechroot
07:18:36 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=281 - Not able to make one contact as favorite from CSM menu
07:18:36 <Merbot> 04Bug 281: normal, Undecided, ---, need-triage, NEW, Not able to make one contact as favorite from CSM menu
07:19:07 <Sage> same
07:19:17 <iekku> #info wontfix, see bug 134
07:19:26 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=282 - Flight mode is not working properly
07:19:26 <Merbot> 04Bug 282: major, Undecided, ---, need-triage, NEW, Flight mode is not working properly
07:19:42 <Sage> high, critical
07:20:02 <Sage> err
07:20:05 <Sage> no, duplicate
07:20:17 <Sage> duplicate with NEMO#18
07:20:31 <iekku> bug 18
07:20:31 <Merbot> 04Bug https://bugs.merproject.org/show_bug.cgi?id=18 normal, Undecided, ---, a9016009, RESOLVED FIXED, Restrict access to bugs of the IT Private component
07:20:40 <iekku> no
07:20:52 <Sage> that is mer not nemo thus I didn't use bug but NEMO# :)
07:20:59 <Sage> Bug 18 - Flight mode control panel does not work (edit)
07:21:38 <iekku> ooh, true
07:21:58 <iekku> #info duplicate for bug 18
07:22:09 <iekku> #link https://bugs.nemomobile.org/show_bug.cgi?id=18
07:22:09 <Merbot> 04Bug 18: normal, Normal, ---, not-taken, NEW, Flight mode control panel does not work
07:22:21 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=283 - Highlighted ring tone is not played
07:22:21 <Merbot> 04Bug 283: normal, Undecided, ---, need-triage, NEW, Highlighted ring tone is not played
07:23:14 <Sage> normal
07:23:39 <iekku> :nod:
07:23:41 <iekku> #info normal
07:23:50 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=284 - Battery level is always showing as 0% in Settings application
07:23:50 <Merbot> 04Bug 284: major, Undecided, ---, need-triage, NEW, Battery level is always showing as 0% in Settings application
07:26:19 <Sage> hmmp
07:26:28 <Sage> high-major
07:26:33 <iekku> :nod:
07:27:03 <iekku> #info high-major
07:27:14 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=285 - Not able to change the time from settings application
07:27:14 <Merbot> 04Bug 285: major, Undecided, ---, need-triage, NEW, Not able to change the time from settings application
07:27:21 <Sage> o_0
07:27:24 <Sage> that should really work.
07:27:29 <w00t> either a duplicate, or alreadyfixed?
07:27:35 <Sage> duplicate actually
07:27:38 <w00t> I seem to remember there was a fix for it and I guess it got merged..
07:27:50 <Sage> moment
07:27:53 <Sage> it is
07:27:58 <Sage> he just didn't do zypper up
07:28:33 <Sage> https://bugs.nemomobile.org/show_bug.cgi?id=16
07:28:33 <Merbot> 04Bug 16: normal, Normal, ---, priyaranjan.singh, RESOLVED CODEAVAILABLE, Setting time with Time & Date control panel does not work
07:29:12 <iekku> #info duplicate for bug 16
07:29:12 <Merbot> 04Bug https://bugs.merproject.org/show_bug.cgi?id=16 normal, Undecided, ---, david, RESOLVED FIXED, support merproject.org email forwarding
07:29:15 <w00t> that needs changing to RELEASED I guess?
07:29:39 <iekku> :nod:
07:29:41 <Sage> changed to released
07:30:00 <iekku> #info duplicate is already released
07:30:03 <Sage> as it is really released, there wasn't bug number in changelog thus I missed it
07:30:29 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=286 - Camera application is not working
07:30:29 <Merbot> 04Bug 286: critical, Undecided, ---, need-triage, NEW, Camera application is not working
07:30:36 <Sage> high
07:30:42 <iekku> critical
07:30:43 <w00t> high-critical
07:30:46 <Sage> next
07:30:47 <w00t> gmta :)
07:30:57 <iekku> #info high-critical
07:31:05 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=287 - Two instances of calendar application are opening
07:31:05 <Merbot> 04Bug 287: major, Undecided, ---, need-triage, NEW, Two instances of calendar application are opening
07:31:58 <w00t> normal? doesn't stop it actually functioning, it's just a big annoyance :)
07:31:58 <iekku> high?
07:31:59 <Sage> normal
07:32:02 <special> normal.
07:32:10 <iekku> #info normal
07:32:19 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=288 - Not able to pan and render properly the opened site in browser
07:32:19 <Merbot> 04Bug 288: major, Undecided, ---, need-triage, NEW, Not able to pan and render properly the opened site in browser
07:32:55 <iekku> worksforme?
07:33:11 <w00t> sounds good to me
07:33:22 <Sage> works on my n950 ok
07:33:28 <w00t> though it could be n900-specific
07:33:33 <w00t> does anyone have an n900 to test that?
07:33:50 <Sage> I have but not with image atm.
07:34:11 <Sage> but might be problem with touch screen things
07:34:34 <iekku> normal? needs retesting?
07:35:18 <Sage> normal it most probably is valid
07:36:24 <iekku> #info normal, needs retesting. works correxctly on N950, might be N900 specific
07:36:33 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=293  - SMS composer windows is shown when trying to open one SMS notification
07:36:33 <Merbot> 04Bug 293: normal, Undecided, ---, need-triage, NEW, SMS composer windows is shown when trying to open one SMS notification
07:36:40 <special> 134 :)
07:36:43 <Sage> ;)
07:36:54 <iekku> :D
07:37:02 <iekku> #info wontfix, see 134
07:37:12 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=294 - opening a site in browser when device is not connected to Internet
07:37:12 <Merbot> 04Bug 294: normal, Undecided, ---, need-triage, NEW, opening a site in browser when device is not connected to Internet
07:37:13 <Sage> special: I saw working sms in qmlmessages at some point can we just push it? :)
07:37:43 <Sage> duplicate... let me find the bug
07:38:03 <Sage> https://bugs.nemomobile.org/show_bug.cgi?id=164
07:38:03 <Merbot> 04Bug 164: task, High, ---, not-taken, NEW, Prompt for internet-connection when opening the browser without connection
07:38:10 <special> Sage: it'll sort-of-work as soon as ring does :p
07:38:20 <iekku> #info duplicate for 164
07:38:29 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=295  - 'Charging not started ,replace charger' error banner shown after device booted up to home screen
07:38:29 <Merbot> 04Bug 295: normal, Undecided, ---, need-triage, NEW, 'Charging not started ,replace charger' error banner shown after device booted up to home screen
07:38:35 <Sage> special: that is good enough as the current one also sort of works :)
07:38:49 <Sage> iekku: duplicate moment
07:39:01 <Sage> https://bugs.nemomobile.org/show_bug.cgi?id=13
07:39:01 <Merbot> 04Bug 13: normal, Low, ---, carsten.munk, NEW, Charging not started -message after boot
07:39:20 <iekku> #info duplicate of 13
07:39:22 <Stskeeps> please remove that from me assignee
07:39:32 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=296  - File manager and People applications are having same icon in application list view
07:39:32 <Merbot> 04Bug 296: normal, Undecided, ---, need-triage, NEW, File manager and People applications are having same icon in application list view
07:40:04 <Sage> duplicate
07:40:21 <iekku> Stskeeps, not taken?
07:40:23 <w00t> that's already fixed
07:40:24 <w00t> Sage: ^
07:40:50 <Stskeeps> iekku: right
07:41:03 <Sage> https://bugs.nemomobile.org/show_bug.cgi?id=136
07:41:03 <Merbot> 04Bug 136: normal, Undecided, ---, jpavelek, NEEDINFO, Wrong icon addressed to File Muncher
07:41:21 <Sage> w00t: can you comment on 136 not sure when it got fixed
07:41:39 <iekku> and it could be low?
07:41:49 <w00t> that was released like.. 1.5-2 weeks ago I think
07:41:49 <Sage> iekku: so duplicate to 136 this 296
07:41:51 <w00t> will comment
07:41:56 <iekku> #info duplicate of 136
07:42:00 <Sage> w00t: also mark it as released please
07:42:09 <Sage> I can see the fix as well. I can verify :)
07:42:16 <w00t> resolved
07:42:17 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=298  - meego-terminal is black under virtualbox, making installing hard
07:42:17 <Merbot> 04Bug 298: normal, Undecided, ---, need-triage, NEW, meego-terminal is black under virtualbox, making installing hard
07:42:28 <w00t> ... or trying (slow internet)
07:42:39 <Sage> duplicate again I think moment
07:42:44 <special> w00t: in the US, we call that high speed.
07:43:06 <w00t> special: i think i'm having issues with wherever bugs.nm.o is hosted
07:43:19 <w00t> it's fast sometimes, but sometimes it hangs for like 20-60 seconds, then times out
07:43:45 <Sage> iekku: err, sry, it was mer bug. So valid. High
07:44:09 <iekku> normal/major/critical?
07:45:14 <Sage> iekku: critical as it prevent using vm properly
07:45:21 <w00t> high/critical?
07:45:27 <w00t> definitely not a good bug
07:45:36 <Sage> :nod:
07:45:43 <iekku> #info high-critical
07:45:52 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=299  - Bluetooth switch in control-panel doesn't work
07:45:52 <Merbot> 04Bug 299: normal, Undecided, ---, need-triage, NEW, Bluetooth switch in control-panel doesn't work
07:46:06 <w00t> huh. didn't even know we had working bt :)
07:46:47 <Sage> I though this is duplicate or at least depends on something else
07:47:29 <Sage> ok, different device
07:47:52 <Sage> high critical probalby as it is whole feature that is missing there
07:48:13 <iekku> :D
07:48:27 <iekku> #info high-critical, whole feature is missing
07:48:37 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=300  - PeopleModel should have a method to look up a contact by phone number
07:48:37 <Merbot> 04Bug 300: normal, Undecided, ---, need-triage, NEW, PeopleModel should have a method to look up a contact by phone number
07:49:08 <w00t> already fixed
07:49:18 <w00t> (and released)
07:49:27 <iekku> sage, could you please?
07:49:41 <iekku> Sage, do the needed changes...
07:49:55 <iekku> #info already fixed and released
07:50:12 <iekku> w00t, or can you do changes?
07:50:17 <w00t> will do
07:50:23 <iekku> thanks
07:50:28 <Sage> w00t: also remember to change assignee
07:50:31 <Sage> who ever fixed it
07:50:35 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=301  - Qt Mobility needs a new custom field on QContactPhoneNumber for localized phone numbers
07:50:35 <Merbot> 04Bug 301: normal, Undecided, ---, need-triage, NEW, Qt Mobility needs a new custom field on QContactPhoneNumber for localized phone numbers
07:50:52 <Sage> iekku: same thing w00t handles. :)
07:51:07 <w00t> i'd say normal/task, what we have (in 300) is working, but that is important for doing it "properly" as the current solution kinda sucks
07:51:18 <Sage> err... what?
07:51:25 <Sage> 300 is fixed but depends on 301 that isn't fixed?
07:51:30 <w00t> i removed the dependency
07:51:34 <Sage> ah, ok
07:51:34 <w00t> we worked around it
07:51:48 <w00t> 301 should stay open for fixing the workaround
07:51:48 <iekku> so, 301 is normal task?
07:52:00 <w00t> think so, yes
07:52:20 <iekku> #info normal-task
07:52:37 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=302  - org.nemomobile.components import required for some shared components
07:52:37 <Merbot> 04Bug 302: normal, Undecided, ---, need-triage, NEW, org.nemomobile.components import required for some shared components
07:53:14 <w00t> low, task
07:53:25 <w00t> (needed to improve code reuse but it works as is)
07:53:31 <iekku> #info low, task
07:53:40 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=304  - wlan0 MAC-address changes on every boot
07:53:40 <Merbot> 04Bug 304: normal, Undecided, ---, need-triage, NEW, wlan0 MAC-address changes on every boot
07:54:01 <Sage> need info what device
07:54:34 <Sage> commented and changed next
07:55:06 <iekku> #info needinfo about device, new triage next week
07:55:18 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=306  - About product: doesn't show WLAN MAC address
07:55:18 <Merbot> 04Bug 306: normal, Undecided, ---, need-triage, NEW, About product: doesn't show WLAN MAC address
07:55:37 <Sage> low
07:55:49 <iekku> oki
07:55:52 <iekku> #info low
07:56:00 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=308  - Support message delivery status when possible
07:56:00 <Merbot> 04Bug 308: normal, Undecided, ---, need-triage, NEW, Support message delivery status when possible
07:56:17 <Sage> should we have another nemo bug triage this week so that we could get through all the bugs at some point? :)
07:56:27 <w00t> special: ^
07:56:34 <w00t> (i guess that might be done in libcommhistory?)
07:56:36 <iekku> could be good idea
07:56:51 <special> mm
07:57:02 <special> implementation is in libcommhistory, still has a UI portion
07:57:44 <iekku> normal?
07:57:52 <special> normal or low, and depends on libcommhistory, I guess
07:58:22 <w00t> normal it is
07:58:25 <iekku> i would really like to have this
07:58:50 <iekku> #info normal, depends on libcommhistory
07:59:07 <special> (which is NEMO#320)
07:59:10 <iekku> is wed 7 UTC ok?
07:59:20 <iekku> to continue triage
08:00:05 <Sage> ok for me
08:00:14 <iekku> i will send invitation
08:00:40 <iekku> #action iekku to set extra bug triage wed 22/8/2012 7 UTC
08:00:48 <iekku> thanks everyone
08:00:53 <iekku> #endmeeting