07:00:28 <iekku> #startmeeting Nemo bug triage 17/9/2012
07:00:28 <Merbot> Meeting started Mon Sep 17 07:00:28 2012 UTC. The chair is iekku. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
07:00:28 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:00:31 <iekku> welcome
07:00:44 <iekku> #topic We'll start with the new bugs:
07:00:46 <iekku> #link https://bugs.nemomobile.org/buglist.cgi?bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=trivial&bug_severity=enhancement&bug_status=NEW&bug_status=NEEDINFO&bug_status=ASSIGNED&bug_status=REOPENED&email1=need-triage&emailassigned_to1=1&emailtype1=substring&query_format=advanced&query_based_on=&columnlist=bug_severity%2Cpriority%2Cassigned_to%2Cbug_status%2Cshort_desc%2Ccomponent
07:01:03 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=200 Terminal does not show toolbar
07:01:04 <Merbot> 04Bug 200: normal, Normal, ---, need-triage, NEW, Terminal does not show toolbar
07:01:31 <Sage_> normal or high as it is missing some essential buttons for developers
07:01:37 <Stskeeps> should be triaged to libmeegotouch or theme probably
07:03:00 <iekku> high, theme?
07:03:21 <Stskeeps> :nod:
07:03:27 <Sage_> theme or libmeegotouch not sure which
07:03:34 <Stskeeps> let's start in libmtf
07:03:36 <Sage_> but yes aI agree
07:04:28 <iekku> hmm, can't find libmtf component :o
07:04:47 <Sage_> iekku: we don't have all the components atm. I pinged you last weeks about that ;)
07:05:17 <Sage_> iekku: maybe adding one or adding to other in middleware for now
07:05:34 <Sage_> I prefer second so we can continue faster
07:05:47 <iekku> Sage_, give me needed info after meeting, i will create that
07:06:09 <iekku> #info high, needs to be moved to libmeegotouch component
07:06:21 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=327 Settings application crashes while trying to open wifi option from it
07:06:22 <Merbot> 04Bug 327: critical, Undecided, ---, need-triage, NEEDINFO, Settings application crashes while trying to open wifi option from it
07:06:42 <Sage_> I would close, but needs testing
07:06:57 <iekku> i don't have device for testing currently
07:08:27 <Stskeeps> isn't that an old bug?
07:08:27 <Sage_> yes
07:08:27 <Stskeeps> can be closed, reporter can try with newst imge
07:08:27 * Sage_ agrees
07:08:27 <iekku> :nod:
07:08:27 * deztructor tried, it is ok
07:08:27 <iekku> #info closing. reporter can try with newst imge
07:08:27 <Sage_> deztructor: thx
07:08:28 <iekku> deztructor, could you please add comments and close?
07:08:37 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=328 Dialer application is not opening
07:08:38 <Merbot> 04Bug 328: critical, Undecided, ---, need-triage, NEEDINFO, Dialer application is not opening
07:08:39 <deztructor> iekku: ok
07:09:03 <Sage_> Verified that works now
07:09:09 <Sage_> 328 that is
07:09:12 <Sage_> I can comment
07:09:20 <iekku> #info works now
07:09:23 <iekku> thanks guys
07:09:33 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=393 [FEA] Ability to merge multiple contacts to one
07:09:34 <Merbot> 04Bug 393: normal, Undecided, ---, need-triage, NEW, [FEA] Ability to merge multiple contacts to one
07:10:06 <Sage_> Would say low atm.
07:10:14 <iekku> :nod:
07:10:19 <iekku> #info low
07:10:27 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=395 [FEA] Ability to remove multiple contacts at once
07:10:27 <Merbot> 04Bug 395: normal, Undecided, ---, need-triage, NEW, [FEA] Ability to remove multiple contacts at once
07:10:47 <Sage_> low as well
07:10:56 <iekku> #info low
07:11:03 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=397 Going to full screen mode and back isn't possible when user has zoomed image
07:11:04 <Merbot> 04Bug 397: normal, Undecided, ---, need-triage, NEW, Going to full screen mode and back isn't possible when user has zoomed image
07:11:27 <Sage_> normal or high very annoying imo.
07:11:48 <Sage_> as the fuctionality changes suddently while using gallery
07:12:24 <iekku> high
07:13:25 <iekku> hmmm, 218 is related and it's normal
07:13:30 <iekku> https://bugs.nemomobile.org/show_bug.cgi?id=218
07:13:31 <Merbot> 04Bug 218: enhancement, Normal, ---, not-taken, NEW, Full image view toolbar should autohide.
07:14:57 <iekku> see comment 3 in bug 397
07:14:58 <Merbot> 04Bug https://bugs.merproject.org/show_bug.cgi?id=397 task, Normal, ---, carsten.munk, ASSIGNED, Package sp-endurance for endurance testing
07:14:59 <Sage_> I would say not entirely same thing. 397 is about tapping and reappearing bars and 218 is autohide after X seconds
07:15:33 <iekku> :nod:
07:15:35 <Sage_> iekku: yes, it says do 218 first and then 397 :)
07:15:58 <iekku> that's why i wondered can we set 397 high, as 218 isn't
07:16:03 <iekku> but i think we can
07:16:22 <Stskeeps> 397 can be closed
07:16:52 <iekku> Stskeeps, ?
07:17:10 <Sage_> Stskeeps: that merbot gave url to mer bug in a middle
07:17:12 <Stskeeps> ah
07:17:17 <Sage_> we should really fix that
07:17:24 <Sage_> and start using NEMO# MER# etc.
07:17:41 <Sage_> bug X should not do anything
07:17:48 <iekku> :nod:
07:17:56 <Sage_> dm8tbr: ^ ;)
07:18:13 <iekku> back to 397, high? and moving on?
07:18:20 <Sage_> sure
07:18:36 <iekku> #info high
07:18:41 <Sage_> 218 is extra feature and 397 is bug
07:18:45 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=398 Contacts is not able to find e-mail icon
07:18:45 <Merbot> 04Bug 398: normal, Undecided, ---, need-triage, NEW, Contacts is not able to find e-mail icon
07:19:25 <Sage_> not sure where is the problem but everything should be fine
07:19:44 <iekku> seems odd
07:20:13 <iekku> normal?
07:20:27 <dm8tbr> Sage_: that's due to change with the move, new bug module
07:20:45 <Sage_> iekku: fine by me.
07:21:03 <iekku> #info normal
07:21:14 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=399 Gallery is flooding debug messages to .xsession-errors
07:21:14 <Merbot> 04Bug 399: normal, Undecided, ---, need-triage, NEW, Gallery is flooding debug messages to .xsession-errors
07:21:17 <dm8tbr> Sage_: as announced a couple of weeks ago. sadly not much spare time for that, but at least now I have the necessary accounts on mer infra I guess...
07:23:06 <Sage_> iekku: should be in nemo-qml-components component in middleware and personally would say high as writing to disk contantly isn't a good thing.
07:23:30 <iekku> :nod:
07:24:10 <iekku> we don't have nemo-gml-component either, just qt-components
07:24:25 <iekku> can that be used?
07:24:44 <Sage_> iekku: totally different thing
07:24:55 <Sage_> iekku: need to create component for it as well
07:24:59 <iekku> :nod:
07:25:17 <iekku> #info high, to QML-component
07:25:22 <Sage_> no :)
07:25:36 <Sage_> nemo-qml-components ;)
07:25:49 <iekku> #info high, to nemo-qml-component
07:25:51 <iekku> :D
07:26:02 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=401 Error message printed when rotating device from landscape to portrait
07:26:03 <Merbot> 04Bug 401: normal, Undecided, ---, need-triage, NEW, Error message printed when rotating device from landscape to portrait
07:26:03 <Sage_> iekku: you really have a filter today ;)
07:26:11 * Sage_ points the missing s in that
07:26:17 <Sage_> ;)
07:26:32 <iekku> heh
07:27:01 <Sage_> this goes to same category than the one before extra io usage, however this is more rare, so normal
07:27:31 <iekku> same component as well?
07:27:59 <Sage_> no, it is in right component atm.
07:28:16 <iekku> #info normal
07:28:25 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=403 Not able to scroll photos with scrollbar
07:28:26 <Merbot> 04Bug 403: normal, Undecided, ---, need-triage, NEW, Not able to scroll photos with scrollbar
07:28:56 <Sage_> task, normal or high I would say.
07:29:06 <Sage_> I tested with 500 photos and it was pain to get to the end ;)
07:29:29 <iekku> high - task then
07:29:55 <iekku> #info high - task
07:30:02 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=404 Double tap zoom in doesn't work in gallery
07:30:04 <Merbot> 04Bug 404: normal, Undecided, ---, need-triage, NEW, Double tap zoom in doesn't work in gallery
07:30:33 <Sage_> for n900 this is quite essential :)
07:30:58 <Sage_> normal?
07:31:21 <iekku> :nod:
07:31:24 <iekku> #info normal
07:31:32 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=405 Calculator is outputting debug information to filesystem
07:31:32 <Merbot> 04Bug 405: normal, Undecided, ---, need-triage, NEW, Calculator is outputting debug information to filesystem
07:32:13 <iekku> normal or high?
07:32:21 <Sage_> high it is caused by every press
07:32:27 <iekku> :nod:
07:32:31 <iekku> #info high
07:32:31 <deztructor> flooding of FS - high
07:32:39 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=407 Desktop files in Nemo have errors that should be fixed
07:32:39 <Merbot> 04Bug 407: normal, Undecided, ---, need-triage, NEW, Desktop files in Nemo have errors that should be fixed
07:33:26 <Sage_> Didn't want to file one liner bugs for each of them :)
07:33:39 <iekku> understand well :)
07:33:42 <deztructor> normal?
07:33:59 <Sage_> yes, there was one more critical error in the group though
07:34:08 <Sage_> err... two
07:34:09 <Sage_> /usr/share/applications/org.formeego.apps.desktop: error: (will be fatal in the future): value "X-MeeGo;" for key "Categories" in group "Desktop Entry" does not contain a registered main category
07:34:18 <Sage_> will be fatal in the future doesn't sound good :D
07:34:43 <iekku> should those have own bugs? or
07:34:58 <Sage_> I think it is fine. Also normal is ok.
07:35:04 <iekku> ok
07:35:07 <iekku> #info normal
07:35:17 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=409 Messages should exit when no windows and no channels are open
07:35:17 <Merbot> 04Bug 409: normal, Undecided, ---, need-triage, NEW, Messages should exit when no windows and no channels are open
07:35:17 <Sage_> It is relatively small task just manual work
07:36:11 <iekku> high
07:36:33 <Sage_> sure, extra memory usage
07:36:42 <iekku> major?
07:37:10 <Sage_> yes, not critical
07:37:14 <iekku> :nod:
07:37:18 <iekku> #info high-major
07:37:33 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=411 UX startup guide for first boot
07:37:34 <Merbot> 04Bug 411: normal, Undecided, ---, need-triage, NEW, UX startup guide for first boot
07:38:07 <iekku> normal-task?
07:38:34 <Sage_> :nod:
07:39:15 <iekku> #info normal-task
07:39:24 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=416 When updating device at times screen goes blank and user is unable see what happens
07:39:24 <Merbot> 04Bug 416: normal, Undecided, ---, need-triage, NEW, When updating device at times screen goes blank and user is unable see what happens
07:39:54 <iekku> high-major?
07:40:10 <Sage_> I think I fixed that
07:40:45 <deztructor> retest?
07:41:18 <Sage_> not in image yet
07:41:26 <Sage_> made a comment there it is in mer review atm.
07:41:45 <iekku> so, lets set it as a high-major and Sage_ can take it?
07:41:59 <Sage_> iekku: sure
07:42:16 <iekku> #info high-major and Sage_ taking
07:42:49 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=417 no TV signal on N900
07:42:50 <Merbot> 04Bug 417: normal, Undecided, ---, need-triage, NEW, no TV signal on N900
07:42:56 <iekku> summary is missleading
07:43:47 <Sage_> depends who reads it :)
07:44:31 <deztructor> high? missing feature as a result
07:45:28 <iekku> +1 for high, is this task?
07:45:59 <deztructor> maybe
07:47:22 <Sage_> sure
07:48:00 <iekku> #info high-task
07:48:09 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=418 Display goes to sleep while playing video
07:48:10 <Merbot> 04Bug 418: normal, Undecided, ---, need-triage, NEW, Display goes to sleep while playing video
07:48:47 <iekku> high
07:49:01 <Sage_> :nod:
07:49:26 <iekku> i would say major also
07:49:42 <iekku> very very very annoying from user point of view
07:50:05 <Stskeeps> sounds like bad qmsystem/mce integration
07:50:57 <Sage_> iekku: agreed
07:51:06 <iekku> 3info high-major sounds like bad qmsystem/mce integration
07:51:27 * Sage_ gives iekku a shift key
07:51:35 <iekku> #info high-major sounds like bad qmsystem/mce integration
07:51:46 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=419 lipstick should set _MEEGOTOUCH_VISIBLE_IN_SWITCHER
07:51:47 <Merbot> 04Bug 419: normal, Undecided, ---, need-triage, NEW, lipstick should set _MEEGOTOUCH_VISIBLE_IN_SWITCHER
07:51:48 <Sage_> \o/ it worked ;)
07:52:46 * Sage_ doens't have comments on this (cc: w00t)
07:53:52 <iekku> no w00t :(
07:54:18 <iekku> skipping this?
07:54:37 <iekku> #info skipped
07:54:44 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=420 Clicking on Connections->GPRS APN crashes the settings app
07:54:44 <Merbot> 04Bug 420: normal, Undecided, ---, need-triage, NEW, Clicking on Connections->GPRS APN crashes the settings app
07:55:32 <Sage_> this app needs rewrite and integration to the common connection cp applet
07:55:49 <iekku> high-critical?
07:55:51 <Sage_> sure
07:56:57 <iekku> #info high-critical. This app needs rewrite and integration to the common connection cp applet.
07:57:04 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=421 Homescreen uses excessive CPU in the background
07:57:05 <Merbot> 04Bug 421: normal, Undecided, ---, need-triage, NEW, Homescreen uses excessive CPU in the background
07:57:37 <iekku> high - major?
07:57:44 <Sage_> yes
07:57:46 <deztructor> :nod:
07:58:13 <iekku> #info high-major
07:58:15 <iekku> #topic https://bugs.nemomobile.org/show_bug.cgi?id=423 Bluetooth doesn't work in VirtualBox
07:58:16 <Merbot> 04Bug 423: normal, Undecided, ---, need-triage, NEW, Bluetooth doesn't work in VirtualBox
07:58:43 <Stskeeps> wellllll.
07:58:44 <Stskeeps> :P
07:58:47 <Sage_> err... :)
07:58:58 <deztructor> hmm
07:58:58 * Stskeeps twitches
07:59:05 <iekku> high-critical invalid?
07:59:07 <iekku> :P
07:59:08 <Stskeeps> well
07:59:16 <Stskeeps> moment, when i try to stop panicing
07:59:42 <deztructor> does virtualbox expose host bluetooth?
07:59:44 <deztructor> :)
07:59:47 <Stskeeps> i think it might be valid but only if its' a USB stick connected
07:59:49 <Stskeeps> to the VM itself
07:59:50 <Sage_> actually there is valid bug in that as well
07:59:53 <Stskeeps> and i didn't see any bugs in there
08:00:01 <deztructor> it exposes usb
08:00:06 <Sage_> I had problems in snowball that bluetoothd doesn't start automatically
08:00:23 <Sage_> so that is part 1, but then having adapter in vm is another thing
08:00:44 <Stskeeps> NEEDINFO and what sage said?
08:00:47 <deztructor> maybe needinfo? conditions can be usb BT stick...
08:01:17 <iekku> Stskeeps, could you please comment?
08:01:56 <Sage_> well, we might not want bluetoothd to start automatically. But it should start at least when bluetooth test scipt are executed or so.
08:02:01 <iekku> #info needinfo
08:02:19 <Sage_> also connman has hands in that "mess"
08:02:40 <iekku> Sage_, could you also add comments?
08:03:11 <iekku> oh, we run out of time already
08:04:00 <Sage_> iekku: let see first the comment to Stskeeps's comment
08:04:05 <iekku> extra meeting on wed?
08:04:14 <Sage_> sure
08:04:27 <iekku> ok, thanks
08:04:36 <iekku> #action iekku to create new components
08:04:46 <Sage_> iekku: I can point out what are needed at least
08:05:01 <iekku> #action iekku to set extra bug triage on Wednesday
08:05:15 <iekku> Sage_, let's continue at #nemo
08:05:19 <iekku> #endmeeting