12:00:18 <E-P> #startmeeting Mer QA meeting 27/09/2012
12:00:18 <Merbot> Meeting started Thu Sep 27 12:00:18 2012 UTC.  The chair is E-P. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
12:00:18 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:00:28 <E-P> #topic Current status
12:00:48 <Stskeeps> o/
12:01:34 <Stskeeps> #info Began work to make blts tests more non-root suitable
12:01:58 <E-P> #info timoph has created rich-core for mer. It can be found from timoph's obs home. It isn't compatible with the maemo/meego version. Documentation still missing.
12:02:42 <Stskeeps> i'll be also spending some more time on getting tests running in the coming future, as well
12:02:47 <Stskeeps> so we can get things properly tested
12:03:19 <E-P> are you executing tests on hw or vm?
12:04:01 <Stskeeps> a bit of both
12:04:22 <E-P> good
12:05:02 <Stskeeps> i've used blts-opengles2 on hw successfully to weed out some bugs as well
12:05:06 <Stskeeps> which was really nice to have available
12:05:59 <Stskeeps> so that will probably also be a standard test
12:06:42 <E-P> we would need more that kind of test assets
12:07:17 <E-P> yunta: any updates from your side? about test automation?
12:07:55 <yunta> not really, maybe kontio has something
12:08:19 <kontio> nope
12:08:39 <yunta> ah, I raised about 10 qa-related bugs in #nemomobile, some of them may be mer-relevant
12:08:49 <Stskeeps> yes, some QA work has started in nemo too as well
12:09:08 <E-P> #info some QA work has started in nemo
12:09:13 <yunta> s/#nemomobile/nemo bz/
12:09:25 <E-P> what is the status of qareports?
12:09:37 <Stskeeps> i think infrastructure things got a bit pushed forward
12:10:00 <Stskeeps> as lbt had to flee UK for a week ;)
12:10:24 <Stskeeps> so we're still waiting to deploy auto-QA
12:10:30 <Stskeeps> but we also need more test cases, so
12:10:35 <iekku> o/
12:10:52 <E-P> ok, would be nice to have the place where to put test results
12:10:57 <Stskeeps> yes
12:10:59 <E-P> easier to share the current status
12:11:19 <E-P> and see the development of test cases
12:11:58 <phaeron> sorry , too many meetings at the same time
12:12:00 <Stskeeps> :nod:
12:12:07 <E-P> phaeron: no problem, welcome
12:12:08 <Stskeeps> we were discussing qa-reports as well
12:12:21 <Stskeeps> as a way to share current status and see development of test cases
12:13:10 <phaeron> yeah nothing new , it needs a vm to be deployed , but lbt and I were way too busy to get on it
12:13:19 <Stskeeps> ok
12:13:26 <phaeron> however with the new imager up , I can get vm_testing + qa reports up in a day
12:13:36 <phaeron> so at least we did *something* :D
12:13:39 <Stskeeps> sounds good
12:13:44 <E-P> heh, nice
12:14:55 <Sage_> o/ sry for being late (as usual)
12:16:00 <E-P> when setting up the qa-reports, we should discuss how to name the targets to the qa-reports
12:16:22 <Sage_> E-P: targets?
12:16:54 <E-P> meaning, do we put just arm, or armv5l, and for i386 or just intel
12:17:20 <Sage_> tagets should be named similarly as mer architectures
12:17:24 <Stskeeps> ah, i think we can go with armv6l/armv7l/armv7hl/i486/i586 / mipsel and then what hw adaptation we're on, maybe
12:17:40 <Sage_> https://wiki.merproject.org/wiki/OBS_architecture_naming <- mer port names
12:18:04 <phaeron> well I guess latest / next , arch , <CI / release>
12:18:46 <Sage_> not sure if we need latest/next there as CI/release already points that out
12:19:00 <E-P> we should have this as a topic for the next meeting?
12:20:09 <phaeron> CI is the per gerrit change
12:20:28 <phaeron> release is when a new release comes out
12:20:41 <phaeron> what else do we have ?
12:21:02 <Stskeeps> well, per gerrit change, snapshots of post-integration, prereleases, and releases
12:21:06 <Sage_> oh, I though CI/release ment mer version
12:21:22 <Sage_> mer version as in one from http://releases.merproject.org/releases/
12:22:00 <phaeron> I think Stskeeps wants visibility per change ( or collection of changes at least ) before creating prerelease
12:22:15 <Stskeeps> ideally we'll be running some degree of test sets on per change
12:22:30 <Stskeeps> so we'll catch late night stskeeps coding before it makes it into production
12:22:35 <Sage_> Sure
12:22:51 <phaeron> then actual prereleases go to next
12:23:01 <Stskeeps> :nod:
12:23:27 <phaeron> snapshots of post-integration : I didn't know there was that
12:23:38 <Stskeeps> that's our 0.0.1 , 0.0.2 stuff
12:23:42 <Stskeeps> 0.1 is a prerelease
12:23:45 <Stskeeps> .1 is a full release
12:23:51 <phaeron> but I think it is redundant if we do testing during the actual changes
12:23:58 <phaeron> so either or IMHO
12:24:01 <Stskeeps> yeah, it might be, but still good to check
12:24:05 <Stskeeps> as sometimes things go wrong
12:24:05 <Stskeeps> :P
12:24:28 <Sage_> I was orignally thinking only testing for .0.0.x, .0.x and .x
12:24:43 <Stskeeps> Sage_: it's better to catch in review phase
12:24:48 <Stskeeps> gives a more dynamic flow
12:24:51 <Sage_> true
12:24:58 <Stskeeps> and you can assess where the damage actually came from
12:25:13 <Sage_> which brings me to the point how to make submit to tests assets and packages at the same time in gerrit?
12:25:29 <Sage_> as some changes needs more than one package
12:28:22 <E-P> how that is done currently?
12:28:24 <phaeron> yeah gerrit is suboptimal :D
12:29:10 <Stskeeps> gerrit's what we use, and there's something called topic branches we might be able to utilize for such a scenario
12:30:02 <Stskeeps> or simple have a "also-needs:" header our BOSS process can uuse
12:30:04 <Stskeeps> nothing impossible
12:30:20 * phaeron hides
12:30:33 <Stskeeps> no hiding, we're in public
12:30:34 <Stskeeps> :P
12:31:08 <E-P> we should collect risk items to somewhere
12:31:46 <Stskeeps> did we have a COBS project for collecting working test cases, btw?
12:32:25 <E-P> hmm...
12:32:42 <Stskeeps> or what did we decide in that area
12:32:49 <kontio> could we have the test run as a voter in gerrit, so it takes the request, builds it, tests it in vm, and gives a vote when ever it passed or not?
12:32:53 <E-P> I think not, a long time ago we decided the project
12:32:59 <Stskeeps> kontio: http://review.merproject.org
12:33:03 <Stskeeps> kontio: check out some sample executions
12:33:12 <E-P> Stskeeps: just a sec
12:34:21 <phaeron> Stskeeps: I am still using E-P's home project for smoke tests
12:34:25 <kontio> Stskeeps, Automation Single Build Checker just checks when ever it builds? or does it do a "make check" ? for the unit test?
12:34:34 <phaeron> but a lot are broken
12:34:38 <Sage_> phaeron, Stskeeps: I would suggest that we take the per commit in to account when planning the structure but forget it before we have the others done?
12:35:02 <phaeron> so yes it would be very useful to start promoting working test suites to a higher level project
12:36:33 <Stskeeps> kontio: ASBC basically runs your package on it's own and checks if it builds on all targets, another on is dependency buildch checker which includes your package and rebuilds everything that's depending on it
12:36:42 <Stskeeps> kontio: a next step from those repos would naturally be to run image builds and tests
12:37:12 <kontio> Stskeeps, yeah that is what I meant :-)
12:37:37 <E-P> for some reason the old meeting minutes don't work
12:37:56 <Stskeeps> they're now on a new url
12:37:57 <Stskeeps> sec
12:38:02 <E-P> but if I remember correctly, the project should be Mer:QA:Tests[:Testing]
12:38:25 <Stskeeps> ok
12:38:35 * Stskeeps looks in cobs
12:39:21 <phaeron> there is no such project on cobs
12:39:23 <E-P> it doesn't exist, so please create :)
12:39:28 <Stskeeps> yeah
12:39:31 <Stskeeps> i'll create it
12:39:32 <phaeron> ah
12:39:53 <E-P> I wrote a guideline for those projects, I just have to find them
12:40:22 <Stskeeps> http://merproject.org/meetings/mer-meeting
12:42:00 <Stskeeps> i'll ask lbt to create Mer:QA:Tests
12:42:13 <Stskeeps> and i guess we can go through each testset with guidelines and add them there?
12:42:50 <E-P> http://merproject.org/meetings/mer-meeting/2012/mer-meeting.2012-05-24-12.00.html
12:42:53 <E-P> yes
12:43:01 <Stskeeps> #action Mer:QA:Tests to be created
12:43:09 <Stskeeps> #action lbt Mer:QA:Tests to be created
12:43:22 <lbt> done
12:43:27 <Stskeeps> thanks
12:43:39 <E-P> https://wiki.merproject.org/wiki/index.php?title=Quality/Development&oldid=2011
12:43:45 <Sage_> when moving to new obs could we start using only lowlever project names? :)
12:43:48 <Stskeeps> lbt: and me as maintainer too?
12:43:53 <lbt> yep
12:44:19 <phaeron> I hope we can agree on how to mark test packages as automatic , manual , needs special hardware bla bla
12:44:33 <Stskeeps> should be possible
12:44:45 <phaeron> otherwise it's be the same mess in that project
12:45:32 <E-P> phaeron: somewhere else than to test-definition?
12:46:27 <Stskeeps> i think it was discussed a while back
12:46:45 <phaeron> anyway we agree on is fine
12:47:00 <Stskeeps> and i didnt come up with anything better than what was suggested, so in 'show me the code' style, the proposal back then becomes the direction..
12:47:58 <E-P> should we go to the next topic?
12:48:47 <Stskeeps> yes
12:48:52 <E-P> #topic Changes in QA tech lead role
12:49:13 <E-P> as I wrote to the mailing list, would be better to select a new tech lead
12:49:51 <Stskeeps> i think we'll go by merit and select when persons show this within the area
12:50:29 <Stskeeps> would phaeron perhaps be interested in being temporary lead of this area until a new one is found, or him?
12:50:53 <E-P> I think that phaeron would be a good one, if you are interested
12:51:01 <Stskeeps> just so we keep the area going forward and somebody who can whip a bit
12:51:14 * phaeron shivers
12:52:04 <Stskeeps> i think we broke phaeron :)
12:52:25 <E-P> someone should invent the cloning machine
12:52:26 <phaeron> temporarily ok and if I don't screw up or someone else comes up then I can continue
12:52:32 <Stskeeps> yep
12:52:36 <E-P> great!
12:52:47 <Stskeeps> #info phaeron as temporarily QA lead
12:53:35 <E-P> I will be hanging on the channel, so you can always ask me
12:53:53 <phaeron> E-P: thanks
12:54:47 <E-P> good, anything else for today?
12:56:07 <phaeron> no from me :D
12:56:18 <E-P> ok, thanks for all
12:56:22 <Stskeeps> thank you E-P for your service
12:56:27 <Stskeeps> and contributions :)
12:56:29 <E-P> it was my pleasure
12:56:31 <phaeron> thanks E-P for getting us here
12:56:39 <iekku> E-P, don't leave us totally, please :)
12:56:59 <E-P> iekku: I won't :) but I am going to be hell busy next weeks/months
12:57:11 <iekku> we need clones!
12:57:40 <E-P> #endmeeting