13:32:44 <notmart> #startmeeting move of Plasma Active to build.merproject.org
13:32:44 <Merbot> Meeting started Tue Mar 19 13:32:44 2013 UTC. The chair is notmart. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
13:32:44 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:33:12 <lbt> Hi
13:33:28 * notmart is here
13:34:36 <notmart> others? aseigo, Beineri, Sage?
13:34:44 * Beineri is present
13:35:40 <lbt> I think Sage may be unwell today
13:36:03 <notmart> ok
13:36:08 * notmart wishes him well
13:38:10 <notmart> so, mainly two things, procedure to actually do the move and status of the new workers for the servers
13:39:08 <notmart> one thing that was said was that is probably wise to follow the same naming scheme of nemo
13:39:31 <notmart> so btw, what is the satatus of the migration of nemo to the new obs? is complete? still in progress?
13:39:50 <lbt> #topic Move PA projects from MeeGo COBS to Mer COBS
13:39:58 <lbt> (just fwiw)
13:42:37 <lbt> So who was doing the migration?
13:43:22 <notmart> for pa we still didn't do anythin (apart a copy of the current packages in my home project)
13:44:13 <notmart> was pretty much waiting nemo definitely up and running, then starting to give to it the same structure
13:44:22 <lbt> fair enough
13:44:43 <notmart> will be done probably by me, Beineri, mdfe (that couldn't be present today)
13:44:45 <lbt> worth identifying someone with the task though - so they can plan+report
13:44:49 <lbt> :)
13:44:51 <dm8tbr> lbt: can you op merbot?
13:48:41 <notmart> lbt: i can be on it
13:49:09 <lbt> So Nemo migration is well under way
13:49:18 <notmart> but particular things/ workflows that should be used?
13:50:01 <notmart> we used in the past a certain workflow, is an occasion to change it a bit, always depends how much..
13:50:01 <lbt> in terms of devel/testing ?
13:50:16 <lbt> OK
13:51:04 <lbt> if you like how Nemo operates with boss doing some validation and trial builds then it would make it easier to use if you have the same project layout/naming
13:51:07 <notmart> in part, in part i just have some doubts on how to both create and maintain the repos in the various "stages"
13:51:18 <lbt> additionally it would help when sharing code
13:51:31 <lbt> Sage has scripts that do that
13:51:39 <notmart> is, for instance nemo done with some ci per se, just osc copypac of packages from one to another when stable, or..?
13:52:26 <notmart> as just general structure i would do:
13:52:32 <lbt> so nemo is going to move towards the model we've evolved in jolla (which is based on Nemo/Mer in the first place)
13:52:42 <lbt> currently Nemo is not perfect
13:52:52 <lbt> the new structure is much better
13:53:00 <lbt> it is still SR based
13:53:01 <notmart> using all nemo:hw:foo when possible
13:53:11 <notmart> ideally havng just kde:mw and kde:ux
13:53:19 <lbt> yep, OK
13:53:47 <lbt> Nemo will also move to more ci/automation too
13:53:54 <notmart> kde:mw is pretty much what's in kde:mer_extras in meego cobs (ideally with less packages, but removing eventual duplications after)
13:53:55 <lbt> as well as being git-based
13:54:09 <lbt> right
13:54:12 <notmart> then kde:ux, basically what's now in kde:devel
13:54:45 <notmart> to be git based, should it use a particular server?
13:55:15 <lbt> I suggest writing this out as per https://wiki.merproject.org/wiki/Nemo/OBS
13:55:18 <notmart> right now we just use osc and a jenkins that uploads tarballs for ci (on devel)
13:55:38 <lbt> right - I have a tool called gitpkg which we use in Mer:Tools
13:55:53 <lbt> it pulls a git repo in and runs git archive locally
13:56:00 <lbt> makes uploads easy
13:56:08 <lbt> I have whitelist of git services
13:56:25 <lbt> github, gitorious, mer (not online yet)
13:56:45 <lbt> mer will be using gitlab soon
13:57:01 * notmart not really convinced yet on using git for packages
13:57:27 <lbt> you will be when your users get bored uploading tarballs :)
13:57:43 <lbt> but that's not a dependency
13:57:51 <lbt> just an FYI on how nemo works
13:59:00 <notmart> yeah, and may get to it (personally would like to do one thing at a time)
13:59:49 <notmart> but please tell if there is something that you would really prefer not happening in the new server..
14:00:19 <lbt> our main concern is likely to be load-based rather than storage
14:01:04 <lbt> so things like only building on minimal # arches in the early phases
14:01:14 <lbt> (if possible)
14:01:23 <notmart> sure
14:01:46 <lbt> also trying to coordinate on big updates which cause load spikes
14:02:12 <notmart> and as i said i would also create only the deel stage at first, so testing and stable would be bult for the first time only when actually needed
14:03:11 <notmart> sure
14:03:57 <lbt> so is there an action to duplicate the Nemo/OBS page for PA ?
14:05:06 <notmart> i can do it
14:05:59 <notmart> provided it will be at first very draft and will evolve with time on an agreed form
14:06:09 <lbt> wiki :)
14:06:22 <lbt> you can #action yourself
14:07:39 <notmart> #action notmart create a page like https://wiki.merproject.org/wiki/Nemo/OBS for Plasma Active
14:09:53 <notmart> so, from my part i'll do, 1) wiki page 2) kde:devel:mw and kde:devel:ux repos on the repo with packages coming from meego cobs
14:10:13 <notmart> (building only against i586 at first for testing)
14:11:01 <lbt> i586 = atom - i486 = generic x86
14:12:19 <notmart> so far our x86 images were just atom since targeted pretty much wetab,exopc
14:12:36 <lbt> fine - just clarifying
14:12:51 <lbt> Sounds like we have some tasks for the week then
14:13:01 <lbt> s/we/you/ :)
14:13:01 <notmart> sure
14:13:23 <lbt> next topic? New servers?
14:13:54 <notmart> #action notmart create kde:devel:mw and kde:devel:ux from meego cobs packages
14:15:39 <aseigo> lbt: we covered that last week?
14:15:46 <lbt> yep
14:15:47 <aseigo> or is there new news on new servers? :)
14:15:49 <lbt> nope
14:16:00 <aseigo> you got my email, yes?
14:16:07 <lbt> yes
14:16:09 <lbt> which is all I was really going to say :)
14:16:10 <aseigo> yay!
14:16:20 * aseigo is pleased at the internets, then.
14:16:32 <notmart> ok, so this is pretty much covered as well i gather?
14:16:37 <lbt> essentially I'm sorting out the finances - servers take an hour or so to come online
14:17:02 <notmart> at this point, if nobody has anything to add i would say that's pretty much it
14:17:03 <lbt> #info servers not ordered yet but only take an hour or so to come online so no problems there
14:17:17 <notmart> then next week we can see how will be working so far..
14:17:43 <lbt> yes - and you can bug Sage and I for scripts when we have a spare few mins
14:18:31 <notmart> ok
14:18:51 <notmart> so btw at this point i would aim pa4 release from the new server already
14:19:03 <aseigo> that would be best it hink
14:19:20 <aseigo> otherwise we need to handle the case where people install with repos on the old systems .. and then have to change to the new ones
14:19:42 <aseigo> will already be frustrating for people running PA3, i imagine
14:19:56 <lbt> FYI - I got an email from intel about shutdowns starting today with some VMs
14:20:01 <notmart> that also means we are pretty much frozen, so after the initial huge spike for building everything there shouldn't be much rebuilding work for a while
14:20:03 * aseigo wishes the relevant meego.com domain names would forward to the new community obs
14:20:25 <lbt> aseigo: meego.com is owned by linux foundation ... a nice public request?
14:20:50 <aseigo> oh, and this is a topic we'll need to hammer down in future, not necessarly now .. -> the mer-project.org domains and ones relevant to the OBS
14:21:07 <lbt> yep ... http://releases.nemomobile.org/
14:21:19 <lbt> proxied to mer repo server
14:21:32 <aseigo> we need to lay out formally a disaster plan for these resources (so the rest of the world may sleep easily at our feet ;)
14:21:41 <lbt> feel free :)
14:21:52 <notmart> those are repositories from obs or a copy?
14:21:58 <lbt> my plan is "keep lbt alive"
14:22:03 <aseigo> from the business, not the technical, perspective. in particular -> what should happen to the domains if the people currently running them lose interest
14:22:04 <lbt> notmart: a copy
14:22:06 <aseigo> haha
14:22:14 <aseigo> lbt: i support that initiative whole-heartedly
14:22:24 <notmart> eheh :)
14:22:40 * aseigo is reminded of that character in snow crash who has a nuclear device wired to his vital signs
14:23:02 <aseigo> (and therefore gets free protective custody / body guards in every city he passes through)
14:23:16 <aseigo> a cunning plan there, mr. lbt ;)
14:23:27 * lbt bows
14:23:44 <aseigo> anyways .. yeah .. we'll require a protocol that can be followed in case of future business / personal failure
14:24:00 <aseigo> i can spearhead that if needed, though i can't do it until probably may/june
14:24:26 <lbt> I think our initial mer steering group may now be more relevant
14:24:32 <aseigo> "never forget the alamo! er .. meego.com!"
14:24:39 <aseigo> yes, rather relevant i'd think
14:25:02 <lbt> but I think a public approach to LF about meego.com would make sense
14:25:10 <aseigo> that would be the body that should be empowered and given a clear set of protocols vis-a-vis these resources and the community dependent on them
14:25:11 <lbt> specifically the community side
14:26:28 <aseigo> yes, that would be a reasonable thing to do .. an open letter sent to His Executiveness Mr. Zemlin perhaps
14:26:53 <CosmoHill> what about the MeeGo forums and mailing list, would they be transferred over to Mer / archived?
14:27:06 <notmart> signed by mer,nemo,kde etc..
14:27:36 <lbt> eek - no forums
14:28:02 <lbt> I'd say we need things which are likely to be embedded and need to be redirected
14:28:17 <lbt> primarily repos
14:29:57 <notmart> purely technical question... i probably need an admin to create the kde project?
14:30:57 <lbt> err, yes, good point
14:31:12 <lbt> we can take this to #mer
14:31:18 <notmart> ok
14:31:33 <notmart> other things to say in topic of the meeting?
14:31:54 <lbt> #action asiego to prepare draft to LF about handling meego.com domain
14:35:02 <lbt> sounds like we're done
14:35:07 <notmart> yep
14:35:10 <notmart> #endmeeting