#mer-meeting: SailfishOS, open source, collaboration and way forward

Meeting started by cybette at 15:00:07 UTC (full logs).

Meeting summary

  1. 1. Introduction of meeting participants (cybette, 15:00:47)
    1. Carsten Munk, Chief Research Engineer @ Jolla (Stskeeps, 15:00:55)
    2. Thomas Ruecker, a community member (tbr, 15:01:05)
    3. Carol Chen, usually Community chief at Jolla, hatless meeting chair for today. (cybette, 15:01:11)
    4. Aleksi Suomalainen, a community member for Nemomobile (locusf, 15:01:15)
    5. would like to consider myself a community member of mer/nemo projects doing mainly device adaptation work. Other hat, working with a vendor internally on a product based on Mer (vgrade, 15:01:19)
    6. Steph Gosling Sailfish and Nemo community member (stephg, 15:01:21)
    7. Vesa-Matti Hartikainen, Jolla, developing browser (veskuh, 15:01:27)
    8. Basil Semuonov - openrepos founder (BasilSemuonov, 15:01:40)
    9. lbtI look after the public Mer infra, mer-tools and the Mer SDK which provide systems and tools to enable contributions. Systems includes stuff like bugzilla, gitlab, OBS, IMG, BOSS etc etc (lbt, 15:01:53)
    10. Simonas Leleiva, in Mer/Nemo community since 2012, Nemo twitter account maintainer, SailfishForAndroid developer @ Jolla (sledges, 15:02:07)
    11. community member and generally interested in how the Jolla is moving forward into the OSSea (netzvieh, 15:02:19)
    12. Andrea Bernabei, Nemomobile contributor/hacker. Jolla user and supporter (faenil_web, 15:02:33)
    13. Raine Makelainen, Jolla, developing Browser (rainemak, 15:03:04)
    14. VDVsx, SW developer at Jolla, Mer/nemo contributor (VDVsx, 15:03:12)
    15. Mohammed Hassan. SW engineer at Jolla and FOSS hacker (mostly listening *again*) (MSameer, 15:04:40)
    16. Richard Braakman, programmer at Jolla, free software ex-fanatic (rbraakman, 15:04:44)
    17. Winfried Dobbe, just generally interested in Jolla (development) (winfriedd, 15:05:29)
    18. Antti Lähtevänoja, young entrepeneur: mobile repairing, hardware and software. Very interested in Jolla and Sailfish (laehtis, 15:06:03)
    19. stezz/marc - cto; coo, here in spirit, posseses stskeeps to speak officially (Stskeeps, 15:06:08)

  2. 2. Community open source package repository for Sailfish apps (cybette, 15:06:22)
    1. Guilherme Mendes, software developer, interested in SailfishOS (guimendes, 15:06:37)
    2. Intro by tbr, also summarized in email https://lists.sailfishos.org/pipermail/devel/2014-April/004015.html (cybette, 15:08:34)
    3. something a lot like Maemo Extras or Apps for MeeGo (tbr, 15:09:03)
    4. 18:07 < tbr> For reference there was also discussion on the sailfish developer mailing list and on last sunday on #jollamobile (2014-04-20) (cybette, 15:09:23)
    5. Jolla commits to welcoming an installable Chum/Sailfish community repository package into the Jolla Store, which will prompt for 3rd party/untrusted SW and then install, in style of how things have been functioning with maemo.org extras and other initiatives in the past (Stskeeps, 15:11:08)
    6. tbr's number 2 option (Stskeeps, 15:11:25)
    7. this carries weight as a harbour rules exception for this purposes (Stskeeps, 15:11:44)
    8. We believe that it should be endorsed due to the benefit of having a rebuildable and open source collection of software, that we can also use to also verify our own platform while in development and help grow the software ecosystem around SailfishOS (Stskeeps, 15:13:13)
    9. Jolla invites to co-create with our PackageKit/SSU experts to help get this done properly (Stskeeps, 15:15:48)
    10. one problem with the OBS approach is with API keys that might be required to kept secret (tbr, 15:16:15)
    11. I believe though the API key problem is solveable (tbr, 15:16:32)
    12. https://github.com/custodian/orn-warehouse (BasilSemuonov, 15:23:14)
    13. https://github.com/custodian/orn-warehouse (Stskeeps, 15:23:23)
    14. Mer as a project wants to develop this kind of rule processing which it already has as BOSS (lbt, 15:27:07)
    15. http://www.merproject.org/logs/%23jollamobile/%23jollamobile.2014-04-20.log.html#t2014-04-20T16:03:08 log of #jollamobile 2014-04-20 (cybette, 15:30:30)
    16. http://www.twitlonger.com/show/n_1s1fioe (Stskeeps, 15:32:17)
    17. Stskeeps commits as contact person for this (for the moment) (tbr, 15:37:10)
    18. Stskeeps will be Jolla contact for this topic until further notic (cybette, 15:37:16)
    19. both sides to work on their "homework" (tbr, 15:37:23)
    20. where "homework": policies, qa, boss (community). platform, pkcon, etc (jolla) (tbr, 15:37:56)
    21. proposal stands that we collaborate with OpenRepos on the client software for mutual benefit (tbr, 15:38:25)
    22. Jolla to agree some criteria for Chum being 'ready'. Negotiation of actual criteria on irc/email :) (lbt, 15:38:28)
    23. Sync again in 14 days on this topic (Stskeeps, 15:38:56)
    24. ACTION: prepare community side, policies, documentation, qa (tbr, 15:39:16)

  3. 4. Plans on SailfishOS for Android (cybette, 15:40:36)
  4. 3. Closed bits of SailfishOS - why/where/how and relation to open source parts (cybette, 15:40:53)
    1. https://together.jolla.com/question/3014/clarification-of-open-source-policy/#post-id-6768 (Stskeeps, 15:41:45)
    2. sailfish browser became open source since that png (Stskeeps, 15:48:30)
    3. http://releases.merproject.org/~carsten/niceview.png (Stskeeps, 15:48:36)
    4. we are also looking into the state of sociald's OSS status, but no commitment yet that i can say today (Stskeeps, 15:49:40)
    5. Stskeeps says Jolla is looking into how people can contribute back fixes to non-oss licensed UI bits that have e.g. QML openly available on device (tbr, 15:49:57)
    6. Jolla appreciates the community tinkering and is ok with it as long as there are no commercial interests involved (tbr, 15:50:47)
    7. and as long as people understand that care can't help them ;) (tbr, 15:51:12)
    8. at own risk of hair lsos, etc (Stskeeps, 15:51:22)
    9. tinkering as in modifying the non-oss licensed parts of sailfish (tbr, 15:52:22)
    10. distributing patch is ok, whole file is not. (tbr, 15:54:16)
    11. Patches for QML changes are acceptable, but not distribution of whole files (cybette, 15:54:38)
    12. http://forums.webosnation.com/webos-patches/ (Stskeeps, 15:54:40)
    13. Stskeeps says that Jolla also welcomes suggestions to improve middleware apis and closed apis for patches (sledges, 15:59:17)

  5. 4. Plans on SailfishOS for Android (cybette, 16:01:04)
    1. Discussion on Sailfish OS for Android devices (Nexus 4 / S3). Early adopter release 2 was released last week. (cybette, 16:04:02)
    2. one reason for the delay is a bit on legal side (and that takes time); and that we want to make sure not to repeat mistakes of the past, and have a factual path for people doing official sailfishos adaptations (Stskeeps, 16:05:36)
    3. http://github.com/mer-hybris (Stskeeps, 16:05:54)
    4. Sailfish OS on Android is SailfishOS 1.0.5.16 release + hardware adaptation (with same apps and APIs) (cybette, 16:08:06)
    5. < tbr> I see an important topic here: The open source community can and SHOULD step in and replace what necessary (cybette, 16:13:16)
    6. necessary: location, android runtime, keyboard prediction - just to name examples (tbr, 16:14:18)
    7. also necessary: maps replacement (that should be easy, OSM hint hint) (tbr, 16:14:54)
    8. [19:12] <tbr> also when people asked why aliendalvik - well you can write it as OSS, I'd love to see that and I would help with it (MSameer, 16:14:58)
    9. HADK = Hardware Adaptation Development Kit, pronounced "Haddock" (cybette, 16:16:59)
    10. For Android adaptation talk, join #sailfishos on freenode (cybette, 16:17:45)
    11. there is also interest in 'tabletizing' sailfishos (tbr, 16:19:52)
    12. ^ by using e.g. sfiet's pandora patcher (sledges, 16:20:12)

  6. 5. Wrap-up, action items and next meeting (cybette, 16:21:30)
    1. ACTION: cybette to set up next meeting and ask for topics (cybette, 16:22:13)
    2. time slot discussion should happen on mailing list (tbr, 16:22:45)
    3. Qt5.2 not in next update and you can observe WIP at http://github.com/mer-qt according to Stskeeps (tbr, 16:25:45)
    4. next meeting 2014-04-29, time to be discussed on mailing list (tbr, 16:26:35)
    5. HELP: Volunteers wanted for the community repository effort! talk to lbt and tbr on freenode IRC, #sailfishos (tbr, 16:27:54)
    6. yes please (lbt, 16:28:10)
    7. ACTION: Stskeeps to go through backlog from previous meeting for next meeting (tbr, 16:28:24)
    8. http://git.merproject.org (cybette, 16:29:47)
    9. follow mer<-nemo merge on mer-general mailing list (cybette, 16:30:00)
    10. I hope that Jolla keeps up this meeting habit (tbr, 16:30:13)


Meeting ended at 16:30:27 UTC (full logs).

Action items

  1. prepare community side, policies, documentation, qa
  2. cybette to set up next meeting and ask for topics
  3. Stskeeps to go through backlog from previous meeting for next meeting


Action items, by person

  1. cybette
    1. cybette to set up next meeting and ask for topics
  2. Stskeeps
    1. Stskeeps to go through backlog from previous meeting for next meeting


People present (lines said)

  1. Stskeeps (155)
  2. tbr (150)
  3. cybette (70)
  4. lbt (69)
  5. MSameer (32)
  6. BasilSemuonov (22)
  7. sledges (11)
  8. laehtis (9)
  9. stephg (8)
  10. veskuh (7)
  11. rbraakman (6)
  12. vgrade (5)
  13. netzvieh (5)
  14. locusf (5)
  15. Merbot (3)
  16. VDVsx (2)
  17. winfriedd (2)
  18. AL13N_work (1)
  19. rainemak (1)
  20. faenil_web (1)
  21. guimendes (1)
  22. iekku (1)
  23. xmlich02 (1)


Generated by MeetBot 0.1.4.