#mer-meeting: SailfishOS, open source, collaboration: 27-May @ 15:00 UTC
Meeting started by cybette at 15:00:16 UTC
(full logs).
Meeting summary
- 
  - Welcome to another week of SailfishOS OSS and
    collaboration meeting (cybette,
    15:00:26)
 
  - Meeting info and agenda:
    https://lists.sailfishos.org/pipermail/devel/2014-May/004409.html
    (cybette,
    15:00:33)
 
 
- Brief introductions (5 min), prefix your information with #info (cybette, 15:01:00)
  - Andrea Bernabei, nemomobile contributor &
    Jolla user (faenil,
    15:01:24)
 
  - Carol Chen, Community chief at Jolla, hatless
    meeting chair today (would be nice to wear a hat sometimes, hint
    hint) (cybette,
    15:01:24)
 
  - Simonas Leleiva, nemomobile community and jolla
    sailor (sledges,
    15:01:57)
 
  - David Greaves; Mer guy and sailor (lbt,
    15:02:06)
 
  - Kimmo Lindholm, community member, user, toh-hw
    developer (kimmoli,
    15:02:08)
 
  - Jozef Mlich - foursail developer, CZ&SK
    community member (xmlich02,
    15:02:11)
 
  - Iekku Pylkk�, Head of Developer Affairs @
    Jolla, Nemo & Mer community member (iekku,
    15:02:22)
 
  - Lucien XU, sailfish dev, Jolla user, Nemo
    contributor (a bit) (SK_work,
    15:02:29)
 
  - Thomas Perl; Sailor and community member
    (thp,
    15:02:33)
 
  - Steph Gosling, community (stephg,
    15:02:49)
 
  - irc://irc.FreeNode.org:6667/#info
    Chris Lamb community member (FlyingSheep,
    15:03:01)
 
  - Tom Swindell, Sailor and community
    member. (alterego,
    15:03:04)
 
  - Martin Kolman, community developer ( modRana
    navigation system) (M4rtinK,
    15:03:26)
 
  - Steve Jayna, Infrastructure @ Jolla
    (sdjayna,
    15:03:50)
 
  - Javier S. Pedro, community (javispedro,
    15:03:54)
 
  - Sebastian Meyer, community member (netzvieh,
    15:04:06)
 
  - Francesco Vaccaro, Jolla Community Italia
    admin, first time here (fravaccaro,
    15:04:16)
 
  - Fabio Isgrò , sysadmin ... and Jolla phone
    breaker (dr_gogeta86,
    15:04:43)
 
  - Pami Ketolainen, the bugzilla guy and t.j.c
    developer/admin @ Jolla (pketolai,
    15:04:50)
 
  - Robin Burchell, Qt/MW hacker at Jolla and wider
    open source community (w00t,
    15:04:55)
 
  - Tomi Virtanen, Sailor / swtester @Jolla, first
    time here (cobu,
    15:05:14)
 
  - Yuvraaj Kelkar Jolla community (uvatbc,
    15:05:24)
 
  - Eric Le Roux, bugzilla & t.j.c admin
    (eleroux,
    15:05:40)
 
  - Denis Zalevskiy, Jolla, engineer (deztructor,
    15:06:08)
 
 
- Need for separate mailing list or forum? (15 min) (cybette, 15:06:25)
  - There has been active discussions on the
    need/advantages/disadvantages of having a separate mailing list (for
    non-technical topics), a forum, or improving current tools.
    (cybette,
    15:06:33)
 
  - Current situation: Developer mailing list is
    polluted with topics shouldn't be handled there. As David Greaves
    pointed out: "How would we (community, not Jolla) determine the
    line? and what measures do we think should be taken?" (SK_work,
    15:12:01)
 
  - Problem 1: No clear agreed rules for mailing
    list. (SK_work,
    15:12:17)
 
  - Problem 2: Currently only Jolla employers are
    moderator. The "moderators" only moderate things like obvious spam,
    emails posted by non-list-member, etc. but not for off-topic
    content (SK_work,
    15:12:33)
 
  - ACTION: : elect
    community moderators (SK_work,
    15:22:39)
 
  - ACTION: iekku to
    continue discussion and work on solutions to the problems you
    stated (iekku,
    15:22:47)
 
  - ACTION: iekku to
    continue discussion and work on solutions to the problems she
    stated (iekku,
    15:23:04)
 
  - ACTION: : send
    application to developer-care@ for application as a modetaror
    (SK_work,
    15:23:26)
 
  - ACTION: iekku to
    create pad for mailing list rules (iekku,
    15:24:37)
 
  - this topic to be continued... (cybette,
    15:24:54)
 
 
- How to manage internal hacking docs (30 min) (cybette, 15:24:59)
  - discuss about how to manage "hacker docs",
    internal doc that can be helpful when hacking a component
    (cybette,
    15:25:18)
 
  - right now it's difficult for new-comers to
    Mer/Nemo to find out about what is Mer/Nemo and how to contribute.
    need better middleware docs to bring in more contributors
    (cybette,
    15:32:19)
 
  - it could be nice to have guides the people into
    the structure of Nemo/Mer (SK_work,
    15:34:00)
 
  - <+lbt> erm .. we'll officially support
    autodoc based documentation efforts :) (SK_work,
    15:39:42)
 
  - Let's wrap up: same status as previous meeting.
    Jolla will publish its documentation which is autodoc-based
    (faenil,
    15:50:15)
 
  - once that documentation is published we'll see
    its quality, what's missing etc and take actions based on
    that (faenil,
    15:50:35)
 
  - ACTION: Aard is
    working on making the autodoc docs public (faenil,
    15:50:58)
 
  - [17:53] <+Aard> faenil: I said several
    times that overview page of modules will come from me (SK_work,
    15:53:43)
 
 
- More docs: Silica API reference (15 min) (cybette, 15:56:40)
  - discuss about pain points, weakness of the doc,
    what to enhance (from Jolla side), how to contribute (from community
    side) (cybette,
    15:56:47)
 
  - 1. Silica API reference docs are pretty hard to
    use if you are new to QML, and haven't done other QML dev
    (sledges,
    15:59:45)
 
  - 1.1 Many components exists, but you have hard
    time to find methods etc (sledges,
    16:00:08)
 
  - faenil: no. we're still working on some changes
    to make coordinating that kind of work more efficient, the ETA for
    that is '2 weeks'. after that I hope we'll be able to give more
    reliable times (Aard,
    16:00:55)
 
  - 2. proposal on ML to include screenshots in
    docs, what would you think about it? (sledges,
    16:01:00)
 
  - Silica docs can be improved: 1. more examples ?
    2. screenshots ? 3. contributed notes ? (SK_work,
    16:01:03)
 
  - proposal on ML to include screenshots in silica
    reference has several supporting votes
    https://lists.sailfishos.org/pipermail/devel/2014-May/thread.html#4277
    (cybette,
    16:04:04)
 
  - https://sailfishos.org/sailfish-silica/sailfish-application-pitfalls.html
    (SK_work,
    16:06:26)
 
  - https://developer.blackberry.com/native/documentation/cascades/
    (faenil,
    16:10:28)
 
  - <+thp> ok, so the C++ <-> QML
    integration thing has been brought up several times, this is
    something we should definitely have (cybette,
    16:10:47)
 
  - ACTION: Jolla
    developer-care to look into making contribution easier with Silica
    doc improvements (cybette,
    16:12:36)
 
 
- Bluetooth in Sailfish (10 min) (cybette, 16:13:17)
  - ACTION: maybe ask the
    community tow contribute some docs (QML + C++, screenshots)
    etc. (SK_work,
    16:13:18)
 
  - Discuss current problems with Bluetooth in
    Sailfish, possible directions for the future, and how it affects the
    developer picture (cybette,
    16:13:31)
 
  - javispedro notices 3 problems: 1. lack of
    public developer API for Bluetooth, 2. Sailfish & Mer use Bluez4
    which is dead upstream, 3. misc bugs in Jolla HW/Adaptation layer
    preventing some use cases e.g. wifi coexistance (cybette,
    16:16:21)
 
  - on my todo-list to figure out if we can
    compensate  by utilizing community to help us there (sledges,
    16:18:56)
 
  - bluez5 is on Aard's todo-list to figure out if
    we can compensate  by utilizing community to help us there
    (sledges,
    16:19:19)
 
  - QtBluetooth may be usable as an abstraction
    point; needs API verification to make sure a possible 4/5 split
    won't break things (w00t,
    16:22:28)
 
  - w00tikins will follow up with ablasche
    (qtbluetooth maintainer) (w00t,
    16:24:28)
 
 
- Update about chum repos progress if any (3 min) (cybette, 16:24:47)
  - xmlich02 and M4rtinK offering to help with
    chum (cybette,
    16:27:51)
 
 
- ETA for paid-apps support on Store (2 min!) (cybette, 16:28:24)
  - Some devs are not uploading apps to Harbour due
    to lack of support of paid-apps (cybette,
    16:30:16)
 
  - Status during june and paid apps 2H 2014
    (SK_work,
    16:31:25)
 
  - current ETA for stats in harbour is june
    (iekku,
    16:31:31)
 
 
- Next meeting (cybette, 16:34:42)
  - Next meeting Tues June-3 @ 10:00 UTC
    (cybette,
    16:37:52)
 
  - http://piratepad.net/SailfishOSSMeetings
    (stephg,
    16:40:34)
 
  - netzvieh chairperson for next meeting
    (cybette,
    16:40:37)
 
 
Meeting ended at 16:41:04 UTC
(full logs).
Action items
  - : elect community moderators
 
  - iekku to continue discussion and work on solutions to the problems you stated
 
  - iekku to continue discussion and work on solutions to the problems she stated
 
  - : send application to developer-care@ for application as a modetaror
 
  - iekku to create pad for mailing list rules
 
  - Aard is working on making the autodoc docs public
 
  - Jolla developer-care to look into making contribution easier with Silica doc improvements
 
  - maybe ask the community tow contribute some docs (QML + C++, screenshots) etc.
 
Action items, by person
  -  Aard 
    - Aard is working on making the autodoc docs public
 
  
 
  -  iekku 
    - iekku to continue discussion and work on solutions to the problems you stated
 
    - iekku to continue discussion and work on solutions to the problems she stated
 
    - iekku to create pad for mailing list rules
 
  
 
  - UNASSIGNED
    - : elect community moderators
 
    - : send application to developer-care@ for application as a modetaror
 
    - Jolla developer-care to look into making contribution easier with Silica doc improvements
 
    - maybe ask the community tow contribute some docs (QML + C++, screenshots) etc.
 
  
 
People present (lines said)
  - SK_work (159)
 
  - faenil (100)
 
  - cybette (84)
 
  - iekku (56)
 
  - lbt (53)
 
  - javispedro (43)
 
  - sledges (42)
 
  - Aard (35)
 
  - AL13N_work (30)
 
  - kimmoli (29)
 
  - M4rtinK (24)
 
  - stephg (22)
 
  - deztructor (18)
 
  - thp (18)
 
  - w00t (15)
 
  - meegobit (14)
 
  - netzvieh (11)
 
  - dr_gogeta86 (10)
 
  - xmlich02 (7)
 
  - fravaccaro (7)
 
  - FlyingSheep (6)
 
  - alterego (4)
 
  - Sage_ (3)
 
  - Merbot` (2)
 
  - sdjayna (2)
 
  - cobu (2)
 
  - Stskeeps (2)
 
  - eleroux (2)
 
  - uvatbc (1)
 
  - Wnt (1)
 
  - pketolai (1)
 
  - nazanin (1)
 
Generated by MeetBot 0.1.4.