#mer-meeting: SailfishOS, open source, collaboration: 03-June @ 10:00 UTC

Meeting started by netzvieh at 10:00:00 UTC (full logs).

Meeting summary

    1. Welcome to another week of SailfishOS OSS and collaboration meeting (netzvieh, 10:00:05)
    2. Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-June/004454.html (netzvieh, 10:00:05)

  1. Brief introductions (5 min), prefix your information with #info (netzvieh, 10:00:11)
    1. Sebastian Meyer, normally community member, hatless chair today (netzvieh, 10:00:18)
    2. Thomas Ruecker, community member, pushes open source and sometimes chum topics (tbr, 10:00:47)
    3. David Greaves - Mer guy and sailor (lbt, 10:01:02)
    4. Simonas Leleiva, member and sailor (sledges, 10:01:03)
    5. Philippe De Swert, sailor (phdeswer, 10:01:15)
    6. Tommi Keisala, Jolla user and community member (JvD_, 10:01:22)
    7. Steph Gosling, community (stephg, 10:01:38)
    8. Mikko Ahlroth, Jolla user, community member, developer of SailTime (Nicd-, 10:02:05)
    9. Artem Marchenko: Flashlight, Quick Launcher, Night Silence, HelloWorld Pro, etc. Managing iOS and Android apps and mobile sites in day time job. Mostly watching meeting for signs of commercial opportunities hoping to provide a greedy 3rd party dev perspective. (artemma, 10:02:07)
    10. Andrey Kozhevnikov, indie developer, opensource contributor (coderus, 10:02:22)
    11. Leszek Lesner, community member, jolla user, developer (leszek, 10:02:23)
    12. Islam Amer, sailor (phaeron, 10:02:47)
    13. Val�rio, open source contributor, sailor, mostly lurking today (VDVsx, 10:03:03)
    14. Steve Jayna, Infrastructure @ Jolla (sdjayna, 10:03:11)
    15. Karl Granström, sailor (grande, 10:03:17)
    16. Carol Chen, Community bunny @ Jolla (cybette, 10:03:33)
    17. Iekku Pylkkä, Head of Developer Affairs @ Jolla, visiting doctor and will join meeting as soon as she can (cybette, 10:03:52)
    18. Aaron McCarthy, Position/Location, Connectivity, @ Jolla (amccarthy, 10:04:09)
    19. Marko Saukko, sailor (Sage_, 10:04:13)
    20. Niels Breet, Store/services/infra @ Jolla (xfade_, 10:04:16)

  2. Harbour and SailfishOS apps compatibility (30 min) (netzvieh, 10:05:05)
    1. Andrea Bernabei, nemomobile contributor with BIG adsl issues (faenil, 10:05:10)
    2. Basil Semuonov, developer (BasilSemuonov, 10:05:54)
    3. line 27 http://piratepad.net/SailfishOSSMeetings (or the one starting with "Harbour & SailfishOS apps compatibil...") (sledges, 10:06:52)
    4. Statement: Problem with SailfishOS fragmentation is coming. Harbour/Store is not prepared for it. (BasilSemuonov, 10:07:38)
    5. Possible solutions: for SailfishOS itself: Introduce core meta packet(s) with sfos version, which, maybe, depend on target device(or its specs), so apps can depend on it. (BasilSemuonov, 10:08:44)
    6. read full logs for detailed description (cybette, 10:08:50)
    7. for Habour: Add target SailfishOS version/device specs for application, while publishing. (BasilSemuonov, 10:09:02)
    8. API based filtering is in the works on store side (cybette, 10:12:57)
    9. <BasilSemuonov> I submit app with sdl support to harbour. it okay with sfos version >= 1.0.6.x and does not work with 1.0.5.x (netzvieh, 10:27:37)
    10. <xfade_> BasilSemuonov: then you will not see it on 1.0.5.x in Store. That is what we are currently working on (netzvieh, 10:28:04)
    11. harbour automatic checking which sfos version an app supports (netzvieh, 10:29:47)

  3. Update on ambiences and icon themes (10 min) (netzvieh, 10:32:02)
    1. this was an action point for iekku on 2014-05-13 (netzvieh, 10:32:02)
    2. http://www.merproject.org/meetings/mer-meeting/2014/mer-meeting.2014-05-13-10.00.html (netzvieh, 10:32:02)
    3. study is ongoing (iekku, 10:32:19)
    4. Ambiences basically need to have the ambience template added to the SDK. There is a planned task for that. (netzvieh, 10:33:29)
    5. <stephg> ambiences currently cannot by definition pass the current validator (netzvieh, 10:34:26)
    6. <xfade_> Probably needs work on lipstick to properly support icon themes. (netzvieh, 10:38:40)
    7. <Aard> in theory we do have proper icon theme support there (minus ability to switch without reboot), we just didn't test it for a very loooong time. (netzvieh, 10:40:27)

  4. Software sources and packages management build into system (10 min) (netzvieh, 10:42:18)
    1. Software sources and packages management build into system (coderus, 10:43:18)
    2. summary from coderus: 1. UI for managing installed packages. Users should have option to check installed packages versions,informatino about maintainers and all existing information (cybette, 10:50:59)
    3. 2. 3rd party repositories not handled automatically. Packages refresh updating only Harbour repo and not affect 3rd party ones. User will never get upgrade notification (cybette, 10:51:11)
    4. <+xfade_> Sound to me like a perfect community project which can be adapted whenever it reaches a certain quality? (tbr, 10:54:12)

  5. Updates on Action points of last meetings (5 min) (netzvieh, 10:54:29)
    1. <Aard> MSameer: for a fully opensource community-managed app we probably can make an exception. the only problematic part there which I see is elevated privileges for talking to packagekit, it'd just mean additional audit effort on submission to make sure that it does not use anything other elevated (MSameer, 10:54:53)
    2. <Aard> or probably have jolla do the binary build for that (MSameer, 10:55:11)
    3. chum progressing slowly on my side. promoted a couple of apps to chum testing for U5 (tbr, 10:55:27)
    4. autodoc see http://autodoc.merproject.org/ (netzvieh, 10:55:49)
    5. <Stskeeps> netzvieh: we're doing OBS upgrade of mer OBS today, or rather, lbt is banging his head against the wall and doing it (netzvieh, 10:56:02)
    6. community translation tool is still pending. IT team might have some time to work on it soon, but no updates at this pont (cybette, 10:56:23)
    7. @roadmap mail <Aard> netzvieh: so far I've only seen positive feedback, but I guess we'll have to see how things develop (netzvieh, 10:56:36)
    8. chum still needs more volunteers to drive forward policies, process definition and also adaptation of the open repos client to the chum use case. (tbr, 10:56:44)
    9. HELP: We need more volunteers for community repo surroundings (netzvieh, 10:59:20)

  6. Community guidelines, communication channels and Jollas communication (30 min) (netzvieh, 11:00:04)
    1. continuing from last meeting (netzvieh, 11:00:06)
    2. http://merproject.org/meetings/mer-meeting/2014/mer-meeting.2014-05-27-15.00.html point 3 (netzvieh, 11:00:06)
    3. we've discussed about keeping mailing list focused to SailfishOS deeveloper related conversations (cybette, 11:01:19)
    4. it will be moderated by Jolla sailors (selected) and communtiy members (no volunteers yet) (cybette, 11:01:42)
    5. nominations/volunteers for moderators to be sent to developer-care@jolla.com (cybette, 11:02:24)
    6. <cybette> netzvieh: at this point we would like to focus on the mailing list, together.jolla.com and irc. We can work on improving these channels (setting up guidelines is a start) but spreading ourselves too thin at this point will not be beneficial (netzvieh, 11:07:02)
    7. <cybette> speaking of moderators, we will also like community involvement as irc channel ops and TJC moderators. similarly, nominations/volunteers to developer-care@ (netzvieh, 11:08:35)
    8. @moderators <cybette> when we have a list of names we will have the voting (on piratepad or some suitable tool). (netzvieh, 11:12:36)
    9. @guidelines <cybette> netzvieh: I think we will have a draft in place and for review and suggestions. (netzvieh, 11:12:56)
    10. #SailfishOS on freenode is official IRC channel, however all sailors are community members there if not mentioned separately otherwise (cybette, 11:15:24)
    11. we're proposing to adopt IRC guidelines from Mer: https://wiki.merproject.org/wiki/IRC_guidelines (cybette, 11:15:51)
    12. sidenote, #jollamobile on freenode is unofficial, founded by Stskeeps and iekku, following Mer IRC guidelines (cybette, 11:16:15)
    13. ACTION: stskeeps to look into #jollamobile vs ##jollamobile (Stskeeps, 11:20:04)
    14. no ETA on guideline pirate pad (netzvieh, 11:24:17)
    15. ACTION: cybette supports iekku with PP (netzvieh, 11:24:32)

  7. Next Meeting (netzvieh, 11:28:21)
    1. AGREED: Next Meeting 10 June @ 15 UTC with cybette as chair unless someone volunteers (netzvieh, 11:30:39)


Meeting ended at 11:30:47 UTC (full logs).

Action items

  1. stskeeps to look into #jollamobile vs ##jollamobile
  2. cybette supports iekku with PP


Action items, by person

  1. cybette
    1. cybette supports iekku with PP
  2. iekku
    1. cybette supports iekku with PP


People present (lines said)

  1. netzvieh (81)
  2. cybette (53)
  3. coderus (53)
  4. iekku (38)
  5. BasilSemuonov (34)
  6. xfade_ (28)
  7. tbr (25)
  8. MSameer (24)
  9. lbt (19)
  10. stephg (19)
  11. artemma (19)
  12. sledges (15)
  13. leszek (11)
  14. faenil_ (10)
  15. kimmoli (8)
  16. Stskeeps (8)
  17. Aard (6)
  18. javisail (6)
  19. KhertanAtwork (4)
  20. Merbot` (3)
  21. javispedro (3)
  22. phaeron (3)
  23. faenil (2)
  24. sletta (2)
  25. grande (2)
  26. jake9xx (1)
  27. sdjayna (1)
  28. VDVsx (1)
  29. mike7b4_on_x230 (1)
  30. phdeswer (1)
  31. Sage_ (1)
  32. Nicd- (1)
  33. JvD_ (1)
  34. amccarthy (1)


Generated by MeetBot 0.1.4.