#mer-meeting: SailfishOS, open source, collaboration 19-August

Meeting started by Stskeeps at 15:04:27 UTC (full logs).

Meeting summary

    1. Welcome to another week of SailfishOS OSS and collaboration meeting (cybette, 15:05:24)
    2. Agenda today can be seen at https://lists.sailfishos.org/pipermail/devel/2014-August/004920.html (cybette, 15:05:45)

  1. Quick introductions (5 min), prefix your information with #info (cybette, 15:05:56)
    1. Thomas B. Rücker, community member (tbr_, 15:06:05)
    2. Carsten Munk, Chief Research Engineer @ Jolla (Stskeeps, 15:06:06)
    3. Lucien Xu, community member (SK_work, 15:06:20)
    4. Simonas Leleiva, sailing community member (sledges, 15:06:22)
    5. Tadeusz Sośnierz, Jolla enthusiast and developer wannabe (tadzik, 15:06:23)
    6. Aleksi Suomalainen, community member (locusf, 15:06:25)
    7. Carol Chen, community chief @ jolla, today hatless chair (cybette, 15:06:33)
    8. Eric Le Roux, Bugzilla & TJC admin @ Jolla (eleroux, 15:06:36)
    9. Martin Brook , community member (vgrade_, 15:06:42)
    10. Soumya Bijjal, SW program manager @ JOlla (bijjal, 15:07:18)
    11. Giulio Camuffo, sw developer @ Jolla (giucam, 15:07:34)
    12. Martin Kolman, community member & modRana developer (M4rtinK, 15:08:03)
    13. Sebastian Meyer, community member (netzvieh, 15:08:17)
    14. Robin Burchell, sailor emeritus (w00t, 15:09:22)

  2. Licensing issues with sailfishsilica-qt5 - tbr (30 min) (cybette, 15:10:17)
    1. Javier S. Pedro, community (javispedro, 15:10:18)
    2. kimmo lindholm, toh (kimmoli_sailing, 15:10:50)
    3. https://together.jolla.com/question/52712/licensing-issues-with-sailfishsilica-qt5/ (cybette, 15:14:50)
    4. Missing license headers not intentional, they ought to be BSD/MIT headers (Stskeeps, 15:16:48)
    5. It's typical for QML/silica apps and intentional use to customize individual QML components or derive from them, hence you need to see how they work. And given that people have differnet licensed apps, they need to be fairly liberal licensed (Stskeeps, 15:17:36)
    6. status quo - we continue with the current approach of community hosting the qml/js bits of silica until c++ side is opensourced (tbr, 15:28:46)
    7. a indexer/lxr is desired by the community (tbr, 15:30:36)
    8. if there is community interest it could pick up the lxr topic as jolla is likely busy with the community translation tool in this aspect (tbr, 15:37:51)
    9. gpl bits of recovery are again tricky because not easily rebuilt, like silica. Stskeeps to look into it. (tbr, 15:38:50)

  3. Updates from Jolla after summer break & discussions - all (45 min) (cybette, 15:40:29)
  4. Jolla's position on paid apps (cybette, 15:41:55)
    1. we are working on this and the current estimate is later in Q4 (cybette, 15:41:59)
    2. IDEA: from M4rtinK, Support for in-store donation (cybette, 15:44:49)
    3. Question about whether paid apps will be geo-locked (cybette, 15:47:43)

  5. Planning outcome after summer holidays (5 min) (cybette, 15:47:54)
    1. https://lists.sailfishos.org/pipermail/devel/2014-August/004939.html (bijjal, 15:48:07)
    2. Shared earlier today on mailing list: https://lists.sailfishos.org/pipermail/devel/2014-August/004939.html (cybette, 15:48:10)
    3. IDEA: Sharing of longer term plans and areas where community can help (cybette, 15:51:55)

  6. Middleware merge (5 min) (cybette, 15:52:34)
    1. ongoing, there will be a lot happening this week on this topic (cybette, 15:52:41)

  7. Bugzilla situation (5 min) (cybette, 15:57:05)
    1. no current plan to deploy a specific instance but we are working on automation between TJC and our internal tracker to follow up - a robot is planned to comment on TJC related items whenever actions are taken (eleroux, 15:59:28)
    2. Bugs are being tracked in nemomobile Bugzilla for HADK adaptations #link https://bugs.nemomobile.org/buglist.cgi?product=Hardware%20adaptation&component=Hybris-ing&resolution=--- (vgrade_, 16:00:00)
    3. We are at the point we need to start doing some triage and we would like to know the best time to organise them to get the best input from Jolla Sailors (vgrade_, 16:00:20)
    4. The same mechanism is under work to make Bugzilla instances talk to each other… More to come when we're closer to deploying (eleroux, 16:01:24)
    5. mer/nemo bz versions will have to be updated (sledges, 16:01:40)

  8. Ambiences/icon packs in Harbour (5 min) (cybette, 16:02:34)
    1. This is a good input to know that the community is also interested on this. We have thought about this and started on the planning but haven't started the implementation yet. (cybette, 16:02:44)

  9. Store/Harbour updates (5 min) (cybette, 16:06:14)
    1. Like you have noticed that we submitted update to harbour couple of weeks ago with support for metrics and other small bug fixes. (cybette, 16:06:21)
    2. We are planning to release soon an update that enables support for python apps to be submitted (cybette, 16:06:25)
    3. IDEA: Download map, statistics (downloads per day etc.), fancy graphs in Harbour (cybette, 16:09:20)
    4. IDEA: Web UI for comments / web UI for store in general (cybette, 16:09:49)
    5. IDEA: CLI tool for submitting packages, perhaps a git hook (cybette, 16:11:55)

  10. HADK porting (5 min) (cybette, 16:12:59)
    1. We have many porters engaged in HADK execution #link https://wiki.merproject.org/wiki/Adaptations/libhybris/porters on #sailfishos-porters (vgrade_, 16:13:13)
    2. Community builds for Nexus5, Galaxy Nexus and Galaxy Note are out with many more in various stages of port (vgrade_, 16:13:28)
    3. multiROM support for N5 after help from the multiROM author (vgrade_, 16:13:37)
    4. we have some take up by xda forum members and on the whole good constructive comments. More engaement with that community planned (vgrade_, 16:13:57)
    5. The main requests are around official store, OTA updates and android app support. (vgrade_, 16:14:06)
    6. there will be a Jolla and sailfish community presence at xda:devcon in Manchester next month, #link http://xda-devcon.com/ (vgrade_, 16:14:16)
    7. a big thanks to everyone (vgrade_, 16:14:35)
    8. requests on camera, too; and gps (gps is blocked by a non-oss sailfish geo component plugin missing for non jolla devices) (sledges, 16:15:05)
    9. we need gpu experts *cough* stskeeps for https://wiki.merproject.org/wiki/Adaptations/libhybris/gpu, blocking many more amazing devices from reaching uiatm (sledges, 16:16:12)
    10. the https://bugs.nemomobile.org/ bugzilla is being used to track issues on the opensource/HA aspects of the HADK (lbt, 16:17:27)

  11. Others: community translations, documentation/autodoc situation, chum repos (5 min) (cybette, 16:17:44)
    1. chum needs more active testers that provide feedback about apps in "testing" (tbr, 16:18:18)
    2. There is a community effort (mainly by me) to bring a push notification framework to sailfish (based on MQTT). First results very promising and we have reliable irssi notifications. We are on #sailfishos-push (tbr, 16:19:15)
    3. no progress on autodoc (lbt, 16:22:46)
    4. <+bijjal> w.r.t community translation tool, we are closer to releasing. A bit more work pending to ensure that we have necessary infra to do fast changes and verify (cybette, 16:23:54)

  12. Wrap up and next meeting (10 min) (cybette, 16:24:19)
    1. Please submit topic proposals for future meetings to SailfishDevel mailing list (instead of the Pirate Pad) (cybette, 16:24:43)
    2. If anybody is in Helsinki, feel free to join for informal/unofficial jolla user beer in Amsterdam Bar in Ruoholahti at 17:30 (next to metro station) on Thursday 21st (Stskeeps, 16:26:02)
    3. If anybody is in Tampere, feel free to join for informal/unofficial Jolla meetup this Saturday - time and venue to be confirmed. Ping cybette (cybette, 16:27:05)
    4. Meeting topic proposals on TJC wiki post instead (cybette, 16:28:16)
    5. ACTION: cybette to create TJC post for next meeting (cybette, 16:28:33)
    6. Next community meeting 2014-08-26, 10:00 UTC (cybette, 16:31:30)


Meeting ended at 16:33:48 UTC (full logs).

Action items

  1. cybette to create TJC post for next meeting


Action items, by person

  1. cybette
    1. cybette to create TJC post for next meeting


People present (lines said)

  1. cybette (88)
  2. tbr (88)
  3. Stskeeps (61)
  4. SK_work (31)
  5. M4rtinK (30)
  6. sledges (21)
  7. javispedro (19)
  8. vgrade_ (11)
  9. bijjal (10)
  10. locusf (9)
  11. w00t (8)
  12. lbt (7)
  13. eleroux (7)
  14. AL13N_work (5)
  15. Merbot (4)
  16. tadzik (4)
  17. tbr_ (2)
  18. jalyst (2)
  19. kimmoli_sailing (2)
  20. MSameer (1)
  21. giucam (1)
  22. Morpog_PC (1)
  23. netzvieh (1)


Generated by MeetBot 0.1.4.