10:00:06 <cybette> #startmeeting SailfishOS, open source, collaboration: 26-August @ 10:00 UTC
10:00:07 <Merbot> Meeting started Tue Aug 26 10:00:06 2014 UTC. The chair is cybette. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
10:00:07 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:00:15 <cybette> #info Welcome to another week of SailfishOS OSS and collaboration meeting
10:00:20 <cybette> #info Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-August/004971.html
10:00:25 <cybette> I'm the meeting chair for today and will be keeping time and order. Please behave and show mutual respect, and let's have a productive discussion!
10:00:30 <cybette> #topic Brief introductions (5 min), prefix your information with #info
10:00:33 <Stskeeps> #info Carsten Munk, Chief Research Engineer @ Jolla
10:00:37 <kimmoli> #info Kimmo Lindholm, TOH-tailor, community member
10:00:47 <cybette> #info Carol Chen, Community chief at Jolla, hatless chair today
10:01:07 <tbr> #info Thomas B. Ruecker, community member
10:01:37 <deztructor> #info Denis Zalevskiy, engineer, Jolla
10:01:52 <eleroux> #info Eric Le Roux, Bugzilla & TJC admin @ Jolla
10:02:53 <niqt> #info Nicola De Filippo, community member
10:03:17 <cybette> intro yourself even if you're mostly lurking :)
10:05:21 <sledges> #info Simonas Leleiva, community sailor
10:05:42 <cybette> #topic Efforts made to generate interest in Mer/Nemo/Sailfish in Asia & elsewhere - jalyst (25 min)
10:06:12 <cybette> #info the interest here refer to dev/ODM/telco etc.
10:06:20 * Stskeeps looks after jalyst
10:06:27 <cybette> hmm, jalyst doesn't seem to be present
10:06:48 <Stskeeps> i guess i can just briefly talk a little bit about and see if anybody else wants to pick up?
10:06:54 <cybette> Stskeeps or marc2: perhaps you can give some comments and we can open it for discussion
10:06:57 <cybette> yes thanks :)
10:07:12 <Stskeeps> so, it's a pretty wide question in the first place
10:08:10 <tbr> *sigh* why do people do drive by topics. they could at least show up to make their case.
10:08:11 <Stskeeps> just to seperate it down a bit: ODM/telco discussions are usually done under a large amount of NDA paperwork as that's how the industry works in general. often there's discussions about roadmaps/marketing plans etc, so practice is that first time anything is public is when agreements has been reached
10:08:33 <Stskeeps> places like MWC are typical meet-ups for operators and ODMs
10:09:23 <cybette> #info ODM/telco discussions are usually done under a large amount of NDA paperwork as that's how the industry works in general. often there's discussions about roadmaps/marketing plans etc, so practice is that first time anything is public is when agreements has been reached
10:10:03 <Stskeeps> which is not terribly transparent but considering the hard competition these companies are in, secrecy is fairly expected.. just to explain a bit how things work
10:10:07 <marc2> It does take a long tme and a huge amount of discussions to even get an agreement with an operator, and it only becomes true at the last minute when it signs. They have a lot of power over the situation and we are thankful we are getting their attention at the moment.
10:11:03 <Stskeeps> regarding developer efforts in asia:
10:11:35 <Stskeeps> last may/june we had a china tour with developers and we were represented at qt dev days this year again, but focus there was more B2B than B2D from event pov
10:12:24 <Stskeeps> .. and that's basically where we're at, at the moment
10:12:57 <cybette> #info about developer efforts in asia: last may/june we had a china tour with developers and we were represented at qt dev days this year again, but focus there was more B2B than B2D from event pov
10:12:59 <Stskeeps> does anybody have some questions in this particular area, things they might want explained etc?
10:14:01 <marc2> yes, direct questions welcomed!
10:15:10 <cybette> let's wait 2 more minutes, if no questions/comments, we move on to next topic
10:16:24 * cybette notices nieldk isn't here either...
10:16:27 <cybette> one more min
10:16:41 <Stskeeps> yeah, but that particular topic is perhaps of wide interest in genreal
10:17:03 <cybette> true
10:17:08 <cybette> ok moving on
10:17:23 <cybette> #topic Strong partner in desktop Linux for Jolla - jalyst (25 min)
10:17:35 <cybette> again, let's have some comments and open for discussions
10:18:43 <Stskeeps> so, general tendancy is that many are using typical operating systems and a lot of the communication that happens today happens with cloud services instead of let's say, computer to mobile..
10:19:06 <Stskeeps> the usual requests that come in revolve around let's say, better support for sailfishos and macos (MTP, RNDIS) as an example
10:19:39 <Stskeeps> so the question is also, since tablets are emerging, if this is more about convergence between devices (where tablet factor / chromebook like devices) are getting more typical than let's say, desktop linux
10:20:16 <Stskeeps> .. so the interest in desktop linux ie, from a partner pov, may not be so big -- desktop/PC business is a very tough one to tackle :)
10:20:54 <Stskeeps> .. do you guys think it makes sense to try and partner with desktop linux projects? there's of course cool projects like LxQt and Hawaii Desktop out there that shares a lot of technology stack
10:21:08 <tbr> for reasons that I fail to understand people seem to cling to USB-MAS mode and like to bring that to every USB argument as the golden hammer
10:21:52 <Stskeeps> mass storage.. the biggest reason is media indexing that is a nightmare, plus having to have applications let go of their own open files
10:22:03 <tbr> JFTR: there are reasonably good MTP implementations out there on Linux, e.g. the gnome3 file browser. For those who don't like that there is always SSHFS, samba and NFS
10:22:03 <Stskeeps> (just explaining in general)
10:22:09 <Morpog_PC> I'm not sure Tablet desktop UI's and Tablet mobile UI's go well together. A worse example is Windows RT, a better idea, but not yet done, is Ubuntu's future approach to this
10:22:11 <Stskeeps> MTP solves a lot of these issues
10:22:30 <tbr> yes, MTP is the right answer to those as it allows concurrent access
10:22:41 <tbr> something that you just won't get on a block-io level
10:23:13 <Stskeeps> adding on top of the challenge is that many people are doing streaming these days, let's say, mobile device to tv screen via miracast
10:23:47 <Stskeeps> desktop linux is also hard from the point of view that if you don't make a 'product' where you have linux system matching the exact hardware, it becomes a pain -- a generic linux is really hard to do
10:24:13 <Stskeeps> which seems to be the tendancy even in windows world, that there's a preconfigured OS for a specific hw
10:24:31 <Stskeeps> which can only happen together with the vendor if it has to be 'perfect' .. :P
10:25:16 <Stskeeps> that's what at least kept me personally from diving into sailfishos for desktop :)
10:25:50 <Stskeeps> thoughts? :P
10:25:59 <kimmoli> desktop-HADK ?
10:26:11 <Stskeeps> hehe
10:26:17 <tbr> I don't think bringing sailfish to the desktop would be a sane choice
10:26:21 <Stskeeps> well, you can already now do a x86 sailfishos image with a bit of a grease
10:26:27 <tbr> x86, yes
10:27:09 <tbr> but for a desktop experience the usage paradigm is far too different and probably awkward
10:27:26 <kimmoli> agree
10:27:26 <leszek> exactly
10:27:42 <leszek> swiping on the desktop is nothing for the mouse
10:27:45 <tbr> I believe MS has learned a lesson there, actually on a similar UI
10:27:57 <Morpog_Tablet> yep
10:28:26 <Stskeeps> which is why the 'surface pro' kind of factor might be one that is emerging better..
10:30:24 <kimmoli> ok, what was the topic again? SFOS to desktops? or better comms between SFOS device and desktops? Define 'partnering' ?
10:30:47 <Stskeeps> i think the latter.. i think the reason was in order to attract attention
10:30:50 <Stskeeps> from what i understood
10:30:51 <tbr> kimmoli: again a drive by topic, where the person who suggested it doesn't bother to show up
10:31:15 <cybette> kimmoli: more details here https://together.jolla.com/question/54157/sailfishos-open-source-collaboration-meeting-planning/
10:32:40 <cybette> I will close the topic if there's no response in the next 3 minutes
10:33:34 <cybette> anything we can #info for this topic?
10:33:52 <Stskeeps> not sure besides check log for discussion
10:34:11 <cybette> #info check full logs for discussion
10:34:38 <kimmoli> for me, samba is enough integration for now
10:35:06 <tbr> kimmoli: should upgrade the version some day, that was old and full of holes probably
10:35:26 <Stskeeps> samba kinda got kicked out of mobile cos of gplv3 :/ but strictly speaking nothing stops it as an addon
10:35:47 <Stskeeps> and even so, it would be a problem on non-NDIS targets like macos
10:36:50 <cybette> ok with everyone to continue to next topic?
10:36:53 <tbr> Stskeeps: yes, that's the community perspective now. We don't have to care about software patents that much, if at all.
10:36:54 <Stskeeps> ok with me
10:36:58 <Stskeeps> tbr: nod
10:37:30 <cybette> #topic Feasable way to distribute a fastboot flashable base image - nieldk (25 min)
10:37:35 <kimmoli> https://twitter.com/nieldk/status/504215406962151424
10:37:57 <Stskeeps> okay.. well, we can do a general discussion as it's just good to remind
10:39:14 <Stskeeps> so basics 1) jolla is not in a position where we can distribute our firmware images, because of there containing 3rd party bits 2) this also transfers to that it is not possible for anybody else in community to do so, either 3) our hardware adaptation is very strongly tied to the 3rd party bits as this is how modern devices are made today
10:39:32 <tbr> today is no-show day... :-/
10:39:49 <Stskeeps> 4) with recovery menu and a unlocked bootloader, it should be very easy to create flashable images with standard fastboot, linux tools and publically available android build tools such as img2simg
10:40:01 <Stskeeps> that you can make a backup of your own device with that
10:40:30 <tbr> make it scriptable then everyone can build their own recovery flash image
10:40:32 <Stskeeps> there are parts of the device that may be unflashable for regulatory reasons
10:40:33 <sharpneli> And 5) Jolla is not Google who can strong arm the 3rd parties to give them permissions
10:40:39 <Morpog_Tablet> how about some stuff thatbautomates this process?
10:40:41 <Stskeeps> it shooould be scriptable over telnet
10:41:02 <Stskeeps> as we have the nice shell option in recovery
10:41:04 <kimmoli> is Jolla allowed to make instructions how to make this, or make this automation-script?
10:41:47 <Stskeeps> in practice it's not something we really condone as it may break in all sorts of funny ways, but, there's nothing stopping community from doing so. i'd encourage something that can be built into the recovery menu
10:41:58 <cybette> #info Jolla is unable to distribute firmware images due to 3rd party bits and this extends to anyone in the community
10:42:27 <Stskeeps> ie, if it breaks when you try it, it's your own fault.. but doesn't mean it's not possible to do something
10:42:39 <Morpog_Tablet> maybe someone from jolla could together with community (probably nieldk) work this out and put it on some community space? maybe first versions on tmo and when its stable on toj?
10:42:45 <Stskeeps> there's multiple layers you can do it on: btrfs level, block level (ie, flash over fastboot), etc
10:43:03 * lbt wonders where to ask questions about this?
10:43:06 <Stskeeps> Morpog_Tablet: it's all about asking the questions and doing the grease work, nobody has asked the questions so far :)
10:43:10 <Stskeeps> and #sailfishos should do
10:43:55 <cybette> #info with recovery menu and an unlocked bootloader, it should be easy to create flashable images with which you can backup your own device
10:44:02 <Stskeeps> in practice the internal storage on the device is, simply seen, a microsd, and at least i know from maemo/meego times people were doing block level backups
10:44:04 <kimmoli> the lowest level you can brick it but still be able to restore through recoveryconsole?
10:44:16 <Stskeeps> i'd very much recommend against toying around with the bootloader
10:44:19 <Stskeeps> if that's gone, no fastboot
10:44:23 <Morpog_Tablet> so who sgpuld community contact on this matter? stskeeps?
10:44:26 <Stskeeps> i guess me
10:44:31 <Stskeeps> also noting, you can lock and unlock your bootloader
10:44:33 <Morpog_Tablet> damn vkb
10:45:27 <Stskeeps> it should be possible, but for very bad situations you would need to have a open bootloader which might pose other issues
10:45:44 <Stskeeps> anyhow, contributions more than welcome
10:45:47 <Morpog_Tablet> would be worth infoing this stuff
10:45:50 <cybette> #info if you want more info, ask questions in #sailfishos on freenode
10:48:07 <tbr> should we agree to document it somewhere e.g. on the mer wiki?
10:48:12 <Stskeeps> yeah.. that might be good
10:48:25 <cybette> who can take an action on that?
10:48:40 <Stskeeps> i think it'll happen naturally as we start looking at it
10:49:09 <tbr> #info Efforts will be documented on Mer-wiki, Jolla side contact on #sailfishos is Stskeeps
10:49:26 <cybette> tbr: thanks :)
10:49:33 <tbr> np
10:49:36 <Morpog_Tablet> i try to trigger nieldk
10:49:57 <Stskeeps> just ask him to come and chat with me
10:49:57 <Stskeeps> :P
10:50:15 <Stskeeps> .. anything else on this topic?
10:52:09 <cybette> 2 more min without response and I close the topic
10:53:34 <kimmoli> hoo i found it https://wiki.merproject.org/wiki/Sailfish
10:54:24 <cybette> ok let's wrap up
10:54:30 <cybette> #topic Wrap up and next meeting (10 min)
10:54:58 <cybette> one qn: how do we make sure those who proposed meeting topics will show up?
10:55:19 <Stskeeps> i propose (personally) that if somebody who proposes and dont send a substitute, topic gets skipped
10:55:20 <tbr> can we make it clear that it's expected from people that they show up and make their case in person if they propose a topic?
10:55:23 <Stskeeps> and that
10:55:57 <Morpog_Tablet> +1 for both
10:56:02 <kimmoli> but meeting schedule might then need to adapt by them?
10:56:22 <tbr> kimmoli: don't propose a meeting topic if you can't make it. full stop.
10:56:41 <eleroux> tbr: I disagree
10:56:54 <cybette> "If you would like to present a topic, and the time does not work for you at all, please consider bringing the topic to the following meeting with new proposed time that suits you." from https://together.jolla.com/question/54157/sailfishos-open-source-collaboration-meeting-planning/
10:57:07 <eleroux> we can still document on IRC, TJC, ML...
10:57:25 <tbr> eleroux: yes, but in the meeting scope that's how it is.
10:57:34 <eleroux> let's be inclusive :D
10:58:11 <tbr> eleroux: by rescheduling meetings the day before they are supposed to happen because someone proposed a topic but wants to have it an hour or a day later?
10:58:13 <cybette> eleroux: the idea for these meetings is so we can get these things discussed "live". or else we can put the discussions on TJC, ML etc.
10:59:00 <tbr> eleroux: it is a related but separate item that you can propose a different meeting time during a current meeting
10:59:24 <tbr> e.g. this meeting is at 10utc so that the australians can participate
10:59:38 <tbr> sadly I don't seem to notice particularly many of those
10:59:57 <cybette> yeah, because last week jaylst mentioned 10utc would work for him
11:00:19 <cybette> that's why we put his topics for today's meeting
11:00:30 <lbt> how about a compromise - if there's a no-show and no sub *and* no-one in the meeting steps as being interested then we skip it
11:00:42 <eleroux> tbr, cybette: I just wanted to point out we just don't skip entirely and keep what was just done today - Though the topic may be revived later or on different medium
11:00:53 <lbt> sometimes (like today) we can just get useful answers without any comment from the proposer
11:01:02 <lbt> other times they need to clarify
11:02:19 <eleroux> lbt: sounds reasonable
11:02:48 <lbt> I'm going to have to stop that ... I have my reputation to think of
11:02:53 <kimmoli> at least these go much faster like this
11:03:22 <kimmoli> but maybe elaborate on TJC with proposer?
11:03:32 <cybette> sure, sometimes we can get some useful info and answers, but we can't be sure we're giving the answers the person is looking for and s/he might propose the topic again... etc. it can end up wasting valuable time
11:03:59 <Stskeeps> i think we can ask that people should show up / make it very clear that a topic == real time participation as it's a discussion, not a canned statement
11:04:20 <Stskeeps> or something
11:04:38 <Morpog_Tablet> +1
11:04:51 <Stskeeps> so setting expectations very clear early on
11:04:57 <eleroux> Like this :)
11:05:18 <cybette> if the person doesn't show up, we give the topic 5 min (max 10) for some comments and then move on
11:05:22 <Stskeeps> nod
11:05:45 <cybette> #action cybette to update wiki with clearer rules about participation for people who have proposed topics
11:06:32 <cybette> alright. let's decide on next meeting: sept 2 @ 15 UTC ?
11:07:13 <Stskeeps> i'd avoid that date, iteration planning..
11:07:18 <cybette> ah...
11:07:57 <Stskeeps> anybody against a breathing space, ie, 9th september instead?
11:08:16 <kimmoli> mi bd
11:08:25 <Stskeeps> kimmoli volunteers to bring cake.
11:08:31 <cybette> :D
11:08:39 <kimmoli> no emonji here ..
11:08:58 <eleroux> Stskeeps: fine with that, also gives more time for topics to arise :)
11:08:59 <iekku> +1 for 9th, i will be back from vacation too :)
11:09:02 <Morpog_Tablet> sounds good
11:09:16 <cybette> +1
11:09:29 <sledges> +1
11:09:35 <cybette> any other volunteers to chair?
11:09:54 <kimmoli> you're doing it so well...
11:09:59 <Stskeeps> i can volunteer to chair next time around
11:10:16 <cybette> #info Next meeting Tues Sept-9 @ 15:00 UTC, Chairperson Stskeeps
11:10:20 <cybette> Stskeeps: thanks :)
11:10:31 <cybette> kimmoli: it'll be nice to wear a hat sometimes :)
11:10:48 <cybette> ok thanks everyone, see you in 2 weeks!
11:10:59 <tbr> ty
11:11:06 <cybette> #endmeeting