15:00:08 <Stskeeps> #startmeeting SailfishOS, open source, collaboration: 9-September-2014 15:00 UTC
15:00:08 <Merbot> Meeting started Tue Sep  9 15:00:08 2014 UTC.  The chair is Stskeeps. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
15:00:08 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:11 <Stskeeps> #info Welcome to another week of SailfishOS OSS and collaboration meetgin ;)
15:00:23 <Stskeeps> #info Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-September/004996.html
15:00:30 <Stskeeps> I'm the meeting chair for today and will be keeping time and order. Please behave and show mutual respect, and let's have a productive discussion!
15:00:37 <Stskeeps> #topic Brief introductions (5 min), prefix your information with #info
15:00:47 <cybette> meetgin :D
15:00:52 <tbr> #info Thomas B. Ruecker, community member, works on push notifications and Chum community repos
15:01:04 * tbr has his meetgin right here, see twitter
15:01:13 <locusf> #info Aleksi Suomalainen, community member
15:01:15 <sledges> #info Simonas Leleiva, community sailor
15:01:20 <situ> #info Siteshwar, community member
15:01:41 <faenil> #info Andrea Bernabei, nemomobile contributor and community member
15:01:49 <kimmoli> #info Kimmo Lindholm, community member, toh-tailor
15:02:06 <beidl> #info Alfred Neumayer, Community maintainer of SailfishOS for Galaxy Nexus port and GNU/Linux enthusiast
15:02:16 <kimmoli> \o meetgin !
15:02:21 <r0kk3rz> #info Lewis Rockliffe, resident australian and community member
15:02:37 <VDVsx> #info Val�rio Val�rio, Sailor, community member
15:02:40 <stephg> #info Steph Gosling, community
15:02:47 <cybette> #info Carol Chen, community chief @ Jolla
15:02:52 <bobsummerwill> #info Bob Summerwill, (new) community member, working on Mono for Sailfish
15:03:31 <iekku> #info Iekku Pylkk�, developer community + developer care @ jolla, community member, mer & nemo community member
15:03:44 <sledges> welcome bobsummerwill
15:03:44 <lbt> #info David Greaves : Mer guy and Sailor
15:03:47 <cybette> bobsummerwill: welcome! glad to see you here :)
15:03:49 <iekku> bobsummerwill, welcome
15:03:58 <M4rtinK> #info Martin Kolman, community member, modRana developer
15:03:59 <bobsummerwill> Thanks, guys!
15:04:58 <MSameer> #info Mohammed Hassan, FOSS hacker and Jolla sailor (Mostly listening)
15:05:08 <qwazix> #info Michael Demetriou, community member
15:05:48 <Stskeeps> #topic App settings integration for third party applications (10 minutes)
15:05:49 <dr_datacenter> #info Fabio Isgro' enthusiast , community
15:06:28 <Stskeeps> Some details about the topic: Currently it is not possible for third
15:06:28 <Stskeeps> party applications to integrate their settings into the official
15:06:28 <Stskeeps> settings page of the settings system application if they are published
15:06:28 <Stskeeps> via Harbour.
15:06:28 <Stskeeps> Additional Q by kimmoli: How about settings for iconless apps, like
15:06:30 <Stskeeps> daemons (e.g. toholed) ?
15:06:38 <Stskeeps> Armadillo_ ? Also noted on item optionally tbr or SK_Work? - if you'd like to introduce the topic further?
15:06:41 <tbr> so, is the guy who proposed it here? if not sk or me can help
15:07:00 <Stskeeps> whois says 'nicht da' :)
15:07:06 <tbr> :)
15:07:41 <tbr> ok, well it's pretty clear already, some jolla statements said it would be possible in the future, it's time to revisit
15:07:48 <tbr> how's status, is it going to happen?
15:07:54 <r0kk3rz> this is a feature I would also like to see happen, in fact i'm surprised that its not part of the design
15:08:42 <r0kk3rz> seems like a perfect, standardised way to locate app settings without clogging up user interfaces in the apps themselves
15:08:54 <lbt> do we have an explanation of why it's not just done 'out of the box' ?
15:09:08 <r0kk3rz> afaik its a permissions issue
15:09:10 <tbr> r0kk3rz: I think it's one of those "oh, yeah, damn, but we can't do this because needs $permission" things and then it dropped through the priority floor
15:09:22 <pvuorela> it's been planned from the beginning and per se possible already, but we wanted some protection for system settings before third party settings get supported.
15:09:23 <sledges> (and all soil is there: all 3rd pty apps are simply greyed out..)
15:09:32 <lbt> I suspect it's to do with running app provided QML/js code in a core jolla application
15:09:33 <tbr> lbt: there is an TJC item, something about "settings has privs that it shouldn't have"
15:09:47 <pvuorela> e.g. running the third party side on separate containers.
15:10:03 <pvuorela> jolla-settings gets run as privileged.
15:10:04 <sledges> (ah, topic is about slots in System/ ;P that looks already cluttered up imho)
15:10:15 <Stskeeps> nah, in applications/
15:10:20 <Stskeeps> which is nice ui to show it in
15:10:27 <tbr> you know the greyed out application grid
15:10:39 <tbr> which nobody uses and nobody knows about because nobody uses it
15:10:43 <sledges> 18:06 <@Stskeeps> settings page of the settings system application if they are published
15:10:57 <dr_datacenter> better to show just enabled/ suppported
15:11:11 <tbr> IIRC it was already almost the same situation with Harmattan
15:11:18 <stephg> yeah
15:12:03 <Stskeeps> just speaking on a very technical basis, couldn't tapping there strictly speaking call a .desktop file with a different command parameter to launch settings of an app? not sure if it would be good ui
15:12:10 <qwazix> IMO I would drop that "applications" page altogether
15:12:24 <tbr> there we go
15:12:27 <stephg> qwazix: where would the settings live?
15:12:28 <r0kk3rz> it just seems pointless to have a whole section of the settings menu for 6 apps
15:12:45 <tbr> stephg: where they already do, in apps
15:12:50 <qwazix> app settings belong inside the apps, and now that it's already inconsistent, it's easier for jolla to move the settings of the 4 apps into the apps than the other way around
15:12:55 <tbr> stephg: because nobody can use the proper settings
15:13:15 <M4rtinK> manipulating the desktop icon would not be very discoverable
15:13:20 <tbr> qwazix: I'm sure some designer will scream murder over this :)
15:13:25 <pvuorela> Stskeeps: possible, yeah, but if that's not a good ui then it's nothing.
15:13:42 <lbt> Stskeeps: that may be a way to make it work quickly
15:13:46 <Stskeeps> but i guess this also shows into a wider problem anyway, plugins into let's say, messaging, etc
15:13:46 <MSameer> How about instantiating the 3rd party QML in its own "qml context"?
15:13:49 <Stskeeps> or other places
15:13:57 <r0kk3rz> i quite like the idea of splitting it up, settings are usually things that you dont look at very often, if ever
15:13:59 <lbt> and then to extend that api to a more integrated one in future
15:14:01 <Stskeeps> .. and i don't want to dive into nested wayland compositors ;)
15:14:04 <MSameer> QQuickContext (or whatever it is called)
15:14:08 <pvuorela> MSameer: needs to be a separate process.
15:14:26 <qwazix> tar, I'm also sure, after all if Apple does it it must be the Right Thing, but I still believe it's stupid
15:14:31 <qwazix> tbr*
15:14:34 <pvuorela> MSameer: qml runs arbitrary c++.
15:14:37 <kimmoli> i could live with separate "settings app" etry in .desktop (as i dont have main app)
15:14:43 <tbr> we're running out of time
15:14:55 <tbr> so there is no statement from jolla?
15:14:58 <M4rtinK> well, it worked fine on the N900 for the various daemons
15:14:59 <lbt> we could solve 90% of the use cases by calling /usr/bin/harbour-app --settings for those which advertise support
15:15:12 <stephg> so there are two questions it seems: drop privs in settings or drop the whole Applications thing from settings altogether
15:15:29 <kimmoli> lbt: +1
15:15:43 <M4rtinK> lbt: +1
15:15:44 <Halo2> I think it was a good Idea to have settings centralized on the apps page
15:15:53 <Stskeeps> tbr: in practice it hasn't moved on, but we haven't gotten as far for the security aspect as we would have wanted.
15:15:56 <lbt> Applications in settings seems good to me - it's just a little sparse atm
15:15:58 <tbr> stephg: the question was if jolla has done anything or plans to do anything. the answer is "couldn't be arsed, had different priorities it seems"
15:16:02 <Stskeeps> the problem seems very real
15:16:05 <M4rtinK> I could do that very easily in modRana
15:16:13 <Stskeeps> as i can imagine it makes 3rd party apps inconsistent
15:16:29 <r0kk3rz> stskeeps +1
15:16:32 <lbt> Stskeeps: provide a template settings page
15:16:40 <cybette> #info 18:09 < pvuorela> it's been planned from the beginning and per se possible already, but we wanted some protection for system settings before third party settings get supported.
15:16:42 <faenil> tbr: nice summary
15:16:46 <lbt> s/provide/jolla provides/
15:16:52 <r0kk3rz> consistency is the key
15:17:02 <tbr> cybette: it's far more important to info what Stskeeps said
15:17:05 <cybette> #info 18:15 <@Stskeeps> tbr: in practice it hasn't moved on, but we haven't gotten as far for the security aspect as we would have wanted.
15:17:12 <iekku> beta channel for store haven't been getting done as fast as we thought, so it most propably will delay from original estimate ie autumn
15:17:18 <tbr> cybette: as pvuorela just described the status quo already known
15:17:22 <iekku> when we have it in place it might help a bit
15:17:32 <tbr> anyway we exceeded the timeslot by 2min
15:17:34 <Stskeeps> as beta would be a way to integrate more experimental apis as well..
15:17:38 <cybette> tbr: just providing more info for people reading about this in minutes :)
15:17:43 <lbt> tbr: just out of interest - what would we stop working on to work on this ?
15:17:50 <Stskeeps> yeah.. i think 10 mins isn't enough for this topics
15:17:51 <Stskeeps> let's move on
15:18:01 <lbt> tbr: tbd later? :D
15:18:03 <tbr> lbt: show me your backlog and I will tell you
15:18:07 <stephg> ;)
15:18:12 <Stskeeps> i'll propose to take kimmoli's question in the wrapup
15:18:19 <iekku> we need another slot for this :)
15:18:35 <Stskeeps> #topic Close vs open parts, why is there closed middleware ? (SK_work)
15:18:45 <Stskeeps> i don't see Sfiet..
15:19:03 <tbr> obvious enough, let's still have it?
15:19:26 <Stskeeps> yeah - Chris Adams posted a good post at
15:19:26 <lbt> do we have any examples ?
15:19:30 <Stskeeps> #link https://lists.sailfishos.org/pipermail/devel/2014-September/005002.html
15:19:34 <tbr> I could inject the question for opening bits of the UI where there is significant interest
15:19:44 <tbr> e.g. the message app
15:20:00 <tbr> it doesn't support multi-user and other things, underlying frameworks do
15:20:06 <tadzik> . o O ( please media )
15:20:08 <r0kk3rz> eg. com.jolla.mediaplayer
15:20:11 <tbr> there is community interest
15:20:17 <Stskeeps> regarding the specific case mentioned in https://lists.sailfishos.org/pipermail/devel/2014-September/004996.html
15:21:18 <Stskeeps> #info interest in opening bits of the UI where there is significant interest: message app - underlying frameworks support multi-user, app doesn't
15:21:29 <Stskeeps> #info community interest, too
15:22:26 <Stskeeps> general comment, it is a bit hard to talk in a wide scope but we try to avoid closed middleware, it causes more trouble than worth, we've had some cases of it and it's getting improved with things like sociald going out
15:22:51 <tbr> also if I read this accounts would also be important. e.g. I will probably need an account plugin for the push notification framework
15:23:11 <Stskeeps> it comes down to a case by case basis and one of them (sailfish.accounts) got discussed a bit by chriadam in link above
15:23:40 <lbt> can we list the closed middleware so we're on the same page?
15:23:46 <Stskeeps> yeah, trying to find my own list
15:23:59 <Stskeeps> (sorry for confusion of hats, this is kinda my area..)
15:26:16 <Stskeeps> ambienced is one middleware that's still closed, tohd,
15:26:26 <bobsummerwill> Test message, to see if my lost connection is back.
15:26:27 <Stskeeps> the store
15:26:56 <Stskeeps> and the 'Sailfish" components QMLs.. which is a bit quirky if it's considered as middleware or support libraries
15:27:05 <Stskeeps> as they can change at any time
15:27:33 <Stskeeps> i'll export a png so people can check for themselves, but we have 3 more minutes to discuss about it
15:27:58 <Stskeeps> as an action point we can take it up regarding messaging as an example where we could have a benefit of opening up further/frameworkising it
15:28:18 <beidl> depending on whether jolla-gallery or ambienced does the actual cropping of background wallpapers, we might need a fix anyhow for black textures on custom wallpapers (non pre-shipped self created ambiences)
15:28:21 <Stskeeps> #action to look into messages and see how we can open or further frameworkise it to make it possible to add new technologies
15:28:40 <cybette> #info still closed middleware: ambienced, tohd, store, 'Sailfish' components QMLs (middleware or support libraries?)
15:28:57 <beidl> geoclue plugins?
15:29:05 <sledges> +1
15:29:15 <Stskeeps> yes, geoclue but that was over in hw adaptation ;)
15:29:19 <Stskeeps> and a qmf oauth2 plugin
15:29:45 <Stskeeps> http://releases.merproject.org/~carsten/non-oss.png is a quick look at non-oss
15:29:46 <MSameer> I don't think geoclue-provider-here can be opened
15:29:55 <Stskeeps> -here can't, -geoclue can possibly
15:29:55 <MSameer> (not sure)
15:29:58 <Stskeeps> err
15:29:59 <Stskeeps> hybris
15:30:05 <MSameer> -hybris :)
15:30:19 <Stskeeps> #link http://releases.merproject.org/~carsten/non-oss.png is a quick look at non-oss
15:30:24 <Stskeeps> hw adaptation not included
15:30:29 <Stskeeps> sociald was since published
15:30:37 <Stskeeps> okay, next topic..
15:30:50 <Stskeeps> #topic Party time? (15 minutes)
15:31:01 <Stskeeps> kimmoli: and i guess cybette from jolla side?
15:31:08 <kimmoli> \o
15:31:20 * tbr proposes something in Tampere, Devaamo happy to help
15:31:26 <stephg> #info https://together.jolla.com/question/42121/first-one-year-party-27-nov-2014/
15:31:34 <kimmoli> tampere meh
15:32:06 <kimmoli> but yes, i had this blink that we could gather together in 1-year anniversary of 1st-one/launch day
15:32:23 <iekku> kimmoli, :D tampere isn't meh :P
15:32:51 <dr_datacenter> think also for non finns
15:32:54 <kimmoli> i'm not myself a party-organizer, so if this is going to happen, lots of love is needed
15:33:02 <cybette> I can help with the organizing
15:33:09 <tbr> kimmoli: somehow the people inside ring-3 consistently suck at organizing open source and sailfish events ;)
15:33:11 <stephg> cybette, iekku do Jolla plan anything (that you can talk about) for an anniversary?
15:33:25 <kimmoli> tbr:  i know.
15:33:34 <stephg> for the record if there were a thing I'd travel .fi
15:33:39 <cybette> stephg: not at the moment :)
15:33:45 <iekku> dr_datacenter, there's several lowcost airlanes coming to tampere. but yeah, it's not the easiest place to reach
15:33:50 <stephg> that you plan or that you can talk about ;)
15:33:53 <cybette> I suggest we can organize something globally as a community
15:34:07 <iekku> video streaming!!!
15:34:09 <dr_datacenter> not from Rome
15:34:13 <cybette> e.g. local meetups and google hangout to connect everyone
15:34:15 <tbr> hangout party? *snerk*
15:34:23 <cybette> tbr: great minds ;)
15:34:23 <Stskeeps> irc party?
15:34:24 * Stskeeps ducks
15:34:32 <tbr> IRC FTW!
15:34:38 <kimmoli> everybody on their own sofas
15:34:41 <dr_datacenter> or hangover
15:34:49 <dr_datacenter> ?
15:34:56 <sledges> no pants
15:34:56 <iekku> dr_datacenter, that will be then 28th party ;)
15:34:58 <kimmoli> it has been suggested Mbar close to kamppi
15:35:03 <tbr> but seriously, for f2f, the tampere offer stands
15:35:06 <beidl> sledges +1
15:35:08 <kimmoli> place for HKI
15:35:46 <cybette> we can use the TJC post https://together.jolla.com/question/42121/first-one-year-party-27-nov-2014/ and put locations for each city as separate answers
15:36:06 <Stskeeps> #info we can use the TJC post https://together.jolla.com/question/42121/first-one-year-party-27-nov-2014/ and put locations for each city as separate answers
15:36:15 <Stskeeps> #info suggested mbar close to kamppi by kimmoli
15:36:37 <kimmoli> or damourti at TJC it was
15:36:38 <Stskeeps> #info tbr suggests devaamo happy to help with tampere
15:37:06 <bobsummerwill> I hope there are some other sailors in Vancouver.   Or indeed in North America as a whole!
15:37:15 <Stskeeps> i've heard of jolla users in canada
15:37:31 <cybette> yeah me too
15:37:38 <kimmoli> äh... Congratulations, you have received a badge 'Stellar Question'
15:37:46 <cybette> kimmoli: :D
15:37:50 <sledges> bobsummerwill: or those who put sailfish on their nexuses;)
15:37:53 <Stskeeps> (some people have working LTE on rogers, or something like that..)
15:38:42 <dr_datacenter> are you plan jolla in canada?
15:38:48 <kimmoli> but decentralized it is. Jolla presence is "sailors at will" ?
15:39:30 <bobsummerwill> That is VERY interesting.   I'm on Rogers, but assumed from what I had read that not even 3G was possible with the existing hardware.   eBay time!
15:39:45 <cybette> kimmoli: yes for now let's plan it this way
15:40:06 <iekku> +1
15:40:11 <iekku> it's more community then
15:40:11 <Stskeeps> (5 minutes left)
15:40:35 <cybette> let's spread the word and continue the discussions in irc/tjc regarding timing and venues. when we get enough interest we can discuss about hangouts or video conf
15:40:46 <kimmoli> i'll edit tjc post a bit
15:41:03 <cybette> I can help with planning in Helsinki/Tampere (will probably attend Tampere one ;)
15:43:46 <cybette> tbr: I think there's also interest for a devaamo/Sailfish hack day in tampere soon (from last meetup)
15:44:00 <tbr> cybette: ok, let's do it!
15:44:35 <iekku> uu! hope i can participate too finally
15:44:45 <cybette> tampere is the happening place ;)
15:44:52 <kimmoli> ...urf...
15:45:07 <r0kk3rz> agreed tampere > helsinki :P
15:45:13 <Stskeeps> #topic Wrapping up, any other business, next meeting
15:45:15 <eleroux> kimmoli: no worries, we'll get something going on in HEL :)
15:45:30 <dr_datacenter> but some roadmap, next update
15:45:35 <Stskeeps> so maybe we should just wrap up kimmoli's question from first topic
15:45:37 <kimmoli> eleroux: i can jump to tampere (but coming back is the issue)
15:45:40 <dr_datacenter> and other crunchy things
15:45:55 <bobsummerwill> I just wanted to talk about BlueZ for a few mins, if there is time?
15:45:59 <Stskeeps> regarding daemon-level stuff such as toholed, would it still belong in 'applications' as such? bit academic when we can't offer it in harbour but..
15:46:16 <Stskeeps> i'd kinda consider it more as a part of the system somehow
15:46:34 <kimmoli> yes, it is tricky creature...
15:46:39 <cybette> Stskeeps: I think we can give bobsummerwill few minutes for BlueZ?
15:46:45 <lbt> mono
15:46:48 <Stskeeps> cybette: yes
15:46:48 <kimmoli> so toholed settings (daemon) could be in settings/system -cat?
15:47:00 <Stskeeps> let's just wrap existing topics out
15:47:03 <kimmoli> not in settings/apps..?
15:47:06 <Stskeeps> kimmoli: i'd think so but i'd ask a designer.. :)
15:47:51 <kimmoli> Stskeeps: ok, point me a designer and i'll poke
15:47:53 <M4rtinK> so maybe a third-party section in settings ?
15:47:57 <Stskeeps> as a general comment we need to 2x the time indicated on a topic in wiki and add 5 minutes to make sure we have enough time to talk about things, it gets a bit stressed else
15:48:10 <stephg> +1
15:48:13 <Stskeeps> ie 10 minutes is too short
15:48:15 <M4rtinK> with apps and services sub-sections ?
15:49:11 <cybette> yeah usually I estimate and add more minutes to the proposed ones. due to the nature of irc meeting, sometimes people underestimate time needed
15:49:22 <Stskeeps> :nod:
15:49:25 <iekku> +1
15:49:27 <Stskeeps> M4rtinK: perhaps
15:49:34 <M4rtinK> this category could be free- for- all basically
15:49:36 <kimmoli> ok, i got my direction now. (but for apps .desktop file [settings} section exec=harbour-app --settings or harbour-app-settings
15:49:41 <r0kk3rz> yeah i think this one is really up to the designers, there is no clear existing place for daemon settings in the gui
15:49:44 <Stskeeps> #action to look at how background 'daemons' could fit into settings u
15:49:45 <Stskeeps> i
15:49:46 <Stskeeps> #action to look at how background 'daemons' could fit into settings ui
15:50:06 <r0kk3rz> the more linux thing to do would be to have daemons with text file configs, but thats not very user friendly
15:50:07 <Stskeeps> #action general to estimate topics as more than proposed longer
15:50:18 <pvuorela> if harbour is not considered, daemons can already create their own settings under system.
15:50:21 <lbt> r0kk3rz: openvpn settings ...
15:50:43 <M4rtinK> well, the daemon might store the settings in a text file :)
15:50:46 <stephg> lbt: +1 (and their ilk)
15:50:48 <Stskeeps> cybette: do i remember wrong or did we discuss bluetooth in a earlier meeting?
15:50:56 <lbt> pvuorela: is that  know-how public ?
15:50:57 <Stskeeps> just to have a #link
15:51:06 <M4rtinK> having a GUI for that does not preclude thay
15:51:13 <M4rtinK> *that
15:51:24 <pvuorela> lbt: not documented, but there are examples for our system settings on the device.
15:51:32 <cybette> Stskeeps: we did, and I shared that meeting with bobsummerwill as well
15:51:35 <Stskeeps> oki
15:51:36 <Stskeeps> anyhow, bobsummerwill, tell us about bluez :)
15:52:03 <lbt> pvuorela: maybe send a post to ml to suggested one to look at as a simple/sane example ?
15:52:13 <bobsummerwill> A month or so back I started chatting with Javier on Twitter about BlueZ, because he had tweeted something along the lines of “Wow.  Tizen has a really complete BLE implementation”.   He then started digging into the code, because it had all happened within the black box of Samsung’s work on Tizen 2.x.   I started a dialog with some Intel architects on whether there was “good stuff” which we needed to pull into Ti
15:52:25 <Stskeeps> bobsummerwill: you got cut off at "we needed to pull into Ti"
15:52:28 <bobsummerwill> Tizen 3.x is using BlueZ5.
15:52:29 <pvuorela> the system settings need just .json file telling where the entry belongs etc.
15:52:41 <bobsummerwill> The question I have is “who is driving BlueZ for Mer/Sailfish/Jolla?”.
15:52:54 <bobsummerwill> Because if we’re sticking with BlueZ4 for the time being, there looks to be “good stuff” to steal from Tizen, which was never upstreamed.
15:53:10 <bobsummerwill> There is a whole longer mail-thread for this, which we could either just post to the mailing list
15:53:27 <bobsummerwill> Or of that is too spammy, could just be directed to somebody appropriate to triage
15:53:43 <Stskeeps> i think mailing list would be good, the guy from our side is hannu mallat, our tree is at https://github.com/mer-packages/bluez
15:54:19 <bobsummerwill> OK - thanks.   Will do mailing list post and follow-up with Hannu.
15:54:24 <Stskeeps> the challenge is bluez moving forward in general, it's quite problematic that bluedroid is what a ODM will deliver for a device, and not a ready-ish bluez setup
15:54:59 <bobsummerwill> Do you have insight into the background to the Bluedroid switchover?
15:55:20 <bobsummerwill> From reading the BlueZ mailing list, it seems it was a bit of a surprise to them, where Google just "made their own"
15:55:27 <lbt> from what I heard at ELC that wasn't a major problem at the driver level
15:55:29 <Stskeeps> not a lot. but i have a hunch lgpl/gpl was involved and that bluez wasn't ready for challenges of today's devices
15:55:42 <Stskeeps> / moving too slowly, but that's my private opinion
15:55:57 <bobsummerwill> It looks like they have done a LOT of work in the last few months, but it might be too late.
15:56:34 <bobsummerwill> See http://www.bluez.org/additional-features-of-bluez-for-android/
15:56:47 <Stskeeps> not to mention that a lot of the required bluez5 things are done on mainline, whereas most devices shipping today are 3.4 reference kernels..
15:58:00 <bobsummerwill> Anyway - I have no real investment in any particular stack.    I just want to have good BLE support, so I can do cool self-hosting stuff.
15:58:16 <Stskeeps> :nod: i think there's a few people interested in BT LE in the sailfishos community
15:58:23 <bobsummerwill> I just happened to be in the middle of the Tizen and Sailfish communities, and was able to tie some people together.
15:58:25 <kimmoli> +1
15:58:37 <Stskeeps> okay, does anybody else have anything they'd like to discuss while we are at it?
15:58:51 <Stskeeps> before moving on to discussion on next meeting and chair of next meeting
15:59:11 <dr_datacenter> vpn supports via connman?
15:59:14 <M4rtinK> python in store ? :)
15:59:25 <Stskeeps> wasn't that discussed last meeting? (python)
15:59:26 <cybette> #info some BlueZ info will be coming soon to mailing list, thanks to bobsummerwill :)
15:59:55 <M4rtinK> sure, but if there are any updates/timelines
16:00:17 <Stskeeps> dr_datacenter: given the challenges we have in connectivity in general and getting the rodeo horse connman can be once in a while under control, it'll probably be sometime after that
16:00:19 <stephg> purely out of interest, the beta launcher for android
16:00:58 <r0kk3rz> i think stabillity should be priority for conman rather than featue creep
16:01:11 <kimmoli> +1
16:01:22 <Stskeeps> stephg: i don't think we have any news on that today
16:01:58 <stephg> kk, no worries
16:02:15 <Stskeeps> M4rtinK: hmm, wasn't it coming with next update? i may remember wrong
16:02:21 <Stskeeps> it's in the old meeting logs :)
16:02:35 <M4rtinK> IIRC it is a store infra issue ?
16:03:05 <Stskeeps> in other news, mer-nemo merge is finally happening: https://build.merproject.org/project/show/mer-core:i486:devel - help to sort out GCC 4.8 build issues very welcome
16:03:18 <Stskeeps> this is on build level at first, git repos merge afterwards
16:03:29 <tbr> btw: I recently built connman from source and am rather happy with the improvements
16:03:39 <Stskeeps> 19 failures with gcc4.8/new glibc
16:03:46 <Stskeeps> nemo mw, to be precise
16:03:51 <tbr> wifi used to die a lot, randomly at home. now it happens rarely
16:04:13 <sledges> \o/ on nemo+mer
16:04:33 <Stskeeps> helping out may also get you a better toolchain faster ;)
16:04:53 <cybette> #info mer-nemo merge is finally happening: https://build.merproject.org/project/show/mer-core:i486:devel - help to sort out GCC 4.8 build issues very welcome
16:05:28 <Stskeeps> okay.. next meeting, i would propose 2 weeks from now, in the 10 UTC slot?
16:05:44 <stephg> +1
16:05:46 <iekku> +1
16:05:55 <M4rtinK> fine by me
16:06:02 <cybette> +1
16:06:17 <cybette> I'll chair, as Stskeeps has too many hats to let go of them all ;)
16:06:23 <tbr> please advertize the 10UTC fact aggressively with people in .au .nz and hong kong
16:06:26 <Stskeeps> nod
16:06:57 <Stskeeps> #info Next meeting 23 September 2014 at 10 UTC, cybette as chair
16:07:15 <r0kk3rz> are there many au/nz sailors?
16:07:25 <Stskeeps> r0kk3rz: there's certainly HK ones coming
16:07:34 <r0kk3rz> for sure
16:07:42 <Stskeeps> thanks everybody for coming to this meeting, feel free to join #jollamobile and #sailfishos afterwards for further conversation
16:07:50 <tbr> r0kk3rz: lpotter is from .au
16:07:50 <cybette> thanks Stskeeps for chairing!
16:07:55 <iekku> thank you everuone
16:07:58 <iekku> everyone
16:08:06 <Stskeeps> #endmeeting