10:00:10 <cybette> #startmeeting SailfishOS, open source, collaboration: 23-September @ 10:00 UTC
10:00:10 <Merbot`> Meeting started Tue Sep 23 10:00:10 2014 UTC.  The chair is cybette. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
10:00:10 <Merbot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:00:22 <cybette> #info Welcome to another week of SailfishOS OSS and collaboration meeting
10:00:29 <cybette> #info Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-September/005035.html
10:00:37 <cybette> I'm the meeting chair for today and will be keeping time and order. Please behave and show mutual respect, and let's have a productive discussion!
10:00:42 <cybette> #topic Brief introductions (5 min), prefix your information with #info
10:01:03 <cybette> #info Carol Chen, Community chief at Jolla, hatless chair today
10:01:14 <kimmoli> #info Kimmo Lindholm, community member, toh-tailor
10:02:11 <kjokinie1> #info Kalle Jokiniemi, kernel dev @ Jolla, toh dev kit documentation author
10:02:38 <phdeswer> #info Philippe De Swert, Jolla
10:03:00 <spiiroin> #info Simo Piiroinen, sailor at Jolla
10:03:27 <tbr> #info Thomas Ruecker, community member
10:03:40 <BasilSemuonov> #info Basil Semuonov, community member
10:03:56 <iekku> #info Iekku Pylkk�, developer community work @ jolla, community member
10:04:10 <pketolai> #info Pami Ketolainen, Bugzilla and TJC developer @ Jolla
10:04:42 * tbr looks around, where are the australians and new zealanders?
10:05:28 <iekku> not so many participants in general
10:05:35 <cybette> yea
10:05:38 <cybette> but let's continue
10:05:40 <kimmoli> y
10:05:44 * lbt arrives
10:05:46 <cybette> #topic TOH EEPROM stuff - Kimmoli (15 min)
10:05:52 <cybette> #info EEPROM reading by tohd fails if TOH is not attached correctly, add delay/retries > Was briefly disussed with K.Jokiniemi > is there any schedule for this?
10:05:57 <cybette> #info Is anyone interested in contributing to https://wiki.merproject.org/wiki/The_other_half ?
10:06:06 <cybette> kimmoli: please take the stage :)
10:06:12 <kimmoli> o/
10:06:19 <iekku> \o
10:06:24 <kjokinie1> cybette: kimmoli: I've done a patch for update10 that retries few times
10:06:43 <kimmoli> ok
10:06:50 <kimmoli> so that answers the first part :)
10:07:05 <kimmoli> is there way i can test it?
10:07:08 <kjokinie1> there's around 400ms time window for the electrical connection appear
10:07:09 <cybette> #info kjokinie1 has done a patch for update 10 that will retry a few times if TOH is not attached correctly
10:08:33 <kjokinie1> kimmoli: I can post the patch on some pastebin, or make a test kernel if you are feeling lucky ;)
10:09:01 <kimmoli> hmm, i have tried to compile kernel but failed
10:09:14 <kimmoli> but i have now more knowledge.
10:09:56 <tbr> compiling the kernel needs magic incantations so that the modules don't fail to load after boot
10:10:39 <kimmoli> but we can return to these details at some other moment i think.
10:10:41 <tbr> unless you are ok with broken wifi and android audio
10:10:57 <kjokinie1> tbr: wlan module I think is the one that fails.. I think it works though if you just copy the module binary from older lib/modules/<kernel-version>
10:11:37 <kjokinie1> ahh.. yes the android thing as well..
10:11:37 <tbr> kjokinie1: IIRC it does some kernel version checks. We had some issues while digging into USB with phdeswer.
10:11:52 <tbr> and --force on insmod/modprobe doesn't help
10:12:05 <tbr> anyway, not strictly necessary for just testing that
10:12:23 <kimmoli> yes, --force not working
10:12:34 <kjokinie1> yes, one can restore the old kernel back after testing
10:13:42 <kimmoli> is the zram module build-thing anything to look at? https://github.com/g7/kernel-module-zram-jolla
10:15:19 <cybette> 5 more min
10:15:22 <kjokinie1> hmm.. maybe I should just write a wiki on compiling the kernel
10:15:24 <cybette> maybe can move on to second part :)
10:15:35 <kimmoli> my 2nd Q was about the contribution to https://wiki.merproject.org/wiki/The_other_half
10:15:45 <kimmoli> but +1 to kernel-compile-wiki
10:15:58 <cybette> kjokinie1: can I #action that? :)
10:16:00 <kjokinie1> kimmoli: I wrote some stuff there already
10:16:24 <kimmoli> oo
10:16:25 <kjokinie1> cybette: sure
10:17:11 <cybette> #action kjokinie1 will update wiki with more info on compiling the kernel
10:17:13 <kimmoli> and my last question "And you ask why no user_data entry.. well, it was never implemented, sorry" was answered too :)
10:17:22 <faenil> kjokinie1: +1
10:18:20 <kimmoli> kjokinie1: was that jolla VendorID already assigned? or did you made-it-up while writing?
10:18:34 <kjokinie1> kimmoli: it's our USB vendor ID
10:18:44 <kimmoli> ok
10:19:16 <cybette> one more min...
10:19:35 <kimmoli> now waiting someone to tweet link there and saying Jolla is making more intelligent TOHs
10:19:47 <cybette> kimmoli: do we get people who want to contribute to ping you?
10:20:09 <kimmoli> i watch that page now
10:20:16 <kjokinie1> kimmoli: I'll post the patch and do some wiki on the kernel compilation
10:20:29 <kimmoli> ok
10:20:44 <cybette> #info join in and contribute to https://wiki.merproject.org/wiki/The_other_half !
10:21:04 <cybette> kimmoli: can we move on?
10:21:08 <kimmoli> yes
10:21:11 <kimmoli> tnx
10:21:16 <cybette> #topic General discussion - all (15 min)
10:21:27 <cybette> I think we have some update
10:21:33 <cybette> bijjal: are you here?
10:21:40 <bijjal> o/ yes i am
10:21:45 <cybette> \o
10:21:53 <bijjal> i have a couple of things to share
10:22:11 <bijjal> #info Update9 release: We expect to have a couple of more release candidates internally before we are good to release. Atleast this week, we will not be releasing it.
10:22:32 <bijjal> #info Visbility on Jolla's software roadmap: Our internal meetings to bring this together got postponed, so it will not be available during this month. I'll keep you updated when I have more info.
10:22:40 <bijjal> tbr ^
10:22:50 <kjokinie1> kimmoli: http://pastebin.com/qN3tpsfp
10:23:10 <tbr> bijjal: thanks
10:23:41 <iekku> bijjal, thanks <3
10:23:53 <cybette> thanks bijjal !
10:23:55 <bijjal> tbr: if you have something in particular that you are looking for, let me know. I can make sure that they are addressed in our meetings
10:23:59 <bijjal> (internal ones)
10:24:19 <bijjal> no problem
10:24:39 <tbr> bijjal: I'll prod you if something specific comes up (I'm split brained right now with something else and don't remember specifics)
10:24:51 <bijjal> ok
10:25:39 <cybette> now the floor is open for general discussions. feel free to ask/share something :)
10:27:20 <cybette> if there's nothing for 2 more min, I'll close the topic.
10:28:14 <lbt> so
10:28:27 <lbt> don't forget we have the XDA dev con this weekend
10:28:48 <lbt> it appears there'll be a panel on wearables and security too
10:29:02 <tbr> oh, I remembered one: could Jolla spare some engineering time and fix up the proprietary bits to at least not crash and burn on SIP?
10:29:30 <cybette> #info Some Jolla sailors and community members will be in XDA DevCon this weekend in Manchester, http://xda-devcon.com/
10:30:08 * faenil prods Stskeeps
10:30:14 <tbr> as the community has pretty much exhausted their possibilities in the area of SIP
10:30:27 <faenil> is there any news re "docs for community to help with Mer/Nemo merge" ?
10:30:34 <cybette> #action Jolla to possibly spare some engineering time and fix up the proprietary bits to at least not crash and burn on SIP
10:30:35 <tbr> I'm happy to help sailors with a test sip account and 'exact steps' for testing things
10:30:50 <faenil> it was discussed for the second time in June's meeting
10:30:50 <javisail> update9 is the one with wayland 1.3?
10:31:02 <tbr> #info tbr is happy to help sailors with a test sip account and 'exact steps' for testing things
10:31:27 <faenil> cybette: will you talk to the SIP guys? or should somebody do that?
10:31:42 <tbr> faenil: specifically that's whoever works on dialer
10:31:50 <tbr> used to be special and someone else
10:31:50 <faenil> s/should/doyouwantsomebodyto :D
10:31:58 <cybette> faenil: i'll take action on that :)
10:32:05 <faenil> cybette: good, thanks
10:32:21 <tbr> jusa_ is the audio side, which would ofc also be very nice if it could get some attention in this regard
10:32:50 <faenil> iekku: is there any news re paid apps? I think it was postponed or something
10:33:04 <faenil> also, any news about ambiance/icons in store?
10:33:22 <faenil> also, any news about beta channel?
10:33:31 <cybette> #action cybette to poke SIP/dialer guys in Jolla
10:33:41 <faenil> also, what about support for different versions of API in store? (which is the blocker for many apps, iirc)
10:34:09 <faenil> (sorry, I should have put all that on the topics list, but I remembered about the meeting only yesterday and it was too late already)
10:34:25 <jusa_> tbr: I'd be happy to look into the routing issues, but I will need help with all the SIP side since I'm not that familiar with that side
10:34:42 <cybette> faenil: i was about to say, next time please put them on topic list so we can try to prepare responses on our side as well :)
10:34:49 <faenil> yeah...
10:34:59 <cybette> 2 more min
10:35:02 <faenil> my fault
10:35:17 <faenil> so no responses available as of now? :D
10:35:40 <giucam> javisail: yes
10:35:44 <bijjal> faenil: the different versions of API would kinda be addressed in the multi version support we are preparing right now
10:35:45 <tbr> jusa_: not a problem. You're invited for beverages and I can help you with everything
10:35:50 <bijjal> but its not ready yet
10:36:15 <cybette> faenil: suggest it for the next meeting and we can discuss more details :)
10:36:38 <faenil> bijjal: yeah that's what I meant, the multiversion support
10:36:39 <cybette> ok topic time's up.
10:36:51 <cybette> #topic Wrap up and next meeting (10 min)
10:36:59 <faenil> it's been discussed a lot of times, but I don't remember what was the last official position
10:37:14 <faenil> (as it's usually just "it's not ready yet" :D )
10:37:16 <bijjal> faenil: ok, then it is under progress atm, we hope to still get it out on time for u9
10:37:20 <cybette> next week we are having Iteration planning at Jolla, so the next community meeting will be on following week
10:37:30 <faenil> bijjal: ah ok that's great to hear!
10:37:34 * tbr motions that meetings should not be at 10:00 UTC unless explicitly requested, turnout is low and no people from the intended time zones show up
10:37:41 <cybette> Oct 7 @ 15:00 UTC. any comments?
10:37:57 <tbr> #info * tbr motions that meetings should not be at 10:00 UTC unless explicitly requested, turnout is low and no people from the intended time zones show up
10:38:04 <tbr> now it's in the minutes and visible
10:38:21 <cybette> tbr: :)
10:38:46 <cybette> also please propose topics as early as possible
10:39:13 <faenil> can I ask to be more transparent on jolla's side? :D
10:39:16 <kimmoli> tbr +1
10:39:22 * phdeswer just checked insmod -f for wlan. It works but you need to load cfg80211 first and give full path
10:39:38 <cybette> faenil: in which aspect?
10:39:58 <faenil> (I'm not referring to this time as I didn't even put topics on the list...but generally, the answers are kind of "we need more time" "we're working on it" "we made progress" but no details)
10:40:00 <tbr> phdeswer: \o/
10:40:05 <faenil> thanks <3
10:40:49 <cybette> faenil: we'll do our best. I'll remind internally :)
10:40:58 <faenil> I think SK_work also wanted to argument on the transparency...but maybe he's not online atm :)
10:41:10 <faenil> cybette: <3
10:41:15 <cybette> so let's set the time for next meeting
10:41:34 <cybette> any volunteers for chair?
10:41:51 <faenil> let's chair o/
10:42:05 <javispedro> giucam, thanks!
10:42:13 <cybette> faenil: you'll chair the next meeting?
10:42:21 <faenil> cybette: yeah, why not
10:42:29 <cybette> \o
10:42:30 <faenil> as long as I can still talk :D
10:42:37 <cybette> sure :)
10:42:55 <cybette> #info Next meeting Tues Oct-7 @ 15:00 UTC, Chairperson faenil
10:43:08 <iekku> sorry, another meeting. no updates for harbour / store
10:43:25 <SK_work> faenil: online but won't be able to go to meeting :(
10:43:27 <SK_work> busy here
10:43:38 <faenil> SK_work: no problem ;)
10:43:42 <cybette> SK_work: hoepfully next meeting's time works better for you
10:43:52 <SK_work> please talk about transparency for me though faenil, counting on you
10:44:12 <faenil> SK_work: we're wrapping up mate, don't worry, let's see in the next meeting :D
10:44:25 <SK_work> ah ?
10:44:26 <SK_work> already
10:44:28 <SK_work> damn ... :(
10:44:50 <faenil> yep, only one topic proposed for this meeting, so it's a short one ;)
10:44:57 <cybette> ok thanks all for today. you can start proposing for next meeting's topics here https://together.jolla.com/question/54157/sailfishos-open-source-collaboration-meeting-planning/
10:45:04 <faenil> o/ cya people
10:45:23 <cybette> cheers
10:45:25 <cybette> #endmeeting