15:00:18 <cybette> #startmeeting SailfishOS, open source, collaboration: 25-November @ 15:00 UTC
15:00:18 <Merbot> Meeting started Tue Nov 25 15:00:18 2014 UTC. The chair is cybette. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
15:00:18 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:32 <cybette> #info Welcome to another week of SailfishOS OSS and collaboration meeting
15:00:34 <kimmoli> #info Kimmo Lindholm, TOH-tailor, tohkbd-team. Community member.
15:00:39 <cybette> kimmoli: hang on!
15:00:43 <kimmoli> oops
15:00:47 <cybette> #info Meeting info and agenda: https://lists.sailfishos.org/pipermail/devel/2014-November/005276.html
15:00:54 <cybette> I'm the meeting chair for today and will be keeping time and order. Please behave and show mutual respect, and let's have a productive discussion!
15:00:59 <cybette> #topic Brief introductions (5 min), prefix your information with #info
15:01:01 <cybette> kimmoli: now go :)
15:01:04 <kimmoli> #info Kimmo Lindholm, TOH-tailor, tohkbd-team. Community member.
15:01:09 <kimmoli> sorry...
15:01:10 <sledges> #info Simonas Leleiva, community sailor, sailfish for everyone (porting to android devices)
15:01:14 <ryukafalz> #info Jonathan Frederickson, community member
15:01:16 <tbr> #info Thomas B. Ruecker, community member
15:01:16 <M4rtinK_jolla_> #info Martin Kolman, community, modRana developer
15:01:23 <SK_work> #info Lucien Xu, community member and dev
15:01:23 <cybette> #info Carol Chen, Community Chief at Jolla, hatless chair today
15:01:24 <faenil> #info Andrea Bernabei, Nemomobile contributor, Sailfish community member
15:01:27 <situ> #info Siteshwar, community
15:01:28 <Armadillo> #info Thomas A., app developer
15:01:32 <Stskeeps> #info Carsten Munk, Chief Research Engineer @ Jolla
15:01:38 <stephg> #info Steph Gosling, community
15:01:51 <daitheflu> #info François, community member, dev-wannabe
15:01:58 <Aard> #info Bernd Wachter, Release Guy and other stuff @ Jolla
15:01:59 <Tofe> #info Christophe Chapuis, community member, qml dev
15:02:01 <BasilSemuonov_> #info Basil Semuonov, community member
15:02:03 <Nokius> #info Julius-Paul Jann, community
15:02:07 <cybette> kimmoli: no worries, I'm glad someone is excited about these meetings :)
15:02:15 <shfit> #info Stephan Hagen, community member
15:02:15 <kimmoli> triggerhappy
15:02:45 <kontio> #info Reto Zingg, Sailor @ Jolla
15:02:46 <Wnt> #info Jonni Nakari, community member, app developer
15:02:53 <giucam> #info Giulio Camuffo, developer at Jolla
15:03:01 <rainemak> #info Raine M�kel�inen, developer @ Jolla
15:03:04 <suy> #info Alejandro Exojo, Qt and Jolla user
15:03:07 <juergbi> #info Jürg Billeter, community member
15:03:12 <Jare> #info Jarkko Lehtoranta, developer @ Jolla
15:03:31 <ryukafalz> lots of people today :)
15:03:36 <MSameer> #info Mohammed Hassan. Hacker and Sailor (Mostly listening)
15:03:38 <Taaeem> #info Tim Klocke, community member
15:03:40 <pketolai> #info Pami Ketolainen, developer @ Jolla
15:04:05 <bijjal> #info Soumya Bijjal program manager at Jolla
15:04:08 <SK_work> yay, many people
15:04:11 <iekku> #info Iekku Pylkk�, develoeper-care + harbour qa @ jolla
15:04:12 <faenil> great to see a few sailors partecipating in meetings again :)
15:04:13 <phaeron> #info Islam Amer, developer @ jolla
15:04:14 <oniongarlic> #info Kaj-Michael Lang, community member, app developer
15:04:26 <SK_work> iekku: \o/
15:04:41 <SK_work> faenil: you know, vacation is over and Tablet is announced :)
15:04:42 <iekku> SK_work, o//
15:04:49 <VDVsx> #info Val�rio, sailor @ Jolla
15:04:58 <iekku> faenil, this timing is really difficult to me
15:05:10 * tbr is also happy to see many sailors on this community tour
15:05:23 <cybette> ok, all infos in? let's get to the topics!
15:05:40 <cybette> #topic Hot news: store API update - bijjal and kontio (15 min)
15:05:54 * cybette passes the stage to bijjal and kontio
15:06:01 <kontio> so as you might have noticed on https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/commits/master
15:06:17 <kontio> there are a few libs which we will allow in Harbour starting with update 10
15:06:46 <kontio> maybe not that many as you hoped for, but that is what we could figure out, can we do w/o too much of work on our side
15:07:18 <kontio> we also discussed a lot of other APIs/Libs
15:07:40 <kontio> e.g. gstreamer
15:07:52 <kontio> here a prepared note:
15:07:54 <kontio> So basically GStreamer 1.x is the API which will be allowed in harbour.
15:07:54 <kontio> The only exception is the interfaces from nemo-gst-interfaces and gst-plugins-bad and those will not be allowed since they are unstable and subject to change. If however there is enough demand then we can work out a solution.
15:07:54 <kontio> The issue with GStreamer 1.x shipped with SailfishOS is it's of limited functionality and allows only playing ogg files (Maybe some other free formats).
15:07:54 <kontio> This is indeed a bit disappointing but we are already improving it with each update. Work is ongoing to enable camera, HW video codecs and more SW codecs.
15:07:54 <kontio> Also please remember that using QtMultimedia is the preferred way of producing and consuming multimedia content on SailfishOS ;-)
15:07:55 <kontio> Please also note that applications dealing with multimedia should use resource policy engine to arbitrate access. Policy engine API is not harbour-whitelisted (But it can be included in the RPMs)
15:08:37 <SK_work> kontio: what are the new APIs ?
15:08:59 <SK_work> compared to U8/9 ?
15:09:14 <Armadillo> the github commit gives a good overview
15:09:16 <VDVsx> SK_work, see link above
15:09:22 <MSameer> SK_work: https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/commits/master
15:09:29 <sledges> #link https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/commits/master
15:09:38 <M4rtinK_jolla_> so no QtPositioning, right ?
15:09:57 <kontio> I think the link gives a good impression, yes no QtPositioning yet
15:10:02 <kontio> also no QtLocation
15:10:06 <faenil> they're mostly side libs
15:10:17 <M4rtinK_jolla_> thats quite unfortunate
15:10:31 <cybette> #info Starting with Update 10, a few new APIs will be allowed in Harbour. For details see log and above link
15:10:42 <iekku> we need to start somewhere
15:10:48 <Wnt> kontio: what is the reason of not icluding QtPositioning / QtLocation at this time?
15:10:53 <M4rtinK_jolla_> (don't care about Location but need Positioning)
15:11:02 <Wnt> is there something a community member could tdo to help?
15:11:09 <M4rtinK_jolla_> +1
15:11:50 <cybette> note this is an on-going process as well. we are sharing with you details right from the start
15:12:51 <MSameer> is QtPositioning API stable and backed by Qt project?
15:13:00 <kontio> Wnt: we have these 2 Qt modules under heavy discussion, there are internally still some things to clarify (relation to HERE) and one is still not yet stable so we need to get that in order first
15:13:44 <M4rtinK_jolla_> there are at least 3 apos tha use only Positioning
15:13:52 <kontio> as mentioned, this is the list of things we recognized, which we just can open w/o any problems
15:14:13 <M4rtinK_jolla_> foursail, maep- qt & modRana
15:14:34 <kontio> we were discussing 9 engineer for about 1 day
15:14:36 <M4rtinK_jolla_> so even Positioning without Locatin will help
15:15:15 <oniongarlic> when will gstreamer be allowed ?
15:15:19 <bijjal> kontio: lets take the demand for Positioning api back inhouse and try to get that sorted first?
15:15:29 <iekku> +1
15:15:35 <faenil> +1
15:15:44 <M4rtinK_jolla_> +1
15:15:59 <kontio> also all the nemo-qml modules we still have some concerns, there we need to discuss in the future how we can keep the api stable, but that shall not yet be a point to discuss
15:16:01 <MSameer> oniongarlic: when I provide the list of libraries but I am busy. If you can help doing that then please step up
15:16:05 <kimmoli> shortly list of new allowed: libssl, libcrypto, liblzma, libxml2, libogg, libvorbis, QtGraphicalEffects
15:16:43 <kontio> we had originally also QtFeedback on the list, but it has some lib name mess, once that is solved we can take that in too
15:16:49 <tbr> #info kimmoli summarized the git commits: shortly list of new allowed: libssl, libcrypto, liblzma, libxml2, libogg, libvorbis, QtGraphicalEffects
15:16:54 <kontio> bijjal: yeah
15:17:00 <MSameer> oniongarlic: but also note that it does not do much yet so it will sort of limit you a bit
15:17:03 <M4rtinK_jolla_> what about Python ?
15:17:12 <jmlich> +1 to positioning
15:17:16 <cybette> #info Demand for Positioning API noted and will be sorted/clarified inhouse
15:17:23 <cybette> 3 more min on this topic
15:17:24 <M4rtinK_jolla_> seems to be there but IIRC not actually allowed ?
15:17:29 <kimmoli> https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/pull/20 ?
15:17:44 <kontio> M4rtinK_jolla_: pyotherside w/ python will be allowed too
15:18:04 <ryukafalz> \o/
15:18:08 <M4rtinK_jolla_> kontion: nice - thanks!
15:18:10 <kimmoli> i dont use it but... nice
15:18:21 <oniongarlic> MSameer: ok
15:18:28 <faenil> cool
15:18:55 <kontio> you don't need to thx me :) I'm just the guy adding stuff to the validator :) thx the Jolla Sailors working in the back ground to make it possible
15:19:28 <sledges> \o/
15:19:49 <iekku> sledges, :D
15:20:17 <cybette> thanks kontio for addressing this topic! let's move on
15:20:25 <cybette> #topic Generic info about Jolla Tablet - SK_work or Armadillo (20 min)
15:20:33 <cybette> #info Idea is for Jolla to share a bit more info about the Jolla tablet followed by Q&A
15:21:10 <cybette> SK_work: please start and list what you would like to know more about
15:21:52 <cybette> or Armadillo ?
15:22:15 <tbr> will the bootloader allow unsigned chain - aka will it be open?
15:22:32 <faenil> boom
15:23:09 <Armadillo> My part was the thing with SailfishOS 2.0 where I wondered, that there's nothing mentioned about new features or concepts on the indiwgogo campaign
15:23:18 <Stskeeps> tbr: i'm currently crafting a blog post where i hope we'll find a good solution together balancing privacy, security, etc. UEFI is a bag of cats. but aim is ability to install alternative OS'es on it.
15:23:25 <Wnt> will the tablet have host mode supporting USB-ports?
15:23:26 <Stskeeps> what alternative OS'es is is a bit up for definition
15:23:36 <Armadillo> we can only see some slight UI changes, but I couldn't believe that this could be all of the changes
15:23:46 <tbr> Stskeeps: so it has UEFI, ok
15:23:47 <Stskeeps> tbr: but as a general note, i tested if i could load a open kernel without problems.
15:23:55 <Nokius> Stskeeps: +1
15:23:59 <tbr> +1
15:24:11 <Stskeeps> we built sailfishos on open devices. it doesn't make sense to deny that ability to others.
15:24:30 <tbr> Armadillo: I guess that will surface over time, they have been quite open with sharing new things as they come up
15:24:48 <tbr> thanks just wanted to have that statement for the record. :)
15:25:03 <ryukafalz> Stskeeps: Do you need libhybris to run on that hardware?
15:25:06 <Stskeeps> remember that this is a crowdsourcing campaign, a lot is to be decided together with you.
15:25:09 <Wnt> will the tablet support Intel Wireless Display?
15:25:11 <BasilSemuonov_> Stskeeps, enable flash(er) support for tablet, export partitions via usb or whatever
15:25:14 <tbr> #info Will the bootloader be open? - <+Stskeeps> we built sailfishos on open devices. it doesn't make sense to deny that ability to others.
15:25:30 <Armadillo> tbr sure time will tlel everything, but a bit more transparency can't be that bad ;)
15:25:35 <Stskeeps> ryukafalz: you don't strictly speaking need. we might, for sake of shipping on time. let's see.
15:25:44 <cybette> #info We built SailfishOS on open devices, and do not plan to deny this ability to others. Together we'll find a solution balancing privacy and security with the aim to install alternative OS'es
15:25:48 <Stskeeps> Wnt: unclear currently, until it's working.
15:25:50 <stephg> on the flasher front, presuming the partition layout will be such that images will be redistributable (versus what happened with the phone)
15:25:55 <Stskeeps> Wnt: it might be not even in CPU.
15:25:58 <faenil> Armadillo: it's not about being transparent, they probably don't know the new features yet themselves :D
15:26:17 <javispedro> Intel WiDi is more software than hardware, and Linux software for it is lacking, afaik.
15:26:21 <Armadillo> faenil great excuse ;D
15:26:50 <Wnt> Stskeeps: any comment about the USB-port question?
15:26:51 <faenil> Armadillo: it's not imho...but I don't work for them, so I don't know the truth ;) but I know the guys
15:27:26 <Stskeeps> Wnt: https://www.indiegogo.com/projects/jolla-tablet-world-s-first-crowdsourced-tablet , "System I/O" section
15:27:41 <Stskeeps> careful on the OTG though, that's another bag of cats, some things might work, some things might not.
15:28:11 <Stskeeps> .. i'm probably not using that term right :)
15:28:15 <faenil> like, what is expected to work?
15:28:21 <tbr> OTG is rarely what you want
15:28:23 <faenil> and what will probably not
15:28:32 <tbr> as OTG is a can of worms
15:28:46 <tbr> dynamic master slave negotiation through ID pin and all that jazz
15:28:47 <leinir> intel widi 4.0 is a subset of miracast, and the linux support stack for that is, as yet, incomplete... no idea if the android stack would be useable through libhybris, though, that'd be interesting
15:29:06 <Stskeeps> i do hope we can do something interesting TOH-like for the tablet through that, but i don't want to promise anything.
15:29:07 <Nokius> Stskeeps: Its only mention on indigogo not on the jolla product page may this the root of the confusion
15:30:19 <Wnt> will the tablet be able to run Andoid ARM binaries?
15:30:23 <daitheflu> Are you guys planning to release the Tablet-SDK earlier with insightful UI/UX guidelines so that apps are ready when the Tablet is launched ?
15:30:31 <Tofe> The "2.0" of SailfishOS 2.0 is because of UI form factor for the tablet ? Are these changes going to be compatible with the Jolla phone ?
15:30:45 <cybette> Nokius: thanks for pointing it out, we'll update the product page
15:31:05 <Nokius> +1
15:31:08 <Stskeeps> Tofe: https://together.jolla.com/question/63989/jolla-tablet-sailfishos-2-what-about-update-9/#post-id-64196
15:31:41 <Tofe> Stskeeps: oops, missed that. Thanks. :)
15:31:46 <cybette> #action cybette to get jolla.com/tablet updated with USB OTG info
15:32:07 <Stskeeps> daitheflu: let's see how things go. SDK is a device like any other from our POV so that enables us to do a lot of interesting things.
15:32:12 <Nokius> Few days back someone posted on tjc that the HW is nearly ready for the factory. So is there a possibility to add / change things like USB-Port / Battery?
15:32:15 <kimmoli> also need USB OTG power output specs
15:32:33 <faenil> kimmoli: +1
15:32:45 <tbr> kimmoli: don't call it OTG it's giving me nightmares :)
15:33:01 <Stskeeps> Nokius: i think there's a together.* topic on that?
15:33:01 <Armadillo> tbr OTG! :P
15:33:06 <javispedro> yeah, the port doesn't seem to be microAB from the pictures
15:33:16 * tbr calls in an orbital anvil delivery for Armadillo
15:33:18 <javispedro> (or is that the power button? =))
15:33:30 <Armadillo> :)
15:33:46 <Stskeeps> remember to raise these things in together.* too, it helps us keep track of things.
15:33:55 <iekku> +1
15:34:11 <Stskeeps> (irc is not an issue tracker, etc..)
15:34:14 <kimmoli> buttons are on same side as the headset connector
15:34:27 <cybette> Armadillo: did the link Stskeeps shared address your question?
15:34:30 <kimmoli> microsd and usb on opposite
15:34:54 <Armadillo> cybette yes :)
15:35:42 <daitheflu> Stskeeps: mkay
15:36:19 <cybette> #info Regarding Sailfish OS progress for phone and tablet, please see https://together.jolla.com/question/63989/jolla-tablet-sailfishos-2-what-about-update-9/#post-id-64196
15:36:26 <cybette> 4 more min on this topic
15:36:37 <Nokius> Stskeeps: had no luck to find information (link)
15:36:57 <Stskeeps> Wnt: i don't have a concrete answer on that but it's being looked into.
15:37:15 <Stskeeps> Nokius: it's there about USB OTG.
15:37:37 <Wnt> Stskeeps: that would be pretty big thing, as there is not much x86 Android binaries available afaik
15:37:45 <reviewjolla> Sidenote, News from the campaign: 1 million EUR has been reached just now (current exchange rate) People here are The First One's who knows this :)
15:38:02 <Stskeeps> http://commonsware.com/blog/2013/11/21/libhoudini-what-it-means-for-developers.html is what intel devices normally use; but how that works without android runtime is a bit unknown. also, a lot of processes are more GPU bound.
15:38:07 <SK_work> sorry, discussion with boss, catching with backlog
15:38:11 <Nokius> Stskeeps: no about the HW changes but stezz answerd / comment a fewso far for me okay
15:38:24 <Stskeeps> without/with our
15:39:30 <cybette> last call for this topic
15:39:35 <Wnt> Stskeeps: ok, great to see that you are looking in to it. thanks for the info!
15:39:49 <kimmoli> one more..
15:40:02 <kimmoli> oh, never mind.
15:40:04 <tbr> SK_work: I'll have a quick paste for the next topic.
15:40:04 <kimmoli> found it on tjc
15:40:17 <sledges> Nokius: https://together.jolla.com/question/63823/jolla-tablet-considering-hardware-requests-usefulness/
15:40:24 <cybette> ok let's move on
15:40:30 <cybette> #topic Is SailfishOS Open Source - SK_work or tbr (20 min)
15:40:31 <SK_work> tbr: ha ? cool
15:40:33 <Nokius> sledges: thanks
15:40:37 <tbr> So, recently there were a few obvious mistakes in the usage of the term "open source" by Jolla marketing. This is causing unnecessary tension and discussion and poisons the atmosphere between Jolla and the open source community. We'd like to remind Jolla about its roots and to respect the community on which its success is built.
15:40:47 <tbr> should info that...
15:40:51 <tbr> #info So, recently there were a few obvious mistakes in the usage of the term "open source" by Jolla marketing. This is causing unnecessary tension and discussion and poisons the atmosphere between Jolla and the open source community. We'd like to remind Jolla about its roots and to respect the community on which its success is built.
15:41:08 <Stskeeps> (i'll be handling this topic..)
15:41:26 * lbt dons flak vest
15:41:47 <tbr> lbt: I said obvious mistakes, less flak from that.
15:41:52 <lbt> :D
15:42:09 <Stskeeps> SK_work: do you have more to add or do you mind if i respond (i'm sorry, but this will be rather long.) to that and the original question?
15:42:10 <tbr> lbt: it draws random friendly fire from open source fundamentalists though...
15:42:15 <lbt> (also, sorry I'm late)
15:42:17 <SK_work> Stskeeps: please respond
15:42:25 <SK_work> tbr pretty summarized it well
15:42:31 <Stskeeps> We’re sorry. This slipped through our review of marketing material by those of us who know more about open source in the company. It has now been changed or is due to change in any upcoming marketing mails, indiegogo campaign and websites. We cannot change what was said in speeches or in videos, nor change already sent out marketing mails. We’ll do our best to not let this happen again - our intention was not to mislead.
15:42:34 <SK_work> maybe I will react or discuss some specific points
15:42:57 <Stskeeps> Open source means different things to different people - and especially since it has been watered out as a specific term by ambigious statements by several companies over the years. We didn’t mean to add to the confusion of what it really means.
15:43:17 <Stskeeps> We think this is a good chance to talk about what open source means to Jolla, both in theory and practice. I'm planning to make this into a blog entry, but here's the basics of the situation we as company and employees live in, so you can step into our shoes and see things from our view, too. .... -- and here i ask if people would like to read the rest.
15:43:26 <ryukafalz> I have a few things to add relevant to the original question on TJC but I'll wait a bit
15:43:49 <Stskeeps> or have any comments first
15:44:33 <jmlich> When you say "truly open source" many people expect source codes of everything. E.g. debian is truly open source, but Jolla?
15:44:37 <tbr> I think the term "open" has seen much more abuse than "open source". At least from my general perception. Not specific to Jolla
15:44:53 <Stskeeps> jmlich: i'll get to that in a bit
15:44:53 <SK_work> +1 for blog post, and more transparancy, as this will help people see that it's not about an evil corporation profiting from open source
15:45:02 <Stskeeps> Let’s start with company 101. A board is responsible towards the shareholders of a company. A board is also responsible for decisions regarding the assets of a company, which includes IPR, for example copyrights, software assets, patents, etc. The valuation of a company is also connected to the value of its assets.
15:45:08 <tbr> jmlich: they used to claim "truly open" for quite long, that also ruffled feathers
15:45:08 <Stskeeps> When an employee of Jolla writes a piece of code as part of his work, it becomes an asset of the company and hence any decisions related to that asset has to be stemming from decisions done by the board.
15:45:27 <Stskeeps> In Jolla, we have a standard policy set forth that allows an employee to open source code by standard unless it is somehow related to: Jolla artwork/trademark and/or look-and-feel (this pretty much means UI). 3rd party closed source software (a natural, really). Contributions that has been written using NDA materials from third party (don't want to taint open source projects). Contributions requiring copyright transfer (can't give away IPR ...
15:45:33 <Stskeeps> ... rights without approval).
15:45:39 <SK_work> tbr: open has so much abuse that nowadays it lost it's original sense (IMO). The use of "open source" wording at Jolla is worse
15:45:49 <Stskeeps> Unless you have explicit approval. Getting approval is a matter of explaining the case, pro/cons and then board will take the current situation of company, market, industry, competition + a lot of different variables that are not necessarily public and make a decision if it’s a wise choice to open source this at this moment.
15:45:54 <Stskeeps> The consequence is that a very big part of our stack (http://monster.tspre.org/~carsten/oss-vs-nonoss.png) is open source and we are slowly when the time and variables are right, open sourcing more of our stack.
15:45:55 <tbr> SK_work: yes
15:46:02 <jmlich> Stskeeps, okay, but I would choose "We support open source" instead of "We are truly open source"
15:46:05 <Stskeeps> [as answer to jmlich]
15:46:09 <Stskeeps> jmlich: i agree
15:46:17 <Stskeeps> We’re a small boat - we have to make the right choices or we sink as a business. That would mean no more Jolla, no more SailfishOS, no more contributions by us to a lot of open source projects. We have to be sustainable. We aren't backed by a large income from ads (Android), search engine referral income (Firefox OS) or have a rich founder (Canonical). We pulled in all our investment by showing what we're capable of and what we want to do. ...
15:46:18 <ryukafalz> Stskeeps: Is that image up to date?
15:46:23 <Stskeeps> ... Countless demos, presentations and investor pitches.
15:46:28 <Stskeeps> ryukafalz: almost, missing sailfishos-office in the wrong box i believe
15:46:46 <SK_work> +1 for support
15:46:49 <Stskeeps> Second, let’s take a look at the situation surrounding mobile device hardware. There’s a depressingly large amount of closed source in the software deliveries that come from the ODMs that make devices today, built on top of chipset vendor deliveries. No matter how much we kick and scream, this isn’t going to change. But at least we can make sure to select devices that have the interfaces to these closed source parts open and ...
15:46:53 <M4rtinK_jolla_> yeah - I don't like if something is marketted as open source when it is not
15:46:55 <Stskeeps> ... importantly, open source Linux kernel. Sometimes compromises are made as we'd end up not shipping in time if we didn't compromise - like with the WLAN driver in Jolla smartphone. And not shipping in time can mean the difference between company life and death.
15:47:05 <Stskeeps> Third, third-party software. Some things are simply too hard to develop on our own and doesn't exist in productised form open source. From our point of view, this is things like input methods, handwriting recognition, dictionary databases, AGPS infrastructure, wifi positioning and the Android runtime. If there is a productised and consumer proof open source solution for a problem we have, we usually opt for that. Nobody likes blobs, ...
15:47:11 <Stskeeps> ... especially engineers.
15:47:42 <SK_work> I would like to orient this topic a little bit
15:47:59 <Stskeeps> i can finish quickly, then we can orient all we want
15:48:01 <tbr> I would like to offer in addition, that by default even before the question "is it going to be open sourced", many jolla engineers contribute _directly_ to open source projects
15:48:06 <SK_work> Stskeeps: please finish then
15:48:09 <Stskeeps> Our open source work flow is such that developers check out open source repositories, work on items, get it building, tests things work, then pushes them to a pull request and then other people involved in the target project or otherwise as stack as a whole reviews it and then merges it to the repository. In many cases, we submit upstream to for example Qt as same time, as maintaining forks is a pain. Because of the policy set forth above, ...
15:48:15 <Stskeeps> ... we can do this without any kind of red tape/bureaucracy.
15:48:15 <tbr> _that_ is in my opinion a major plus on their balance sheet
15:48:16 <Stskeeps> We acknowledge that we aren't good enough at working properly in the open on many things but we are trying hard to make this better in between satisfying, improving your user experience on not the largest budget in the world and keeping afloat. Especially now it's a priority for us. We are pushing for open sourcing bits when we can and when the stars are appropriately aligned so the variables are right in order to do so and push a convincing ...
15:48:22 <Stskeeps> ... case.
15:48:24 <Stskeeps> It's not about an unwillingness on our side to do so - we are people who originate from open source communities just like you and we didn't leave our values at the door when we got employed and built this company.
15:48:28 <Stskeeps> I hope this helps to understand a little more about how things work in practice. and I'm happy to elaborate more if you have specific questions. I can understand if people may be disappointed, but I hope you also are able to see this point of view. I hope that the tablet campaign, especially as it's meant to be crowdsourced, will lead to good reasons for open sourcing more of SailfishOS. And that by you now knowing how to be in our shoes, to ...
15:48:34 <Stskeeps> ... help us argue why certain things should be, from a business point of view.
15:48:37 <Stskeeps> (EOF)
15:48:50 <SK_work> first oriented topic then
15:49:16 <SK_work> thanks Stskeeps for the summary
15:50:04 <SK_work> as I agree with Stskeeps about a lot of things that usually is not open source (driver blobs and 3rd party usually aren't), but for many GNU Linux users, this don't matter the most.
15:50:23 <SK_work> usually what's important to be open (sourced) is what they use and see, apps, and UI in general
15:50:41 <SK_work> SailfishOS do have these blobs etc. but also have a close UI
15:50:56 <SK_work> and this can be a major no-go for many users
15:51:12 <SK_work> ie: how to contribute to the ui ? fix things myself etc ?
15:51:45 <ryukafalz> SK_work: As a user, I disagree somewhat; I would rather have a closed UI on top of an open stack than an open UI on top of a closed stack.
15:51:45 <SK_work> moreover, there were promises from some sailors that part of the UI will be opensourced (veskuh at FOSDEM 2013 about Silica)
15:51:49 <stephg> SK_work: all devs are users but not all users are devs (not that I disagree with you)
15:51:52 * tbr will drag out the "can we please open messaging ui" so that someone could contribute multi-user chat etc
15:51:56 <Tofe> SK_work: for me, what I want/would like to be open-source are the bits that could need some fixing when the software isn't updated anymore, whatever the reason is.
15:52:03 <SK_work> sure some stuff are being opened now (browser), but it is not yet here
15:52:09 <Sail0r> Maybe the wlan issue with 802.1x no available via GUI would be fixed already if this would be open
15:52:10 <ryukafalz> tbr++ - messaging is one I'm particularly interested in
15:52:22 <ryukafalz> esp. since the underlying framework (telepathy) is open
15:52:31 <tbr> the underlying framework is magically powerful
15:52:34 <M4rtinK_jolla_> I think most people don't have issues with third party closed stuff
15:52:36 <cybette> #info TL;DR - Stskeeps providing a look at how things are inside Jolla the company and Jolla Sailors/engineers as part of the open source community. For more details, please read log.
15:52:39 <SK_work> ryukafalz: well, it's not comparing closed stack open ui vs open ui closed stack, it is about open ui
15:53:08 <SK_work> just to empasize: the point about UI is somehow more important because there were promises coming from sailors
15:53:09 <M4rtinK_jolla_> but with closed software from Jolla, brcause it is something that could be open but is not
15:53:31 <SK_work> M4rtinK_jolla_: +1
15:53:46 <faenil> +1
15:53:54 <shfit> +1
15:53:58 <Stskeeps> so, as a general note: we are embarking on both UI changes and a new device, we have an opportunity to really do much more in terms of transparency and really doing it together. When you have that framework put down, contributions becomes much easier, too. It's easy to contribute code, but sometimes it has to fit in a larger vision, for example design one..
15:54:17 <javispedro> development model is another story
15:54:18 <M4rtinK_jolla_> many people ask me why Sailfish os when there is AOSP that is fully open and kinda working
15:54:35 <Stskeeps> M4rtinK_jolla_: and at same time they really don't use the open parts in practice, like google closed homescreen, apps, etc..
15:54:36 <SK_work> and AOSP is open with open GUI
15:54:39 <Tofe> Could it be possible to know what is the reason for the closed source parts ? (NDA, IPR, etc)
15:54:46 <M4rtinK_jolla_> ew. they basically see the clisedness in Sailfish IS as a step back...
15:54:46 <tbr> M4rtinK_jolla_: the answer to that is Nemomobile as the UI. yes the silica issue remains, sorely.
15:54:50 <SK_work> s/AOSP/Cyanogen
15:54:53 <javispedro> UI components developed behind walls with code thrown over the wall would still qualify as open (no bazaar)
15:55:02 <SK_work> javispedro: +1
15:55:18 <ryukafalz> Stskeeps: You can build a usable system (including GUI) from AOSP
15:55:21 <SK_work> designers have the right to orient the developement of (eg) Silica
15:55:22 <M4rtinK_jolla_> Cyanogenmod ?
15:55:27 <SK_work> ryukafalz: this is called cyanogen :)
15:55:39 <SK_work> but if code is dropped, it would qualify as open source
15:55:52 <SK_work> not talking about open developement yet
15:55:58 <SK_work> that can come later
15:56:10 <ryukafalz> javispedro++ - even if the code were open, it doesn't mean Jolla needs to accept contributions if they want to keep their design focused
15:56:12 <jmlich> It would be nice if you could provide some "open source images". Nemo based OS without closed blobs (as it is possible), but with working gsm part (with this blob) and gpu (and this blob).
15:56:14 <tbr> I think the question is: why does jolla think it needs to excert the level of control over silica that it does?
15:56:18 <M4rtinK_jolla_> dropped ( which is unfortunate) but open
15:56:27 <Tofe> (or maybe, a note, from 0 to 10, about the probabiliy of seeing that part open-sourced in the short/medium term)
15:56:28 <tbr> because only providing binaries is control
15:56:34 <stephg> Tofe: +1
15:56:56 <tadzik> there was an idea to opensource com.jolla.mediaplayer, any news on that?
15:57:00 <stephg> this seems to me a forthcoming issue of intent for those components
15:57:07 <SK_work> jmlich: Jolla cannot even redistribute the binary blobs for the qualcomm part, so it wont happen
15:57:08 <M4rtinK_jolla_> at the same time I want to say I really like how transparently the open parts of Sailfis OS are developed ! :)
15:57:09 <SK_work> (sadly)
15:57:19 <ryukafalz> M4rtinK_jolla_: +1
15:57:20 <SK_work> M4rtinK_jolla_: +1
15:57:22 * tbr notes the prominent absence of any jolla statement in the last 3 minutes
15:57:29 <Stskeeps> and sometimes it comes down to variables that isn't share-able. the mobile industry is a really murky place with NDAs, etc
15:57:29 <jmlich> M4rtinK_jolla_, +1
15:57:35 <lbt> tbr: listening
15:57:44 <Stskeeps> tbr: trying to get a hold of the conversation but it just keeps scrolling..
15:57:44 <Stskeeps> :P
15:57:47 <tbr> lbt: contrast that with what Stskeeps said
15:57:50 <M4rtinK_jolla_> I just wish more components would be developed like this
15:58:05 <Tofe> Stskeeps: NDA is a valid reason to me, for saying that there is an NDA on a component is ok (for me)
15:58:06 <daitheflu> if we can't contribute directly to the UI/apps with code or PR requests, could we agree on a way for the community to fix things and get answers/POV from Sailors ?
15:58:09 <tbr> lbt: NDA, IPR, etc, no statement in that context _is_ a statement
15:58:18 <ryukafalz> Stskeeps: Haha, understandable. I think this topic might have needed more than 20 minutes. :P
15:58:34 <Stskeeps> daitheflu: that's also one big part of the whole crowdsourcing campaign.
15:58:40 <Stskeeps> to really build a product that way
15:58:41 <lbt> what are the sub-topics ?
15:58:41 <Armadillo> I like Tofe's idea to mark a open source requested component with a reason why it is not open source
15:58:46 * cybette adds 5 more min to this topic. so 7 more min total
15:58:47 <lbt> Silica as OSS
15:58:55 <lbt> Apps as OSS
15:58:56 <kimmoli> was there a roadmap of components being opened?
15:59:08 <lbt> cmp AOSP/UI
15:59:11 <SK_work> kimmoli: no
15:59:19 <M4rtinK_jolla_> what about crowdsourcin open source Sailfis OS ? :)
15:59:26 <SK_work> :D
15:59:27 <kimmoli> :)
15:59:31 <ryukafalz> Armadillo: +1 - if there are blockers for specific packages (NDA, third party components) it would be nice to have this information available
15:59:33 <M4rtinK_jolla_> or even separate components
15:59:39 <ryukafalz> even if vague
15:59:44 <M4rtinK_jolla_> I would pledge on that :)
15:59:45 <SK_work> I'm sharing tbr's skepticism about Silica's control
15:59:52 <Tofe> M4rtinK_jolla_: not sure we can pledge that much :p
16:00:00 <daitheflu> Stskeeps: for now I see a lot of things on TJC, but I never know if someone at Jolla answers or takes part of the discussion, would it be possible to add a tag to the discussion when a Sailor is watching it ?
16:00:04 <shfit> I think the important part right now is not to promise too much. It irritates people with false expectations.
16:00:10 <ryukafalz> e.g. I remember hearing something about something related to geoclue being blocked by inclusion of HERE maps integration
16:00:28 <M4rtinK_jolla_> BTW, closed Silica mens no community contributed fixes
16:00:30 <SK_work> shfit: +4
16:00:31 <daitheflu> so that we know we didn't just launch a message in a bottle
16:00:31 <SK_work> +1
16:00:36 <tbr> I think shfit makes an important point
16:00:39 <ryukafalz> but having this information available would be nice
16:00:57 <lbt> daitheflu: bring that up again in tjc topic
16:00:58 <M4rtinK_jolla_> and that Nemo needs to needlessly reinvent the wheel
16:00:58 <tbr> Setting the right direction for people to expect things helps to avoid disapointment and ruffled feathers.
16:01:19 <Stskeeps> there's no satisfactory answer from point of view of a public user or open source contributor to many of these questions and i have tried to hint to that a bit in my irc-blog above. it may be that silica is seen as a major asset when discussing with investors (as a example that is not necessarily true)
16:01:29 <Stskeeps> and that many of these variables are not ones that can be shared, no matter how much we wanted
16:01:35 <Stskeeps> we push our hardest
16:01:39 <cybette> daitheflu: we're working on a way to flag a TJC topic that's being worked on internally
16:01:46 <M4rtinK_jolla_> end result is that Nemo is almost unusable which is preventing people from contributing
16:02:18 <ryukafalz> cybette: That sounds like a great thing to have
16:02:34 <Stskeeps> i'd also like to emphasise a bit that a lot of the initial development of nemo UI was -also- done by jolla participants, while we were still in stealth, though, which many seem to forget
16:02:35 <locusf> M4rtinK_jolla_: almost unusable?
16:02:46 <cybette> 3 MIN left of the extended time
16:02:47 * SK_work reads the IRC blog again
16:03:23 <ryukafalz> Specifically, since I'm not the only one here interested in this: is there anything blocking open sourcing of the messaging UI?
16:03:27 <juergbi> might open sourcing UI components as GPLv3 + copyright assignment to Jolla be an option? phone vendors typically avoid selling devices with GPLv3 (if they don't have another license), so this might protect Jolla's asset to some extent and still provide open source to the community
16:03:36 <M4rtinK_jolla_> it was very very broken when I tried it a ~mobth (?) ago
16:03:41 <daitheflu> cybette: knowing it's being worked on is great, but knowing we, the community, can help in some way would be even better imho (by discussing, proposing ideas, or whatever...)
16:03:57 <faenil> juergbi: China's sellers fear nothing :P
16:04:01 <Stskeeps> i'd like to propose that we take this topic up again in 14 days and discuss a bit more in depth.
16:04:12 <stephg> +1
16:04:16 <ryukafalz> +1
16:04:21 <daitheflu> cybette: I see a few topics where people are waiting for a sign for almost a year :/
16:04:21 <lbt> can we sub-topic it as I suggested ?
16:04:26 <kimmoli> imho one can call yoghurt fat-free even it has 0.9% fat (9 written with small font), and for me there is enough open stuff that i can live with it. But that is just me (I can call "SFOS open enough source")
16:04:32 <SK_work> lbt: yes please
16:04:33 <sledges> M4rtinK_jolla_: nemo being wip is due to OBS not handling patterns, all related to its updates and also mer+nemo merge, guys are working on n9 already, and polishing along the way to bring back the VM image to stability - nemo'd gone through changes for better and still is
16:04:34 <tbr> juergbi: that's something seen as "sneaky tactic", wouldn't want to add that to jollas balance sheet :/
16:04:35 <cybette> daitheflu: well the idea did come from discussions with the community
16:04:37 <M4rtinK_jolla_> juergbi: that would be similar to what Digia started doing recently
16:04:41 <faenil> daitheflu: +100
16:04:46 <iekku> kimmoli, :D
16:04:47 <SK_work> kimmoli: open source enough is not open source
16:04:54 <Stskeeps> i'm trying to deliver a bit of more understanding how things work, it'll probably take a little bit to sink in :)
16:04:56 <juergbi> tbr: i don't consider it ideal either but better than closed source, don't you think?
16:05:13 <SK_work> Stskeeps: if we rediscuss about this in 14 days, please give us some insights in the meantime
16:05:24 <cybette> i'm closing this topic
16:05:28 <SK_work> like maybe putting what you have wrote here in a publically visible blog post
16:05:29 <SK_work> etc.
16:05:31 <tbr> juergbi: in that context yes, but the question is also, will it invite more people from the open source fundamentalist brigade
16:05:33 <daitheflu> cybette: well, then that's great, we're doing our job, and it proves you actually listen :)
16:05:41 * lbt wonders about a "what can you do with jolla sw - even if it's not open"
16:05:46 <cybette> #topic How to test for different devices with SDK - Armadillo (15 min)
16:05:50 <Stskeeps> SK_work: noted, thanks
16:05:54 <lbt> eg the on-device QML
16:06:09 <Armadillo> Well, the question is quite simple I think. We will get different devices (and I hope there will be much more in the future), with different resolution and architectures and last but not least different usage profiles.
16:06:11 <SK_work> Stskeeps: otherwise, the topic won't move (IMO)
16:06:14 <Armadillo> Do you plan to release different SDKs for the different devices or for each architecture or something like that? I'm also thinking about problems with very high resolutions on the tablet vs. mostly fullhd resolutions on developer desktop developer computers. Could get problematic and annoying I think.
16:06:14 <tbr> lbt: a way to contribute those fixes that people do would be nice...
16:06:20 <Armadillo> I may also add that I have no experience with other platforms like Android and the possibilities there.
16:06:28 <daitheflu> +1 for the publicly available (commentable ?) blog-post
16:06:34 <SK_work> daitheflu: +2 for commentable
16:06:58 <lbt> Armadillo: we don't have concrete answers as yet
16:07:17 <lbt> the SDK uses targets though - so there'll be a target per device
16:07:29 <lbt> eg right now you have a target for the emulator
16:07:46 <kontio> so multi arch is already supported with the target design
16:07:53 <lbt> yes the emulator is an x86 device
16:08:04 <SK_work> the only problem I see about emulator is lack of interaction with it
16:08:11 <kimmoli> changing emulator screen resolution/orientation (for UI) - is it possible?
16:08:14 <SK_work> you cannot emulate rotation, gps, messages etc.
16:08:18 <lbt> ha - try making a vbox screen too
16:08:30 <SK_work> BB emulator works quite the same, (they just use vmware player)
16:08:31 <lbt> SK_work: would love community help on emulator screen rotation
16:08:33 <M4rtinK_jolla_> I guess the store will need to support multiple packages per application
16:08:41 <M4rtinK_jolla_> arm & x86
16:08:44 <SK_work> but they have this Qt "controller" app that controls the emulator
16:08:46 <lbt> all that is OSS ... and we know community wants to hack on it
16:09:01 <SK_work> lbt: appended in the list of tasks I need to experiment
16:09:11 <Armadillo> lbt ok, already expected this :)
16:09:18 <lbt> yep - we need some kind of PoC of capabiity
16:09:18 <tbr> lbt: how can it be made more visible then?
16:09:25 <cybette> #info Sailfish OS SDK uses targets, so there'll be a target per device. Multi-arch is already supported with the target design.
16:09:31 <lbt> haha - v 0.1 of the SDK supported all this
16:10:00 <lbt> tbr: good question - as always we have limited resource on the SDK
16:10:09 <Jare> kimmoli: it is not possible in a vbox screen, where the emulator currently runs. But we have some plans for the future ie. using a different approach than the vbox screen
16:10:09 <Armadillo> how are those mega hype super resolutions handled in Android SDKs?
16:10:17 <Armadillo> anyone has knowledge about this?
16:10:20 <lbt> plus some of these things take a lot of effort for frankly limited reward
16:10:24 <Stskeeps> probably scaling
16:10:38 <SK_work> Armadillo: scaling the emulator screen ?
16:10:41 <SK_work> you can do this atm
16:10:44 <tbr> you can use much more resolution in Vbox and have it scale the output
16:10:53 <Armadillo> ok
16:10:53 <lbt> tbr +1
16:11:00 <Armadillo> wasn't aware of this
16:11:00 <SK_work> made it work on my thinkpad that have a limited screen height
16:11:07 <SK_work> Armadillo: yes it is pretty hidden
16:11:08 <cybette> #info We welcome community help on emulator, it's OSS :)
16:11:28 <tbr> except for the silica bits ;)
16:11:36 <locusf> yep and jolla-home
16:11:52 <SK_work> don't try to inject the previous topic here :)
16:11:53 * lbt wonders if cybette's #info was marketing and should have been vetted
16:11:58 <Armadillo> is there a TJC post how the scaling can be done?
16:12:01 * Stskeeps takes cybette to reeducational camp
16:12:08 <kimmoli> poor cybette
16:12:14 <SK_work> Armadillo: IIRC right control + C
16:12:18 <tbr> Stskeeps: 24h of RMS speeches?
16:12:24 <stephg> ick
16:12:25 <SK_work> and then you can resize the window to stretch the view
16:12:27 <SK_work> tbr: aww
16:12:27 <lbt> tbr: just the slush one
16:12:28 <faenil> cybette: welcoming help is not enough...you need at least a task list, a wiki, someone to talk to...all put together in a nice webpage :p
16:12:46 <Armadillo> SK_work thanks I'll try this :)
16:12:47 <tbr> lbt: RMS was at slush?
16:12:50 <faenil> you can't just throw the stone and expect people to pop in :)
16:12:51 <SK_work> faenil: thanks for volunteering to do paperwork for this :D
16:12:52 <M4rtinK_jolla_> faenil: +1
16:13:00 <lbt> tbr: yup ... was ... interesting
16:13:04 <lbt> anyhow ot
16:13:04 <SK_work> faenil: well, I got assigned a bit on the rotation thing
16:13:05 <SK_work> so
16:13:11 <cybette> #undo
16:13:11 <Merbot> Removing item from minutes: <MeetBot.items.Info object at 0x9760e90>
16:13:12 <M4rtinK_jolla_> oh, really ?
16:13:18 <M4rtinK_jolla_> interesting!
16:13:34 <cybette> sorry, trying to summarize stuff withint vetting myself :P
16:13:50 <tbr> ;)
16:14:14 * VDVsx thinks soon "open source" will be forbidden words in these channels :P
16:14:15 <lbt> there's lots of OSS stuff in the SDK and emulator to work on
16:14:43 <lbt> and afaik the key stuff for the emulator for rotation and such is all OSS
16:14:49 <SK_work> lbt: yes
16:14:59 <SK_work> just notifying the window that it orientation has changed
16:15:00 <SK_work> Qt stuff
16:15:06 <lbt> yep
16:15:08 <SK_work> (should be Qt stuff)
16:15:11 <lbt> now that stuff is cool
16:15:24 <lbt> I'd like to look at a generic event emulator framework
16:15:36 * SK_work thinks about doing a Qt emulator controller like on BB10 emulator
16:15:42 <SK_work> the one on BB10 was pretty nice
16:15:48 <lbt> that would fit into mer-core I'm sure
16:15:55 <lbt> and QA
16:15:55 <SK_work> lbt: :)
16:16:15 * SK_work don't have much time :(
16:16:24 <SK_work> anyway
16:16:35 <SK_work> cybette: how much time left on this topic ?
16:16:38 <lbt> yah - fyi it was always the plan that the emulator would do that (event simulation)
16:16:54 <cybette> SK_work: 4 MIN more
16:16:58 <SK_work> actually what faenil said is pretty right
16:17:02 <lbt> and of course accelerometer -> rotation
16:17:04 <SK_work> I would like to comment a bit on this
16:17:14 <SK_work> lbt: you said that there is a plan to do so
16:17:22 <SK_work> but lack of resources ?
16:17:23 <lbt> intention
16:17:26 <lbt> design
16:17:26 <SK_work> intention, ok
16:17:33 <lbt> mental idea
16:17:35 <SK_work> ok
16:17:36 <SK_work> :d
16:17:37 <SK_work> :D
16:17:39 <Armadillo> :D
16:17:58 <lbt> ok, ok - I thought about it in Amsterdam with a cider
16:18:02 <suy> The simulator in the Nokia Qt SDK had tons of features. I think it was based on QVFB, so that's a dead end, right?
16:18:07 <SK_work> so, community can get interested by this topic, tinker etc. without being afraid of reinventing a wheel that is running fine inside Jolla
16:18:10 <SK_work> isn't it ?
16:18:24 <SK_work> suy: it is based on a heavliy patched Qt version that is compiled on desktop
16:18:38 <SK_work> in Sailfish case, you will need to provide silica builds on desktop
16:18:46 <phaeron> actually the "plan" was to do it using statefs
16:18:54 <SK_work> that is unlikely to happen (see previous topic), at least from a community point of view
16:19:02 <SK_work> phaeron: ha ? interesting
16:19:04 <phaeron> and yes we lacked resources so far
16:19:38 <javispedro> features like GPS emulation are indeed possible to implement
16:19:40 <SK_work> phaeron: can we ask you questions on how to do these kind of stuff on IRC if needed ?
16:19:43 <deztructor> while needed providers are there
16:19:52 <phaeron> SK_work: deztructor would be more useful
16:19:53 <Stskeeps> SK_work: deztructor is probably better for statefs stuff
16:20:00 * Stskeeps high-fives phaeron
16:20:06 <phaeron> :)
16:20:07 <tbr> gps should be 'easy' as it's geoclue IIRC
16:20:29 <javispedro> OR at the qtpositioning level
16:20:31 <SK_work> deztructor: so there is only a need to connect a controller to emulator statefs ?
16:20:40 <deztructor> as btw also geolocation provider is in plans
16:20:54 <SK_work> deztructor: lack of resources too ?
16:21:06 <cybette> time is up. let's continue this discussion on e.g. #sailfishos
16:21:11 <lbt> deztructor: maybe a bit of a blog/paper on statefs in mer/sailfish ?
16:21:12 <SK_work> there are other interesting stuff to have too, like messaging emulation, email emulation etc.
16:21:16 <cybette> #topic Generic info on how's going inside Jolla about topic discussed before - SK_work (10 min)
16:21:16 <SK_work> lbt: +1
16:21:19 <SK_work> cybette: ok
16:21:27 <deztructor> SK_work: yes
16:21:40 <cybette> Aard: if you'd like to share your topic, this is the time :)
16:21:41 * deztructor is on the way to home, so losing connection periodically
16:21:48 <SK_work> this topic is more dedicated to faenil actually
16:22:07 <faenil> SK_work: why didn't you warn me then...I'm not ready :p
16:22:07 <deztructor> lbt: yes, it should be added... there is also docs on github
16:22:23 <Aard> a pre-announcement, full announcement will be on together in a few days
16:22:25 <SK_work> wanted to know the current status about work done on open part of Sailfish OS (basically mer nemo) that is going at Jolla
16:22:32 <SK_work> foor example: Mer Nemo merge
16:22:33 <faenil> but there are so many things that were discussed in the last year and never realized
16:22:41 <faenil> that it really doesn't take a rocket scientist :D
16:22:43 <SK_work> faenil: yeah, trying to pick interesting topics
16:23:25 <SK_work> Stskeeps: any status for the Mer Nemo merge topic ?
16:23:25 <Aard> after the testruns with opt-in we had for hotfix + u9 we decided now to make updates available as opt-in when we're qa-wise ready to release from our side, and will push it to the general public about 1 week later (having fixed critical issues, if found during that time)
16:24:00 <SK_work> thanks Aard
16:24:01 <Armadillo> a very good decision I think
16:24:03 <SK_work> that's cool
16:24:04 <SK_work> yeah
16:24:05 <stephg> Aard: cool. Will each need to be opted in or once you're opted in is that it?
16:24:06 <cybette> #info After the testruns with opt-in we had for hotfix + u9 we decided now to make updates available as opt-in when we're qa-wise ready to release from our side, and will push it to the general public about 1 week later (having fixed critical issues, if found during that time)
16:24:15 <tbr> nice
16:24:31 <Stskeeps> SK_work: ongoing, also much more important now with tablet effort. xulrunner compile issues
16:24:47 <Aard> stephg: you opt in once, and that's valid until you opt out. you won't be able to opt out when there's an opt-in update pushed out to avoid downgrading issues.
16:24:49 <shfit> cool, good move
16:25:00 <Stskeeps> when not doing blogs & fighting memory problems it's my fulltime thing..
16:25:01 <stephg> Aard: okies
16:25:02 <SK_work> Stskeeps: eww, is this the main blocker issue, what's remaining after that ?
16:25:11 <Stskeeps> SK_work: git repo moves
16:25:21 <SK_work> Stskeeps: moving everything from github to mer ?
16:25:21 <Armadillo> Aard sounds great :)
16:25:22 <Aard> it's just a start, but it should help us learn a lot we then can use for an (additional) full scale developer program
16:25:27 <Stskeeps> and bz stuff
16:25:30 <cybette> #info you opt in once, and that's valid until you opt out. you won't be able to opt out when there's an opt-in update pushed out to avoid downgrading issues.
16:25:47 <SK_work> thanks Stskeeps
16:25:54 <faenil> we can talk about the bugzilla-tjc integration, or about the repo/maintainer lists?
16:25:55 <Tofe> Aard: I like this opt-in thing. Makes real sense with such a community :)
16:25:59 <faenil> or about the documentation?
16:26:06 <faenil> there are so many things :)
16:26:18 <locusf> yeah whats the situation about autodoc?
16:26:19 <faenil> all with no updates
16:26:25 <faenil> for months
16:26:31 <faenil> (I'm evil >< )
16:26:35 <Stskeeps> i'd love to but typing with one hand.. kid wants me away from computer
16:26:38 <SK_work> #info Mer-Nemo merging status: currently, xulrunner compilation issue is blocking. Next: git repos moving and bugzilla stuff
16:26:46 <Stskeeps> but it has much bigger prio now
16:26:56 <SK_work> faenil: I wanted to talk about the docs issue
16:27:21 <SK_work> but seems to be a quite low priority as there is no much demand either
16:27:37 <Armadillo> what's that about?
16:27:46 * tbr won't bring up things that were handled in previous topics today
16:27:51 <faenil> Aard: did you just say you're releasing a more updated Update10 RC, basically? (sorry, didn't understand your previous msg)
16:28:08 <VDVsx> one nice task to pick would be make a qdoc template for Mer/Nemo that could be used as based for the ones without docs
16:28:22 <SK_work> Armadillo: docs auto-generated for every / most Nemo projects
16:28:30 <SK_work> so that people can use / hack nemo libs
16:28:40 <Armadillo> mhm
16:28:53 <SK_work> VDVsx: I have seen documentation effort done in nemo qml dbus plugin, but with sphinx
16:29:04 <Aard> faenil: when we're happy with the quality we'll make what is available to opt-in users. then we collect feedback. if there's someting critical to fix it, we'll fix it, if not, the same version will go out to everyone about 1 week later
16:29:13 <SK_work> maybe should we have a discussion about which should be used
16:29:28 <VDVsx> SK_work, that's the problem, no rules no template, will be a mess at the end, everybody will use whatever...
16:29:32 <SK_work> for example qdoc is quite painful to use, but you have nothing else for QML modules
16:29:46 <Aard> faenil: so this one is opting in to something reasonably stable, but it provides us data on bits like feedback handling for being able to at a later point make early release candidates available to developers
16:29:47 <SK_work> the lack of standardization disturbs me a bit
16:29:58 <SK_work> and it seems that inside Jolla there isn't any standardization either
16:30:14 <cybette> 2 more minutes
16:30:17 <cybette> i mean 1
16:30:25 <faenil> Aard: ok, awesome! :)
16:30:44 <VDVsx> SK_work, afair we would offer qdoc based stuff(silica), but maybe something escaping me
16:30:47 <SK_work> what disturbs me is the lack of mails in mer ML for example
16:31:05 <SK_work> of course, stuff happen on github and IRC
16:31:07 <M4rtinK_jolla_> community location project status ? :)
16:31:19 <M4rtinK_jolla_> ( eq that poitle thing)
16:31:29 <M4rtinK_jolla_> *pootle
16:31:35 <cybette> M4rtinK_jolla_: please propose it for next meeting :)
16:31:41 <cybette> wrapping up
16:31:48 <M4rtinK_jolla_> ok
16:31:49 <cybette> #topic Wrap up and next meeting (5 min)
16:31:50 <SK_work> ok
16:31:55 <faenil> Aard: so the next optin is coming in...approximately, how long? ("when it's ready" is not accepted :D )
16:32:03 <SK_work> faenil: when it's ready
16:32:07 <SK_work> you know with sw
16:32:11 <sledges> soon(TM)
16:32:14 <SK_work> this is the best you can have
16:32:15 <sledges> :P
16:32:17 <Aard> faenil: give me a few days to prepare the togethe-message first :p
16:32:19 <faenil> I also know that you know it's going to be 1month, or 1 year :P
16:32:19 <cybette> btw I'll be away for a couple of weeks, and I propose next meeting for Dec 16, last one for this year before Christmas holidays
16:32:20 <VDVsx> in coming months :P
16:32:30 <Aard> for u10 we're currently working on harbour intake, as mentioned earlier
16:32:31 <faenil> Aard: ok, so not less than a week
16:32:49 <stephg> cybette: +1 fwiw
16:32:53 <cybette> stephg: thanks :)
16:33:11 <cybette> let's decide on next meeting. Dec 16 @ 15 UTC. objections?
16:33:27 <kontio> faenil: and you know each time you ask, we delay it by some days, just for the fun of it :p
16:33:30 <faenil> I propose another meeting next week to discuss the opensource stuff, which we didn't have enough time for today
16:33:30 <SK_work> cybette: in 3 weeks ? :(
16:33:39 <SK_work> +1 faenil
16:33:43 <faenil> just to hit on the nail while it's hot (or how was the saying?)
16:33:47 <M4rtinK_jolla_> faenil: +1
16:33:47 <SK_work> otherwise the topic will get cold
16:34:08 <Stskeeps> ok
16:34:09 <M4rtinK_jolla_> definitely a good idea!
16:34:16 <tbr> but is jolla willing to?
16:34:17 <cybette> we need a chair, I won't be around
16:34:21 <stephg> faenil: also +1
16:34:25 <Stskeeps> anybody wants to chair?
16:34:26 <faenil> kontio: and each time you delay the update, people get more disappointed about Jolla's 1month update promises...you know, just for the fun of it! ;D
16:34:31 * tbr can chair, reluctantly
16:34:34 <stephg> (seems we need to have it hashed out more before coming here again)
16:34:44 <tbr> as it's a topic that I'd probably also have things to say
16:34:46 <tbr> but I'll do it
16:34:48 <shfit> just one quick afterthought: when announcing the opt in updates, dont explicitly mention that offucial updates will follow 1 week later
16:35:03 <faenil> tbr: maybe we can look for another chair during the week
16:35:17 <Aard> shfit: why?
16:35:18 <kontio> faenil: touche :)
16:35:19 <cybette> ok next meeting Dec 2 @ 15 UTC, chairperson tbr (tentative) - agreed?
16:35:22 <M4rtinK_jolla_> tbr: thanks! ( just in case)
16:35:23 <faenil> kontio: :)
16:35:26 <SK_work> yes, please, tbr should not be chair IMO
16:35:43 <shfit> if it takes longer that a week to fix things, people will get anxious
16:35:57 <VDVsx> and disappointed
16:36:03 <shfit> yep
16:36:04 <tbr> I propose we have a specific TJC item for next week
16:36:07 <VDVsx> if does not come in one week
16:36:13 <faenil> tbr: +1
16:36:15 <stephg> +1
16:36:32 <Aard> shfit: the idea is that we're quite open about what shows up during that time, so people should see what we're working on. also, the message will not be "in one week", but "one week, given stuff does not blow up unexpectedly"
16:36:33 <faenil> we could just handle the opensource discussion with the subsections as proposed by lbt
16:36:39 <M4rtinK_jolla_> shfit: lets call it beta update or pre-updatec ? :)
16:36:54 <cybette> special meeting next week, "regular" comunity meeting resumes on Dec 16
16:37:21 <kimmoli> cybette: remember to change channel topic too :)
16:37:55 <cybette> #info "Special" meeting next week Tues Dec-2 @ 15:00 UTC, Chairperson tbr (tentative)
16:37:57 <shfit> yeah, ok, im just bringing it up, because many users get quite impatient when deadlines are not kept
16:38:00 <cybette> #info Next regular meeting Tues Dec-16 @ 15:00 UTC, Chairperson cybette
16:38:20 <sledges> indeed
16:38:27 <cybette> #action tbr to create specific TJC item for next week's special meeting
16:38:40 <cybette> #action cybette to change channel topic for next meetings
16:39:05 <cybette> any further clarification needed?
16:39:18 * tbr will need to read log before opening that item
16:39:29 <tbr> I'm a bit unclear about the exact scope of the meeting
16:40:11 <cybette> tbr: we can discuss this in the regular channels to define the agenda
16:40:14 <tbr> yes
16:40:18 <stephg> perhaps even the TJC item needs the full collaborative attention
16:40:22 <stephg> ahead of that
16:40:22 <tbr> I didn't want to hold up this meeting
16:40:46 <cybette> it's been a great meeting though, lots of participation. thank you everyone!
16:40:53 <cybette> #endmeeting