#mer-meeting: SailfishOS, open source, collaboration: 10-March 2015

Meeting started by iekku at 15:00:22 UTC (full logs).

Meeting summary

    1. intoduce yourself, use #info in the beginning (iekku, 15:00:37)
    2. Kimmo Lindholm, TOHs et.al. (kimmoli, 15:00:45)
    3. Aleksi Suomalainen, Nemo Mobile community (locusf, 15:00:47)
    4. Martin Brook , community member, HADK eater (vgrade_mm, 15:00:58)
    5. Nokius, community (Nokius|jolla_, 15:01:14)
    6. Lucien Xu, community (SfietKontantinW, 15:01:15)
    7. Ville Määttä, random dev, Ruriat (vmaatta, 15:01:17)
    8. Richard Rondu, app developer (RPNCalc, Parrot Zik 2.0 Manager) (lainwir3d_, 15:01:20)

  1. Intro (5 min) (iekku, 15:01:24)
    1. Osmo Salomaa, app developer (otsaloma, 15:01:55)

  2. Intro (5 min) (iekku, 15:02:03)
    1. Martin Kolman, community member & modRana navigation system developer (M4rtinK_jolla_, 15:02:23)

  3. Intro (5 min) (iekku, 15:02:41)
    1. Kimmo Lindholm, TOHs et.al. (kimmoli, 15:02:46)
    2. intoduce yourself, use #info in the beginning (iekku, 15:02:51)
    3. Martin Brook , community member, HADK eater (vgrade_mm, 15:02:54)
    4. Richard Rondu, app developer (RPNCalc, Parrot Zik 2.0 Manager) (lainwir3d_, 15:02:57)
    5. Simonas Leleiva, Jolla sailor, #sailfishos-porters, community pootle (sledges, 15:03:07)
    6. Lucien Xu, community, dev (SfietKontantinW, 15:03:08)
    7. Carol Chen, community chef @ Jolla, tired but happy sailor from mwc (cybette, 15:03:15)
    8. Nokius , community (Nokius|jolla_, 15:03:18)
    9. Ville Määttä, random dev, Ruriat (vmaatta, 15:03:29)
    10. Simo Piiroinen, Jolla sailor, mostly nemo mw (spiiroin, 15:03:37)
    11. Iekku Pylkk�, Developer community sailor, hatles chair today (iekku, 15:03:47)
    12. Thomas Perl, sailor (thp, 15:04:17)
    13. Osmo Salomaa, app developer (otsaloma, 15:04:22)
    14. Timo Munnukka, developer (Munnu, 15:04:54)
    15. Ville Määttä, random dev, Ruriat (vmaatta, 15:05:13)
    16. Aleksi Suomalainen, Nemo Mobile community (locusf, 15:05:26)
    17. community member, currently attempting to get android compatibility working via cyanogenmod (nh1402_, 15:05:59)

  4. SailfishOS and SailfishOS Secure - Nokius (10-20 min) (iekku, 15:07:13)
    1. Nokius can't join, "Please tell more about the plans will be the consumer SFOS Version be an other branche or will it have the same Core." (iekku, 15:07:22)
    2. https://cdn.jolla.com/wp-content/uploads/bsk-pdf-manager/49_PRESS_RELEASE_MWC_SAILFISHSECURE_FINAL.PDF (iekku, 15:08:26)
    3. we made the announcement for Sailfish Secure at MWC, however the project has just started and things are still being defined (iekku, 15:12:25)
    4. there is plan to make it available for consumers (iekku, 15:12:37)
    5. will it be open source, and if so, what type of licence? i.e. permissive or not etc. (vmaatta, 15:14:17)
    6. "others require customized solutions" i.e. proprietary? (vmaatta, 15:16:16)
    7. ACTION: iekku will collect unaswered questions (iekku, 15:20:56)
    8. integration of gpg at system level would be quite beneficial and fit the Secure OS theme (iekku, 15:21:43)
    9. https://together.jolla.com/question/887/gpg-for-email-and-other-stuff/ (thp, 15:22:27)
    10. gpg integration into system/apps best discussed/brainstormed at a together.jolla.com topic (iekku, 15:22:35)
    11. https://together.jolla.com/question/887/gpg-for-email-and-other-stuff/ (iekku, 15:22:54)
    12. more info will be shared as project progress (iekku, 15:24:58)

  5. Clarification about GPS & QtPositioning usage in Jolla store applications - M4rtinK (20 min) (iekku, 15:25:26)
    1. technically, starting with qt 5.2, we can now allow qtpositioning. just waiting on legal team to approve some details. (iekku, 15:30:31)
    2. thp tries to push it internally (iekku, 15:36:47)
    3. you guys have to submit apps to harbour then using qtpositioning :p (iekku, 15:36:56)
    4. ACTION: thp to push forward qtpositioning internally. eta 1 week, no promises. (thp, 15:37:00)

  6. General discussions - everyone (10 min) (iekku, 15:38:04)
    1. ACTION: iekku to find out status of offline HERE maps (stefano said that it would start this year) (iekku, 15:39:04)
    2. https://together.jolla.com/question/339/downloadable-map-data-and-offline-turn-by-turn-navigation-in-maps/?answer=54921#post-id-54921 next january (NSA-Rep, 15:42:21)
    3. https://together.jolla.com/question/8779/no-notification-when-new-voicemail/?answer=76513#post-id-76513 (SfietKontantinW, 15:44:47)
    4. vmaatta hopes the Qt Purchasing API is being taken into consideration and usable where possible (iekku, 15:46:59)
    5. http://www.qtday.it/ (iekku, 15:47:52)
    6. get 30% discount on qtday: https://ti.to/develer/qtday2015?discount_code=GNR30 (cybette, 15:48:36)

  7. Wrap up and next meeting (5 min) (iekku, 15:49:33)
    1. next meeting 24-March 2015, 15:00 UTC (iekku, 15:53:15)


Meeting ended at 15:53:45 UTC (full logs).

Action items

  1. iekku will collect unaswered questions
  2. thp to push forward qtpositioning internally. eta 1 week, no promises.
  3. iekku to find out status of offline HERE maps (stefano said that it would start this year)


Action items, by person

  1. iekku
    1. iekku will collect unaswered questions
    2. iekku to find out status of offline HERE maps (stefano said that it would start this year)
  2. inte
    1. thp to push forward qtpositioning internally. eta 1 week, no promises.
  3. thp
    1. thp to push forward qtpositioning internally. eta 1 week, no promises.


People present (lines said)

  1. iekku (64)
  2. SfietKontantinW (32)
  3. cybette (25)
  4. M4rtinK_jolla_ (21)
  5. vmaatta (21)
  6. thp (18)
  7. NSA-Rep (16)
  8. inte (5)
  9. lbt (4)
  10. Nokius|jolla_ (4)
  11. vgrade_mm (3)
  12. otsaloma (3)
  13. lainwir3d_ (3)
  14. kimmoli (3)
  15. locusf (3)
  16. merbot (2)
  17. Munnu (1)
  18. nh1402_ (1)
  19. spiiroin (1)
  20. sledges (1)


Generated by MeetBot 0.1.4.