14:31:45 <cybette> #startmeeting SailfishOS, open source, collaboration: 6-Oct @ 14:30 UTC
14:31:45 <merbot> Meeting started Thu Oct 8 14:31:45 2015 UTC. The chair is cybette. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
14:31:45 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:31:56 <Mikaela> lbt: /msg chanserv op #channel nick
14:32:12 <cybette> there seems to be log at least
14:32:38 <sledges> o/
14:32:38 <iekku> should bot has ops too?
14:32:44 <cybette> #info Welcome to a new season of SailfishOS OSS and collaboration meetings!
14:33:08 <cybette> #info Meeting info and agenda: http://lists.sailfishos.org/pipermail/devel/2015-October/006578.html
14:33:09 <sledges> #info Simonas Leleiva, sailor, porters and pootles
14:33:16 <cybette> sledges: hold your horses :)
14:33:20 <iekku> :D
14:33:22 <sledges> mostly afk today:/
14:33:26 <sledges> ooops:D
14:33:26 <cybette> I'm the meeting chair for today and will be keeping time and order. Please behave and show mutual respect, and let's have a productive discussion!
14:33:31 <cybette> #topic Brief introductions (10 min), prefix your information with #info
14:33:38 <cybette> sledges: now :)
14:33:40 <jfred> #info Jonathan Frederickson, community member
14:33:43 <kimmoli> #info Kimmo Lindholm, TOHs et.al. , community
14:33:43 <sledges> lol, writing from fingerterm doesn't imply reading channel, vkb in a way :D
14:33:46 <Tofe> #info Christophe Chapuis, community member
14:33:49 <lbt> #info David Greaves: sailor and Mer guy
14:34:04 <lainwir3d> #info Richard Rondu, community member & app developer
14:34:05 <stephg> #info Steph Gosling, community
14:34:07 <sledges> #info Simonas Leleiva, sailor, porters and pootles, limited presence today due to vkb and afk
14:34:10 <cybette> #info Carol Chen, Community chief at Jolla, hatless meeting chair today
14:34:12 <urjaman> #info Urja Rannikko, sometimes helps out with TOHKBD
14:34:23 <iekku> #info iekku Pylkk�, developer-community sailor at Jolla
14:34:25 <eugenio> #info Eugenio Paolantonio, community member, patch developer, professional lurker
14:34:26 <M4rtinK> #info Martin Kolman, community member, modRana developer
14:34:59 <bobsummerwill_> #info Bob Summerwill, community member, CEO http://doublethink.co
14:35:06 <Aldrog> #info Andrew Penkrat, community member and app developer
14:35:11 <lukedirwalker> #info Lukas Vogel, community member, app dev
14:35:19 <pketolai> #info Pami Ketolainen, backend developer @ Jolla
14:35:22 <daitheflu> #info François, community member, app dev
14:35:22 <Nokius_work> #info Julius-Paul Jann, community member
14:36:17 <SfietKonstantinW> am I late ?
14:36:25 <cybette> if you're just joining, please intro yourself with #info
14:36:26 <kimmoli> no
14:36:28 <cybette> SfietKonstantinW: nope!
14:36:29 <SfietKonstantinW> #info Lucien Xu, community member and dev
14:36:43 <stephg> 09889321S No
14:37:18 <locusf> #info Aleksi Suomalainen, community member
14:38:09 <cybette> 5 more min for introductions (prefix with #info) since we haven't had meetings for a while, let's get (re)acquainted!
14:38:31 <olpe> #info Olavi Haapala, community member and dev
14:39:44 <vgrade_w> #info Martin Brook, community porter
14:39:47 <cybette> vgrade_w, MoritzJT: we're still in intro round! #info yourself
14:40:48 <IgorSK> #info Igor Korolyuk, community member
14:41:02 <MoritzJT> Never attended this before and will mostly stay silent. Am Student of electrical engineering and IT using Jolla on SFOS 2.0 UI right now. Community member
14:41:26 <MoritzJT> #info Moritz Thiele, community member, tester of all openrepos
14:41:52 <cybette> MoritzJT: welcome!
14:42:10 <iekku> MoritzJT, welcome. i hope we see you in the future meetings as well
14:42:50 <MoritzJT> Thank you, will try to attend when possible
14:43:07 <cybette> ok great! thanks everyone for the intros and glad to see many of you joining today's meeting. let's get onto the topics!
14:43:17 <SfietKonstantinW> hi MoritzJT :)
14:43:26 <cybette> #topic How to ease 3rd party contribution to SailfishOS/Mer Middleware OSS components - locusf (30 min)
14:43:31 <dr_gogeta86> #info Fabio Isgrò , community member, StuntMan
14:43:34 <cybette> #info It is apparently not very well known how to contribute to the components in the topic. See for example: https://github.com/sailfishos/sailfish-utilities/pull/33
14:43:40 <cybette> #info Namely the commit message must conform to a specific form only. This is not well known information to other contributors who might have changes to the OSS components, wether Mer Middleware or SailfishOS.
14:44:10 <cybette> locusf: you have the stage
14:45:00 <locusf> ok
14:45:26 <locusf> so the idea about introducing common guidelines to contributions to the Mer Middleware has arised a couple of times before
14:46:16 <locusf> but essentially since the "new" contribution rules are not well known, I was wondering if there is a possibility to create something that applies for all of the middlware components
14:46:36 <locusf> the new rules meaning to link the PR to a Mer bugzilla bug
14:46:48 <locusf> and hinting this in the commit message
14:47:24 <locusf> the question is, do the same contribution guidelines apply to whatever component/software there is available for modification by the community?
14:47:30 <Aard> this pull request was handled very badly by dez. he should've just accepted the pull request as-is, add a changelog reference in an annotated tag, and _then_ inform about the changelog guidelines, in case the contributor is interested in further contributions
14:47:50 <Aard> exactly that problem of 'drive by' contributors was highlighted here several times when discussing the bz linkage several months ago
14:47:54 <locusf> eg the one above is linked to sailfish-utilities has but I'm aware there has been some more done to eg. browser
14:48:04 <locusf> Aard: indeed
14:48:33 <urjaman> I'm curious as to why that contribution even needed an essentially dummy mer bug made for it? (and maybe others for text changes or whatever, but still...)
14:49:29 <M4rtinK> I'll just note that similar rules are often used elsewhere
14:49:31 <locusf> I've heard things about this relating to the releasing/integration
14:49:37 <locusf> but just things
14:49:43 <lbt> locusf: it sounds like we do need to get this stuff written up and into the open. There's been ml information but should there be a wiki page about it ?
14:50:19 <locusf> lbt: I doubt people read Mer wiki as much as they read tjc, I could be wrong though
14:50:25 <M4rtinK> we use it for example if Fedora for update tracking
14:50:36 <locusf> but it is kind of a black hole to put something "sticky" to tjc
14:50:43 <locusf> which essentially this is
14:51:01 <lbt> locusf: *nod* ... but we're moving to mer being more the central location for contribution to the core OSS side
14:51:10 <locusf> rather something that people could find in eg. https://sailfishos.org ?
14:51:27 <locusf> lbt: good, a link to that location could do
14:51:44 <lbt> eg the bugzilla etc ... so I'd stick with nemo and mer PRs to be described there and linked from sfos.org
14:51:46 <iekku> locusf, not a bad idea
14:51:50 <Mikaela> if I recall correctly, the original commit message was "RestartKeyboard: fix wording" and on different lines "Fixing clipboard requires home screen restart. Closes #github_issue_number_here". CONTRIBUTING.md for the project was written afterwards when I said that I couldn't find the rules. I am same Mikaela by the way.
14:51:51 <locusf> but in general, are the guidelines different for Mer and for Sailfish?
14:52:12 <locusf> lbt: sure
14:52:16 <lbt> locusf: not really - sfos is a bit more picky atm but we'd like to make mer more picky too
14:52:30 <lbt> the maintainer role is meant to be the place to handle missed details
14:52:36 <iekku> lbt, link we can arrange easily. should we take a action to organize this?
14:52:37 <Mikaela> another concern I have is GitHub issues being enabled causing confusion instead of just pointing to MER bugzilla in CONTRIBUTING or README file
14:53:14 <lbt> iekku: yes
14:53:35 <lbt> Mikaela: many projects will move from github to mer git hosting
14:53:37 <cybette> #info would be good to have contribution guidelines written up and put in the open. question: where? mer wiki, TJC, sailfishos.org?
14:54:01 <iekku> cybette, make that as a action for me and lbt
14:54:03 <lbt> I'm not sure what the policy is on issues vs bugs - personally I think we should choose one and stick with it
14:54:39 <lbt> we have a lot of tooling around bz so ... what gains would be made by moving to issues - and at what cost?
14:54:45 <cybette> #action iekku and lbt to organize the required info and find best location for it
14:54:54 <iekku> :)
14:55:01 <Mikaela> in case of that PR I was confused on how would I close GitHub issue by referring to MER issue that didn't even exist at first
14:55:11 <lbt> Mikaela: yep
14:55:34 <lbt> the next topic will overlap on this - and that's moving from github to gitlab
14:56:22 <locusf> true
14:57:29 <locusf> heh, I warranted 30 minutes for this :)
14:57:37 <cybette> we have quite a bit of time allocated to the first topic (16 min left), we can start on next topic if there's no more comments on this
14:57:41 <locusf> and seems like everything has already been set in motion :)
14:57:51 <locusf> at least nothing on my part
14:57:57 <lbt> I think as well as guidlines we also need detailed info on our packaging process ?
14:58:14 <locusf> yes
14:58:14 <lbt> eg how to handle tar_git and how we handle upstream git repos
14:58:54 <lbt> the goal of mer is to be reasonably self-hosted .. ie not to refer to remote git repos which may not be available to people behind firewalls
14:58:55 <pketolai> imho, only plus side with using github/gitlab/whatever issues is that the code and the bug tracking would be in the same place, but as lbt said, lot of the tooling depends on bugzilla
14:59:22 <cybette> #info also need more detailed info on packaging process in addition to guidelines
14:59:40 <lbt> pketolai: yes. atm bz is actually the master for all Mer identities so it's not going away :)
15:01:06 <cybette> shall we move on?
15:01:21 <locusf> sure
15:01:22 <bobsummerwill_> Is there a practical distinction between Mer and Sailfish now, in terms of hosting and process?
15:01:29 <lbt> yes
15:01:48 <bobsummerwill_> But Nemo and Mer were merged, right?
15:01:54 <lbt> yes, so mer is still the open core
15:02:28 <cybette> let's continue to the second topic, related
15:02:32 <cybette> #topic Situation update about the Mer Middleware merger from Nemo Middleware - locusf (20 min)
15:02:41 <cybette> #link http://www.mail-archive.com/mer-general@lists.merproject.org/msg01557.html
15:02:47 <cybette> #info Message to Mer mailing list suggested that this is started but ongoing. A small status update would help Nemo community decide on its roadmap.
15:02:53 * lbt looks ...
15:02:57 <lbt> oh, I wrote that... :D
15:03:00 <locusf> yeah :D
15:03:01 <cybette> :D
15:03:06 <locusf> I was just gonna say that :D
15:03:14 <lbt> so ... http://www.merproject.org/dash2
15:03:22 <lbt> is my current drop of this stuff
15:03:34 <dr_gogeta86> nice
15:03:38 <lbt> it's a bit more complete and handles the hw adaptations and mw
15:03:52 <stephg> lbt: that's great btw
15:03:53 <lbt> I keep finding bugs 'cos it's a PITA
15:04:05 <cybette> #link http://www.merproject.org/dash2/
15:04:10 <lbt> one big issue is that we're mid-migration
15:04:12 <locusf> try converting base-29 letter digits to binary
15:04:27 <lbt> :)
15:04:31 <lbt> so eg http://www.merproject.org/dash2//obs/mer-core%3Adevel/bluez.html
15:04:44 <lbt> vs http://www.merproject.org/dash2//repo/merproject.org/mer-core/bluez.html
15:05:01 <lbt> the first is the mer-core devel package - builds from github src
15:05:12 <lbt> the second is the not-yet-used merproject git repo
15:06:02 <lbt> maintainers have been asked to move stuff over but it's not been happening
15:07:06 <lbt> we (well I) don't want to break jolla's build infra which points to github since they'd not be very happy
15:07:13 <cybette> #info main issue is being in mid-migration, maintainers have been asked to move stuff but it's not happening
15:07:42 <lbt> to be fair they've not been nagged and are kinda busy!
15:07:52 <locusf> indeed
15:08:34 <cybette> should there be action to nag? or hold off for the time being?
15:08:43 <stephg> lbt: so it's wetware and IRL problems rather than technical/bureacratic?
15:08:57 <lbt> stephg: yes
15:09:12 <iekku> instead of nagging, maybe nicely remind them?
15:09:27 <lbt> iekku: that's how I nag :)
15:09:36 <iekku> lbt, oh.
15:09:44 <lbt> cybette: I am in the process of updating Maintainer file and I'll probably take over maintainer role for neglected projects
15:10:13 <locusf> woah
15:10:19 <locusf> aren't there like ton of them?
15:10:23 <cybette> #info lbt is in the process of updating Maintainer file and will probably take over maintainer role for neglected projects
15:10:36 <cybette> lbt: you're too nice :)
15:11:12 <lbt> locusf: yeah but maintainership will be more admin to move them to gitlab on mp.o
15:11:19 <dr_gogeta86> lbt, how many packages are orphan ?
15:11:21 <locusf> lbt: ok
15:11:32 <lbt> dr_gogeta86: http://www.merproject.org/dash2//repo/merproject.org/mer-core.html
15:11:54 <dr_gogeta86> but many are x11 related
15:12:08 <cybette> 10 more min on this topic
15:12:22 <lbt> dr_gogeta86: yes - and I currently want them for mer-tools since tools run in sdk which runs on linux desktop which is ... X11
15:12:52 <dr_gogeta86> but bash unmantained ....
15:12:56 <lbt> so part of this may be to either support X11 builds (which we may need to keep for legacy reasons) or move X11 to mer-tools
15:13:13 <lbt> dr_gogeta86: unmaintained means me+stskeeps
15:13:17 <dr_gogeta86> ok
15:13:24 <lbt> so by adding my name there nothing really changes
15:13:36 <dr_gogeta86> I'm looking for some easy packages for me
15:13:38 <stephg> x11 is presumably needed for folks other than sfos
15:13:38 <lbt> realistically we'll be looking to delegate these
15:13:54 <stephg> can that burden be shared
15:14:19 <stephg> I somewhat share locusf sentiment, only because it's alot to take on?
15:14:24 <lbt> all of it can be
15:15:03 <lbt> volunteer to be a maintainer - which basically means submit patches, get stuff working, show you're responsible and eventually get told it's yours
15:15:15 <lbt> and by all means say "I'd like to maintain <blah>"
15:15:50 <lbt> ^^ should also be in the stuff iekku and I write up from topic #1
15:16:04 <stephg> yes, and I entirely understand
15:16:08 <cybette> #info volunteer to be a maintainer - which basically means submit patches, get stuff working, show you're responsible and eventually get told it's yours. simply say "I'd like to maintain <blah>"
15:16:10 <locusf> gotta love that meritocracy
15:16:34 <iekku> :D
15:16:50 <cybette> #action lbt and iekku to add the above to guidelines
15:17:29 <cybette> 5 more min
15:17:45 * lbt looks at topic to see if there's more to it
15:18:20 <nh1402> Seeing as I'm still unemployed I would like to, but I'm not too experienced at this low-level or in general really as I graduated last year or that experienced with C++ and even less (non-existent) experience with QT.
15:19:24 <lbt> nh1402: one thing we want to do is move packaging from 'dumb' to proper git repos. It's a big job and it's more getting used to git than coding
15:19:48 <iekku> and getting used to git is always good
15:20:20 <lbt> once we get the guidelines sorted and some docs on tar_git and such talk to me in #mer and I'll try to explain how you can help there
15:20:22 <sledges> +1
15:20:40 <cybette> nh1402: you can join #mer to discuss more and learn how you can help bit by bit
15:20:43 <lbt> stephg: ^^ is somewhere I could do with help
15:21:01 <bobsummerwill_> RE: 'dumb' repos. Looking at https://git.merproject.org/mer-core/boost/tree/master, for example, is that an example of what you would mean by dumb?
15:21:10 <bobsummerwill_> In that it is a packaging of a library
15:21:21 <bobsummerwill_> Rather than being a clone of the actual repo
15:21:31 <stephg> lbt: tbh I'd not yet be comfortable instructing others myself but increasingly have bandwidth again so also want to help
15:21:34 <bobsummerwill_> Not sure where Boost is hosted, and that might be an example.
15:21:42 <bobsummerwill_> be a bad example
15:21:46 <lbt> #info moving mer-core git packages from 'dumb' to tar_git is a chore. Help would be appreciated here. Talk to lbt in #mer about it. First step is actually help writing the HOWTO
15:22:00 <cybette> 1 min
15:22:01 <nh1402> cybette: I'll look into it.
15:22:05 <bobsummerwill_> OK - gotcha.
15:22:12 <lbt> bobsummerwill_: yeah ... tarball in git ... eeeeek!
15:22:42 <stephg> lbt: anything that lowers this barrier so the less experienced folks can help and support each other is good
15:22:45 <bobsummerwill_> yeah ... not so pretty
15:22:46 <M4rtinK> we have a separate ervice for taralls
15:22:51 <stephg> lbt in at least 2 dimensions
15:22:53 <M4rtinK> in fedora
15:22:54 <lbt> bobsummerwill_: the issue now is that you can't see the src w/o downloading/unpacking and applying patches .. pain
15:23:01 <cybette> ok let's carry on to next topic (and welcome back MoritzJT)
15:23:08 <cybette> #topic Request more information on Roadmap for open-sourcing more of Sailfish - bobsummerwill (20 min)
15:23:13 <M4rtinK> otherwse our distgit is similar
15:23:19 <cybette> #info It has been mentioned on several occasions that there is a plan with regard to further open-sourcing of components within Sailfish. It would be great to have some more public information on that.
15:23:25 <cybette> #info In particular, the status of Silica is a constant 'sore point'. With the company split and the move towards licensing of Sailfish 2.0, perhaps there is an opportunity to restore some lost faith in Jolla with regard to licensing.
15:24:11 <bobsummerwill_> So yeah ... I think that pretty much covers it :-)
15:24:30 <nh1402> I do have some experience with git, but other than the basics of pushing, pulling, merging and creating new branches I haven't really done anything else. I am aware of the other stuff reverts, and what have you.
15:24:31 <bobsummerwill_> What's the plan? To whatever degree that Jolla want to make that public.
15:24:42 <bobsummerwill_> Silica is of particular interest for licensing plans
15:24:56 <cybette> unfortunately I think the person best to comment on this, Stskeeps, is unavailable today (traveling back and recovering from QtWS I believe)
15:25:14 <cybette> iekku and sailors, do you have comments on this?
15:25:50 <nh1402> would this mean it would be easier for the community to officially add new features to say the lockscreen, eg. coderus' mazelock.
15:26:34 <jfred> Personally I'm most interested in the licensing status of the core apps (e.g. messaging)
15:26:38 <bobsummerwill_> Or an easier question is ... are "the lines" the same for SF2.0 and SF1.x?
15:26:53 <M4rtinK> I think thats part of another component
15:27:06 <SfietKonstantinW> well, I'm interested in both
15:27:07 <SfietKonstantinW> :)
15:27:08 <M4rtinK> (lockscee)
15:27:16 <cybette> bobsummerwill_: apologies for the oversight on my part. i should have made sure the right people are attending the meetings.
15:27:19 * lbt hasn't heard anything concrete ... but he's aware that work is actually ongoing in this area
15:27:42 <cybette> we can take your questions and try to get answers to share at the next meeting
15:27:42 <urjaman> lockscreen would be part of the lipstick homescreen etc stuff ...
15:27:43 <nh1402> as am I. I've been working on a messaging app on and off, and wouldn't mind adding the features to the standard Sailfish messaging app.
15:27:45 <dr_gogeta86> lbt you are mantain a full blown distro
15:27:46 <M4rtinK> +1 for messaging
15:27:57 <dr_gogeta86> I can volunteer as sysadmin
15:28:18 <nh1402> and have a few lockscreen ideas, only one that I could implement at this stage. (LG's Knock Code)
15:28:22 <M4rtinK> it has tons of RFEs and has been totaly neglected
15:28:38 <bobsummerwill_> cybette: no problem. If we don't have the right people to answer this, then perhaps we should just move on to the next topic.
15:28:43 <urjaman> I'd say +1 for the compositor bits and messaging
15:28:46 <lbt> I know Antti Saarnio has commented that we have a timeline for OSS - so that's been said publicly
15:28:56 * iekku propose to postpone this topic as stskeeps isn't able to join
15:29:13 <iekku> today i mean
15:29:19 <SfietKonstantinW> lbt: + Stskeeps also said that during his presentation (Jolla, the imposible story)
15:29:20 <stephg> iekku: +1
15:29:21 * jfred can agree with that
15:29:23 <lbt> there was a techcrunch article on BRICS a few months back
15:29:29 <nh1402> another idea I spoke to coderus about is simulating force touch.
15:30:00 <bobsummerwill_> lbt: Yeah - I saw that 'tease' :-) That was what made me ask the question!
15:30:18 <iekku> i will ask him to check minutes from this meeting (i know he will do that anyhow) to see main questions
15:30:34 <cybette> #info we will revisit this topic in next meeting, and get answers to questions brought up here
15:30:35 <bobsummerwill_> iekku: Thanks
15:30:35 * lbt is just trying to provide what info he has about the OSS opening up aspect. You've gotta know how frustrating it is for us too :)
15:30:44 <stephg> lbt: +1
15:30:49 <jfred> lbt++
15:31:59 <ericcc> sailfishos csdn
15:32:01 * lbt looks at other questions/comments intermixed and waits for AOB
15:32:04 <cybette> since we don't have much to go on for this topic, let's close it now. keep something to look forward to in future meetings ;)
15:32:06 <M4rtinK> would not e frustrating if it was open from the start ;-)
15:32:08 <ericcc> sailfishos csdn
15:32:15 <bobsummerwill_> Jolla - The Impossible Story - https://www.youtube.com/watch?v=oI0aqx37pO0. Thanks - I'd not seen that. Will watch it today.
15:32:37 <jfred> oh interesting, I'll have to watch that as well
15:32:40 <cybette> next topic:
15:32:43 <cybette> #topic Update on localization status (keyboards and translation tool) - ApBBB (5 min)
15:33:05 <ericcc> sailfishos can make a lock for some picture safety
15:33:22 <cybette> I don't think ApBBB is here but he just asked for an update and I believe we have prepared some
15:33:28 <cybette> iekku, or sledges?
15:33:46 <iekku> for the traslation tool
15:33:56 <sledges> iekku pls,i'm on the phone:)
15:33:59 <iekku> Work is progressing nicely and we are already testing it in-house. We will be able to deploy it in the open once any remaining rough edges have been polished and all infra is in place (such as the Jolla Store publishing a snapshot of translations)
15:34:20 <SfietKonstantinW> iekku: any ETA ?
15:35:12 <cybette> #info For translation tool, work is progressing nicely and we are already testing it in-house. We will be able to deploy it in the open once any remaining rough edges have been polished and all infra is in place
15:35:14 <iekku> SfietKonstantinW, there's so many moving parts that i don't want to give ETA. as soon as we can
15:35:38 <kimmoli> soon(tm)
15:35:48 <M4rtinK> soon, eh ? ;)
15:36:13 <sledges> you got it :D
15:36:26 <iekku> :D
15:36:29 <stephg> iekku: for folks that may not know can you give a quick summary of the project/thing (dunno quite what to call it
15:36:32 <stephg> )
15:38:02 <stephg> (or a link)
15:38:39 <iekku> it's open sourced translation tool, one can use via browser without huge technical knowledge
15:38:40 <cybette> #info Jolla is working on a community translation tool (based on Pootle localization server) to enable community to contribute to Sailfish OS translations
15:39:04 <stephg> iekku, cybette thx
15:39:10 <iekku> cybette, <3
15:39:44 <cybette> iekku: :) was there something also for keyboards, or no?
15:40:02 <iekku> no update for that, unfortunately
15:40:17 <urjaman> want a list of issues? :P
15:40:39 <cybette> ok, thanks iekku. let's move on.
15:40:40 <iekku> urjaman, if those aren't yet in TJC, yes please :)
15:40:46 <urjaman> or is it all known...
15:41:03 <cybette> #topic General discussions - everyone (15 min)
15:41:04 <urjaman> well they're mostly referenced in the tohkbd tjc faq
15:41:09 <pvuorela> urjaman: impossible to tell :)
15:41:32 <iekku> urjaman, seriously, please check. if there's something missing add it, it's valuable information for us
15:41:33 <pvuorela> could have answered on keyboard question, but wasn't sure what was asked there.
15:41:47 <urjaman> there's an altgr thing, for some reason the system still uses boston.qmap for the modifiers
15:41:49 <kimmoli> for kbd, we have 2 majors. boston.qmap, and android other-than-US
15:41:51 <daitheflu> I think ApBBB issue was mostly related to the unavailable greek keyboard layout (see https://together.jolla.com/question/33768/greek-keyboard-layout/ )
15:42:13 <bobsummerwill_> Is anybody working on community SFOS 2.0 ports for Nexus and other devices?
15:42:18 <pvuorela> urjaman: kimmoli, known issues.
15:42:21 <cybette> since we haven't had these meetings in a while, let's take this chance to catch up and provide feedback
15:42:26 <cybette> or talk about keyboards :)
15:42:28 <stephg> bobsummerwill_: afaik yes
15:42:39 <kimmoli> pvuorela: yes, i think there is no other blocking ones
15:43:04 <kimmoli> and both has some haxored work-a-rounds
15:43:06 <bobsummerwill_> I have a Nexus 7 and a Nexus 5 and would love to start looking at SFOS 2.0 before my Jolla Tablet arrives.
15:43:08 <urjaman> yeah just checked that they're known of
15:43:21 <stephg> bobsummerwill_: drop by #sailfishos-porters
15:43:21 <kimmoli> bobsummerwill_: there is #sailfishos-porters
15:43:25 <locusf> lol
15:43:26 <bobsummerwill_> Will do
15:43:26 <kimmoli> :9
15:44:09 <locusf> rpi2 would work too
15:44:17 <cybette> pvuorela: that's why it helps to have the person who asked the question attend the meeting and clarify his question. i'll let him know.
15:44:40 <vgrade_w> bobsummerwill_: https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_hammerhead
15:44:41 <urjaman> kimmoli: i think alt-tab could use some help from teh compositor?
15:45:01 <urjaman> it's basically unusable for me since i mostly run android and terminals :P
15:45:08 <cybette> #info Check #sailfishos-porters if you're interested in finding the progress of SFOS ports to Nexus and other devices
15:45:15 <kimmoli> urjaman: yes, that is not "blocker"
15:45:19 <sledges> bobsummerwill_: nexus5 is already on 2.0 ui,only video recording prevets from using daily imho
15:45:30 <sledges> *no video recording
15:45:39 <bobsummerwill_> Thanks for the info, everyone. I'm over there now.
15:46:39 <sledges> for nexus 7 pls nag respective porters:)
15:46:41 <urjaman> yeah i was just thinking of stuff that's like we'd like it better but cant since jolla stuff (there's also all the jolla closed apps that could support keyboards better etc)
15:47:22 <kimmoli> urjaman: i started to make a lipstick-plugin-thingy, but got .. eh.. flu
15:47:26 <nh1402> whatever happened to the filemanager
15:48:07 <urjaman> nh1402: the one in repos by jolla? or the one in store?
15:48:17 <urjaman> and what has happened to it?
15:48:59 <nh1402> it used to be preinstalled in the nexus 5 roms but was removed a long time ago, I thought something happened.
15:49:21 <stephg> the jolla one got deprecated iirc?
15:50:46 <lbt> are there any outstanding questions from the merge section - I thought some comments were carried over
15:51:01 <stephg> yeah
15:51:12 <cybette> 5 more min for general discussions
15:52:13 <nh1402> is there anyone here experienced with egl/gles, Android internals that are willing to help with android app support for ported devices?
15:52:25 <stephg> cybette: massively critical question, enquiring minds need to know:
15:52:40 <stephg> will there be a beanie refresh for the winter
15:53:01 <cybette> stephg: :D well...
15:53:25 <cybette> stephg: i'll take the suggestion forward ;)
15:54:01 <nh1402> Is there an update on the splitscreen multitasking feature?
15:55:00 <cybette> nh1402: https://sailfishos.org/developmentroadmap/ (see section Q3)
15:56:02 <cybette> ok time to wrap up
15:56:06 <Aldrog> thanks for all the info, bye
15:56:11 <cybette> #topic Wrap up and next meeting (10 min)
15:57:10 <cybette> does this meeting time work for most of you? comments?
15:57:23 <iekku> some sailors have said earlier time would work better for them
15:58:15 <bobsummerwill_> This time is good for me, but it is 7.30am here on the West Coast of Canada.
15:58:47 <bobsummerwill_> But I imagine that your North American developer numbers in total are pretty tiny right now, eh?
15:58:54 * lbt is fine with it
15:59:00 <bobsummerwill_> Let alone idiots like me right over on the wrong side.
15:59:02 <stephg> it's perhaps antepodeans
15:59:08 <stephg> but fine for me also
15:59:38 <bobsummerwill_> Earlier would "knock me out" of the meeting
15:59:49 <cybette> bobsummerwill_: we also have some people in australia who are unable to participate due to the timing, but i suppose it's hard (impossible) to find a time that suits all
15:59:55 <iekku> sorry folks, but i have to leave now. thanks everyone.
16:00:06 <stephg> question to the channel, does the channel think we need to revisit moderators and such?
16:00:11 <iekku> cybette, i can chair next time
16:00:15 <stephg> (perhaps for discussion next time)
16:00:15 <cybette> iekku: ok thanks!
16:00:23 <bobsummerwill_> Indeed it is. If only the world was flat, eh?
16:00:30 <cybette> :)
16:00:30 <sledges> we use to rotate timing
16:00:52 <bobsummerwill_> Have a great day, everyone. Best wishes!
16:01:09 <cybette> sledges: yeah but it was something like 15 UTC / 11 UTC which is difficult for US/Canada anyhow
16:01:30 <stephg> also .usian clocks are about to change no?
16:01:44 <stephg> basically this month is a mess :D
16:01:53 <cybette> but let's stick with 14:30 UTC for next meeting, the timing will be a non-ending discussion
16:02:03 <stephg> hehe
16:02:28 <cybette> stephg: yeah, so might be better not to make too many changes for now
16:02:34 <cybette> nice to see so many people participating.
16:03:03 <stephg> yeah, makes sense, and yes
16:03:44 <cybette> so let's have the next meeting in 2 weeks, at same time (or depending on summer time changes, could be an hour earlier)
16:04:21 <cybette> #info Next meeting Thurs Oct-22 @ 14:30 UTC, Chairperson iekku
16:04:47 <cybette> last call for comments
16:06:03 <cybette> great, thank you all! see you next time! in the meantime, join #jollamobile, #sailfishos, #mer, #nemomobile and #sailfishos-porters!
16:06:11 <cybette> #endmeeting