14:30:11 <cybette> #startmeeting SailfishOS, open source, collaboration: 9-Dec @ 14:30 UTC
14:30:11 <merbot> Meeting started Wed Dec 9 14:30:11 2015 UTC. The chair is cybette. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
14:30:11 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:15 <coderus> 14:30!
14:30:18 <cybette> #info Welcome to another week of SailfishOS OSS and collaboration meeting
14:30:26 <cybette> #info Meeting info and agenda: http://lists.sailfishos.org/pipermail/devel/2015-December/006797.html
14:30:29 <tortoisedoc> .w0t
14:30:32 <cybette> I'm the meeting chair for today and will be keeping time and order. Please behave and show mutual respect, and let's have a productive discussion!
14:30:36 <tortoisedoc> its 16:25 in ruoholahti :P
14:30:42 <cybette> #topic Brief introductions (5 min), prefix your information with #info
14:30:48 <coderus> #info Andrey Kozhevnikov, community coderus
14:30:54 <cybette> #info Carol Chen, community member, hatless meeting chair today
14:30:56 <kimmoli> #info Kimmo Lindholm, Community
14:30:56 <tortoisedoc> #info tortoisedoc, community dev
14:31:03 <daitheflu> #info François, community
14:31:09 <dirkvl> #info Dirk van Leersum, community
14:31:18 <r0kk3rz> #info Lewis Rockliffe, community / developer
14:31:19 <veskuh_> #info Vesa-Matti Hartikainen, Jolla, SW Program Manager
14:31:20 <ljo> #info Leif-Jöran Olsson, community
14:31:23 <cos-> #info Ville Ranki, community
14:31:24 <mattaustin> #info Matt Austin, community/dev
14:31:35 <olpe> #info Olavi Haapala, community dev
14:31:39 <lainwir3d> #info Richard Rondu, community developer, whisky guru, rum learner, spirits drinker
14:31:48 <Sage__> #info Marko Saukko, Sailor @�Jolla
14:31:50 <Aldrog> #info Andrew Penkrat, community, app dev
14:31:58 <eugenio> #info Eugenio Paolantonio, community member
14:32:07 <fravaccaro> #info fravaccaro, community
14:32:13 <cfb014> #info Carmen Fdez. B. sailor
14:32:18 <jwalden> #info Jari-Pekka Walden, Jolla, Testing
14:32:21 <s5pik3> #info s5pik3, community
14:32:25 <M4rtinK2> #info Martin Kolman, community member, modRana developer
14:32:37 <Raymaen> #info
14:32:57 <bree> #info Xiaobi Xu, Jolla, Testing
14:33:14 <cybette> couple more minutes to intro yourself with #info
14:33:54 <hge> #info Hongwei Ge Sailor @ Jolla
14:34:05 <pketo_> #info Pami Ketolainen, backend dev @ Jolla
14:34:12 <r0kk3rz> lots of sailors today :)
14:34:26 <dirkvl> maybe even all of them ;)
14:34:32 <jwalden> :)
14:34:38 <daitheflu> r0kk3rz: exactly what I was thinking :)
14:34:48 <Tofe> #info Christophe Chapuis, community member
14:34:57 <veskuh_> haha, well there is still couple of shy ones not present :)
14:35:11 <cybette> ok let's move on!
14:35:11 <Tofe> meh :)
14:35:11 <dirkvl> rattle their cages
14:35:18 <cybette> #topic Community help to Harbour QA? - coderus (10 min)
14:35:19 <pdanek2> hey!
14:35:28 <cybette> #info Is it possible for community to help Jolla Harbour QA team to test more applications?
14:35:33 <ApBBBB> while dirkvls coment was funny it kind of made me felt sad :/
14:35:38 <cybette> coderus, or someone from Jolla?
14:35:39 <ApBBBB> feel
14:35:44 <coderus> yo, is there are ways community can help Harbour QA to approve/test apps faster?
14:36:01 <pdanek2> Peter Danek, community member
14:36:19 <jwalden> our idea is that we could give rights to the volunteer community members so that they could give + or - verdicts to apps and then we could approve or reject those apps with lighter process. We are also open for other proposals This proposal however comes with a disclaimer that we don't know yet if/when this can be imlemented
14:36:25 <coderus> maybe not full QA process, but some stages can get some speed-up with community help
14:36:32 <dcaliste> #info Damien Caliste, community member
14:36:56 <r0kk3rz> jwalden: what are the primary things Harbour QA Looks for?
14:37:19 <cybette> #info Jolla's idea is to give rights to volunteer community members to vote for apps, making lighter process for Jolla's QA. Also open to other proposals.
14:37:19 <coderus> jwalden: community approval is cool, but i'm asking about real QA process
14:37:25 <ApBBBB> jwalden: the when is the problem not the if. i mean the community can help with a lot more than QA but we cant (ie translations)
14:37:48 <cybette> #info Jolla's proposal comes with disclaimer that it is not known yet if/when this can be implemented.
14:38:03 <jwalden> Good points, we just started to think how this could be done
14:38:22 <coderus> i.e. give some tools to community members, they can pick apps on approval list, test it, upload results, and Jolla members will check it and approve/reject apps
14:38:45 <ApBBBB> make it available to early access users and have them vote somehow
14:38:45 <coderus> i mean selected ones members, not random users of course :)
14:38:46 <M4rtinK2> also general Sailfish OS QA
14:38:54 <jwalden> and all ideas/comments are welcome so we can think how to move on
14:39:01 <tortoisedoc> I'd propose for those who opt-in
14:39:07 <M4rtinK2> Community QA is overall very important for most Linux Distros
14:39:25 <tortoisedoc> just the same as for SFOS releases
14:39:28 <r0kk3rz> jwalden: having a clear objective statement would help with coming up with alternative arrangements, without compomising quality
14:39:30 <M4rtinK2> even enterprise Linux distros, such as RHEL, have public betas
14:39:49 <Smar> (early access updates ;)
14:40:08 <jwalden> r0kk3rz: true, this is just in very early process atm
14:40:17 <coderus> jwalden: okay if you started, having community approval for apps not matching some harbour qa rules, but highvoted by users is cool
14:40:44 <ApBBBB> the main problem is that discussions usually don't materialize and its not a time to delay stuff. :/
14:41:03 <ApBBBB> imediate actions is somehow needed
14:41:15 <veskuh_> ApBBBB: yes, but now we are thinking something easy at first so that it can be actually implemented
14:41:28 <fravaccaro> opt-in sounds good to me too, like some kind of repo which needs to be enabled in settings and provides apps in QA
14:41:36 <coderus> for example apps which have projects in obs can be approved easily
14:41:43 <veskuh_> ApBBBB: for example for the translations the community pootle was major developement and we come quite close but not finished
14:41:43 <ApBBBB> veskuh_: what are the easy stuff you can do?
14:41:50 <cybette> #info perhaps make the QA/voting available to early access/selected users, an opt-in repo of sorts
14:42:21 <veskuh_> ApBBBB: so the + and - looks like relatively doable task as infra change. Then + and - already helps us scoping our internal level of testing needed
14:42:36 <cybette> 3 more min
14:43:13 <M4rtinK2> overall I think *something* which what people can help is urgently needed
14:43:32 <M4rtinK2> the current crisis mobilized the (remaining) community quite a bit
14:43:48 <veskuh_> M4rtinK2: yes, I think we all agree on that
14:43:54 <coderus> cool, so to not break existing stuff community approved apps can be placed in special section and activated in store settings, so regular users wont see it without activating, as it not tested properly by pro jolla crew, but ones who want can enable and install it, and later it can be moved to regular category and visible for everyones
14:44:03 <M4rtinK2> but as long as there is actually nothing direct people can help with, the momentum can dissipate
14:44:22 <tortoisedoc> that's quite alot of overhead for jolla if they have to mod the store
14:44:33 <M4rtinK2> or even cause backslash ("they would not be in this situation if they let people help them", etc.)
14:44:34 <ApBBBB> the community wont solve all the problems but at least some can be solved if we are given the chance.
14:44:48 <coderus> anywway, will be cool to hear something from you on next meeting about that :)
14:45:00 <cybette> coderus: do you want more time for this topic? or continue discussion on ML + next meeting
14:45:02 <phlixi_o> kind of like devel testing and stable repo
14:45:11 <coderus> we gave you ideas, tell us later which ones have chance to be implemented
14:45:13 <M4rtinK2> frankly, the store infra has always seemed very neglected to me
14:45:26 <coderus> cybette: next meeting i think is okay
14:45:31 <cybette> ok cool
14:45:33 <coderus> so give info when possible
14:45:34 <tortoisedoc> M4rtinK2 : there is a store infra publically available?
14:45:38 <M4rtinK2> so I'm not keeping my hopes high for substantial changes happening any soon
14:45:54 <cybette> #info let's continue discussion on sailfish os devel mailing list + next meeting
14:45:58 <M4rtinK2> unless priories have been shifted
14:46:05 <cybette> moving to next topic
14:46:16 <cybette> #topic Update allowed qmlimports for rpmvalidator - coderus (5 min)
14:46:24 <cybette> #info Some new qml imports from 2.0 update are missing. For example QtMultimedia 5.4. This need to be checked and allowed/updated for next public update.
14:46:37 <coderus> so, thats just request to internally check available but not whitelisted qmlimports
14:46:46 <coderus> and make it available in 2.0.1.x for everyone
14:47:01 <cybette> comments from Jola?
14:47:05 <cybette> comments from Jolla?
14:47:21 * cybette forgets how to type Jolla :P
14:47:21 <coderus> like QtMultimedia 5.4 which was not included to whitelist of 2.0.0.x because nobody care of it (via MSameer)
14:48:11 <veskuh_> We can check. I'm not promising for 2.0.1 since we are quite close already.
14:48:37 <coderus> there is should be no harm for ones existing from 2.0.0.x
14:48:47 <tortoisedoc> veskuh_: any chances to accept pull request from community for that?
14:48:51 <Sage__> coderus: anything else than QtMultimedia in mind? You mean https://github.com/sailfish-sdk/sdk-harbour-rpmvalidator/blob/master/allowed_qmlimports.conf right?
14:48:59 <coderus> as i saif qtm 5.4 is must have, but some others should be checked also
14:49:08 <coderus> Sage__: yeah
14:49:26 <coderus> qtm 5.4 can be the only missing and can be not, so check it please :)
14:49:35 <cybette> #info these will be checked by Jolla, although not promising for 2.0.1 since the release is quite close
14:50:19 <M4rtinK2> should it really conflict with the next release if the stuff is already included in the current one ?
14:50:31 <coderus> M4rtinK2: i'm talking the same :)
14:50:45 <tortoisedoc> +1 to these guys
14:50:47 <coderus> it was implemented in 2.0.0.x (or evn 1.0.9.x)
14:50:59 <r0kk3rz> sounds like its just an RPM checker issue
14:50:59 <coderus> 1.1.2.x oops
14:51:03 <tortoisedoc> perhaps there are other issues (performance?)
14:51:06 <coderus> forgot these versions
14:51:28 <tortoisedoc> in which case a pull request even from ommunity should fix the issue?
14:51:30 <coderus> r0kk3rz: yeah MSameer said thats just becccause nobody added it here
14:51:31 <tortoisedoc> *community
14:51:34 <veskuh_> Its more about our release infra, even rpmvalidator is tagged for certain release so that sdk gets right version, etc.
14:51:46 <cybette> any last responses before moving on? (coderus you need to give more time for these topics ;))
14:52:01 <coderus> cybette: :D
14:52:20 <coderus> sloth time!
14:52:31 <coderus> cybette: well, nothing to add
14:52:35 <Nicd-> maybe coderus used jolla time ;)
14:52:40 <cybette> #info the release infra needs to be considred, rpmvalidator is tagged for certain release so that the SDK gets the right version and so on
14:53:09 <cybette> next topic..
14:53:16 <cybette> #topic Jolla Tablets - coderus (10 min)
14:53:22 <cybette> #info Any possible details why tablets not delivered. Any details please. I mean real state of Tablets: if it was produced or not, if produced if it stuck at factory or at delivery center, and so on.
14:53:24 <dirkvl> talbots!
14:53:26 <coderus> last topic is... we need to know anything
14:54:06 <coderus> was the tablets really produced? they're ready to ship in some warehouse, or not produced at all. maybe need extra funds for shipping?
14:54:49 <veskuh_> I'm a SW guy, so my understanding from manufacturing and logistics is limited.
14:54:51 <coderus> i vote for make this topic permanent at the end of each meeting, until it will be solved
14:55:03 <coderus> so each week jolla can tell any info or tell nothing :D
14:55:11 <daitheflu> coderus: +1
14:55:14 <veskuh_> RnD side is done. We have SW and no major HW issues in the small patch of devices delivered so far.
14:55:15 <tortoisedoc> coderus +1
14:55:22 <TylerTemp> +1 for permanent topic :D
14:55:25 <r0kk3rz> coderus: depends if we get meaningful replies, we know Antti is onto it, and thats about it
14:55:26 <M4rtinK2> coderus: +1
14:55:34 <M4rtinK2> (tablet canary :D)
14:55:41 <veskuh_> Company financials is the main problem now. Without financial security our partners will not commit to any plan.
14:55:46 <cfb014> coderus: +1
14:55:53 <cybette> perhaps we can make the "general discussions" topic to always include "Jolla Tablet update"
14:55:54 <a1kar> coderus: +1
14:56:03 <daitheflu> r0kk3rz: I bet Antti is onto Jolla Adventures now
14:56:05 <veskuh_> We have been doing planning for various scenarios, but until financial situation is clear we cannot say what finally will happen.
14:56:27 <veskuh_> When financial issues are clear, we can get definitive answers from our partners on how we can go forward.
14:56:29 <Nicd-> veskuh_: there has been no money coming through?
14:56:31 <tortoisedoc> veskuh_ : so any day now it should be clear?
14:56:36 <Nicd-> from investors
14:56:39 <coderus> main question is: "does jolla tablets wave 2 exists? means is devices for 2nd wave was produced?"
14:57:11 <coderus> answer this question can give enough information for now :D
14:57:18 <lainwir3d> Wait, some people still don't have their tablets ?
14:57:21 * lainwir3d hides
14:57:25 <tortoisedoc> no flames please :P
14:57:33 <tortoisedoc> (at least until the end of the meeting)
14:57:34 <veskuh_> Nicd-: we are selling phones still, but we still need investment
14:57:39 <cybette> #info RnD side is complete for Jolla Tablet; company financials is the main problem now, until the financial situation is clear, Jolla cannot say what finally will happen.
14:57:54 <fravaccaro> but is this Jolla Adventures stuff still going on? I mean, it may be better to focus on Jolla, at least until things get better...
14:58:05 <coderus> veskuh_: thats is the question. so i personally can pay extra 100 euro for shipping
14:58:10 <coderus> if tablet exists :D
14:58:18 <r0kk3rz> fravaccaro: save it for general discussion
14:58:36 <Markkyboy> Yes, phones are still being sold, only just. Will there be a return of the Lime TOH, or any other colour/type?
14:58:52 <r0kk3rz> coderus: extra shipping? i'll personally pick it up from the warehouse if need be
14:59:04 <ApBBBB> what you see on the store is stock stuff i believe
14:59:08 <coderus> r0kk3rz: for me that will cost more than 100 eur
14:59:15 <Nicd-> Markkyboy: wait for general discussion
14:59:16 <coderus> i bet it in hk warehouse, if exists at all
14:59:16 <r0kk3rz> coderus: same
14:59:42 <Markkyboy> okay @Nicd (noob @ irc) :)
14:59:54 <Tofe> so, who knows about current tablet delivery status? should that person be invited to next meeting?
15:00:11 <tortoisedoc> Tofe : read above veskuh_'s line
15:00:14 <fravaccaro> @r0kk3rz my bad, I thought we were already there :)
15:00:22 <r0kk3rz> Tofe: +1 we need Antti
15:00:27 <daitheflu> coderus: would there be a reason not to ship them if they are produced ?
15:00:29 <coderus> Tofe: tablets delivery is unknown due to investments
15:00:34 <cybette> 3 more min
15:00:43 <coderus> main questions is was the tablets really produced :D
15:00:46 <ApBBBB> antti is better working on sorting the financial situation
15:00:50 <ApBBBB> :O
15:00:52 <ApBBBB> :P
15:00:55 <Tofe> coderus: that doesn't make sense, I'm not talking about the future, but the present
15:01:00 <coderus> daitheflu: iinvestments investments investments :)
15:01:15 <r0kk3rz> antti can take 10min out of his busy schedule to answer his community
15:01:16 <coderus> Tofe: same
15:01:29 <dirkvl> would be nice gesture
15:01:35 <coderus> so, invite Antti to next meeting? :D
15:01:38 <dirkvl> or at least say why not
15:01:41 <fravaccaro> +1
15:01:42 <coderus> should i tweet it now? :)
15:01:46 <Stskeeps> (11pm in hong kong..)
15:02:00 <dirkvl> but then again, if it only hang on investor outcome then what is the point
15:02:00 <cybette> #info It'll be good to have someone from Jolla who can comment on the Tablet status attend next meeting(s) or have a message prepared from them
15:03:00 <dirkvl> +1
15:03:06 <cybette> #info this will probably be a recurring topic in following meetings until more clarity is achieved
15:03:07 <M4rtinK2> +1
15:03:14 <coderus> okay, i'm done for this meeting, thanks :)
15:03:15 <M4rtinK2> yeah
15:03:30 <M4rtinK2> one issue is devs not having tablets
15:03:40 <cybette> ok i think there are a couple topics waiting for...
15:03:43 <cybette> #topic General discussions - everyone (10 min)
15:03:44 <M4rtinK2> but that might be moot depending on the actual outcome
15:04:22 <ApBBBB> two questions for veskuh_ 1) the community has a lot of stuff ready that can be ported into SF without disrupting anything bit (ie keyboards) can you do something about that?
15:04:24 <daitheflu> any info about refunds ?
15:04:27 <r0kk3rz> M4rtinK2: but should devs be given priority? will the other backers like that outcome?
15:04:27 <M4rtinK2> any news on the open sourcing/dual licensing front ?
15:04:32 <Raymaen> any info about Fairphone an Sailfish?
15:04:54 <M4rtinK2> r0kk3rz: do they want apps and working OpenRepos ? ;-)
15:05:11 <Venty> .oO( Shall I chime in about Intex and their Sailfish OS phone..? )
15:05:19 <r0kk3rz> M4rtinK2: i dont mind if i get my tablet before igg backers ;)
15:05:20 <ApBBBB> 2) there are stuff that are missing (ie avahi) is there anything that can be done for that also ?
15:05:21 <TylerTemp> Any info about any phones with SailfishOS pre-installed?
15:05:53 <veskuh_> ApBBBB: keyboards sounds like something that could be relatively easy to integrate if lisence is ok
15:05:57 <cybette> for porting questions, #sailfishos-porters might be a better place to ask/discuss them
15:06:08 <ApBBBB> ok tell us what lisence do you want them in
15:06:19 <cos-> any info on availability of alien dalvik on ported sailfish phones?
15:06:27 <pdanek2> Is Intex deal still in game?
15:07:19 <r0kk3rz> pdanek2: intex deal likely hangs on jollas future, not much of a deal without jolla really
15:07:21 <fravaccaro> my question, again: is this Jolla Adventures still going on? Does it interfere/may it be good even for Jolla somehow? And if the two co-founders last are focusing on something else, who's in charge of Jolla?
15:07:44 <ApBBBB> i'll start a topic in TJC for getting the community to submit keyboards after you give a licence type you prefer and the requirements
15:08:22 <ApBBBB> please lets not keep this only as a discussion and act on it :D
15:08:33 <veskuh_> ApBBBB: Yeah, that's cool. BSD is one we have preferred, but we really do not have problems with most OSS licenses (except GPLv3)
15:08:38 <a1kar> r0kk3rz: and what about Fairphone 2 ??
15:08:41 <cybette> #info community contributions such as keyboards sound like something relatively easy to integrate if license is ok.
15:08:56 <ApBBBB> ok any other requirements?
15:09:12 <r0kk3rz> a1kar: fyi i'm not a sailor, so my answers are just speculation
15:09:19 <veskuh_> ApBBBB: I'd need to check with pvuorela
15:09:25 <pdanek2> r0kk3rz: So you think Intex freezed any R&D or possible manufacturing of Intex device with Sailfish until Jolla's future gets clarified?
15:09:25 <cybette> #action ApBBBB to start a topic in TJC for getting keyboard submissions from community after agreeing on license type and requirements
15:09:26 <r0kk3rz> a1kar: but last I heard sledges was waiting on FP
15:09:28 <a1kar> oh. ok :P
15:10:01 <ApBBBB> i'll start the topic and wait for pekka to come and give directions.
15:10:23 <r0kk3rz> pdanek2: that seems likely, i mean, its what I would do in their situation
15:10:34 <cybette> a1kar, r0kk3rz: you might get more info about fairphone porting status from #sailfisos-porters
15:10:40 <sledges> a1kar: r0kk3rz: stay tuned;)
15:10:43 <lainwir3d> meanwhile, my tablet is pretty much alive : http://lainwir3d.net/20151209_001.jpg
15:10:45 <cybette> sledges: hi :)
15:10:47 <dirkvl> yes, stay tuned
15:10:59 <veskuh_> ApBBBB: For the avahi I'm not so sure. Stskeeps would that be more of mer thing?
15:11:06 <sledges> hey cybette!
15:11:22 <cybette> 2 more min
15:11:23 <a1kar> lainwir3d: how many apps in store?
15:11:32 <ApBBBB> yes its mer i think paging Stskeeps
15:12:01 <r0kk3rz> ApBBBB: talk in #mer
15:12:08 <ApBBBB> ok
15:12:10 <kimmoli> is there any confirmation for this on jolla side? https://twitter.com/Fairphone/status/673804601707991040
15:12:27 <lainwir3d> a1kar: I don't know how to check :-(
15:12:54 <cybette> fravaccaro: unfortunately, I think your question is probably better answered by the people involved (founders themselves) rather than in this meeting...
15:13:27 <veskuh_> kimmoli: We have been talking with them and promising support.
15:13:49 <cybette> wrapping up...
15:13:54 <cybette> #topic Wrap up and next meeting (5 min)
15:14:02 <kimmoli> ok veskuh_
15:14:28 <cybette> will people be around for another meeting next week?
15:14:34 <cybette> it's quite close to christmas
15:14:58 <cybette> we do have some topics already (added minutes before this meeting)
15:15:25 <cybette> next Thurs, 17-Dec, same time, same place?
15:15:48 <daitheflu> more info ? :P ;)
15:15:56 <veskuh_> fravaccaro: I don't know about Jolla Adventures status, but Antti and Sami are doing huge amount of work to keep Jolla going.
15:16:12 <fravaccaro> carol Guess it's better to ask Juhani. btw I'll be here next week :)
15:16:50 <cybette> fravaccaro: here as in #mer-meeting or finland? :D
15:16:57 <fravaccaro> thanks for the info veskuh :)
15:17:00 <cybette> any volunteers to chair next week?
15:17:52 <fravaccaro> unluckily only on the meeting :)
15:18:03 <cybette> well if no objections etc.,
15:18:07 <r0kk3rz> community meeting in JHQ Helsinki!
15:18:14 <cybette> #info Next meeting Thurs Dec-17 @ 14:30 UTC, Chairperson cybette
15:19:02 <cybette> thanks everyone for participating in the meeting, see you next week (back to Thursday!)
15:19:09 <cybette> #endmeeting