14:30:08 <stephg> #startmeeting SailfishOS, open source, collaboration 28th of January 2016
14:30:08 <merbot`> Meeting started Thu Jan 28 14:30:08 2016 UTC.  The chair is stephg. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
14:30:08 <merbot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:12 <tortoisedoc> lbt i recall you inquiring about merbot before too :P
14:30:14 <stephg> #info Happy Data Protection Day and welcome to the second SailfishOS OSS and collaboration meeting of 2016
14:30:20 <stephg> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2016-January/006903.html
14:30:26 <tortoisedoc> #info tortoisedoc hello world developer
14:30:27 <stephg> I'm the meeting chair today and will be doing my best to keep time and order. Please behave, be gentle and show due respect.
14:30:33 <stephg> We have a few things to get through today so please lets not stray from the topics too much
14:30:39 <stephg> #topic Brief introduction (5 minutes), please prefix your name/handle with #info
14:30:45 <stephg> info away!
14:30:47 <stephg> :D
14:30:49 <kimmoli> #info Kimmo Lindholm, community, wannabe porter, tohs et al
14:30:51 <tortoisedoc> duh
14:30:56 <kimmoli> tortoisedoc: triggerhappy?
14:31:04 <tortoisedoc> #info tortoisedoc hello world developer
14:31:11 <lbt> #info David Greaves, Sailor and Mer guy
14:31:12 <stephg> #info Steph Gosling, community, also wannabe porter
14:31:13 <tortoisedoc> kimmoli : nah, typing tourette
14:31:20 <elfio> #info elfio, sailfishOS fan
14:31:22 <Munnu> #info Munnu Jolla enthuatist, wannabe developer
14:31:28 <JvD_> #info Tommi Keisala, community
14:31:30 <occirol> #info occirol, community, developer
14:31:35 <sledges> #info Simonas Leleiva, sailor (porting, pootle, and stuff)
14:31:35 <jlassila> #info Juhani Lassila, Jolla
14:31:37 <schmittlauch> #info schmittlauch, Jolla phone owner, tablet backer, community member, hopefully future developer
14:31:40 <M4rtinK> #info M4rtinK, community member, modRana developer
14:31:47 <eugenio> #info Eugenio Paolantonio, community member
14:31:56 <toxip> #info Topias Vainio, founder of the Telegram Jolla Fan Club group, wannabe Sailfish dev
14:31:56 <daitheflu> #info François, community
14:31:57 <tathhu> #info tathhu, community
14:32:07 <r0kk3rz> #info Lewis Rockliffe, community
14:32:15 <pketo> #info Pami Ketolainen, backend developer @ Jolla
14:32:15 <richdb> #info Richard de Bruin, community
14:32:23 <eekkelund> #info  Eetu, community
14:32:29 <pascalstein> #info pascalstein, Jolla phone owner, Jolla tablet owner, community member, believer in SailfishOS
14:32:45 <vgrade> #info Martin Brook, vgrade, community porter
14:32:47 <tortoisedoc> pascalstein : i buy your jolla tablet any day :P
14:33:21 <pascalstein> tortoisedoc: not for sale, i love it too much
14:33:27 <veskuh_> #info Vesa-Matti Hartikainen, Jolla, SW Program Manager
14:33:37 <Jare> #info Jarkko Lehtoranta, developer @Jolla
14:33:41 <a1kar> #info Amilcar Santos, app developer
14:33:47 <tortoisedoc> bah why it will be deadware soon enoug ;)
14:34:00 <tortoisedoc> pascalstein : so sell it to me :P
14:34:08 <tortoisedoc> (j/k)
14:34:15 <vgrade> tortoisedoc: how much would you pay for a tablet with SF2.0 wihout prop bits?
14:34:23 <cfb014> #info Carmen Fernández, community, sailor
14:35:02 <stephg> ok then
14:35:06 <tortoisedoc> vgrade : lets move this discussion to #sailfishos
14:35:15 <stephg> Because tortoisedoc is constrained with time we're going to deal with his two (short items). On the agenda first, please stay on topic, we won't be long!
14:35:23 <stephg> #info due to participant time constraints the agenda is to be juggled slightly
14:35:33 <stephg> #topic libcontentaction Merge Request on Mer (tortoisedoc, 5 minutes)
14:35:37 <stephg> ortoisedoc, stage is all yours
14:35:38 <daitheflu> ?
14:35:38 <tortoisedoc> thanks stephg;
14:36:12 <stephg> daitheflu: tortoisedoc to do his bits quickly then the agenda will be as per the email
14:36:15 <tortoisedoc> id like to get some feedback on the timeframe for the libcontentaction merge request that is currently pending on my side
14:36:24 <lbt> link ?
14:36:51 <cybette> #info Carol Chen, community memeber (sorry for being late)
14:37:11 <stephg> #info a tentatively valid MR for libcontentaction is ready; what are the next steps? What timeframe to expect?
14:37:34 <tortoisedoc> lbt : see mer-core/libcontentaction on mer git (for some reason my credentials do not seem to work anymore)
14:37:50 <tortoisedoc> tigeli was reviewing the commit
14:38:19 <tortoisedoc> but there is no info on the next steps (what needs to be done next, what will be followed up..)
14:38:20 <pketo> https://git.merproject.org/mer-core/libcontentaction/merge_requests/1
14:38:34 <lbt> quicker than me :)
14:38:48 <stephg> #link https://git.merproject.org/mer-core/libcontentaction/merge_requests/1
14:39:32 <stephg> couple more minutes guys, the silence is deafening ;)
14:39:48 <toxip> or are we done here?
14:39:54 <lbt> I guess the first thing is to check the Maintainer file
14:39:57 <cybette> i can make some noise but i might get kicked out ;)
14:40:00 <lbt> to see who should be nagged
14:40:05 <tortoisedoc> ok i see
14:40:07 <tortoisedoc> so its tigeli
14:40:16 <tortoisedoc> but what I am saying is
14:40:22 <veskuh_> Tigeli is not working at Jolla anymore so probably not having too much time to contribute in his new job
14:40:35 <schmittlauch> oh, that's sad news
14:40:37 <sledges> http://www.merproject.org/dash/repo/libcontentaction.html
14:40:38 <tortoisedoc> can there be some things done on my side to help expedite ?
14:40:47 <stephg> #link http://www.merproject.org/dash/repo/libcontentaction.html
14:40:48 <dr_gogeta86> #info Fabio Isgro community
14:40:51 <tortoisedoc> (test cases, etc)
14:41:06 <tortoisedoc> ...which leads us to the next topic
14:41:08 <bree> #info bree, tester
14:41:15 <sledges> tortoisedoc: ping all of the maintainers
14:41:22 <stephg> ok this is unresolved so onto tortoisedoc next topic:
14:41:24 <tortoisedoc> sledges : done already many times
14:41:28 <stephg> #topic Merge Request policies on Mer (tortoisedoc, 10 minutes)
14:41:35 <tortoisedoc> yes
14:41:37 <sledges> all 12 maintainers?
14:41:38 <tortoisedoc> thanks stephg
14:41:41 <tortoisedoc> lol 12?
14:41:44 <sledges> http://www.merproject.org/dash/repo/libcontentaction.html
14:42:12 <lbt> #info previous link is incorrect - use http://www.merproject.org/dash2/ until I replace the /dash one with the newer version
14:42:17 <tortoisedoc> this topic is about understanding how to proceed and what to expect when submitting a merge request
14:42:20 <stephg> thx lbt
14:42:31 <tortoisedoc> is there a process of sort?
14:42:32 <lbt> #link http://www.merproject.org/dash2/repo/merproject.org/mer-core/libcontentaction.html
14:42:47 <tortoisedoc> also, which tools need to be taken in consideration ?
14:42:57 <tortoisedoc> this all in hindsight for the developer to be able to help as much as possible
14:43:04 <tortoisedoc> and facilitate the merging
14:43:28 <tortoisedoc> for instance, for libcontent action implementation is done, and testing on device is done as well
14:43:29 <sledges> all should be documented in https://wiki.merproject.org/wiki/Contribution which needs housekeeping:)
14:43:32 <lbt> tortoisedoc: the process was evolving and then jolla hit the iceberg and ... it needs to be rescued and dried out
14:43:34 <tortoisedoc> but how about unittests?
14:43:41 <sledges> (i.e. dash and stuff isn't documented there now... sorry about that)
14:43:53 <tortoisedoc> lbt : sure thing, not blaming the hard working crew, just hunting for solutions :)
14:44:15 <stephg> #info contribution instructions to be found in the mer wiki
14:44:20 <stephg> #link https://wiki.merproject.org/wiki/Contribution
14:44:27 <tortoisedoc> for instance, I (as a developer) am not even aware if the unittests are run at all or not
14:44:34 <lbt> sure. It's part of the timeframe ... it's good to highlight this.
14:44:35 <tortoisedoc> (by the OBS I mena)
14:44:55 <lbt> I have some tasks to update the automation on Mer OBS to run various checks
14:45:03 <tortoisedoc> or if they are supposed to be (of course they should, but you never know..)
14:45:59 <tortoisedoc> run various checks include unit tests I assume?
14:46:01 <stephg> 5 more minutes folks
14:46:16 <lbt> on Mer tests are only generally run as part of the build
14:46:18 <sledges> #info those instructions are outdated and needs lots of gardening
14:46:27 <stephg> thx sledges
14:46:40 <lbt> there was (a *long* time ago) a qa-runner system that never really got off the ground
14:47:49 <tortoisedoc> okay
14:47:58 <tortoisedoc> sorry my time's up, so i need to leave
14:47:59 <tortoisedoc> but
14:47:59 <sledges> lbt: nice dash2, with obs projects and archs \o/
14:48:06 <lbt> you're right that we should quantify this
14:48:17 <tortoisedoc> i will then ping all 12 mantainers one by one :P until someone can tell me what to do next with libcontentaction :D
14:48:27 <lbt> anyone up for an action to garden the Contribution page ?
14:48:35 <tortoisedoc> thanks guys!
14:48:41 <lbt> maybe me?
14:48:54 * sledges will help lbt
14:49:04 <stephg> mark you two down then for action?
14:49:05 <r0kk3rz> lbt: happy to help, but i will probably need guidance as to what it needs to say
14:49:05 <tigeli> tortoisedoc_away: I really haven't had any extra time to work on mer, sorry
14:49:23 <lbt> #action lbt, sledges & others to garden the contribution page
14:49:25 <dr_gogeta86> hi tigeli
14:49:35 <stephg> thx lbt
14:49:48 <stephg> one more minute unless tortoisedoc_away is actually away
14:50:23 <stephg> ok thanks everyone for indulging us with the reordering of the agenda
14:50:31 <stephg> #topic Status update from Jolla (tablets, financing, resourcing, etc.); please address the subject of tablet covers - LastuCase and MapBagrag (10 minutes)
14:50:38 <stephg> As with last week, the topic wasn't asked by anyone specifically for this meeting but coderus had raised it in the past.
14:50:43 <stephg> It's marked as sticky in TJC.
14:50:51 <stephg> I see we have several sailors today which is good, so here we go..
14:51:11 <stephg> #info a new blog post on the official Jolla blog detailing shipment for some tablet owners
14:51:16 <sledges> #link https://blog.jolla.com/jolla-tablet-closure/
14:51:16 <stephg> #link https://blog.jolla.com/jolla-tablet-closure/
14:51:24 <stephg> too quick :P
14:51:30 <sledges> argh!:))
14:52:11 <stephg> veskuh_: or jlassila is there anything Jolla would like to say?
14:52:11 <jlassila> Hi all! So I'm here to answer any questions you have regarding the latest blog.
14:52:14 <sledges> any questions to that? jlassila is here to help with answers :)
14:52:15 <pascalstein> #link https://blog.jolla.com/jolla-tablet-closure/
14:52:16 <stephg> thanks
14:52:20 <gerbick> Closure indeed. Glad to see clear communication as to what's happening, moving forward.
14:52:26 <stephg> gerbick: +1
14:52:45 <jlassila> So basically, if you did not read the post yet:
14:52:56 <jlassila> The situation in a nutshell is that we are able to ship a small additional batch of tablets (540 to be exact) that have been assembled already. For all the rest we have a refund program described in the blog.
14:53:09 <pascalstein> jlassila: Can you add an option "Donate full amount to Jolla"
14:53:20 <pascalstein> To help the restructuring and not want the refund
14:53:21 <schmittlauch> What's happening with those accesories like the LastuCase? Will they be refunded?
14:53:24 <jlassila> Yes this will definitely be an option!
14:53:24 <stephg> pascalstein: I saw that comment and think it's a nice gesture
14:53:32 <kimmoli> how about the referral-race tablets? :P
14:53:35 <gerbick> pascalstein +1
14:53:35 <cfb014> How may tablets were sending in first batch?
14:53:40 <jlassila> Yes all accessories will be refunded as well.
14:53:46 <tathhu> cfb014, 121 :P
14:53:50 <jlassila> According to the plan
14:54:06 <jlassila> Unless you ordered directly form e.g. Lastu of course.
14:54:11 <cfb014> Thanks, @tathhu
14:54:34 <schmittlauch> Is Jolla dropping the idea of SailfishOS on tablets or are there still plans about other tablets?
14:54:35 <r0kk3rz> jlassila: I think there was also concern of the makers of the Lasucase and mapbagrag being unpaid as of yet
14:55:21 <jlassila> Well we'll deal with this project first before planning additional tablets.
14:55:38 <M4rtinK> also any idea where all the "Jolla Tablets" that have been showing-up on various Chinese actions sites are coming from ?
14:55:39 <ln-> some people have already paid the VAT in the autumn; is having paid the VAT an indication of being within the 540 who will receive a tablet?
14:55:40 <elfio> Also I'd like to know if there is another partnerting on the roadmap apart of Intex one
14:55:43 <Sage_> schmittlauch: the scalability enablers are in the sailfish os now so in future scaling up to bigger screens is easier.
14:56:18 <M4rtinK> and as for Sailfish OS & tablets - I think this is indeed quite important to know for app developers
14:56:21 <jlassila> If you have been invited to our shop to finalize the order, you will receive a tablet for sure.
14:56:28 <pascalstein> Will the current and next to be send out tablets be fully supported in SailfishOS?
14:56:41 <sledges> schmittlauch: we have sailfishos ported by community on all many factors and screen sizes (last one being oneplus x) https://wiki.merproject.org/wiki/Adaptations/libhybris
14:56:41 <pascalstein> And all it's iterations to come
14:56:42 <M4rtinK> as many counted on the tablet form factor being available (Twablet, Mieru, etc.)
14:56:43 <coley> if any of the 540 backers don't want their tablets will they be given the option of refund? and these tablet then go to the 540+n backer?
14:56:50 <JvD_> \o/
14:57:01 <stephg> uuf lots of questions :)
14:57:18 <jlassila> So many questions…
14:58:09 <gerbick> M4rtinK - those chinese tablets on Taobao have been flashed with Android. I've confirmed that 4 times over. They do not have Sailfish on them.
14:58:15 <jlassila> Sailfish OS will be supported for tablets, but of course the installed base is quite small.
14:58:22 <schmittlauch> I'm afraid that, as there probably won't be that many apps for a tablet with max 700 users, many people wil install another OS on the device.
14:58:40 <stephg> coley: I'd expect at the shopping stage those lucky users will have the option to back out
14:58:40 <schmittlauch> So can the tablet be seen as a dead platform (at least currently)?
14:58:50 <stephg> #info Sailfish OS will be supported for tablets, but of course the installed base is quite small.
14:59:09 <pascalstein> Or will Jolla make sure their own apps are still working 100% on the tablets...
14:59:11 <TylerTemp_> @gerbick No. Some are with Sailfish OS, I can comfire
14:59:26 <pascalstein> They can't leave the backers behind now by just shipping the tablets and then dropping support
14:59:32 <gerbick> Those first 500 with it still have been removed TylerTemp_
14:59:37 <jlassila> If you are among the 540 and don't want a tablet, you're spot will be given to the next one in line.
14:59:49 <stephg> #info If you are among the 540 and don't want a tablet, you're spot will be given to the next one in line.
14:59:50 <Stskeeps> it's really hard to drop support for a device in sailfish :)
14:59:57 <stephg> :)
15:00:21 <andybranson> the tablet is an x86 device with a large screen. hopefully there will be more of those, either as community ports or licensed devices
15:00:31 <elfio> jlassila: we'll see any more partnership coming apart of intex one?
15:00:49 <elfio> in the near future
15:00:50 <pascalstein> I bet on both, community port first and later licensed ones
15:00:55 <jlassila> We have some interesting discussions going on, but unfortunately can't tell yet.
15:00:55 <sledges> schmittlauch: if a non complex app is written by using scalability guidelines, it will work fine on any form factor https://sailfishos.org/develop/docs/silica/sailfish-application-scalability.html/
15:00:58 <stephg> couple more minutes for this then I'll roll it into the next (related) topic
15:01:13 <sledges> pascalstein: ^^
15:01:13 <elfio> jlassila: thanks
15:01:35 <pascalstein> jlassila: What about that "positive surprise" that was mentioned in the new year blog pst
15:01:49 <jlassila> Well good question!
15:02:16 <jlassila> We have something up our sleeve yes, but we just didn't get it into this communication.
15:02:29 <schmittlauch> jlassila: have all invitations to shop already been sent out?
15:02:30 <jlassila> pressure to get this out was too big to wait.
15:02:51 <dr_gogeta86> jlassila, a small question
15:02:57 <dr_gogeta86> I got for mistake two perks
15:02:57 <pascalstein> Can we expect what you have up your sleeve still this month?
15:03:08 <jlassila> Out of the 540 about 70 have already received invitations, rest is yet to be sent.
15:03:08 <pascalstein> Or the communication about it at least.
15:03:11 <dr_gogeta86> first the 199 dollar and the second for 189 mark
15:03:26 <dr_gogeta86> may I ditch just one ?
15:03:40 <dr_gogeta86> in order the  199 is first then 189 one
15:03:46 <stephg> dr_gogeta86: you may have better luck asking care@ that?
15:03:55 <jlassila> dr_gogeta86: you should contact our supprt about this.
15:03:55 <fpe> 70 received invitations, those from October?
15:04:15 <jlassila> Yes those are older invitations.
15:04:39 <stephg> ok one more minute:- jlassila have you got anything else you'd like to add?
15:04:58 <jlassila> Can't promise any shcedule for the next news, don't want to overpromise.
15:05:12 <pascalstein> please communicate more frequently, that's all :)
15:05:24 <fpe> thank you very much!
15:05:25 <sledges> heartbeat:))
15:05:26 <elfio> jlassila: thanks for answer our questions
15:05:28 <jlassila> Mobile Word Congress is in a few weeks, we're targeting to have some news there!
15:05:38 <elfio> wow, great!
15:05:38 <fpe> *exited
15:05:41 <jjoe> are those 540 devices 64GB or 32GB or mixed?
15:05:41 <stephg> hehe
15:05:42 <Stskeeps> you mean mobile powerpoint congress ;)
15:05:43 <jlassila> My pleasure.
15:05:45 <kimmoli> random appearances in irc also appreciated ...
15:05:48 <Stskeeps> (mobile world congress)
15:05:51 <stephg> kimmoli: +1
15:05:53 <pascalstein> jlassila: thanks a lot for answering and joining! highly appreciated!
15:06:04 <stephg> ok then moving on
15:06:10 <sledges> Mobile Excel, we shall!;)
15:06:11 <stephg> #topic What are Jolla plans to rebuild trust with the community? (daitheflu, 20 minutes)
15:06:12 <jlassila> I'll still hang around for the next topic!
15:06:16 <stephg> daitheflu, the stage is all yours
15:06:25 <daitheflu> thanks stephg
15:06:35 <daitheflu> Since the subject is propitious for trolls, I'll try to keep things factual and constructive.
15:06:44 <stephg> good call! :)
15:07:00 <daitheflu> For reasons -that are mostly known- the community is slowly (but surely) fading away. I see a lot of people leaving for greener land. Reading blog.jolla.com comments is painful and you will see a lot of people really, REALLY pissed. These people were the same that supported Jolla a few months ago.
15:07:11 <daitheflu> Some of them invested time (and maybe even money) to comment, fill bugs in TJC, discuss, help... Some also spent some time to develop app(s). As you know, you can't really earn money from this since the store doesn't support paid apps.
15:07:19 <daitheflu> And sadly, some of these people don't even want to ear about Jolla anymore :(
15:07:32 <daitheflu> I understand why they are pissed. To be honest, I'm also pissed : I spent almost all 2015 learning C++ and Qt so I can actually develop for SFOS. I did trust the "open source", "people powered" marketing stuff, I invested time and money. And I really feel betrayed right now. I know I'm not alone, just read the TJC or the blog comments.
15:07:47 <daitheflu> So, for a few months now, the community has been left with almost nothing more than a laconic blog post ~every month. As a consequence, it's slowly dying. And Jolla doesn't seem to care. At least, I haven't seen them doing anything to invert this momentum.
15:07:58 <daitheflu> So my questions are simple :
15:08:05 <daitheflu> 1. What does Jolla plan to do to rebuild trust with the community ?
15:08:12 <daitheflu> 2. How can we (=what's left of the community) help ?
15:08:57 <jlassila> Thanks for the topic. I can discuss this if I may.
15:09:03 <stephg> please
15:09:34 <jlassila> First of all: We fully realize that lately we have not been able to nurture the community as we should have.
15:09:34 <jlassila> It’s been really tough and challenging times, we were quite deep in the death valley this time and  we have had to concentrate on saving the company, and now rebuilding everything and so on.
15:09:48 <jlassila> The thing really is that we DO care.
15:10:23 <jlassila> Honestly, lately this has also been a resource issue - as you know, Carol is no longer with Jolla (a big Jolla supporter still, thanks Carol!!). We’re looking to solve this part of the gap in some way very soon. More on that when we have the answers.
15:11:05 <jlassila> For actual plans on this front, we need to come back to this. I do not have the answers here.
15:11:17 <r0kk3rz> I guess we may see some injection with new community members with the Intex device
15:11:27 <r0kk3rz> which will hopefully get sold to sailfish first-timers
15:11:30 <cybette> jlassila: <3
15:11:32 <stephg> jlassila: communication always helps!
15:11:35 <M4rtinK> what about the Pootle translation instance ?
15:11:44 <sledges> effort has been renewed
15:11:49 <M4rtinK> is at least that finally ready ?
15:11:51 <elfio> Maybe this is a bit offtopic but I think it's related: does Jolla have any plan to don't fall again? that could help to trust again
15:12:08 * lbt notes that the Mer Project is still a community project at the core of Jolla and we've seen a lot more community (and Jolla) activity there recently
15:12:14 <stephg> elfio: I suspect they didn't plan to fall the first time ;)
15:12:17 <sledges> M4rtinK: when it's ready, it will be published right out
15:12:28 <stephg> #info the Mer Project is still a community project at the core of Jolla and we've seen a lot more community (and Jolla) activity there  recently
15:12:41 <elfio> stephg: of course
15:12:56 <ghosalmartin> When working with mer packages, Stskeeps has been very helpful :)
15:13:08 <schmittlauch> Are there still talks with investors about open-sourcing SFOS according to the idea Stskeeps mentioned last year? (dual-license, etc.) @jlassila
15:13:19 <sledges> first face-to-face input about how can community help will be brainstormed in two days at FOSDEM: https://together.jolla.com/question/126575/fosdem-2016-get-together/?answer=126578#post-id-126578
15:13:24 <sledges> thank you all those who can come!
15:13:34 <ghosalmartin> do you think you guys can setup a stream to that
15:13:36 <sledges> topics are in the round-table comments
15:13:42 <jlassila> schmittlauch: Yes that is still on the agenda.
15:13:50 <schmittlauch> \0/
15:13:52 <stephg> #info first face-to-face input about how can community help will be brainstormed in two days at FOSDEM
15:13:58 <stephg> #link https://together.jolla.com/question/126575/fosdem-2016-get-together/?answer=126578#post-id-126578
15:13:59 <tathhu> ghosalmartin, periscope :P
15:14:10 <M4rtinK> also I second daitheflu - it was really painful during the recent crisis as you could not actually help!
15:14:18 <M4rtinK> even if you wanted
15:14:24 <pascalstein> And how about the inclusion of all the translations that are done by the community?
15:14:28 <sledges> ghosalmartin: surely if someone hacks it together (people of caliber that come to fosdem;))
15:14:28 <cybette> sledges: see you at FOSDEM!
15:14:50 <schmittlauch> because I think many people feel so betrayed that only a big step like open-sourcing could make them return.
15:14:52 <M4rtinK> and even if the topic of "how can the community help ?" was raised - no answers were given & no action was taken
15:15:03 <ghosalmartin> sledges: just a simple skype call or hangouts, or alternative
15:15:04 <M4rtinK> this is not how you foster community support...
15:15:08 <LarstiQ> sledges: can you say more about the progress on community translations?
15:15:34 <M4rtinK> schmittlauch: definitely!
15:15:37 <sledges> mal- is developing FM Radio API framework and app, the contribution of which Jolla is planning to embrace, paving way to other similar contributions while SailfishOS is not yet opensource
15:15:45 <daitheflu> M4rtinK: the issue remains valid. You still cannot actually help, even if you want to
15:15:58 <r0kk3rz> "How can community help" well mer/nemo is now in a better state to accept contributions than it was just recently
15:16:11 <sledges> mal-'s goal is to reward Fairphone 2 Sailfish OS port with that app
15:16:28 <M4rtinK> I can count the number of obnoxious little issues I'm sure could be fixed by a simple patch, if only there was the source (there kinda is for the QML..) and a place where to send those patches...
15:16:59 <daitheflu> r0kk3rz: I meant "how can the community help rebuild trust between Jolla and...well...people"
15:17:10 <sledges> LarstiQ: for community translations we still need to polish the workflow of community<->Jolla, document that (will commence in FOSDEM), and finalise community languages translation packs served via Jolla Store
15:17:15 <daitheflu> M4rtinK: +1
15:17:31 <sledges> other infra (of actual translation suggestions and their sync) has already been tested last year
15:17:40 <jlassila> daitheflu: we are also open to all kinds of ideas and suggestions!
15:18:21 <daitheflu> jlassila: I have a bunch of them that I'll probably post on TJC sometime. Just wanted to hear from Jolla before
15:18:21 <stephg> #info for community translations we still need to polish the workflow of community<->Jolla, document that (will commence in FOSDEM), and finalise community languages translation packs served via Jolla Store
15:18:25 <sledges> mal-'s case is a low hanging/short term fruit, opensourcing has never been off the table
15:18:34 <M4rtinK> I'll just note that some of the translation efforts have been going almost from day one
15:18:39 <pascalstein> What about the last Jolla phones that are on stock to be sold for a lower price?
15:18:40 <M4rtinK> like the Czech/Slovak one
15:18:49 <pascalstein> How many are there left in stock in total?
15:19:00 <pascalstein> Indeed M4rtinK :)
15:19:01 <M4rtinK> and they even picked-up some ex-MeeGo translators
15:19:26 <daitheflu> I just want to make sure I'm not investing time and resources in something that will die in 6 months because there are just a hundred guys still interested in the project
15:19:49 <sledges> M4rtinK: that's great when you gather a community around a culture/language, having said that i would like to encourage you to upvote also keyboard layouts, as that let's us prioritise things easier: https://together.jolla.com/question/124266/keyboard-contributions-for-inclusion-in-sfos/
15:20:12 <M4rtinK> sledges: well I have been wondering about the layouts
15:20:17 <dr_gogeta86> daitheflu, personally i've bought an android phone just to replace its main os ...
15:20:30 <M4rtinK> sledges: and kinda worried if that also gets deadlocked indefinitely
15:20:57 <stephg> daitheflu: I'm in the same position as you and take some comfort that there is still a thriving community around the n900 and the n9 too...
15:20:57 <sledges> M4rtinK: and i wondered why the numbers are so low on upvotes, so here's when you come in ;)
15:20:59 <M4rtinK> lots have been submitted but AFAIK non actually pulled to the official repos (??)
15:21:21 <M4rtinK> stephg: N900 for sure - N9 - not so sure...
15:21:22 <sledges> M4rtinK: it was during the time the split layout was implemented, so it was difficult to standardise anything
15:21:31 <sledges> with sfosv2 it should be doable
15:21:42 <stephg> M4rtinK: point is these are old 'un-supported' devices
15:22:09 <stephg> 5 more minutes folks
15:22:14 <r0kk3rz> thanks sledges, its little details like that which make all the difference
15:22:26 <M4rtinK> well, unfortunately old device with a community is more of an exception than a rule
15:22:34 <M4rtinK> anyway - back to topic
15:22:46 <M4rtinK> any appliable action items or stuff to info/link ?
15:22:56 <sledges> r0kk3rz: yep, i'll get in a habit of repeating little details more often == communication :))
15:23:05 <M4rtinK> at least something community can do in the meantime ?
15:23:18 <r0kk3rz> sledges: :)
15:23:21 <stephg> #info Jolla ask for help in prioritizing translations
15:23:24 <M4rtinK> BTW, even negative information will help
15:23:26 <stephg> #link https://together.jolla.com/question/124266/keyboard-contributions-for-inclusion-in-sfos/
15:23:27 <daitheflu> FWIU, upvote on TJC
15:23:31 <sledges> M4rtinK: create a transifex2pootle convertor ;)
15:23:38 <M4rtinK> "we will never opensource X"
15:23:48 <M4rtinK> would help community prioritize efforts
15:24:03 <sledges> i already mentioned - that has never been off the table
15:24:09 <M4rtinK> rather than wait for the thing to be maybe open-sourced someday
15:24:31 <schmittlauch> M4rtinK: They will for sure never opensource 2rd party components like AlienDalvik or Exchange
15:24:33 <jlassila> I will take on an action point to communicate more and more often!
15:25:05 <pascalstein> Even small details/communication can help
15:25:07 <schmittlauch> M4rtinK: *3rd party
15:25:12 <pascalstein> It doesn't have to be big news all the time
15:26:04 <ddh87> You can even communicate more by being active on Together. A short reply can do a lot of good.
15:26:04 <stephg> one more minute
15:26:27 <M4rtinK> schmittlauch: yeah, that can be expected - any people are already working on replacement as a result
15:26:28 <sledges> community TJC moderators are doing great job in pinging required people around
15:26:42 <toxip> I keep the telegram community up-to-date on where the community can help :)
15:26:48 <M4rtinK> schmittlauch: so that kinda works as expected
15:26:52 <sledges> M4rtinK: schmittlauch: yes, android compat layer by krnlyng :)
15:27:04 <cybette> #action jlassila to communicate more often, even with small details, such as responding on TJC
15:27:11 <sledges> toxip: how big is the group ooi?:)
15:27:30 <M4rtinK> but other components are a gray area
15:27:31 <jlassila> cybette: <3
15:27:41 <kimmoli> and in irc ?
15:27:47 <toxip> sledges: atm only about 90 members... we used to have 120 on the old group but we hit some trouble with that so we had to migrate
15:27:53 <stephg> sledges: android compat which brings us nicely onto AoB
15:27:58 <sledges> M4rtinK: if you think we are too silent, step up and become a TJC mod, to ping us directly :) way to help -> we're more responsive on TJC thanks to you
15:28:04 <stephg> #topic All other business  (everyone, 10 minutes)
15:28:11 <cybette> kimmoli: step by step :)
15:28:29 <kimmoli> cybette: i'm just poking with a toothpick
15:28:38 <sledges> toxip: cool!
15:28:38 <stephg> so two things from me, all of the porty-goodness that's been going on (its fast moving and I don't know what it all is, I want to hear!)
15:28:47 <M4rtinK> sledges: well, I already at least monitor, vote & comment on TJC quite a lot
15:28:49 <stephg> and also, there's this thing I've heard about called FOSDEM ;)
15:28:51 <sledges> *poring (to those unaware:)
15:28:54 <pascalstein> jlassila: Will the SailfishOS roadmap page be updated?
15:29:07 <M4rtinK> sledges: but would probably not have enough time to be a proper mod
15:29:27 <pascalstein> #link https://sailfishos.org/roadmap/
15:29:39 <M4rtinK> pascalstein: very good point!
15:29:45 <jlassila> pascalstein: We need to take that as an action point.
15:30:09 <pascalstein> Now it looks like development stopped, which we know is not
15:30:10 <stephg> #action jlassila updates to the SFOS roadmap
15:30:24 <ddh87> Is there any news on the "new" hardware company that will be formed?
15:30:29 <jlassila> Currently the future is not as clear as it used to be, so this is not a very easy task.
15:30:34 <veskuh_> I wouldn't promise update at this point.
15:30:51 <elfio> +1 ddh87
15:31:12 <pascalstein> jlassila: Do you have any idea when the shipments of eg Jolla phones and accessoires from the webstore are back in normal operation
15:31:18 <stephg> veskuh_: can you elaborate so I can info it:- resource I presume?
15:31:22 <ddh87> Jlassila: There has to be a plan for SFOS af this point. A goal where the software has to be next years and all the steps to take.
15:31:43 <pascalstein> The current mailing says there is no visibility on the logistical part of it... Can you clarify please
15:31:46 <sledges> stephg: it's known what to drop, but probably current status could be updated, veskuh_ ?
15:31:49 <toxip> The fan club has been hoping for a possibilty to buy a license for community ports that would allow the installation of alien dalvik, jolla store and ms exchange for example. Do you have anything to share about that?
15:32:22 <veskuh_> stephg: current status can be updated, the timeline for future is more difficult
15:32:23 <vgrade> toxip: good Q.  The 1+ guys are itching to get something like that
15:33:02 <jlassila> ddh87: sure we do have plans, but they are living/changing.
15:33:05 <stephg> #info the current roadmap status can be updated but timelines for future features/development are not yet clear
15:33:15 <toxip> vgrade: there's a high potential on the 1+ side. We could get a really nice injection of new community members there
15:33:48 <pketo> Access to jolla store for more of the ported devices is hopefully somewhere in the near future
15:33:58 <vgrade> jlassila: something which could be investigated on your side?
15:34:08 <jollafan> Hey, is it possible to download Dalvik package with a Jolla and install it on a ported device? How legal is it?
15:34:09 <sledges> toxip: that would come nicely together with paid apps in general, but nothing ongoing there atm; please suggest ways to pay for apps, like would all people be fine with bitcoins? :) etc; especially those who know finnish paid appstore nuances
15:34:18 <M4rtinK> I think a surprising number of people would still give Jolla money
15:34:23 <M4rtinK> if Jolla let them
15:34:25 <stephg> sledges: do you have anything about store for ported devices
15:34:27 <richdb> jlassila: any plans to let return the good things of the 1.0 GUI?
15:34:43 <M4rtinK> (eq. cut on paid apps, user licenses, more hardware with Sailfish OS, etc.)
15:34:51 <eugenio> I guess we aren't to expect anymore monthly sfos updates (that's understandable of course). Will future updates be released "when they are ready" or is there a more definite timeframe (like ~3 months)?
15:34:59 <ddh87> jlassila: moving plans are the best that makes you agile. But never stop development midway. This is very expencive, I know from experiance.
15:34:59 <sledges> stephg: resourcing problem, please stick with warehouse for the moment, but i keep pushing weekly, will switch to every other day :D
15:35:00 <itdoesntM-att-ER> hi to all.
15:35:18 <stephg> pketo: ^^
15:35:19 <vgrade> sledges: great , thanks
15:35:24 <pketo> yep
15:35:25 <toxip> sledges: bitcoins please. Need a SFOS bitcoin client though
15:35:41 <pketo> as I said, hopefully in the near future :)
15:35:44 <M4rtinK> separate security update stream might not be a bad idea
15:35:54 <eugenio> +1
15:35:58 <jlassila> ddh87: thanks for the comment, noted :)
15:36:06 <stephg> toxip: https://github.com/khertan/BitPurse
15:36:13 <stephg> may need some love but I see he's updated it recently
15:36:13 <M4rtinK> especially if the update tempo might get slower
15:36:23 <M4rtinK> well, even till now it was not exactly ideal
15:36:31 <M4rtinK> CVEs were slowing updates
15:36:35 <stephg> 3 more minutes folks
15:36:37 <M4rtinK> or taking weeks to be available
15:36:40 <M4rtinK> (CVE fixes)
15:36:59 <pascalstein> jlassila: How may original Jolla Phones are still in stock?
15:37:09 <toxip> stephg: nice I think I've seen this before
15:37:12 <stephg> M4rtinK: I'd expect that (again) to be resourcing and recovering
15:37:43 <jollafan> Can someone answer is it possible/legal to download Dalvik on Jolla and install on port?
15:37:44 <jlassila> pascalstein: no clear answer on that, since there are some devices with our local partners that might come back to us.
15:37:51 <sledges> toxip: here's hoping 3rd party apps would be offered via store, due to our evolving partnership business model, then should come paid abilities for other apps, so we should be happy jolla's changing strategy at least for this reason :)
15:37:53 <jlassila> But we have some stock still left!
15:38:21 <stephg> jollafan: not possible nor legal currently but the community is working on an equivalent
15:38:22 <sledges> and yep there's TJC on that too https://together.jolla.com/question/6522/harbourstore-support-for-paid-applications/, but this is old thread, things and strategies changed since.. and no word there about finnish laws i'd be interested to hear
15:38:25 <pascalstein> jlassila: but when are the shipping operations to be expected normal again?
15:38:42 <pascalstein> currently orders have a 20-30+ days of being shipped
15:39:02 <jollafan> stephg ok, thanks!
15:39:21 <jlassila> There has been some uncertainties with the shipping partner, but they should be shipping, AFAIK.
15:40:04 <M4rtinK> I got a new Jolla in December
15:40:10 <M4rtinK> took about 3 weeks back then
15:40:18 <jollafan> By the way, when can Jolla Phone owners set an app to the partner space?
15:40:40 <stephg> one more minute
15:40:49 <toxip> sledges: thanks for that but I asked specifically the possibility to buy a license for the 3rd party stuff on SFOS.
15:40:55 <pascalstein> jollafan: good question
15:41:24 <jollafan> Thanks, is there a good answer?
15:41:29 <sledges> toxip: understood, just saying that the demand that has reached critical mass (partnerships) will be driving this, and hopefully you'll benefit indirectly
15:41:31 <itdoesntM-att-ER> toxip +1
15:41:34 <sledges> as the infra will be there
15:41:43 <stephg> ok then
15:41:44 <pascalstein> #link https://together.jolla.com/question/90201/what-exactly-is-the-partner-space/
15:41:54 <stephg> #topic Wrap up, and next meeting (5 minutes)
15:42:10 <toxip> sledges: thank you!
15:42:18 <stephg> are we happy with February the 11th, same time?
15:42:23 <kimmoli> +1
15:42:26 <elfio> yeah
15:42:30 <pascalstein> yeah
15:42:35 <vgrade> FOSDEM flu permitting
15:42:41 <sledges> oh!
15:42:41 <stephg> and anyone volunteers for moderators?
15:42:45 <sledges> forgot the term:))
15:42:49 <stephg> vgrade: nooo, gws!
15:43:01 <sledges> stephg: we're yet to get one ;D
15:43:19 <sledges> so yes, see you in fosdem, cybette and many you lot!!
15:43:27 <pascalstein> hopefully FOSDEM live stream or video afterwards
15:43:29 <stephg> indeed
15:43:33 <cybette> stephg: i can chair (will be in taiwan then, but should be doable)
15:43:51 <stephg> ok for meeting and moderator (cybette will cover if you can't)
15:44:03 <stephg> #info next meeting 11th February at 14:30 UTC
15:44:11 <stephg> #info next chair cybette
15:44:14 <cybette> stephg: thank yo u<3
15:44:39 <daitheflu> thanks for chairing stephg
15:44:43 <vgrade> stephg: I'm fine, but always have post FOSDEM flu
15:44:50 <stephg> oh I see
15:44:54 <stephg> 'flu'
15:44:57 <jlassila> Thanks everyone :)
15:44:58 <stephg> 'drank too much'
15:45:00 <cybette> great job stephg, thanks again
15:45:00 <jollafan> Thanks and good bye!
15:45:04 <stephg> thanks everyone for a cooperative meeting
15:45:07 <toxip> thank you
15:45:08 <vgrade> stephg: probably
15:45:09 <daitheflu> thanks jlassila
15:45:12 <stephg> you were all very well behaved
15:45:14 <elfio> thanks everybody :)
15:45:14 <richdb> thank you
15:45:15 <veskuh_> thanks
15:45:15 <pascalstein> great job stephg, thanks
15:45:15 <sledges> stephg: no, that is actuall a thing! :D
15:45:17 <cybette> jlassila: thanks for joining the meeting and anaswering all the questions!!!
15:45:19 <pascalstein> thanks jlassila
15:45:23 <daitheflu> and thanks everybody
15:45:25 <stephg> sledges yehyeh
15:45:26 <ddh87> Thanks to all of you!
15:45:28 <stephg> #endmeeting