#mer-meeting: SailfishOS, open source, collaboration 31st of March 2016

Meeting started by stephg at 14:30:24 UTC (full logs).

Meeting summary

    1. Happy World Backup Day and welcome to another SailfishOS OSS and collaboration meeting (stephg, 14:30:35)
    2. Meeting information and agenda can be found here: http://lists.sailfishos.org/pipermail/devel/2016-March/007022.html (stephg, 14:30:47)

  1. Brief introduction (5 minutes), please prefix your name/handle with #info (stephg, 14:31:08)
    1. Eugenio Paolantonio, community, professional lurker (eugenio, 14:31:45)
    2. Lewis Rockliffe, community (r0kk3rz, 14:31:47)
    3. Steph Gosling community, porter (stephg, 14:31:50)
    4. Leif-Jöran Olsson, community (ljo_, 14:31:54)
    5. Jonathan Frederickson, community (M-jon, 14:32:02)
    6. kimmo lindholm. adhoc. (kimmoli, 14:32:10)
    7. Vesa-Matti Hartikainen, Program Manager, Jolla (veskuh, 14:32:15)
    8. Adam Pigg, community (piggz, 14:32:46)
    9. Martin Kolman, community member & modRana developer (M4rtinK, 14:32:51)
    10. Simonas Leleiva, pootle and portle, Jolla (sledges, 14:32:57)
    11. Carol Chen, community, in between meetings so might drop off anytime (cybette, 14:32:57)
    12. Luis Da Costa, community and LibreTrend CEO (Aliasbody, 14:33:15)
    13. Damien Caliste, community, contributor when possible (dcaliste, 14:33:37)
    14. Bolesław Tokarski, community (ballock, 14:33:40)
    15. Tadeusz Sośnierz, community, developer (tadzik, 14:34:05)
    16. Pami Ketolainen, backend developer @ Jolla (pketo, 14:34:19)
    17. Philip Ries, community (linphilrie, 14:34:31)
    18. Samu Voutilainen, lurker (Smar, 14:34:40)
    19. Philippe Bollard, community member, software engineer and ex-entrepreneur (PhixGre_, 14:34:53)
    20. Stefan, user and lurker (the_mgt, 14:35:05)
    21. Andrew Branson, community and occasional developer (andybranson, 14:35:38)
    22. Nikita, community (NeKit, 14:36:12)

  2. Paid app situation (ApB, 5 minutes) (stephg, 14:36:21)
    1. (from tjc: some details about the topic: Someone to answer: 1) what holds them back 2) is there a ETA on when they will be allowed) (stephg, 14:37:25)
    2. There is no ETA at the moment. (veskuh, 14:38:36)
    3. James, Community Manager (Jaymzz_, 14:38:48)
    4. Unfortunatly, we lost many people involved in this activity (veskuh, 14:39:18)
    5. schmittlauch, community member, currently on a train with bad internet connection (schmittlauch, 14:42:49)
    6. Qt has already the Purchasing (for the inapp purchases on Android and iOS) and some other things that should be implemented in order to monetize Apps, but nowadays we have nothing, we don't even have a good Qt Ads library compactible with SailfishOS (this is why paid apps was and still is the best solution so far) (stephg, 14:45:25)

  3. Platform Development documentation (ArmsOfSorrow, 5 minutes) (stephg, 14:45:44)
    1. (from tjc): some details about the topic: this https://sailfishos.org/wiki/Platform_Development and various other sites about platform development are still just placeholders. I'd really like to help advance the platform (e.g. update some old packages), but the documentation on the whole process is scattered around various sites. When is it going to be (more) complete? (stephg, 14:46:41)
    2. ACTION: inquire UI team about docs to components like filepicker etc (sledges, 14:54:09)

  4. Future of Jolla in the professional environment (Aliasbody, 30 minutes) (stephg, 14:56:27)
    1. (from tjc): I've been promoting Jolla as a platform for my clients and their feedback might be good to be heard. More in details, every time we gain a client/project for a mobile app (mostly Android and iOS) we always propose a version for Jolla or Ubuntu Touch for free (in order to promote those platforms and to help them understand the benefits of a convergent code), but usually everyone chooses Ubuntu. (stephg, 14:56:57)
    2. (from tjc): At start I thought that it was because they knew the name (so there were more attracted to it) but after long discussions with our clients we found out that this wasn't the case. If you allow me I would be interested in explaining what are their concerns (and why, if this doesn't change, we might at libretrend change also everything to Ubuntu Touch). (stephg, 14:57:09)
    3. (About harbour) as an example, we are creating a library to support Chromecast and we are having problem because some of the Components we need aren't supported by the Harbour team to be included in the store, so at this point we could already have an app launched but we don't have for those reasons (stephg, 15:11:45)

  5. Handling critical security fixes (schmittlauch, 10 minutes) (stephg, 15:19:23)
    1. (from tjc): As CVE-2015-7547 still isn't fixed we need to talk about how to handle security fixes. Jolla has already released very small hotfix updates for critical problems, so why don't they do it for this very critical issue? I understand that the testing effort for Q&A may be a reason to ship it as part of Taalojärvi, but as this hasn't been released for over a month now just releasing a patched glibc is quite necessary. (stephg, 15:20:18)
    2. (from tjc): What are the criteria for Jolla on releasing a hotfix? How to cope with similar issues in future? (stephg, 15:20:33)
    3. So 2.0.1 releasing is pending on the incoming call silence issue. (veskuh, 15:23:12)
    4. the plan has been to release the hotfixes along with 2.0.1, but if that is still too far we should reconsider doing it as a separate hotfix as is now the proposal (veskuh, 15:24:23)
    5. Jolla don't have definition of what makes issue critical, but we do have process for hotfix releases (stephg, 15:31:38)

  6. All other business (everyone, 10 minutes) (stephg, 15:33:25)
    1. (regarding release of 2.0.1) Jolla did two fix attempts neither were fully effective and now we evaluate if by changing design we could go around the issue (stephg, 15:35:54)
    2. ghosalmartin is at the edge from having aarch64 mer, kimmoli is polishing sfos on OnePlus X which looks like N9 reincarnation:) and supports mindblowing touchscreen gestures while suspended, piggz Moto G got camera and i think is complete port, fairphone got jolla store. (stephg, 15:39:51)
    3. new sony xperia tablet and galaxy have porting activity (stephg, 15:41:37)
    4. community translations (pootle) have started among beta testers, because translation round came too quick (stephg, 15:44:54)
    5. Open-sourcing is still in plans quite similarly as stskeeps presented in community meeting couple times ago (stephg, 15:45:15)

  7. Wrap up, and next meeting (5 minutes) (stephg, 15:50:10)
    1. Next meeting Thursday the 14th of April, 13:30 UTC, stephg to chair (stephg, 15:58:01)


Meeting ended at 15:58:48 UTC (full logs).

Action items

  1. inquire UI team about docs to components like filepicker etc


People present (lines said)

  1. stephg (90)
  2. M4rtinK (53)
  3. Aliasbody (49)
  4. sledges (40)
  5. schmittlauch (39)
  6. r0kk3rz (32)
  7. veskuh (24)
  8. ApBBB (15)
  9. cybette (14)
  10. lbt (12)
  11. linphilrie (12)
  12. Smar (12)
  13. Jaymzz_ (9)
  14. Raymaen (7)
  15. PhixGre_ (7)
  16. urjaman (7)
  17. merbot (4)
  18. ballock (3)
  19. dcaliste (3)
  20. M-jon (3)
  21. Wnt (2)
  22. otsaloma (2)
  23. tadzik (1)
  24. MSameer (1)
  25. kimmoli (1)
  26. pketo (1)
  27. ljo_ (1)
  28. eugenio (1)
  29. NeKit (1)
  30. daitheflu (1)
  31. andybranson (1)
  32. the_mgt (1)
  33. piggz (1)
  34. locusf (1)


Generated by MeetBot 0.1.4.