#mer-meeting: SailfishOS, Open Source, Collaboration 5th of September 2016

Meeting started by Jaymzz at 09:00:57 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2016-September/007390.html (Jaymzz, 09:01:09)

  1. Brief introduction (5 minutes). Please prefix your name/handle with # info (Jaymzz, 09:01:50)
    1. James Noori, Community Manager (Jaymzz, 09:02:10)
    2. chriadam / Chris Adams / UI and middleware developer for Jolla (chriadam, 09:02:16)
    3. Lewis Rockliffe - Community (r0kk3rz, 09:02:34)
    4. Simonas Leleiva, hw&l10n@jolla (sledges, 09:02:55)
    5. schmittlauch, interested community member, probably just reading (M-schmittlauch, 09:03:01)
    6. Raine M�kel�inen, browser, ui, middleware developer for Jolla (rainemak, 09:03:05)
    7. Tommi Keisala, community (JvD_, 09:03:21)
    8. abranson / Andrew Branson / middleware dev for Jolla (abranson, 09:03:31)
    9. Leif-Jöran Olsson, community (ljo, 09:03:31)
    10. Pekka Vuorela, developer at Jolla (pvuorela, 09:03:34)
    11. André Walker, community member (andrewalker, 09:03:38)
    12. Vesa-Matti Hartikainen, Program Manager at Jolla. (veskuh, 09:03:43)
    13. Damien Caliste, community member (dcaliste, 09:04:20)
    14. Pami Ketolainen, developer @ Jolla (pketo, 09:04:52)
    15. Dylan Van Assche, SFOS developer (modulebaan, 09:05:06)

  2. CalDAV bugs - request for contributors (10-15 min, asked by chriadam) (Jaymzz, 09:07:07)
    1. There are a variety of bugs in the CalDAV sync adapter (https://git.merproject.org/mer-core/buteo-sync-plugin-caldav) which are difficult for me to test and fix for a variety of reasons (access to servers of correct versions, different language issues, internal company prioritisation, etc), which I would love to see some community contributions for. The bug numbers are: MER#1500, MER#1569, MER#1623, MER#1624, MER#1625 (see e.g. (Jaymzz, 09:07:27)
    2. https://bugs.merproject.org/show_bug.cgi?id=1624). So, this topic is basically reaching out to the community to see if some person or persons would be willing to help investigate these issues and hopefully provide fixes. I can provide information on how to get started, how to get more debug output, and so on, to help reduce the learning curve as much as possible. Aside from fixing bugs directly, I'd really like to have unit tests added (Jaymzz, 09:07:28)
    3. https://git.merproject.org/mer-core/buteo-sync-plugin-caldav (Jaymzz, 09:07:49)
    4. https://bugs.merproject.org/show_bug.cgi?id=1624 (Jaymzz, 09:07:59)
    5. https://bugs.merproject.org/buglist.cgi?quicksearch=caldav (chriadam, 09:13:50)
    6. https://bugs.merproject.org/buglist.cgi?quicksearch=caldav (Jaymzz, 09:14:16)
    7. ACTION: if you're able to help, please send an email to chris dot adams at jolla dot com with your irc nick + the manner in which you might be able ot help (Jaymzz, 09:16:17)

  3. Security and authorization on SFOS (30 min, asked by Lucien Xu / Sfiet_Konstantin / SfietKonstantinW ) (Jaymzz, 09:19:47)
    1.  At the moment, there is no security, nor authorization frameworks. However, security and privacy on mobile device is an important topic. The major OSes all implement sandboxes to prevent malicious applications to do unwanted things. I would like to explore how to enhance the situation on SFOS, and how to proceed. This topic would be a discussion and a brainstorming about what the technologies involved (SELinux ? Polkit ? etc) and (Jaymzz, 09:20:03)
    2. At the moment most activity is around getting the stack more up-to-date (regarding security) (Jaymzz, 09:25:33)
    3. Then we will be doing key security enablers like improved bootup security & flashing. (Jaymzz, 09:25:48)
    4. And as features file system encryption and vpn support are being worked on. (Jaymzz, 09:26:02)
    5. any contributions from the community are welcome (Jaymzz, 09:28:18)
    6. https://git.merproject.org/mer-core/polkit/merge_requests/2 (SfietKonstantin, 09:29:16)
    7. https://git.merproject.org/mer-core/polkit/merge_requests/2 (Jaymzz, 09:30:09)
    8. https://github.com/mer-hybris/mer-kernel-check/blob/master/mer_verify_kernel_config (Jaymzz, 09:43:25)
    9. the real question is "how hard is it to get an selinux policy that allows full functionality and provides meaningful security benefits" : and the answer is "we don't know but hard" (lbt, 09:46:13)
    10. ACTION: log a bug in the Mer bugtracker: enable SELinux for the emulator kernel (SfietKonstantin, 09:51:13)
    11. ACTION: If anyone can help him with the investigation, please comment on the Mer Bug (Jaymzz, 09:52:12)

  4. General discussion (15 minutes) (Jaymzz, 09:53:35)
    1. https://github.com/sailfishos/sailfish-components-webview/tree/master/components (Jaymzz, 09:55:07)
    2. https://bugs.merproject.org/show_bug.cgi?id=1645 (Jaymzz, 09:56:34)
    3. https://github.com/sailfishos/sailfish-browser/issues/478 (modulebaan, 09:58:21)
    4. https://github.com/sailfishos/sailfish-browser/issues/478 (Jaymzz, 09:58:43)
    5. General comment. lbt is working on getting mer-core updated (again/still). This should help with development on public OBS. (lbt, 09:58:55)
    6. pastebin.com/0LpAqLq2 (Jaymzz, 10:02:52)
    7. https://git.merproject.org/mer-core/Maintainers/blob/master/maintainers.yaml#L366 (Jaymzz, 10:03:51)
    8. https://git.merproject.org/tortoisedoc/qtpurchasing (Jaymzz, 10:04:33)
    9. ACTION: please email chris dot adams at jolla dot com if you're interested in helping with CalDAV/CardDAV testing/fixing/etc. (Jaymzz, 10:06:30)
    10. https://github.com/systemd/systemd/commit/b52a4a3b05a2a0d69868d57fd54f6e4b8fa0e7ca (Jaymzz, 10:07:31)
    11. https://github.com/mer-hybris/mer-kernel-check (Jaymzz, 10:07:40)

  5. : Next meeting time and date (Jaymzz, 10:10:41)
    1. Next meeting will be held on Monday, 3rd of October 2016 at 09:00 UTC (Jaymzz, 10:13:22)


Meeting ended at 10:13:44 UTC (full logs).

Action items

  1. if you're able to help, please send an email to chris dot adams at jolla dot com with your irc nick + the manner in which you might be able ot help
  2. log a bug in the Mer bugtracker: enable SELinux for the emulator kernel
  3. If anyone can help him with the investigation, please comment on the Mer Bug
  4. please email chris dot adams at jolla dot com if you're interested in helping with CalDAV/CardDAV testing/fixing/etc.


People present (lines said)

  1. SfietKonstantin (86)
  2. Jaymzz (67)
  3. chriadam (58)
  4. tortoisedoc (40)
  5. lbt (38)
  6. dr_gogeta86 (28)
  7. sledges (14)
  8. M-schmittlauch (12)
  9. elfio (11)
  10. veskuh (10)
  11. modulebaan (9)
  12. merbot (7)
  13. Sage (7)
  14. pketo (5)
  15. r0kk3rz (5)
  16. pvuorela (4)
  17. rainemak (3)
  18. eekkelund (3)
  19. OhDaeto_ (3)
  20. dcaliste (2)
  21. abranson (2)
  22. OhDaeto (2)
  23. ljo (2)
  24. andrewalker (1)
  25. Yaniel (1)
  26. JvD_ (1)


Generated by MeetBot 0.1.4.