08:31:48 <chriadam> #startmeeting CalDAV/CardDAV Contributor Meeting
08:31:48 <merbot> Meeting started Mon Dec  5 08:31:48 2016 UTC.  The chair is chriadam. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
08:31:48 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:31:54 <chriadam> #topic Introductions
08:32:11 <chriadam> Please introduce yourself, with #info Name / nick, brief notes
08:32:32 <chriadam> #info Chris Adams, developer at Jolla working on CalDAV/CardDAV stuff amongst other things
08:33:09 <dcaliste> #info Damien Caliste / dcaliste, interested in knowing how CalDAV is working and helping where I can.
08:33:27 <c-la_> @chriadam has the community meeting started!
08:33:30 <c-la_> ?
08:33:46 <chriadam> c-la_: no, it starts in half an hour.  this is the caldav/carddav meeting
08:34:23 <c-la_> thx sorry
08:34:28 <chriadam> np :-)
08:34:45 <chriadam> i'll wait another 5 mins for introductions, then we'll start on the agenda
08:36:30 <Venty> #info Martin Ebnoether SailfishOS Fanboy
08:38:27 <chriadam> ok, let's get started on the agenda :-)
08:38:33 <chriadam> #topic Follow-up Agenda Items From Last Meeting
08:39:07 <chriadam> Lots of progress, thanks to the testing infrastructure (test servers, plus the unit tests) enabling easier testing and iterating fixes.  Thanks to everyone who has contributed
08:39:51 <chriadam> specifically, MER#1647 was fixed (thanks William__), MER#1568 was fixed, and with it MER#1623, and dcaliste has fixed MER#1625 but I haven't yet merged it because git.merproject.org is having some SSL issues at the moment
08:40:15 <chriadam> I also started MER#1696, and dcaliste has some review comments there which I need to fix etc.
08:40:35 <chriadam> Nothing outstanding from the last meeting, as far as I'm aware, so let's go on with the current items:
08:40:49 <chriadam> actually, before I do that, dcaliste do you have anything to add there?
08:41:05 <dcaliste> I'm working on MER#1646, and I've proposed two MR but some additional checkings and discussions are needed, see gitlab.
08:41:20 <chriadam> ok, thanks, I will double check on that afterward!
08:41:24 <chriadam> ok, let's continue:
08:41:26 <chriadam> #topic Manual Testing + Test Scripts - Any Volunteers?
08:41:33 <dcaliste> I've also created MER#1712 from a TJC question.
08:41:43 <dcaliste> And proposed a patch for it.
08:41:58 <chriadam> dcaliste: thanks, I will look at that one also
08:42:09 <dcaliste> It is just additional error checking in reader.cpp.
08:42:20 <chriadam> We do need some volunteers to "hunt for bugs" by performing various manual testing, against the test servers in the Mer infra
08:42:26 <chriadam> this doesn't require any programming knowledge
08:42:32 <chriadam> it's just manual poking to try to find things which break
08:42:41 <chriadam> if anyone can volunteer for this sort of thing, please let me know!
08:42:58 <ljo> I am still up for this.
08:43:22 <chriadam> ljo: great - thanks.  the credentials are listed in the wiki - if you have any issues please email me and I will help you get set up
08:43:24 <ApBBB> chriadam: you should also add a topic for this in TJC. More people will see it there i believe.
08:43:34 <chriadam> ApBBB: you're right, I will do that next time
08:43:48 <chriadam> #action ljo to perform manual testing against the test server instances in Mer infra
08:43:53 <chriadam> ok, great, let's continue:
08:43:59 <chriadam> #topic Any Volunteers For MER#1711 (and MER#1606)
08:44:07 <ApBBB> not the meeting. i meant the whole testing.
08:44:18 <ApBBB> carddav
08:44:22 <chriadam> this is vCard / cardDAV related - the BDAY field handling is a bit fragile
08:44:33 <chriadam> if no-one volunteers for this, I am willing ot take these two
08:45:16 <chriadam> 5 more seconds for folks to volunteer for these, otherwise I'll take these and we'll continue (bit of a rush since we have to be finished in 15 min ;-)
08:45:33 <chriadam> #action chriadam to take MER#1711 and MER#1606
08:45:39 <chriadam> cool, onto the next agenda item:
08:45:45 <chriadam> #topic Any Volunteers For MER#1714 - phone number fields have ISDN type appended during CardDAV sync
08:45:53 <chriadam> this one is slightly trickier, as I believe the offending code is in QtVersit
08:45:56 <chriadam> but I haven't verified that
08:46:16 <chriadam> if someone is willing to investigate this, that would be appreciated, otherwise we can postpone it until the next meeting.
08:46:42 <chriadam> it doesn't prevent sync, so it's not a critical error, but it's obviously incorrect behaviour.
08:47:02 <chriadam> waiting 5 more seconds for volunteers, else continuing...
08:47:22 <chriadam> #action MER#1714 postponed as it's not critical (doesn't prevent sync)
08:47:33 <chriadam> noving on:
08:47:34 <chriadam> #topic Any Volunteers For MER#1689 - captive portal (wifi gateway) can cause failure reported as authentication issue
08:47:54 <chriadam> this was discussed briefly last meeting - it's a tricky one which can be difficult to reproduce if you don't have access to a captive portal gateway
08:48:18 <chriadam> dr_gogeta86 mentioned that a proxy could be used to do the same thing, which might be a nice way to reproduce
08:48:44 <chriadam> any volunteers for this one, otherwise we can continue (again, I don't think this is as critical as some others, plus its difficulty to reproduce is an issue)
08:49:12 <chriadam> #action MER#1689 postponed due to difficulty to reproduce without a captive portal gateway
08:49:21 <chriadam> moving on:
08:49:23 <chriadam> #topic Any Volunteers For MER#1500 - double percent-encoding issues with caldav calendar resources
08:49:41 <chriadam> This one is basically: come up with a set of unit test XML files with a variety of different special characters which are percent encoded in the href / filename / etc
08:49:47 <dr_gogeta86> chriadam, isn't easy ... but doable
08:50:02 <dcaliste> I can give a look for this one (#1500), if no one else volonteer.
08:50:02 <chriadam> once we have a set of unit tests, we can determine what the appropriate fix for the corner cases might be
08:50:13 <chriadam> waiting 5 more seconds, otherwise dcaliste gets it ;-)
08:50:29 <chriadam> #action dcaliste to investigate MER#1500 - Thanks!
08:50:38 <chriadam> next one:
08:50:39 <chriadam> #topic Any Volunteers For MER#1569 - event occurrences shared between calendars don't work if parent series not also shared
08:50:49 <chriadam> This is one which dcaliste had some comments / discussion on, IIRC
08:50:58 <dcaliste> I'm looking at this one.
08:51:04 <chriadam> great, thanks
08:51:07 <dcaliste> As said in the bug report,
08:51:15 <chriadam> #action dcaliste investigating MER#1569
08:51:22 <chriadam> thanks!
08:51:29 <dcaliste> it's quite tricky to get the parent from another calendar.
08:51:41 <dcaliste> But allowing the error to past is simple.
08:52:15 <chriadam> yep, I think that might be necessary - I just hope it doesn't hide other issues
08:52:23 <chriadam> but that's better than failing the entire sync cycle, I guess.
08:52:26 <chriadam> ok, next topic:
08:52:34 <chriadam> #topic Discussion about MER#1646
08:52:39 <chriadam> dcaliste was working on this one
08:52:45 <dcaliste> Maybe a third path would be to create a fake parent from the exception occurence ?
08:52:54 <dcaliste> Ah, #1646 is interesting one !
08:52:55 <chriadam> #action dcaliste to investigate MER#1646, chriadam to review his PRs etc
08:53:11 <chriadam> yes
08:53:41 <dcaliste> But solutions for #1646 may have a lot of undesired side effects if not correctly.
08:53:53 <chriadam> dcaliste: not sure about creating fake parent item, would prefer to just ignore the save error in that case, but I haven't given it deep thought yet
08:54:02 <chriadam> dcaliste: yeah.  I agree, it's a tricky one.
08:54:20 <chriadam> let's discuss further in the gitlab discussion etc
08:54:27 <chriadam> #topic Discussion about WebCal subscriptions (iOS feature?)
08:54:37 <chriadam> Can anyone provide me with more concrete information about what's required to implement this?
08:55:02 <chriadam> if you can send me the info, I can create some bugs to concretely track the work which is required to implement support for this feature in our plugins
08:55:52 <chriadam> #action chriadam to create a bug about this feature, to collect information related to webcal subscriptions
08:56:06 <chriadam> ok, that's all for the agenda, so:
08:56:10 <chriadam> #topic Any Other Business?
08:56:22 <dcaliste> Could we write a white paper or some wiki page equivalent on a framework for error reporting to the user interface in buteo ?
08:56:32 <dcaliste> Is it too early for this ?
08:56:39 <dcaliste> Should there be a sync-agent or some equivalent that can popup info or a place in settings that can be looked at asynchronously ?
08:56:40 <chriadam> once again, huge thanks to dcaliste and also William__ for the contributions since the last meeting.  really greatly appreciated.
08:57:14 <chriadam> dcaliste: buteo does support reporting the errors for a given sync cycle, however we currently don't have any UI (in jolla-settings, for example) which can display it
08:57:32 <chriadam> it involves design input, which makes it tricky since MartinS is very very busy
08:58:07 <chriadam> but it's definitely something we can consider (e.g., what are the needs from user POV, what actions can be triggered from that UI, and what should plugins ensure they provide (translated strings?) in the results object?)
08:58:08 <c-la_> @chriadam: may I ask if the caldav has been tested with synology nas self hosted devices?
08:58:17 <chriadam> c-la_: not officially, no
08:58:38 <chriadam> Ok, we have to wrap up else we'll block Jaymzz from starting the SFOS Community Meeting!
08:58:42 <dcaliste> I propose this because for my POV, many users don't understand what happen.
08:58:44 <chriadam> Thanks to everyone for their participation!
08:58:50 <Jaymzz> cheers chriadam
08:58:55 <chriadam> #endmeeting