09:01:07 <chriadam> #startmeeting CalDAV/CardDAV Contributor Meeting
09:01:07 <merbot> Meeting started Mon Mar 13 09:01:07 2017 UTC.  The chair is chriadam. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:01:07 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:01:57 <chriadam> Not sure how many folks will be able to make it to this one, since we had to push it back a week due to the Sailfish OS Community Meeting.
09:02:13 <chriadam> Anyway, will wait a few minutes and start on the agenda :-)
09:02:16 <chriadam> #topic Introductions
09:02:34 <chriadam> Please introduce yourself with #info nick/name
09:02:45 <chriadam> #info Chris Adams, developer at Jolla
09:03:30 <ljo> #info Leif-Jöran Olsson, community
09:05:20 <chriadam> hi ljo, dcaliste :-)
09:06:38 <chriadam> will wait another 4 minutes for people to join in case they're running late
09:07:05 <kimmoli> #info Kimmo Lindholm, community payload
09:08:01 <chriadam> hi kimmoli
09:08:16 <dcaliste> #info Damien Caliste, community
09:08:26 <kimmoli> hi
09:08:27 <dcaliste> Hi everyone
09:09:43 <chriadam> hi!  will wait one more minute then start on the agenda :-)
09:10:14 <occirol[m]> #info occirol, community
09:10:56 <chriadam> hi occirol[m]
09:10:59 <chriadam> ok, let's start!
09:11:04 <occirol[m]> hi !
09:11:09 <chriadam> #topic Follow-up Agenda Items From Last Meeting
09:12:43 <chriadam> There isn't much to follow up on.  I fixed a couple of issues which I think were related to known issue (e.g. MER#1699), but not 100% sure so we'll have to keep an eye on that
09:13:15 <chriadam> dcaliste: actually, you were able to repro that MER#1699 issue (via a device restart iirc) - could you try to repro with the fix included (latest caldav from master should have that fix) to see if it is indeed fixed now?
09:13:49 <ljo> I have been trying to keep reported  issues together in tjc. But working on the phone is suboptimal.
09:14:03 <chriadam> aside from that, I still haven't merged dcaliste's patch for MER#1646 - dcaliste, is that one ready to be merged?  if you say "yes" I will push the button and then ask on TJC for people who are willing to test that one thoroughly.
09:14:22 <dcaliste> Ok, I'll try this week to see if bug #1699 appears again after your fix and report in gitlab.
09:14:22 <merbot> Mer bug 1699 in buteo-sync-plugin-caldav "CalDAV calendars get lost when the sync server isn't available" [Normal,Resolved: fixed] https://bugs.merproject.org/show_bug.cgi?id=1699
09:14:27 <chriadam> ljo: I did see you triaging some issues, thanks for that!
09:14:46 <chriadam> ljo: what do you mean by "working on the phone is suboptimal"?
09:14:53 <chriadam> dcaliste: thanks
09:15:08 <dcaliste> *checking about bug #1646
09:15:08 <merbot> Mer bug 1646 in buteo-sync-plugin-caldav "CalDAV sync fails due to annually-recurring event" [Task,New] https://bugs.merproject.org/show_bug.cgi?id=1646
09:16:05 <chriadam> UID-prefixing related IIRC
09:17:37 <chriadam> that was all of the outstanding items AFAICR
09:17:44 <chriadam> #topic Outstanding Reviews (PR/MR) and Next Steps
09:17:51 <chriadam> This follows on nicely from before
09:18:02 <chriadam> There are currently 3 open PRs which I think are "ready":
09:18:17 <chriadam> https://git.merproject.org/mer-core/buteo-sync-plugin-carddav/merge_requests/11 (although there are more issues in MER#1751 which can be fixed too)
09:18:22 <dcaliste> The MR for #1646 should be fine, but as you mentioned it lacks unit testing. I'll try to add a unit test for this in the coming one or two weeks. But showing the failure is random because it depends on hashtable ordering.
09:18:48 <chriadam> https://git.merproject.org/mer-core/buteo-sync-plugin-caldav/merge_requests/15 thanks Erik! -- more reviewers would be appreciated
09:18:58 <chriadam> dcaliste: if you could, that would be fantastic
09:19:19 <chriadam> FYI, not sure when 2.1.1 will be released - 2.1.0 obviously got delayed while we fixed some critical issues, and so I think 2.1.1 timeline will be impacted, but I might be wrong
09:19:35 <chriadam> but that's kind of unrelated anyway
09:19:57 <chriadam> the other PR which is open is that 1646 one but that's been addressed
09:20:16 <chriadam> did I miss any open PRs?  please poke me if there's something which needs my attention because otherwise I'm likely to forget :-)
09:21:26 <chriadam> dcaliste: btw is the hashtable ordering deterministic?  i.e., could we "find" a set of uids which exhibit the behaviour?
09:21:38 <chriadam> dcaliste: or is it somehow randomised?
09:21:47 <chriadam> (or am I misunderstanding the issue?)
09:22:00 <dcaliste> You're understanding it right I think.
09:22:33 <dcaliste> From the same test set (the one coming from the bug 1646 report), I obtained the wrong ordering, sometime not…
09:22:33 <merbot> Mer bug 1646 in buteo-sync-plugin-caldav "CalDAV sync fails due to annually-recurring event" [Task,New] https://bugs.merproject.org/show_bug.cgi?id=1646
09:22:49 <chriadam> ah byzantine errors, aren't they fun.
09:23:27 <dcaliste> I didn't check further in Qt to see if it's reasonable not to be deterministic and blame the hashtable, but I may be wrong.
09:23:33 <chriadam> well, we do the best we can.  I could not spot any logic errors in your code, so as long as we have some basic unit tests to sanity check, that's all I can possibly ask, really.
09:24:10 <chriadam> beyond that, it just needs testing (and I'll ask community members ot help with that, on TJC.  I will create a few more test users on the mer infra servers to help with that, I suppose)
09:24:36 <chriadam> #action chriadam to create more test users on the Mer test server instances, and ask on TJC for help with testing MER#1646 solution PR
09:24:49 <chriadam> ok, anything else, or should we move on to next agenda item?
09:25:51 <chriadam> ok, moving on:
09:25:52 <chriadam> #topic Current Open/New High Priority Bugs/Tasks
09:26:54 <chriadam> No critical bugs I would say, but MER#1624 and MER#1751 would be useful.  I think that MER#1751 would be good for a new contributor, since one of the issues there in particular (support .eml files) should be quite simple to add support for
09:27:22 <chriadam> Aside from that, I wonder if MER#1757 affects caldav plugin also, or only Google calendars?  ljo has any reported issues on TJC about caldav plugin had similar symptoms?
09:27:42 <chriadam> (i.e., where the error message is something like: "Could not dissociate occurrence ..." etc)
09:29:54 <chriadam> well, something to keep in mind, anyway.
09:30:03 <dcaliste> Do you think #1624 can be looked at without synologic account to exactly reproduce ?
09:30:13 <ljo> i suspect it is the same issue. But not sure yet.
09:31:02 <chriadam> dcaliste: I suspect that dr_gogeta86 could tell us how to prevent any form of discovery / .well-known etc from working, in the Mer owncloud test instances
09:31:56 <chriadam> dcaliste: basically, I think the case is: the server doesn't support discovery at all, but the user knows the addressbook path directly, or something like that.
09:32:28 <dr_gogeta86> hi
09:32:42 <dr_gogeta86> chriadam i've seen the push ... but i was in a outage
09:32:56 <dr_gogeta86> so dcaliste chriadam what's the problem ?
09:33:22 <chriadam> dr_gogeta86: hi :-)  any idea if it's easy to "temporarily" break .well-known requests or any form of addressbook-home-set etc discovery requests on one of the Mer test server instances?
09:33:44 <chriadam> (to test a particular bug, and potential solution... but then after that, put the test server back to the way it was)
09:33:59 <dr_gogeta86> just put a nginx filter on topo
09:34:00 <dr_gogeta86> just put a nginx filter on top
09:34:22 <chriadam> dr_gogeta86: aha, there's already an nginx filter to do something, so I guess we could extend what's already there?
09:34:44 <chriadam> great I will look into that (but probably won't get a chance to do so within the next week or so).  I will add a note to MER#1624 about this.
09:34:47 <chriadam> thank you
09:35:32 <dcaliste> Ok, I don't promise because I'm busy on something else, but I will try to see how to reproduce and fix #1624 with the help of your note.
09:36:12 <chriadam> dcaliste: yeah, consider it super low priority
09:36:33 <chriadam> maybe we can tackle that one after next month's meeting, since I need to figure out how to modify the docker-compse env to get it to do what we want
09:37:09 <chriadam> but we'll see whether I get time before hand.  if I do, I will update 1646 again
09:37:19 <chriadam> ok, moving on in the agenda:
09:37:26 <chriadam> #topic Any Other Business?
09:37:37 <dcaliste> Ok, anyway, my top priority is currently to polish and push the GPG email stuff.
09:37:44 <chriadam> yep :-)
09:38:23 <dcaliste> Just a question, what do you think is a reasonable time schedule to begin to discuss introducing new features like Todos… ?
09:39:50 <chriadam> from implementation point of view: 1) does mkcal currently support todos properly? 2) does its API allow effective synchronisation or will it also need hacks like the timestamp nonsense we did for events, etc?
09:40:07 <chriadam> then from there: 3) can we add support for todos into jolla-calendar application / UI
09:40:54 <dcaliste> Yes, but I'm more wondering when you think we'll be ready to start discussing (and later on work) on things like that ?
09:41:52 <chriadam> I don't know.  It's possible that one of Jolla's major clients will have need for better PIM and Sync support, and if so, they may push us to start work on these sorts of issues quite soon.  But they may not.
09:42:38 <chriadam> I guess: currently, Jolla is very much "customer project" driven at the moment, so until a particular customer wants us to work on this, then we don't really have the bandwidth to put serious effort into it, unfortunately.
09:42:45 <chriadam> that's not a very good answer but it's the best I can give.
09:43:23 <dcaliste> We may add to the next agenda, if bug flow slow down, to discuss a draft paper on where to look and test…
09:43:43 <chriadam> yes, I think that's a very good suggestion.
09:43:43 <dcaliste> For the business model of Jolla, I understand, no problem.
09:44:22 <chriadam> #action Raise topic of "Feature Support (e..g, TODOs)" at next meeting
09:44:52 <chriadam> ok, anything else to discuss?
09:44:56 <dcaliste> That part is open source so the implementation can be looked at by community if any incentive. The UI will follow (if not by patch) later on when machinery is ready anyway.
09:46:13 <chriadam> dcaliste: yeah.  personally, I wish we had already open sourced jolla-calendar etc but that still is ongoing discussion at board level, it seems.
09:46:29 <chriadam> but yes the investigations can all be done in open source components, absolutely.
09:46:55 <chriadam> from mkcal to caldav to nemo-qml-plugin-calendar.  just jolla-calendar is missing, really.
09:47:17 <chriadam> Ok, I will quickly summarise then will close the meeting:
09:47:42 <dcaliste> I'm not bother much by UI being closed source as long as code that is indeed doing the job is free software based on standards (and UI is patchable).
09:48:01 <chriadam> 1) Reviews appreciated on the three outstanding PRs (MER#1751, MER#1727, MER#1646).
09:48:34 <chriadam> 2) dcaliste to look into adding a unit test for MER#1646.  chriadam to build a package based on (rebased) 1646 PR, and ask on TJC for testers to help test.
09:49:10 <chriadam> 3) chriadam to look into nginx filter rules to allow reproing MER#1624 (but may not get a chance for a couple of weeks, probably)
09:49:27 <chriadam> 4) raise TODOs and other feature support investigations at the next meeting
09:49:31 <chriadam> (did I miss anything?)
09:50:23 <chriadam> 5) new contributors: MER#1751 has a couple of open issues remaining, and one of those would be very suitable for a new contributor to investigate - ping me if you would like to get involved with development :-)
09:50:46 <ljo> I continue triaging.
09:51:03 <dcaliste> 6) See if dcaliste can reproduce #1699 again after patch and report.
09:51:48 <dcaliste> thanks ljo :)
09:51:52 <chriadam> ljo: thanks, I am having less time to spend on triaging these days so your help is very much appreciated there.  especially if my recent patch for 1699 broke something important, ping me if you see something which points to that possibility :)
09:52:00 <chriadam> dcaliste: yes, thanks :-)  forgot that one
09:52:08 <chriadam> ok - thanks to everyone for the discussion and planning!  much appreciated!
09:52:13 <chriadam> ending the meeting in 5...
09:52:22 <chriadam> 4...
09:52:30 <chriadam> 3...
09:52:35 <chriadam> 2...
09:52:39 <chriadam> 1...
09:52:43 <chriadam> #endmeeting