#mer-meeting: Sailfish OS, open source, collaboration – April 19th 2017

Meeting started by Jaymzz_ at 08:00:21 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-April/007852.html (Jaymzz_, 08:00:30)

  1. Brief introduction (5 min). Please prefix your name/handle with # info (Jaymzz_, 08:00:51)
    1. Aleksi Suomalainen, SailfishOS community, porter, Nemo enthusiast/master (locusf, 08:01:04)
    2. James Noori, Community Manager and Chairperson for this meeting (Jaymzz_, 08:01:06)
    3. Lewis Rockliffe,community member (rkz, 08:01:22)
    4. Chris Adams, developer at Jolla (chriadam, 08:01:27)
    5. Bhushan Shah, KDE developer and Plasma Mobile maintainer (bshah, 08:01:35)
    6. Carsten Munk, crazy person (Stskeeps, 08:01:37)
    7. Marko Saukko, Sailor @ Jolla (Sage___, 08:01:43)
    8. Martin Kolman, community member and modRana developer (M4rtinK_phone_, 08:01:47)
    9. Jonatan Walck, Community member and home-developer (jwalck, 08:01:52)
    10. eekkelund, Maemo Community Council, community dev (eekkelund, 08:01:52)
    11. pavi, community (pavi[m], 08:01:55)
    12. PureTryOut, community (PureTryOut[m], 08:02:00)
    13. Kostadin Damyanov, community (Max-Might, 08:02:02)
    14. Vesa-Matti Hartikainen, Program Manager at Jolla (veskuh, 08:02:10)
    15. Andrew Branson, sailor at Jolla (abranson, 08:02:13)
    16. Adam Pigg, Sailfish OS Community Porter, KDE Developer (piggz, 08:02:23)
    17. Christophe Chapuis, community, also LuneOS developer (Tofe, 08:02:28)
    18. Simonas Leleiva, l10n'n'hw at Jolla (sledges, 08:02:30)
    19. Pami Ketolainen, backend developer @ Jolla (pketo, 08:02:30)
    20. m2ko, community (m2ko, 08:02:45)
    21. Kaj-Michael Lang, community (oniongarlic, 08:02:48)
    22. pasko user (pasko_, 08:02:52)
    23. Thomas Ruecker, a mer community member (tbr, 08:02:54)
    24. Wouter van Heijst, infra at Jolla (LarstiQ, 08:03:38)
    25. Hongwei Ge, sailor@Jolla (hge, 08:03:45)
    26. Steph Gosling, community, porter (stephg, 08:03:53)
    27. Rodolphe Sequeira, community (RodSeq, 08:04:18)
    28. Martin Ebnoether, Community Member (Venty, 08:04:38)
    29. juiceme, general hacker (juiceme, 08:05:35)
    30. Fabio Isgrò, Community Member (dr_gogeta86, 08:06:25)

  2. Sailfish Browser /servo (revisit) asked by nh1402 (20 min) (Jaymzz_, 08:06:40)
    1. Federico_III, software designer, python samurai, C (Federico_III, 08:06:41)
    2. tadzik, community, app developer (tadzik, 08:06:52)
    3. Servo components are slowly being added to Firefox, WebRender, Quantum etc. on target to be added some point this year. I think we should jump straight to these components once they are stable enough, and bypass these old versions of embedlite/firefox. (Jaymzz_, 08:07:06)
    4. Raine M�kel�inen, developer @ Jolla (rainemak, 08:07:14)
    5. Julius Enriquez, Community member, Android and Linux power user, technology enthusiast, curious person (linux_unix-10, 08:07:33)

  3. Possibility to enable 802.11r support in wpa_supplicant, asked by pasko (10 min) (Jaymzz_, 08:11:12)
    1. Nokius community sailfishos-porter (Nokius, 08:11:15)
    2. Support for 802.11r is disabled at compilation time in package wpa_supplicant. As explained in https://together.jolla.com/question/154955/80211r-roaming-implemented/ it is relatively easy to enable this feature. I've been using it for the last weeks and didn't notice any abnormal behaviour. (Jaymzz_, 08:11:25)
    3. https://together.jolla.com/question/154955/80211r-roaming-implemented/ (Jaymzz_, 08:11:32)
    4. https://git.merproject.org/mer-core/wpa_supplicant/blob/master/rpm/build-config (Jaymzz_, 08:14:06)
    5. sage thinks that there is no reason why it could not be enabled other than testing and making sure nothing breaks if it is enabled. (Jaymzz_, 08:15:00)
    6. ACTION: pasko_ to PR merproject (https://git.merproject.org/mer-core/wpa_supplicant/blob/master/rpm/build-config ) and see what comes on reviews (Jaymzz_, 08:16:09)
    7. to help with the process in case someone else is going to use it: https://www.youtube.com/watch?v=xtcEQNOKbg8 (Jaymzz_, 08:17:29)

  4. Project Halium, collaboration on common android base, by bshah, toxip, mariogrip (15 min) (Jaymzz_, 08:18:22)
    1. Description: Currently Ubuntu Touch, SailfishOS/Mer, Plasma Mobile and others have different android source trees and methods on how our stacks are built even though much of the underlying technologies are the same. There is a lot of unneeded fragmentation. Project Halium aims solve this by the having common android base and perhaps common middleware between different projects so that we could collaborate and distribute each (Jaymzz_, 08:18:35)
    2. http://lists.sailfishos.org/pipermail/devel/2017-April/007842.html (Jaymzz_, 08:18:43)
    3. https://xkcd.com/927/ ? this remind me of this (Coolgeek, 08:23:52)
    4. https://sailfishos.org/wp-content/uploads/2016/02/Sailfish_Architecture.jpg (Jaymzz_, 08:30:44)
    5. Topias Vainio, Sailfish OS Fan Club founder (sorry I overslept) (toxip, 08:34:34)
    6. ACTION: myself to finally release the long-overdue HADK v2 to bring 64bit ports to-date (apologies, been carried away with xperia stuff), in turn to make sfos porting even more easier <- do own housekeeping first :) (sledges, 08:50:30)
    7. Just a summary of what went on in the beginning, sage- said: We need to remember here one important thing, what works with the ODM's? It does not really matter what we think is the best if it doesn't work with the ODM's. Also things like merging to same codebase things like kernel or drivers or using same caf tag is basically going back to MeeGo times and the issues that were already existing there that we have been working (Jaymzz_, 08:51:45)
    8. This was a pretty long topic with a LOT of information crammed into it. I suggest going back and reading the logs in case you need to revisit something. (Jaymzz_, 08:52:39)
    9. for anyone interested please join #halium on freenode (rkz, 08:53:40)

  5. General discussion (15 min) (Jaymzz_, 08:54:39)
    1. Sony Open Devices project with Xperia X is progressing steadily. (Jaymzz_, 08:59:08)
    2. https://together.jolla.com/question/156475/2109-swipes-lag-behind-on-jolla-c-aqua-fish/?sort=votes&page=1 (toxip_, 09:10:56)

  6. Next meeting time and date (5 min) (Jaymzz_, 09:15:55)
    1. Next meeting will be held on Wednesday, 3rd of May 2017 at 08:00 UTC (Jaymzz_, 09:18:10)


Meeting ended at 09:18:44 UTC (full logs).

Action items

  1. pasko_ to PR merproject (https://git.merproject.org/mer-core/wpa_supplicant/blob/master/rpm/build-config ) and see what comes on reviews
  2. myself to finally release the long-overdue HADK v2 to bring 64bit ports to-date (apologies, been carried away with xperia stuff), in turn to make sfos porting even more easier <- do own housekeeping first :)


Action items, by person

  1. pasko_
    1. pasko_ to PR merproject (https://git.merproject.org/mer-core/wpa_supplicant/blob/master/rpm/build-config ) and see what comes on reviews


People present (lines said)

  1. Jaymzz_ (57)
  2. sledges (39)
  3. bshah (37)
  4. rkz (27)
  5. tbr (18)
  6. Sage- (14)
  7. juiceme (13)
  8. jwalck (12)
  9. toxip_ (12)
  10. nh1402 (11)
  11. M4rtinK_phone_ (9)
  12. dr_gogeta86 (9)
  13. pavi[m] (9)
  14. pasko_ (8)
  15. Tofe (8)
  16. locusf (7)
  17. veskuh (6)
  18. toxip (6)
  19. Nokius (6)
  20. rainemak (5)
  21. chriadam (4)
  22. jpetrell (4)
  23. LarstiQ (3)
  24. merbot (3)
  25. locusf_ (3)
  26. M4rtinK (3)
  27. piggz (3)
  28. Venty (2)
  29. abranson (2)
  30. hge (2)
  31. Max-Might (2)
  32. Stskeeps (2)
  33. RodSeq (2)
  34. stephg (2)
  35. linux_unix-10 (2)
  36. Coolgeek (2)
  37. Federico_III (1)
  38. tadzik (1)
  39. Sage___ (1)
  40. pketo (1)
  41. PureTryOut[m] (1)
  42. eekkelund (1)
  43. niqt (1)
  44. mal (1)
  45. oniongarlic (1)
  46. m2ko (1)


Generated by MeetBot 0.1.4.