09:00:20 <chriadam_> #startmeeting Sailfish OS CalDAV/CardDAV Contributors Meeting
09:00:20 <merbot> Meeting started Mon Jun 5 09:00:20 2017 UTC. The chair is chriadam_. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:00:20 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:00:29 <chriadam_> #link https://sailfishos.org/wiki/CalDAV_and_CardDAV_Community_Contributions#05.2F06.2F2017_Meeting
09:00:37 <chriadam_> #topic Introductions
09:01:00 <chriadam_> Please introduce yourself with #info Name/Nick. We'll wait 10 minutes for folks to arrive and then we'll start on the agenda.
09:01:08 <chriadam_> #info Chris Adams, developer at Jolla.
09:01:54 <dr_gogeta86> morining all
09:02:07 <chriadam_> hi dr_gogeta86 :-)
09:02:23 <dr_gogeta86> #info Fabio Isgrò, Full Time ( and beyond ) Stacker ...
09:03:21 <dr_gogeta86> chriadam_, just us ?
09:03:38 <chriadam_> so far. will wait another 5 minutes or so
09:03:48 <chriadam_> in case people are running late :-)
09:05:19 * LarstiQ runs lurk
09:05:33 <chriadam_> hi LarstiQ :-)
09:07:49 * guhl is listening
09:08:45 <chriadam_> hi guhl! I'm glad you could come. Unfortunately due to higher priority things I got shifted off working on that bug actively - but later this week I will definitely take you up on the offer of the account so I can test some fixes for that issue
09:08:54 <chriadam_> if possible
09:09:25 <guhl> fine, just tell me when you need something
09:09:32 <chriadam_> thanks very much!
09:09:39 <chriadam_> let's get started on the agenda:
09:09:45 <chriadam_> #topic Follow-up Agenda Items From Last Meeting
09:10:11 <chriadam_> Firstly, dcaliste fixed MER#1773 - huge thanks to him as always
09:10:20 <abranson_> #info Andrew Branson, another sailor
09:10:23 <abranson_> sorry I'm late!
09:10:30 <chriadam_> hi abranson_ :-)
09:10:53 <chriadam_> I got the MER#1751 fix promoted for the soon-to-be released update
09:11:07 <chriadam_> that pretty much covers the action points from the last meeting.
09:11:30 <chriadam_> Other activity since then is mostly related to JB#38601 (which is the issue which guhl saw, I believe, after further testing with abranson_ who has been able to repro also)
09:11:37 <chriadam_> but more about that in a moment
09:12:04 <chriadam_> Huge thanks to Manatus for helping with testing both caldav and carddav packages I made, to give me more confidence that we're not introducing regressions with these fixes.
09:12:27 <chriadam_> And as always, if you'd like to help out in that capacity (testing pre-release packages) please get in touch via email or irc :-)
09:12:44 <chriadam_> Anybody have anything else to add, with regards to action points from last meeting?
09:13:16 <chriadam_> if not, let's continue with the next topic:
09:13:32 <chriadam_> #topic JB#38601 - CalDAV plugin fails during sync of some "broken" events, resulting in duplications
09:13:55 <chriadam_> This is the main issue we have at the moment. There is a Work-In-Progress PR to resolve this issue
09:14:04 <chriadam_> however we haven't resolved all of the problems yet
09:14:14 <chriadam_> abranson_ and guhl are helping me with testing etc
09:14:40 <chriadam_> I'm sick today and probably won't be at work tomorrow either, but i'm hoping to get back to investigating this one later this week.
09:14:59 <chriadam_> #action chriadam to work with abranson_ and guhl to finally resolve this caldav issue JB#38601
09:15:14 <chriadam_> abranson_: did you have anything to add for this one?
09:15:57 <abranson_> chriadam_: No, all good! Hope you get well soon...
09:16:00 <chriadam_> the only other thing I'd add is: code review (and further testing) of the PR would be greatly appreciated. there will be a couple of changes made to fix this issues, so regression risk is non-zero.
09:16:35 <chriadam_> abranson_: cheers, just resting as much as I can at the moment
09:16:44 <chriadam_> ok, moving onto the next topic:
09:16:52 <chriadam_> #topic MER#1714 - isdn field added to phone numbers on upsync (investigation required)
09:17:02 <chriadam_> relatively minor although very annoying issue
09:17:31 <chriadam_> QtVersit seems to prefer ISDN subtype in cases where no subtype is specified by the user
09:17:50 <chriadam_> if anyone is willing to help investigate that one (it's all open-source code / components) that'd be appreciated
09:18:20 <ljo_> I hsve been under the ice, but could do some code review and testing soon again.
09:18:22 <dr_gogeta86> chriadam, ISDN such so 90's
09:18:52 <chriadam_> several possible locations to fix: 1) either fix the qtversit code itself, 2) add a preprocessing step to add a specific subtype prior to conversion to vcard, 3) add a postprocessing step to remove any ISDN subtype after conversion to vcard.
09:19:00 <chriadam_> dr_gogeta86: indeed
09:19:05 <chriadam_> ljo_: great!
09:19:16 <abranson_> i've seen ISDN numbers appear in my phonebook before. will see if there are any now
09:19:26 <chriadam_> anyway, that one is free for anyone to take / investigate :-)
09:19:32 <chriadam_> abranson_: thanks
09:19:37 <chriadam_> moving on to the next topic:
09:20:03 <chriadam_> #topic MER#1751 - supporting .eml-suffixed vcards
09:20:16 <chriadam_> the main problem in MER#1751 was resolved, however there are two "minor" issues remaining
09:20:36 <chriadam_> one in particular would be nice to solve: it seems like some servers allow vCards to be stored with a .eml extension instead of .vcf
09:21:20 <chriadam_> so it would be nice if we could support that way (but in a way which doesn't cause us to erroneously attempt to sync email parts, etc) by allowing to sync files of that type so long as the resource type is specifically reported as vCard
09:21:58 <chriadam_> I think only Kerio servers have that behaviour from what I've seen so far, but I may be wrong
09:22:14 <chriadam_> and we don't have a Kerio server in our test server instances (I am not familiar with Kerio at all)
09:23:02 <chriadam_> once again, if anyone is willing to investigate that one, please get in touch. I should be able to give you some logs of sync cycles with such a server (once I redact some details from it).
09:23:29 <chriadam_> ok, that's the only three things I had marked for the agenda!
09:23:34 <chriadam_> #topic Any Other Business
09:23:48 <chriadam_> Does anyone have anythign else to discuss or suggestions or things?
09:26:40 <chriadam_> I was hoping to get the JB#38601 fix into upgrade-2.1.1 but the changes of that are extremely slim unfortunately.
09:26:55 <chriadam_> so eta for that is upgrade-2.1.2 I guess.
09:28:22 <chriadam_> well, if no-one has anything else specific to discuss, I will close the meeting :-)
09:28:39 <chriadam_> Thanks to everyone for joining!
09:28:43 <chriadam_> closing in 5...
09:28:51 <chriadam_> 4...
09:28:56 <chriadam_> 3...
09:29:00 <chriadam_> 2...
09:29:03 <chriadam_> 1...
09:29:07 <chriadam_> #endmeeting