08:00:09 <Jaymzz_> #startmeeting Sailfish OS, open source, collaboration – June 28th 2017
08:00:09 <merbot> Meeting started Wed Jun 28 08:00:09 2017 UTC.  The chair is Jaymzz_. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
08:00:09 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:21 <Jaymzz_> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-June/007921.html
08:00:33 <Jaymzz_> I am the meeting’s chairperson today and will be doing my best to keep time and order. Please behave, respect the timings and be gentle.
08:00:52 <Jaymzz_> #topic Brief introduction (5 min). Please prefix your name/handle with # info
08:01:03 <nh1402> #info nh1402, community member
08:01:10 <locusf> !info Aleksi Suomalainen, Nemo dev, porter, sfos community
08:01:11 <merbot> locusf: (info <url|feed>) -- Returns information from the given RSS feed, namely the title, URL, description, and last update date, if available.
08:01:15 <Jaymzz_> #info James Noori - Community Manager @ Jolla
08:01:17 <ljo_> #info Leif-Jöran Olsson, community member
08:01:18 <r0kk3rz> #info Lewis Rockliffe, community
08:01:23 <chriadam_> #info Chris Adams, developer at Jolla
08:01:32 <LarstiQ> #info Wouter van Heijst, infra at Jolla
08:01:38 <Venemo_j> #info Venemo_j Timur Kristof, cbeta community member
08:01:45 <Xray2000> #info Rudi Timmermans, app dev
08:01:45 <locusf> #info Aleksi Suomalainen, Nemo dev, porter, sfos community
08:02:00 <eekkelund> #info eekkelund
08:02:05 <HUBAT> §info hubat, community member
08:02:16 <M4rtinK_phone_> #info Martin Kolman, community member and modRana developer
08:02:24 <pavi[m]> #info pavi, community
08:02:31 <jwalck> #info Jonatan Walck, community member
08:02:35 <bshah> #info Bhushan Shah, KDE Plasma Mobile, Halium
08:02:37 <locusf> wrong prefix galore ftw
08:02:43 <oniongarlic> #info Kaj-Michael Lang, app developer
08:02:47 <LarstiQ> locusf: very hipster
08:03:38 <veskuh> #info Vesa-Matti Hartikainen, Program Manager @ Jolla
08:03:48 <jusa_> #info Juho Hämäläinen, Developer @ Jolla
08:04:01 <sledges> #info Simonas Leleiva, sailor {at} Jolla
08:04:01 <tadzik> #info tadzik, community member, app developer
08:04:26 <kro> #info kro, user
08:04:55 <Stskeeps> #info Carsten Munk, CTO @ Zipper, community member
08:04:56 <citylight2> #info citylight2, user
08:05:07 <Jaymzz_> Nice, we're quite many today!
08:06:12 <Jaymzz_> #topic "emoji" support in clipboard (10 min, asked by nh1402)
08:06:15 <Jaymzz_> #info The Sailfish clipboard doesn't support copying "emoji's", are there any plans to add support?
08:06:31 <nh1402> the question speaks for itself, I think
08:06:40 <chriadam_> pvuorela: might know about that one?
08:07:49 <tbr> moaning
08:08:08 <Jaymzz_> This is exactly why I say 5 min ain't never enough ;)
08:08:58 <pavi[m]> What happens with other unicode characters?
08:10:06 <nh1402> when you try to copy an "emoji" and paste it, it appears as a diamond with a question mark in it
08:11:09 <sledges> nh1402: only in dalvik apps
08:11:11 * LarstiQ wonders how much source/destination matter
08:11:11 <Jaymzz_> nh1402: What if you have the emoji keyboard from openrepos installed? Does the same thing happen?
08:11:25 <sledges> just copied it fine from emoni keyboard across native apps
08:11:56 <sledges> s/emoni/emoji
08:12:06 <nh1402> ok so it's not fully supported
08:12:16 <nh1402> just natively
08:12:16 <sledges> so, aliendalvik issue
08:12:59 <Jaymzz_> sledges: Does that mean we can't fix it?
08:13:10 <pavi[m]> Ahh android specific issue. Showing up as Diamond means the encoding is not supported.
08:13:31 <sledges> it doesn't ;) looks like something for TJC to get some votes..
08:14:05 <Jaymzz_> nh1402: You heard (read) the man! Make it a TJC post and father proper votes for it so we can make it happen :)
08:14:21 <lupastro> hi
08:14:28 <Jaymzz_> Hello
08:14:28 <locusf> sailfish usually renders characters which it doesn't recognize as encodable as question marks
08:14:31 <nh1402> I'll do that after the meeting, as the next topic, was also started by me
08:14:40 <nh1402> raised*
08:14:49 <Jaymzz_> Alright then, I'll change topic in a sec
08:15:07 <nh1402> locusf: it was both a diamond and a question mark
08:15:12 <nh1402> the question mark was in the diamond
08:15:20 <Jaymzz_> #action nh1402 to make a post on TJC and gather votes so sailors can do their magic
08:15:38 <Jaymzz_> #topic: dismissing notifications (10 min, asked by nh1402)
08:15:39 <sledges> thanks nh1402
08:15:49 <Jaymzz_> #info I find it quite irritating that you have to wait for the notification pop up to go away, having a way to dismiss it would be highly appreciated. I'm aware a swipe gesture would probably conflict with other gestures, but just a dismiss button would suffice I feel. If the button that says dismiss, or an arrow pointing to the left is up to you, just have a way to dismiss it, please. I hate waiting for it to go away before I can
08:15:50 <Jaymzz_> use that part of the screen again.
08:16:10 <Venemo_j> yes, I totally agree
08:16:37 <M4rtinK_phone_> +1
08:16:46 <LarstiQ> also with remorse timers blocking page stack navigation
08:16:55 <nh1402> I think that too is self explanatory
08:16:57 <Venemo_j> this is especially bad when you try to enable wifi or mobile data and a notification pops up and covers the switch
08:17:26 <Jaymzz_> I agree with this one too. We should be able to swipe it away if needed.
08:17:36 <sledges> when do you need to touch at the top of an app? probably mostly on android apps..:)
08:17:40 <chriadam_> jpetrell: any thoughts on this?
08:17:47 <Jaymzz_> jpetrell: I think this should be your area
08:17:57 <Venemo_j> sledges: like I said  when you try to enable wifi
08:17:59 <Jaymzz_> chriadam_: ha, you beat me :D
08:18:04 <chriadam_> ;-)
08:18:12 <sledges> Venemo_j: i added less used buttons as top row there ;) so it's less thumb stretching
08:18:39 <Venemo_j> that's a workaround
08:18:42 <Venemo_j> not a fix
08:18:58 <LarstiQ> sledges: in Tidings for example to get back to rss feed from reading an article
08:19:22 <sledges> no swipe?
08:20:02 <sledges> Venemo_j: yep, while waiting for fix:)
08:20:50 <Venemo_j> +1 to Jaymzz_ idea to be able to “swipe away” the notifications to dismiss them
08:21:04 <nh1402> I did suggest that in the topic
08:21:15 <nh1402> I also said it might conflict with other gestures
08:21:25 <Venemo_j> which ones?
08:21:45 <M4rtinK_phone_> I don think it will conflict
08:21:57 <nh1402> “swipe away” the notifications to dismiss them
08:22:10 <nh1402> "I'm aware a swipe gesture would probably conflict with other gestures"
08:22:11 <r0kk3rz> native apps should take it into account, but androidy apps often have buttons on the top
08:22:11 <M4rtinK_phone_> as long as it is started on the notification
08:22:13 <Jaymzz_> I think if your finger is on the notification itself while swiping, it won't conflict with anything else. The only "problem" will be reaching the notification on the top left corner of the device
08:22:30 <M4rtinK_phone_> exactly
08:22:37 <HUBAT> +1 for swiping away to dismiss
08:22:40 <c_la_phone> hi, sorry for being late
08:22:46 <nh1402> Jaymzz_: the same argument can be said for the app covers, but the gestures were replaced by buttons
08:22:59 <qeef_> Could be possible to disable notifications in settings?
08:23:02 <Jaymzz_> c_la_phone: Welcome :)
08:23:08 <sledges> Jaymzz_: if you want to dismiss it, means you needed to access something at the top already:)
08:23:21 <c_la_phone> Jaymzz_: thanks :)
08:23:30 <Venemo_j> since the notification only disturbs you when you want to use the topleft corner, it's not a bad thing having to reach the topleft to dismiss it
08:23:47 <Jaymzz_> nh1402: Yeah but that's quite a different story as we needed a fluid home screen. With app covers being swipable, I don't think th eexperience would have been as fluid really
08:23:55 <Jaymzz_> sledges: Word
08:24:57 <Jaymzz_> Time is almost up and we didn't get a solution from jpetrell. He is unfortunately not available to answer this (yet).
08:25:27 <Jaymzz_> nh1402: we could bring this issue up during the next meeting if it failed to get an answer by the end of the meeting. What says you? :D
08:25:33 <sledges> i hate to say this..but TJC time;)
08:25:51 <Jaymzz_> Boom! :D
08:26:17 <nh1402> I'll get on to it now
08:26:18 <Jaymzz_> Actually, I think it is valid, As you can see a lot of people including me are sharing the same experience and wanting the same feature.
08:26:20 <r0kk3rz> i did suggest that TJC items should be created for these :)
08:26:23 <nh1402> r0kk3rz: looks like you were right
08:26:33 <Jaymzz_> Alright then
08:26:59 <r0kk3rz> unfortunately a lot of the time it seems that TJC improvements are filed under /dev/null
08:27:05 <Jaymzz_> #action nh1402 make another TJC post. Feel free to paste the link here during the general discussion so they won't get ignored or missed
08:27:27 <pavi[m]> There was one member from telegram saying that he also finds this issue annoying.
08:27:33 <Jaymzz_> We need to move on now, running over time
08:27:51 <Jaymzz_> pavi[m]: You take the link to telegram please whenever it's created! thanks :)
08:28:03 <Jaymzz_> So they can vote too
08:28:12 <pavi[m]> yeah sure
08:28:12 * M4rtinK_phone_ things its partially due to TJC is not a real bug/issue tracker so important stuff easiky gets lost in the noise
08:28:26 <r0kk3rz> M4rtinK_phone_: keep banging that drum!
08:28:44 <Jaymzz_> I'm moving on guys
08:28:49 <Jaymzz_> #topic Any update on Xperia X process? (10 min, asked by kro)
08:29:00 <Jaymzz_> #info Is it foreseeable if the Xperia X Compact will be supported as well (HW-specs look very similar to the non-Compact X, except for the screen obviously)
08:29:30 <kro> no additional info (except my personal preference to have a phone sized about same as the Jolla 1)
08:29:47 <Jaymzz_> #info a blog post is scheduled to be published this week addressing the situation of Xperia X. Until then I can't share more than what we already have shared till now.
08:29:56 <r0kk3rz> many people have expressed a desire for the X Compact
08:30:16 <M4rtinK_phone_> I dont even want to *think* how bad it woukd be if we would develop Fedora and RHEL with just askbot for all outside issue and bug tracking ;-)
08:30:29 <kro> Jaymzz_: ok, that counts as an answer then :) thanks
08:30:37 <Venemo_j> M4rtinK_phone_ +1
08:30:38 <Jaymzz_> About the X compact: First of all let us be done with the normal X, any other device could be considered afterwards. kro
08:30:49 <LarstiQ> M4rtinK_phone_: no? Sounds like a fun thought exercise to realize how good you have it ;)
08:31:04 <lupastro> well....it would be interesting to know if an image will be provided, or the device will be shipped with it already installed
08:31:20 <Venemo_j> would be nice to know
08:31:28 <Jaymzz_> kro: We have already said that we are not going to stop at Xperia X. But we need to get that done first before thinking about other projects. Think about the limited resources ;)
08:31:38 <lupastro> i am without a mobile phone now. and i am waiting the announcement to buy the X, X Compact, or wait...
08:31:43 <r0kk3rz> i expect that will be the subject of the blog post
08:32:05 <Jaymzz_> lupastro: Your answer will be on the blg post!
08:32:06 <r0kk3rz> or hope rather
08:32:34 <lupastro> nice....however, i already reserved an X, just in case....
08:32:58 <Jaymzz_> I'm pushing to get the post out ASAP, but since it's a rather sensitive matter, it needs many extra eyes to read it and approve it first.
08:33:07 <M4rtinK_phone_> I hope both will be covered
08:33:08 <r0kk3rz> sledges: any word on opening up the adaptation work for porters?
08:33:20 <kro> Jaymzz_: I can offer my eyes to look over it ;)
08:33:29 <r0kk3rz> Jaymzz_: you have my approval!
08:33:36 <lupastro> kro, +1
08:33:39 <lupastro> :)
08:33:42 <M4rtinK_phone_> as each basically targets a different group of users
08:33:53 <Jaymzz_> kro, r0kk3rz Sure, just let me get it past some sailor's eyes first haha :D
08:33:53 <pavi[m]> Jaymzz_:  Isnt the phone supposed to come out by end of the week?
08:34:11 <pavi[m]> We are getting a blog post instead of phone?
08:34:13 <nh1402> pavi[m]: are you referring to the Q2 thing?
08:34:15 <r0kk3rz> Jaymzz_: just tell them i said it was fine, they'll understand :)
08:34:28 <sledges> r0kk3rz: this question will be addressed after blog post
08:34:37 <r0kk3rz> sledges: cool cool
08:35:26 <Jaymzz_> pavi[m]: A blog post can contain many things ;) I stand by my advice, please wait until the post is published!
08:35:37 <lupastro> so....then we will have to wait. i hope not much longer..........
08:35:47 <Jaymzz_> Not much at all.
08:36:06 <Jaymzz_> Alright moving on :)
08:36:10 <Jaymzz_> #topic Any update on SIP integration (10 min, asked by kro)
08:36:20 <Jaymzz_> #info there hasn't been any update from Jolla in a while: https://together.jolla.com/question/415
08:36:28 <Jaymzz_> #link https://together.jolla.com/question/415
08:36:37 <Jaymzz_> So,  this one alrady has a TJC post sledges :P
08:36:50 <pavi[m]> ohh Yeah SIP is more important for me than the new phone
08:37:01 <sledges> whew `,:)
08:38:00 <kro> so current status seems to be: there's the necessary software in repos, a package jolla-settings-accounts-extensions-sip exists and basically works (by adding a page to setting to set up a new SIP account), but the account itself isn't really usable - no possibility t make outgoing SIP calls
08:40:06 <pavi[m]> I think someone was able to make calls using existing account.
08:40:06 <kro> meaning "only" UI needs SIP integration, and some tweaks to make sound properly work over headphone/bluetooth
08:40:09 <r0kk3rz> too hard basket im assuming, this has been hanging around for years
08:40:22 <Stskeeps> developer who worked on it is not working with jolla either anymore
08:40:35 <jusa_> well, the short answer about SIP status is: no work has been done for it for a while
08:40:56 <kro> anything on the roadmap?
08:41:00 <pavi[m]> Stskeeps:  That was the answer 2 years back :(
08:41:07 <jwalck> I can just +1 that this is something I'd really like to see, and something I used on the N900 and now sorely miss:)
08:41:51 <HUBAT> jwalck +1
08:42:04 <ljo_> +1
08:42:06 <pavi[m]> Even if we get SFOS on shiny devices whats the point when we cant even make a VOIP call using the native OS? N900 had it.
08:42:12 <jwalck> since Jolla is not a one person company, someone dropping off musn't mean development stops forever? Maybe point to "The new guy"?:)
08:42:38 <r0kk3rz> well sailfish wasnt on the n900
08:42:50 <jusa_> short of voicecall-ui I'd think it's something community could do, unfortunately jolla doesn't currently have resources to further the implementation
08:42:51 <Xray2000> +1
08:43:32 <jusa_> I can try to give tips where to work on, if somebody is interested
08:43:43 <locusf> jusa_: so voicecall needs just a way to switch between voip/gsm ?
08:43:50 <locusf> ie telepathy accounts
08:43:53 <jusa_> locusf: "just"
08:43:54 <jusa_> ;)
08:43:58 <locusf> heheh
08:44:00 <r0kk3rz> jusa_: please do
08:44:08 <LarstiQ> r0kk3rz: are you volunteering?
08:44:25 <r0kk3rz> LarstiQ: no :)
08:44:44 <Venemo_j> perhaps summarize in a TJC post
08:44:55 <jusa_> it's quite a lot of work still, and most likely need to dive in to the mysterious world of ohm/policy/prolog/dres
08:45:12 <sledges> Venemo_j: beat me to it:)
08:45:24 <abranson_> *the* TJC post
08:45:34 <nh1402> prolog as in the logical programming language?
08:45:37 <locusf> jusa_: anything on the audio routing side?
08:46:06 <Jaymzz_> Just FYI, I'm giving more time to this topic since it's an actual on-going discussion
08:46:15 <jusa_> locusf: anything? many things, yes :)
08:46:50 <locusf> jusa_: I mean I saw some pulseaudio stuff related to voip at some point
08:47:17 <locusf> resource policy things might be tricky though
08:47:46 <jusa_> as there's been a while since anything's been done with the feature just summarizing what's the actual status is a bit work too.. but like I said, if somebody is really interested in implementing SIP further I can try to help
08:48:35 <Jaymzz_> jusa_: What's the best way for the volunteer to contact you?
08:49:22 <jusa_> I'm hanging at (all?) the usual joints in freenode irc, I'll answer when I can
08:50:48 <jusa_> but those things can be done outside this meeting, I think the actual question "what's the status" was answered as much as possible for the moment
08:50:55 <Jaymzz_> There we have it. So bottom line is that we haven't been able to touch this in a long time but if any kind developer would like to help us out and get this thing running, jusa_would be more than happy to help out whenever he can.
08:51:29 <Jaymzz_> Yes. Moving on, this one went way over time, but thanks jusa_for explaining what's up.
08:51:47 <Jaymzz_> #topic General discussion (15 min)
08:51:50 <M4rtinK> thanks! :)
08:52:14 <Jaymzz_> so, nh1402did you create those TJC posts? :)
08:52:50 <kro> thanks jusa_ for the explanations! :)
08:53:01 <oniongarlic> any ETA on fix for the incoming calls not working bug?
08:53:20 <sledges> #info ping jusa_ on irc if yiu want to help with SIP (ohm/policy/prolog/dres expertise/curiosity required) -- this is from previous topic
08:53:25 <nh1402> Jaymzz_: yes, both
08:53:41 <nh1402> https://together.jolla.com/question/163349/have-a-way-to-dismiss-notifications/
08:53:50 <nh1402> https://together.jolla.com/question/163348/emoji-support-in-clipboard-for-android-apps/
08:53:58 <Jaymzz_> Guys, those in favor of these topics, please go ahead and vote!
08:54:10 <Jaymzz_> pavi[m]: Could you take these links to telegram please? :)
08:54:13 <M4rtinK> will do
08:54:52 <GAndrel> any plans to update HADK porting guide?
08:54:57 <sledges> #link ? pls :)
08:55:01 <Jaymzz_> and thanks nh1402 for creating those.
08:55:04 <Jaymzz_> sledges: yes sir
08:55:15 <Jaymzz_> #link https://together.jolla.com/question/163349/have-a-way-to-dismiss-notifications/
08:55:16 <r0kk3rz> GAndrel: sledges needs to finalize HADK 2.0
08:55:24 <Jaymzz_> #link https://together.jolla.com/question/163348/emoji-support-in-clipboard-for-android-apps/
08:55:25 <sledges> GAndrel: working on that (plans)
08:56:06 <r0kk3rz> GAndrel: what areas do you want updating? the previous HADK is still quite relevant
08:56:42 <sledges> niggly bits mostly, i gather
08:57:18 <locusf> aarch64?
08:57:47 <GAndrel> Nexus 4 porting is no more, I'm thinkg how to start and bumping at "CyanogenMod"
08:59:21 <r0kk3rz> GAndrel: seek help in #sailfishos-porters
08:59:22 <sledges> locusf: hadk document is arch-independent, that extends to src dhd
09:00:47 <GAndrel> r0kk3rz: OK
09:00:59 <locusf> sledges: okay
09:02:54 <Jaymzz_> I think I can safely say that general discussion is over? :)
09:03:19 <Jaymzz_> And that's a yes, so moving on.
09:03:22 <Jaymzz_> #topic Next meeting’s time and date (5 min)
09:04:01 <Jaymzz_> So 2 weeks fro now is Wednesday, 12th of July 2017. Same time, 08:00 UTC. Everyone OK with that?
09:04:19 <mattaustin> I'm guessing this blog post might cause discussion/questions... shall we meet again next week? Or is 2 weeks better?
09:04:51 <r0kk3rz> it should be clear and straight forward right Jaymzz_ :)
09:05:03 <mattaustin> :) ok then!
09:05:04 <Jaymzz_> This meeting is a bi-weekly meeting. I think we can hold that discussion in the comment section of that blog post. Will that be OK?
09:05:16 <mattaustin> Sounds good
09:05:30 <Jaymzz_> r0kk3rz: IMHO it is. It depends on your POV too ;)
09:05:39 <abranson_> not sure about that - blog post comment sections are only for refund discussions aren't they?
09:05:59 <Jaymzz_> mattaustin: We most definitely can discuss it here in 2 weeks time, too, if needed!
09:06:10 <Jaymzz_> abranson_: Putting salt on my wound huh? :DD
09:06:29 <Jaymzz_> nay, OPEN wound.
09:06:51 <jwalck> that's ok, this is a good time!
09:06:57 <Jaymzz_> But anyhow, let's say 2 weeks from now :)
09:07:01 <mattaustin> :)
09:07:04 <jwalck> I might not make it due to vacations, but that's life:)
09:07:24 <Jaymzz_> #info Next meeting will be held on Wednesday, 12th of July 2017 at 08:00 UTC
09:07:33 <r0kk3rz> Jaymzz_: will any sailors be around then? isnt that midsummer break?
09:08:35 <Jaymzz_> r0kk3rz: Many will be away (I will be away too, but since I work remotely, I just need a laptop and an internet connection so that's fine) but I think we will have enough people here. Let's see if we'll have so many topics
09:08:50 <pavi[m]> I would also like to have a meeting after blog post.
09:08:57 <pavi[m]> It will raise too many questions.
09:09:24 <pavi[m]> And its not every month that we get a new device.
09:09:50 <Jaymzz_> Ok let me see if anyone would be available to answer, I'm not promising anything but if I managed to make a meeting happen by next week wednesday only dedicated to the blog post, would it be ok?
09:10:11 <nh1402> "I would also like to have a meeting after blog post."
09:10:16 <pvuorela> (sorry, was elsewhere during the meeting. commented on t.j.c that emoji clipboard works all the way for me.)
09:10:32 <nh1402> depends on if pavi[m] means immediately after the blog post, or next week
09:10:58 <pavi[m]> Yeah 1 week to read the blog comments :)
09:11:30 <Jaymzz_> I'll get back to you guys on the usual mailing list about this. I can't promise anything since the schedule is tigt esp with summer holidays closing on us
09:11:32 <nh1402> not sure if I want to read comments about tablet refund
09:11:59 <Jaymzz_> nh1402: I think it will be reduced since we addressed some stuff on our previous post.
09:12:16 <pavi[m]> Yes thats all we want. Only for the blog post. Thanks
09:12:21 <r0kk3rz> Jaymzz_: yeah good luck with that, the refunders are persistant
09:12:47 <Jaymzz_> pavi[m]: Alright let me see what I can do.
09:12:58 <Jaymzz_> r0kk3rz: you know it. But let's be positive ;)
09:13:04 <Jaymzz_> Anyway, time to end the meeting now
09:13:37 <Jaymzz_> Thanks everyone for joining and prticipating. I'll email you the minutes as usual and if I could arrange a meeting dedicated to the blog post, I will email you again.
09:13:43 <Jaymzz_> So keep your eyes peeled.
09:13:46 <Jaymzz_> Cheers!
09:13:50 <Jaymzz_> #endmeeting