#mer-meeting: Sailfish OS, open source, collaboration – August 23rd 2017
Meeting started by sledges at 08:03:36 UTC
(full logs).
Meeting summary
-
- Meeting information and agenda can be found
here:
https://lists.sailfishos.org/pipermail/devel/2017-August/007978.html
(sledges,
08:04:26)
- Brief introduction (5 min). Please prefix your name/handle with # info (sledges, 08:04:52)
- Leif-Jöran Olsson, community member
(ljo_,
08:05:13)
- tbr, mer community (tbr,
08:05:14)
- juiceme, general hacker (juiceme,
08:05:18)
- Jens Müller, Sailor / SFOS User (jenix,
08:05:21)
- Chris Adams, developer at Jolla (chriadam__,
08:05:21)
- nh1402, community member (nh1402,
08:05:26)
- LSRB, newbie (LSRB,
08:05:29)
- Drummer12, SFOS User and Community
member (Drummer12,
08:05:43)
- Rodolphe Sequeira, community member
(RodSeq,
08:05:45)
- Nekron, golang developer (nekron,
08:05:45)
- jolladiho, user (jolladiho,
08:05:46)
- Leszek Lesner, developer and community
member (leszek,
08:05:47)
- eekkelund (eekkelund,
08:05:49)
- bshah, Halium, Plasma Mobile (bshah,
08:05:50)
- piggz, community porter
(mido/falcon/ace) (piggz,
08:05:51)
- Mister_Magister, mad porter (Mister_Magister,
08:05:52)
- James Noori, won't be available the whole time,
community manager (Jaymzz,
08:05:53)
- Damien Caliste, community (dcaliste,
08:05:56)
- Lewis Rockliffe, shenannigans bringer
(r0kk3rz,
08:05:56)
- Kostadin Damyanov, community (Max-Might,
08:06:02)
- Pami Ketolainen, sailor @ Jolla (pketo,
08:06:08)
- Wouter van Heijst, infra at Jolla (LarstiQ,
08:06:10)
- ExPLIT, community member (ExPLIT,
08:06:13)
- Steph Gosling community, lapsed porter
(stephg,
08:06:13)
- schmittlauch,community member (M-schmittlauch,
08:06:15)
- Jonatan Walck, community member (jwalck,
08:06:22)
- raj/user (Sailor5811_,
08:06:25)
- remote1, user (remote1,
08:06:29)
- Martin Ebnoether, Humble SailfishOS User and
Community Member (Venty,
08:06:29)
- marmistrz, currently porting SFOS (marmistrz,
08:06:39)
- Carmen Fdez, community member (cfb014,
08:06:40)
- herdem, prospective SailfishOS user
(herdem,
08:07:05)
- Simonas Leleiva, hw & l10n at Jolla
(sledges,
08:07:41)
- Vesa-Matti Hartikainen, Program Manager at
Jolla (veskuh,
08:08:25)
- Timur Kristof, community member (Venemo,
08:09:08)
- Simo Piiroinen, developer at Jolla (spiiroin,
08:09:12)
- vk, future SFOS user and tinkerer (vk,
08:09:39)
- Energy Aware Scheduling (EAS) support in Sailfish (10 mins, asked by nh1402) (sledges, 08:09:41)
- some details about the topic: EAS is designed
with SoC's with the big.Little design in mind, so that the more
energy efficient CPU's are used more effectively. This should in
theory increase battery life by quite a bit, and with the Xperia X
coming, it would be a suitable device to use it with. (sledges,
08:11:29)
- Now EAS isn't just a kernel tweak, it requires
numerous patches on the kernel, but some things also need changing
at the OS level also. (sledges,
08:11:34)
- https://developer.arm.com/open-source/energy-aware-scheduling/eas-mainline-development
(nh1402,
08:12:42)
- https://developer.arm.com/open-source/energy-aware-scheduling
(nh1402,
08:20:34)
- https://developer.arm.com/open-source/energy-aware-scheduling
(sledges,
08:20:56)
- https://developer.arm.com/open-source/energy-aware-scheduling/eas-mainline-development
(sledges,
08:21:01)
- https://www.linuxplumbersconf.org/2016/ocw//system/presentations/3693/original/LPC-%20EAS%20for%20Android.pdf
(sledges,
08:21:14)
- Jolla'll have that technology in mind in case
battery life performance becomes a priority, in the meantimg nothing
prevents community from experimenting while doing ports to
sfos (sledges,
08:21:55)
- UnitTesting QML apps (20 min - asked by M-schmittlauch) (sledges, 08:22:10)
- What are the recommended setups (tools, project
structure, frameworks) for testing QML apps? What's still
missing? (sledges,
08:22:23)
- https://gist.github.com/schmittlauch/172c39a9e669ece1e5a080a0869e7a87
(sledges,
08:24:46)
- http://doc.qt.io/qt-5/qttest-qmlmodule.html
(chriadam__,
08:25:55)
- these are used internally e.g. in jolla-gallery
etc to test that our interaction flows work as expected (sledges,
08:27:25)
- ACTION: chriadam__+Jolla to document best UI testing
practices about project structure and QtCreator integration
(sledges,
08:40:17)
- Update for Xperia X port (10 min - asked by jenix) (sledges, 08:42:05)
- A lot of Sailors (me included) are getting
excited about the planned release of SFOS for Sony's Xperia X. I'd
like to ask a few questions regarding the status of the project
(current status, model variety, release schedule and prices).
(sledges,
08:42:18)
- https://github.com/ExAnimoso/counter-application
(coderus1,
08:50:51)
- (links for previous topic about QML UI
testing): (sledges,
08:51:59)
- https://habrahabr.ru/post/320808/
(sledges,
08:52:03)
- https://github.com/ExAnimoso/counter-application
(sledges,
08:52:08)
- we are getting closer to announcing the
details, getting good progress with the issues we’ve had and
I(veskuh)’m using the device happily as my daily device already
:) (sledges,
08:53:00)
- Still only supported model is F5121
(sledges,
08:53:13)
- My advice is still wait to hear the
[announcement] details first before going to shop (sledges,
08:53:33)
- Alien Dalvik [on Xperia X] will be based on the
4.4.4 (sledges,
08:54:10)
- General discussion (15 min) (sledges, 08:55:36)
- ideas for next meeting (those who didn't get
their answers, please suggest meeting questions in the next
fortnight): (sledges,
09:05:04)
- gcc upgrade (sledges,
09:05:09)
- feasibility of adding firefox improvement to
sfos browser (sledges,
09:05:27)
- harbour in russia ; paid apps support
(tortoisedoc,
09:05:40)
- (insert your unanswered question here:)
(sledges,
09:05:40)
- unanswered question: Is Jolla working together
with YouYota on the tablet? Would Jolla help YouYota increase
awareness on the YouYota tablet project? See
https://www.indiegogo.com/projects/youyota-sailfish-os-2-in-1-tablet/#/
(Venemo,
09:06:34)
- Next meeting time and date (5min) (sledges, 09:07:47)
- Next meeting will be held on Wednesday, 6th of
September 2017 at 08:00 UTC (sledges,
09:11:25)
Meeting ended at 09:11:31 UTC
(full logs).
Action items
- chriadam__+Jolla to document best UI testing practices about project structure and QtCreator integration
Action items, by person
- chriadam__
- chriadam__+Jolla to document best UI testing practices about project structure and QtCreator integration
People present (lines said)
- sledges (71)
- nh1402 (32)
- Mister_Magister (32)
- M-schmittlauch (25)
- r0kk3rz (20)
- piggz (18)
- veskuh (17)
- chriadam__ (17)
- jenix (15)
- Venemo (13)
- tortoisedoc (12)
- Sailor5811_ (12)
- ApBBB (11)
- remote1 (10)
- leszek (8)
- LarstiQ (7)
- marmistrz (7)
- c_la (6)
- RodSeq (4)
- stephg (4)
- nekron (4)
- Coolgeek (4)
- merbot (3)
- ljo_ (2)
- vk (2)
- eekkelund (2)
- tbr (2)
- coderus1 (2)
- cfb014 (1)
- bshah (1)
- ExPLIT (1)
- spiiroin (1)
- jwalck (1)
- dcaliste (1)
- Venty (1)
- jolladiho (1)
- occirol (1)
- LSRB (1)
- herdem (1)
- Drummer12 (1)
- pketo (1)
- rainemak (1)
- Max-Might (1)
- juiceme (1)
- Jaymzz (1)
Generated by MeetBot 0.1.4.