07:59:59 <sledges> #startmeeting Sailfish OS, open source, collaboration – September 20th 2017
07:59:59 <merbot> Meeting started Wed Sep 20 07:59:59 2017 UTC.  The chair is sledges. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
07:59:59 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:43 <sledges> #info Meeting information and agenda can be found here: https://together.jolla.com/question/54157/sailfishos-open-source-collaboration-meeting-planning/
08:01:09 <sledges> I am the meeting's chairperson today and will be doing my best to keep time and order. Please behave, respect the timings and be kind.
08:01:15 <sledges> #topic Brief introduction (5 min). Please prefix your name/handle with # info
08:01:40 <nh1402> #info nh1402, community member
08:01:55 <stephg> #info Steph Gosling, community, porter
08:02:03 <chriadam_> #info Chris Adams, developer at Jolla
08:03:53 <vknecht> #info vknecht, community
08:04:23 <dr_gogeta86> #info Fabio Isgrò, community
08:04:45 <lantern1> #info lantern, community
08:05:45 <Mister_Magister> #info Mister_Magister, mad porter/community
08:05:51 <dcaliste> #info Damien Caliste, community
08:05:56 <jenix> #info Jens Müller, Sailor / community
08:06:13 <kimmoli> #info Kimmo Lindholm, community
08:06:53 <sledges> #info Simonas Leleiva, sledge, chair, and sailor
08:07:54 <sledges> #topic Vulkan support in Sailfish (Asked by nh1402 - 10 min)
08:08:29 <sledges> #info You now have 2 official devices that support Vulkan. The argument before was that there wasn't Vulkan support for the Android driver for the tablet, but it seems that has now changed.
08:08:34 <sledges> #link http://www.phoronix.com/scan.php?page=news_item&px=Android-ANV-Vulkan-Support
08:08:54 <nh1402> sounds self explanatory to me
08:09:30 <M-schmittlauch> #info schmittlauch, community member sorry for being late
08:10:02 <nh1402> is it on Jolla's roadmap?
08:10:31 <sledges> nh1402: a brief description to those unaware of Vulkan?
08:11:40 <nh1402> the successor to OpenGL, but is the same between embedded devices and desktop.
08:12:06 <sledges> nh1402: which two devices do you mean we have that could support Vulkan?
08:12:16 <nh1402> Xperia X, Jolla Tablet
08:12:52 <nh1402> X compact if that's going to be next
08:13:28 <sledges> nh1402: I can't see ARM mentioned in the article, is it not only for Intel arch?
08:14:00 <nh1402> sledges: that link was to say the tablet should support Vulkan
08:14:15 <nh1402> it's a fact the Xperia X supports it
08:15:02 <sledges> #info It is not on Jolla's roadmap, but creating TJC question is a good way to keep track of that!
08:15:28 <sledges> #info Xperia X adaptation will be open sourced and then community can as well look into it
08:15:40 <sledges> which sfos components in the graphics stack would have to be adapted?
08:15:51 <sledges> just trying to get around the scope of things
08:15:58 <sledges> as it's an opengl substitute - so only libhybris?
08:17:27 <sledges> 2 more minutes
08:18:13 <nh1402> it's also more efficient, so more performant
08:18:36 <nh1402> I think Samsung demonstrated that using it for their Android launcher also helped battery life a tad
08:18:40 <chriadam_> I suspect that the Qt scenegraph would have to be updated to support a Vulkan rather than OpenGL backend.  Completely different draw calls etc
08:19:53 <vknecht> http://blog.qt.io/blog/2017/06/06/vulkan-support-qt-5-10-part-1/ ...
08:20:21 <sledges> #info chriadam suspects that the Qt scenegraph would have to be updated to support a Vulkan rather than OpenGL backend.  Completely different draw calls etc
08:20:27 <sledges> #link http://blog.qt.io/blog/2017/06/06/vulkan-support-qt-5-10-part-1/
08:20:40 <sledges> thanks for initial cover of this, moving on!
08:21:23 <sledges> #topic open sourcing of Sailfish OS components (Asked by c_la - 30 minutes)
08:21:44 <sledges> #info during the last community meeting (September, 6th) it was discussed the idea of implementing multiscreen or PiP but it was turned down because key components of SFOS are not opensourced and thus the community can't do much.
08:21:49 <sledges> #info Many community members believe Jolla should urgently release a list of components that will be open sourced otherwise the community can't help Jolla improve sailfish.
08:22:44 * sledges looks for c_la
08:23:02 <jenix> looks like c_la is not here, but maybe we can discuss the topic nontheless
08:23:11 <sledges> substitues: M4rtinK, leszek (to be confirmed)
08:23:15 <sledges> none of them are here
08:23:41 <jenix> as far as I remember from the last meeting, at least one question we could discuss is how the open sourcing of the still closed SFOS compotents is progressing
08:24:42 * sledges wonders if jpetrell is around to comment on the components
08:24:57 <Mister_Magister> Yes on the last meeting we couldnt do anything with multiwindow due to closed source lipstick
08:24:59 <nh1402> sledges: a sister topic to that was crowdfunding feature requests for Jolla to implement.
08:25:26 <abranson> Mister_Magister: lipstick is OSS I think
08:25:36 <abranson> I think it's silica that was the closed bit
08:25:37 <Mister_Magister> abranson: doubt
08:25:46 <chriadam_> abranson: sort of.
08:26:08 <abranson> Mister_Magister: https://git.merproject.org/mer-core/lipstick
08:26:20 <Mister_Magister> it's only backend
08:26:22 <chriadam_> there's lipstick (the daemon service) and then there's the UI and compositor bits.  lipstick-jolla-home.
08:26:30 <chriadam_> the latter is closed.
08:26:49 <abranson> sometimes I wonder if we need a bit more publicity of which bits already are open source.
08:27:04 <chriadam_> the wiki is pretty comprehensive
08:27:43 <chriadam_> in each category of https://sailfishos.org/wiki/Core_Areas_and_APIs we list which bits are closed and which are open
08:27:55 <abranson> yeah, but that's not getting out into general attitudes about sailfish
08:27:55 <chriadam_> but back to the question: I think veskuh is needed ot clarify the roadmap on open sourcing
08:28:57 <M-schmittlauch> If we want to broaden the scope of this: It's similar for many other components: Based on open stuff (e.g. telepathy), the last step towards the user (e.g. actual app + UI) are still closed.
08:28:59 <sledges> also as well at the bottom of https://sailfishos.org/about/
08:29:00 <M-schmittlauch> Same for Silica.
08:29:29 <nh1402> I believe the current topic was branched off this: http://merproject.org/logs/%23sailfishos/%23sailfishos.2017-09-13.log.html#t2017-09-13T09:53:30
08:30:39 <chriadam_> M-schmittlauch: right.  my understanding is that some components may be opensourced before other, i.e. a staged open-sourcing roadmap.  so, e.g., the jolla-calendar app might be opensourced first, then jolla-email or something.  But concrete plans / roadmaps / blocking issues - we'd need veskuh to comment.
08:30:58 <chriadam_> and I don't know any details of progress or what the blockers are at this point.
08:31:11 <jenix> That's unfortunate that he's not around today
08:31:34 <chriadam_> oh, he must be at mindtrek
08:31:54 <M-schmittlauch> Afaik the community can currently mostly help with bugs/ enhancements in the backend, but actual user-facing changes are hard as they're affecting still closed components.
08:32:27 <M-schmittlauch> The sad thing is: We're dealing with this state for over 1 year now.
08:32:41 <chriadam_> M-schmittlauch: what can I say other than "I agree"
08:32:51 <abranson> changing UIs is tricky, because it overlaps into the whole design subject
08:33:35 <abranson> it's not like the backend stuff where we can implement new functionality and PR for approval
08:33:41 <nh1402> that's why I said to discuss in more detail and agree on implementation details
08:33:49 <abranson> it needs input by the people who make things look nice
08:34:14 <jenix> So, since neither c_la, nor his substitutes or veshkuh are present, it may be best to move this question to the next meeting !?
08:34:22 <chriadam_> jenix: sounds sensible suggestion
08:34:28 <M-schmittlauch> abranson: Well, there's a difference between components being open so people could play with it, change it & customize it, and about Jolla actually merging them back (if we can consider them the upstream)
08:34:31 <abranson> there has been some discussion internally about this, because the pioneering element in this is dcaliste's brilliant GPG contribs to the email cleint.
08:34:51 <chriadam_> yes, and potentially more for sync log / sync errors
08:35:02 <chriadam_> see the MR in caldav for the start of that discussion
08:35:16 <abranson> M-schmittlauch: you can already play - the vast majority of those components are plain QML on the filesystem
08:35:21 <dcaliste> Maybe for the multiwindow stuff, one should begin to implement in the backend what is needed. Then, discuss together on white board for UI principles, and finally experiment in glacier if nothing else.
08:35:22 <abranson> this is the world of patch manager
08:35:36 <abranson> what we're lacking is a dialog between community UI hackers and the design team
08:35:37 <M-schmittlauch> The latter is also important and there need to be procedures for it, but it's no direct dependency
08:35:59 <nh1402> dcaliste: that's why any discussion of multiwindow stuff is being done over at #nemomobile
08:36:01 <abranson> if you use tIDE, you can edit the system QML on-device :D
08:36:38 <dcaliste> nh1402, ah I forgot, yes I will read back log there. Thanks.
08:37:08 <nh1402> r0kk3rz: was throwing around some ideas, for his/her use-case
08:37:14 <M-schmittlauch> abranson: "The source code is lying around so I can change it, but may be published by copyright when distributing it" is neither Open Source nor Free Software
08:37:43 <M-schmittlauch> s/published/punished
08:37:45 <nh1402> leszek: you're a substitute on the topic being discussed right now
08:37:49 <abranson> M-schmittlauch: no, I'm not saying that it is. But in the meantime it is possible to play with things.
08:38:02 <leszek> nh1402: oh nice :)
08:38:57 <jenix> leszek: unfortunately, veskuh, who is the one from Jolla who could give us the best answers regarding this topic is not with us today
08:39:01 <chriadam_> I still think that without veskuh's input we cannot really progress this topic more.  I suspect this is a top-level management decision which needs buy-in from all stakeholders and investors, so it's not a discussion that we developers can contribute much to, at this point...
08:39:21 <nh1402> leszek: wasn't this branched off the other discussion we had about bountys/crowdfunding?
08:39:44 <leszek> true
08:40:14 <nh1402> if we can't talk about open-sourcing, we could talk about the bounty/crowdfunding thing
08:40:19 <nh1402> which is different
08:40:41 <leszek> yes true. Let me explain my main point regarding the bounty stuff
08:40:50 <dcaliste> The more community contributions to valuable additions to SFOS (like multiwidowing) we have blocked by closed parts, the easier I guess it will be to convince the shareholders that open sourcing parts is good for their business…
08:40:58 <sledges> leszek: that's not on the topic, please wait for general discussion
08:41:04 <leszek> ok ok
08:42:12 <vknecht> would be  nice to have news before next meeting ;-)
08:42:26 <M-schmittlauch> dcaliste: Problem about that: Can you differentiate between contribution efforts started that ran against the wall of closed components and the ones never having started because seeing the closed components?
08:42:49 <leszek> Jolla and its investors have to recognize the potential of opensourcing the silica ui. That would make it possible for others to contribute more and of course it will attract more and more users aswell as other companies contributing back
08:43:30 <M-schmittlauch> I guess "Jollas Position regarding GPLv3" is also better off in General Discussion or even its own topic?
08:43:48 <dcaliste> sure, I agree, but it's easier to show them actual contributions being done than potential contribs (that myself I believe into, but that's not the point) arriving later.
08:45:16 <sledges> 5 more mins
08:45:22 <leszek> and I am not even talking about the apps like jolla-email and others which are partly "open" in code but not license. The community can find replacements for this if necessary. They aren't fully needed for the operating system to spread much. Though the main home screen (wayland compositor) Lipstick needs to be open aswell as this shows the main concept of how to use SailfishOS for the users
08:46:25 <leszek> this would catapult SailfishOS as the target for main OS usage for more projects just like the Libem 5 phone
08:46:26 <abranson> maybe a priority list of components most desired to be OSS from the community side would help? along with possible plans/improvements that could be done
08:47:16 <dcaliste> abranson: good point. I agree.
08:47:38 <nh1402> I agree
08:48:17 <sledges> for now there could be more proximate collaborations like dcaliste contributions, and chriadam_'s caldav/cardav sync community
08:48:18 <leszek> so basically a usable os which is open but has some closed apps is not that bad for most projects, manufacturers and so on in contrast to a an os which has closed source components in its core (like silica or lipstick)
08:48:24 <sledges> but that's incentive to sailors
08:48:43 <sledges> HW adaptation is also profounding in that regard, but we're talking about UI here
08:49:00 <sledges> like having a mentor sailor that dcaliste has
08:49:07 <sledges> and chriadam_ being mentor himself, and organising weeklies
08:49:13 <M-schmittlauch> If I recall veskuh s reports from the past correctly, it was mainly a problem of convincing shareholders. So it'd be interesting to see what their problems with open sourcing are.
08:49:28 <sledges> such thing can be continued doing without board approvals
08:49:29 <M-schmittlauch> (but that's probably confidential)
08:51:19 <sledges> #topic General discussion (20 min)
08:51:20 <M-schmittlauch> It also feels like the pachmanager community isn't that active anymore. One could see them as a try to change closed components, nevertheless them being closed. But these patches currently never have a chance on being merged
08:51:48 <leszek> oh yeah thats true
08:51:54 <jenix> so, i'll guess noone from Jolla is around that can give us an update regarding the Xperia X / SFOS X project
08:51:57 <nh1402> Well one thing I wanted to bring up was swipe keyboard
08:51:59 <abranson> I guess the list of popular patched components would make a good initial priority list
08:52:12 <dcaliste> Following abranson suggestion, I'll start a TJC wiki this afternoon listing closed parts and which one community would love to see OSS and potential contributions.
08:52:37 <M-schmittlauch> Any updates on Jolla's position re GPLv3 or is this anotger topic?
08:52:39 <leszek> good idea.
08:52:52 <abranson> jenix: well the adaptations were open sourced and there are now community ports built and running for the X and X compact.
08:52:57 <abranson> that's quite exciting
08:53:09 <leszek> :)
08:53:11 <sledges> dcaliste: one component per answer to vote for?:)
08:53:23 <nh1402> yes
08:53:30 <jenix> abranson: I aggree, that's great. But any news regarding bluetooth support and the F5122
08:54:12 <dcaliste> sledges: you're right with some words about current and potential work from the community.
08:54:42 <sledges> #action dcaliste (from previous topic) To open TJC wiki this afternoon listing closed parts and which one community would love to see OSS and potential contributions
08:54:48 <mal> jenix: I hacked support for F5122 was also done, just by modifying some files on the device
08:54:50 <jenix> james mentioned in the blog comments that they tested the F5122 and it will not be "fully funcitonal" in the first release, but didn't specified how
08:55:04 <lantern1> yeah, what did he mean?
08:55:08 <abranson> jenix: Bluetooth support is being worked on, and there's even been a working prototype. But android bluetooth is weird, so it involves a lot of changes to the kernel etc. No promises.
08:55:09 <Max-Might> What is holding the last release? It was released and then it was reverted?
08:55:31 <abranson> don't know anything about the f5122 myself though sorry
08:55:43 <jenix> abranson: no problem :)
08:56:00 <stephg> abranson: jenix I seem to recall someone in the community over the weekend had dual sim support working as properly as they could test on the 5122
08:56:09 <mal> abranson: I was the one who helped one person get it running, it was just adding some configs, android properties and packages
08:56:11 <sledges> Max-Might: from https://together.jolla.com/question/164349/release-notes-211-jamsanjoki/: [Roll out ceased on Aug 31 for now due to few problem cases with the security code. We are investigating the issue.]
08:56:22 <jenix> mal: great work
08:57:01 <abranson> M-schmittlauch: what were you looking for about GPLv3? we discussed the situation last time iirc
08:57:14 <mal> jenix: so making a proper build by creating new repos based on the ones for f5121 is trivial
08:57:32 <nh1402> I suppose I should have brought up my topic in the next meeting
08:57:35 <jenix> so i guess, for me it's continuing to wait, since BT support is essential for me.
08:57:43 <nh1402> in this meeting*, but forgot
08:58:00 <leszek> if bt support is added hopefully also with blueborne fixed
08:58:05 <abranson> jenix: well you can always test a community port in the meantime ;)
08:59:21 <jenix> abranson: I'll have to get a device first :) but this way, I may be able to grab a F5122 and enjoy the multi-SIM
08:59:39 <sledges> leszek: aliendalvik doesn't support bluetooth
09:00:03 <jenix> until then, I'm quite happy with my Jolla C-ified Aqua Fish... 2.1.1 fixed a lot of issues for me
09:00:15 <M-schmittlauch> abranson: Oh, good, can't remember seeing it in the logs. I only remember one year ago Jolla's lawyers had some problems with it prohibiting lock-down of devices.
09:00:21 <leszek> sledges: and native apps/system is not affected?
09:01:13 <sledges> leszek: being investigated
09:01:25 <leszek> at least the kernel is vulnerable
09:01:40 <abranson> M-schmittlauch: yes that's it. not so much for Jolla's case, but it's discourages potential customers who may want to do that.
09:02:10 <leszek> sledges: so in general better turn off bluetooth on sailfishos devices for now I guess
09:03:12 <leszek> so as we are now in general discussions I can explain a bit about the bounty idea
09:03:18 <sledges> leszek: test them for vulnerability with testing tools
09:03:35 <sledges> ok leszek, 8mins remining, be quick:)
09:03:43 <leszek> sledges: I only know about the android testing tool though
09:04:02 <sledges> shouldn't there be some "tizen" testing tool we could port?:)
09:04:11 <leszek> so other free and open source projects have bounty projects where they vote for a top feature to be implemented into the os
09:04:27 <leszek> then they collect money for one or two developers to pay to actually implement this feature
09:04:33 <sledges> i thought on server (victim) side nothing should be installed, blueborne should be detected by client (attackers) device/PC
09:05:24 <leszek> I think the bounty project should be introduced for SailfishOS aswell.
09:05:48 <leszek> the community could finance certain features for a independant or jolla developer to implement a certain feature the community wants.
09:05:48 <sledges> i think you'd find Jolla company being small company as the first issue
09:06:52 <leszek> also this would strenghten the influence the community has on the development of SailfishOS
09:06:53 <sledges> it's not so much about the money, it's revenue/time
09:07:12 <sledges> IMO (maybe our chiefs would think different)
09:07:24 <M-schmittlauch> leszek: This only makes sense if SFOS finally becomes a real FLOSS system 0:)
09:07:52 <sledges> M-schmittlauch: that's not needed - jolla would hire an independent developer to implement a feature
09:08:02 <jenix> leszek: that's a great idea, i just suspect it will hit the issues we discussed earlier (closed source, features not being merged etc)
09:08:04 <sledges> it's just the overhead that i'm concerned in a company of headcount as we are
09:08:05 <leszek> M-schmittlauch: for independent devs true. for devs @ jolla not
09:08:22 <sledges> +1 leszek too
09:08:29 <sledges> if it was someone from outside
09:08:38 <lantern1> any news on payment countries/methods for sailfish X?
09:09:12 <leszek> sledges: they are very very small projects like haikuos that had very good results when it comes to bountys
09:09:16 <M-schmittlauch> Well, you're right. Although I'm not sure whether I'd crowdfund a feature not being free software.
09:09:36 <leszek> M-schmittlauch: thats another question
09:09:39 <sledges> leszek: yet for a jolla sailor, more hours in a day+night would be a better incentive ;)
09:09:55 <leszek> :P
09:10:33 <sledges> lantern1: as soon as any news come up, they'll be out through our comms channels
09:11:00 <PurePremium> lezsek: they are paid to do work why should community fund a worker while they are already working on the said project especially when it is not a libre project.
09:11:00 * M-schmittlauch increases his bounty on "time machine"
09:11:02 <jenix> I guess the problem for external devs would be the closed source of some key components (and licencing etc), the issue for Jollas dev would be that they don't really have the time as they are busy already
09:11:04 <leszek> M-schmittlauch: maybe bountys in general should be free software in general as the community would pay for it and can basically make this one requirement
09:11:06 <nh1402> can we discuss gesture keyboard or is too ate now
09:11:09 <sledges> leszek: but i'll bring it up during the next planning
09:11:34 <nh1402> late*
09:12:02 <M-schmittlauch> leszek: Is your idea comparable to what Krita does?
09:12:05 <leszek> jenix: basically let one jolla dev only work for 1-2 months on the community financed bounty
09:12:27 <M-schmittlauch> PurePremium: ߑ̀ed
09:12:41 <leszek> M-schmittlauch: i don't know for 100% what krita actually does
09:12:52 <sledges> nh1402: we're doing overtime [sic] :))
09:12:57 <M-schmittlauch> PurePremium: +1
09:12:57 <jenix> leszek: I'm not sure Jolla can currently spare a dev for that long.. but that's for them to say ultimately
09:13:00 <leszek> jenix: so basically have him/her free from other work this time
09:13:16 <leszek> jenix: alternatively hire a new developer for that said money
09:13:55 <r0kk3rz> im sure theres some mer things we could bounty for someone in the community
09:13:59 <jenix> leszek: I definately agree with you that this may be a great thing for SFOS. Maybe we just need to test it somehow
09:14:02 <sledges> thanks for nice gems of ideas, i'll blend them in during our next internal planning next week
09:14:14 <nh1402> sledges: well gesture keyboard has been requested before, topic on tjc has gotten 500+ votes, but no implementation, it was said by Aard that the autocorrect license also includes gesture based input
09:14:15 <leszek> though clearly the dev sometimes for core components needs access to source code that might be not free already. Not sure how to solve this
09:14:16 <sledges> r0kk3rz: convo stemmed mainly around UI bits
09:14:46 <nh1402> and for a gesture based OS not having a gesture based keyboard, is just plain wrong
09:14:57 <leszek> nh1402: agree
09:15:00 <M-schmittlauch> leszek: Open Source ALL the things ;)
09:15:10 <sledges> nh1402: a whole new topic, let's present it in the fortnight, my 2p: swype keyboard is patented by original inventor, and that's legal forest we'd get into
09:15:13 <leszek> M-schmittlauch: yep would be the solution :)
09:15:14 <jenix> leszek: I guess Jolla needs to discuss this internally (which sledges will do) and then get back to us
09:15:17 <r0kk3rz> sledges: as always, but thats what patchmanager is for
09:15:18 <Mister_Magister> opensource E V E R Y T H I N G
09:15:21 <leszek> yep
09:15:41 <sledges> r0kk3rz: 11:51 < M-schmittlauch> It also feels like the pachmanager community isn't that active anymore. One could see them as a try to change closed components, nevertheless them being closed. But these patches currently never have a chance on being merged
09:15:43 <nh1402> sledges: but the license you have for autocorrect, includes swype keyboard
09:15:54 <leszek> nh1402: agree. If even parts are licensed like I heard last time it does not make sense to not implement a swype like keybpoard
09:15:59 <sledges> nh1402:  i wouldn't know that, need to doublecheck (and i'd doubt)
09:16:02 <sledges> #topic Next meeting date
09:16:19 <nh1402> sledges: a former employee of jolla said so
09:16:32 <sledges> i need to be careful planning here, not to end up on another mindtrek-like event in two weeks :D
09:16:40 <Mister_Magister> sledges: no general?
09:16:47 <sledges> Mister_Magister: general just ended
09:16:50 <PurePremium> leszek: """ clearly the dev sometimes for core components needs access to source code that might be not free already. Not sure how to solve this""" well, i am sure you can see the problem about this. you want to fund a companies worker so that they can develop something on a closed source.
09:16:56 <Mister_Magister> oh missed that
09:16:57 <jenix> Mister_Magister: That was 25 Minutes of General Discussion :)
09:17:07 <nh1402> http://merproject.org/logs/%23sailfishos/%23sailfishos.2017-09-13.log.html#t2017-09-13T08:59:19
09:17:10 <Mister_Magister> jenix: lol missed the general info :D
09:17:33 <jenix> nh1402: I guess it would be best to add your question for the next meeting, so jolla can prepare for it
09:17:35 <leszek> PurePremium: like I said if the community is financing it they can require that feature to be free software
09:18:11 <nh1402> jenix: yes, I just forgot to bring it up, until it was too late today
09:18:30 <sledges> #info Next meeting date in two weeks: Wednesday, 4th of October 2017, 08:00 GMT
09:18:50 <jenix> sledges: no mindtrek then? :)
09:19:06 <sledges> at least not in my calendar :D (that's always empty anyway:))
09:19:30 <sledges> also no big launches on that day, (but one in awaitings)
09:19:46 <sledges> no objections, couple of +1s and we'll wrap up!
09:19:56 <jenix> sledges: here we go: +1 :D
09:20:01 <r0kk3rz> sledges: +1
09:20:04 <Mister_Magister> +1
09:20:10 <nh1402> +1
09:20:18 <leszek> +1
09:20:33 <sledges> thanks all, it wasn't a huge list in the introductions, but nontheless heated conversations!
09:20:36 <sledges> #endmeeting