09:00:28 <Jaymzz> #startmeeting Sailfish OS, open source, collaboration – November 2nd 2017
09:00:28 <merbot> Meeting started Thu Nov  2 09:00:28 2017 UTC.  The chair is Jaymzz. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:00:28 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:00:42 <Jaymzz> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-November/008079.html
09:00:55 <Jaymzz> I am the meeting’s chairperson today and will be doing my best to keep time and order. Please behave, respect the timings and be gentle.
09:01:06 <Jaymzz> #topic Brief introduction (5 min). Please prefix your name/handle with # info
09:01:15 <kimmoli> #info Kimmo Lindholm, community
09:01:24 <Jaymzz> #info James Noori, sailor @Jolla
09:01:26 <stephg> #info Steph Gosling, porter, community
09:01:32 <eekkelund> #info eekkelund
09:01:32 <Mister_Magister> #info Mister_Magister. porter, community
09:01:37 <sledges> #info Simonas Leleiva, l10n+hw @Jolla
09:01:48 <nekron_web> #info nekron community
09:01:54 <r0kk3rz> #info Lewis Rockliffe, king of the north
09:01:54 <cy8aer> #info cy8aer, community
09:02:43 <leszek> #info Leszek Lesner, Dev + Community
09:02:45 <M4rtinK> #info Martin Kolman, modRana developer, community
09:03:00 <ljo> #info Leif-Jöran Olsson, community
09:04:46 <Max-Might> #info Kostadin Damyanov, community
09:05:44 <Jaymzz> So as we did not have any topics announced on the planning page on TJC, we ar egoing to have a 20-30 minute general discussion. The time may vary depending on the discussions of course
09:05:49 <Jaymzz> #topic General discussion (20 min)
09:06:11 <guhl> #info Guhl, community
09:06:47 <stephg> can we quickly talk about OBS?
09:07:23 <leszek> Ok starting off with general I want to emphasize this qtwebkit issue on xperia x. Would be nice if jolla devs would track it. I guess its a graphics driver issue: https://together.jolla.com/question/171114/xperia-xbug-qtwebkit-unusably-slow/
09:07:34 <sledges> stephg: 1st rule of irc; don't ask to ask, ask ;)
09:07:48 <Jaymzz> stephg You can talk about anything you like :) Although personally I'm pretty uninformed in that area.
09:08:15 <leszek> regarding qtwebkit issue. Those who can reproduce the issue. Please vote
09:08:26 <stephg> sledges: ok well it's my understanding that teh webhook admin is currently b0rken but I've also got a little problem and could use some halp
09:08:34 <r0kk3rz> Jaymzz: any news about offering Sailfish X outside the EU?
09:08:36 <Jaymzz> leszek: Note taken, I will be taking it up with sailors :)
09:08:46 <leszek> thx :)
09:08:55 <sledges> stephg: ping lbt daily for webhooks; what's the prob?
09:09:27 <Jaymzz> r0kk3rz: No real news at the moment other than "It's in our plans and we are working on it :) "
09:09:45 <r0kk3rz> Jaymzz: thanks
09:09:49 <guhl> also pattern updating does not work on OBS right?
09:09:50 <stephg> my droid-hal-img-boot-$DEVICE won't build whereas ghosalmartin's does, he didn't remmber fixing it so thought something had happened behind the scenes
09:09:58 <leszek> another thing I wanted to ask: Is the focussing working fine on your Xperia X devices? Somehow I get too much misfocussing also with the latest update and the half button press behavior I think needs some explaining
09:09:59 <stephg> sledges: just looking for the error int he logs now
09:10:21 <Jaymzz> r0kk3rz: And that is actually the case, it's not an answer that means "I don't wanna talk about this" :D
09:10:26 <sledges> stephg: have you tagged yours?
09:10:40 <stephg> sledges: no, that'd probably do it
09:10:45 <r0kk3rz> Jaymzz: i was assuming you werent lying, but good to know!
09:10:46 <sledges> give that a try
09:10:51 <stephg> yep will do, thanks!
09:10:54 <sledges> np
09:11:21 <Jaymzz> leszek: That is a known issue, yes. It has that misfocusing issue but we are tracking it down and it will be fixed in a future update
09:11:24 <sledges> guhl: general rule is to ping lbt daily until he folds (that's two pings already :D)
09:11:53 * tbr checks in
09:12:04 <kimmoli> so you mean to ping lbt deaily?
09:12:04 <tbr> any Mer topics on for today?
09:12:19 <guhl> sledges, will do but i have little hope as this is already quite some time
09:12:34 <Jaymzz> tbr: today's only general discussions :)
09:12:44 <r0kk3rz> tbr: unless you have one?
09:12:52 <tbr> r0kk3rz: nah, not really
09:13:22 <sledges> guhl: perserverance is a bliss, lbt may have had another holiday or just busy as we all;)
09:13:27 <leszek> and just as a annoying reminder. I am still waiting for some more free / open source code of SailfishOS
09:13:51 <r0kk3rz> leszek: anything in particular?
09:14:17 <leszek> r0kk3rz: nothing new compared to the thread on tjc
09:14:50 <leszek> so silicia, lipstick are on my priority list on top. Jolla-email is there aswell
09:15:08 <leszek> *silica
09:15:22 <r0kk3rz> Jaymzz: another reminder for the devs, SDL2 has been patched for horizontal support, would be nice to get that released to us https://bugzilla.libsdl.org/show_bug.cgi?id=2943
09:15:22 <merbot> bugzilla.libsdl.org bug 2943 in video "Support for QtWayland content orientation and window flags via SDL hints" [Normal,Resolved: fixed]
09:15:23 <stephg> silicia sounds tasty ;)
09:15:46 <Jaymzz> leszek: It's not annoying really :) circumstances and lack of resources + a lot of projects that keeps our resources busy haven't allowed us to get to open sourcing yet. As you know, it's not as simple as opening the source and making it available to the masses. There is loads of documentation to be written, testings to be done, etc etc. We haven't had a chance to put that in our priority yet.
09:15:51 <r0kk3rz> meh, we need kirigami :)
09:16:24 <sledges> and also maintainership after opensourcing
09:16:26 <cy8aer> Just a question for the 2.1.3.7 "Hide internet calling tone until the feature is supported in the OS." - does this mean: silent removal? What about the whole sip complex? As I understand the core part is working but the UI is missing?
09:16:27 <Jaymzz> r0kk3rz: Note taken :)
09:16:35 <Jaymzz> sledges: +1
09:17:31 <Jaymzz> sledges: do you have a reply for cy8aer? I'm not involved in that area unfortunately
09:17:41 <sledges> cy8aer: it means internet calling tone is never played in any parts of sfos at the moment
09:18:15 <sledges> cy8aer: your another question about sip answers as: yes, ui bindings are missing
09:19:35 <Mister_Magister> Is ota using OBS working? Patterns don't generate anymore so ota is not working too right?
09:19:38 <cy8aer> sledges: where is the sip in the priority list? IMHO this is also a core part for stuff like VoLTE.
09:19:46 <leszek> Is there anything in the piplines for improving ambiences? Like adding an option to activate a specific ambience on a specific time a day? Or bugfixing it to work with custom sounds stored on a micro-sd card (like delaying ambienced starting until mount of microsd card is done in systemd)
09:20:32 <sledges> cy8aer: not in plans of the current iteration (monthly)
09:21:00 <guhl> Mister_Magister, yes the answer/solution is ping lbt daily
09:21:02 <cy8aer> sledges: ok, thanks
09:21:07 <Jaymzz> leszek: Not in the nearest future I would say. But those are great ideas you presented there. I'll definitely take them up and will dig deeper if those are a possibility
09:21:17 <Mister_Magister> guhl: i'm pinging it since 1 week didn't help
09:21:23 <Mister_Magister> any other ideas?
09:21:25 <r0kk3rz> leszek: is there a TJC for that?
09:21:27 <sledges> Mister_Magister: daily?
09:21:30 <Mister_Magister> yes
09:21:36 <leszek> r0kk3rz: I don't know
09:21:38 <Mister_Magister> almost
09:21:42 <sledges> well ;p
09:21:49 <r0kk3rz> leszek: find one, or make one :)
09:22:00 <leszek> r0kk3rz: for the microsd sound issue there should be one
09:22:03 <sledges> Mister_Magister: old OTAs work, those that have patterns generated and had no changes since
09:22:03 <guhl> Mister_Magister, I know i've been watching that
09:22:33 <Mister_Magister> sledges: i know but i have 2 new devices waiting for ota
09:22:40 <sledges> Mister_Magister: new OTAs won't work
09:22:59 <Mister_Magister> sledges: when they will work?
09:23:04 <sledges> when patterns work
09:23:07 <guhl> Mister_Magister, I messed up my OBS totally by manually updating the patterns
09:23:11 <leszek> r0kk3rz: there is this https://together.jolla.com/question/23068/why-do-ambiences-which-have-sounds-on-the-sd-card-lose-their-settings-periodically/
09:23:13 <Mister_Magister> and when patterns will work?
09:23:20 <Mister_Magister> guhl: lol
09:23:22 <sledges> Mister_Magister: when lbt gets to them
09:23:33 <Mister_Magister> gosh
09:23:42 <Mister_Magister> so i can't do anything with that
09:24:03 <sledges> Mister_Magister: you can build image locally, with your local patterns, and declare that it won't have OTAs for now
09:24:15 <pketo> what patterns are you talking about?
09:24:20 <sledges> pketo: Mer OBS
09:24:48 <sledges> (to generate _patterns meta package)
09:24:52 <Mister_Magister> sledges: i know but then how people with not ota image could do ota?
09:25:06 <sledges> Mister_Magister: change repos
09:25:16 <stephg> yeah just some ssu'ing would work right?
09:25:20 <Mister_Magister> oh only that? i had it in my ota instructions
09:25:22 <pketo> Ok, I don't know what that does :)
09:25:40 <Mister_Magister> okay then
09:25:53 <sledges> like stephg says, check `ssu lr` and adjust from there
09:25:57 <guhl> Well Mister_Magister your seen on the porters channel tells us everything
09:26:11 <Mister_Magister> btw sledges could you make testing repo for me then? :D
09:26:22 <Mister_Magister> guhl: what?
09:26:23 <sledges> Mister_Magister: but might be challenges with community-adaptation package
09:26:40 <guhl> that lbt has not be seen for more than 2 weeks
09:26:45 <sledges> Mister_Magister: sure
09:26:47 <Mister_Magister> sledges: i think it will be okay
09:26:51 <Mister_Magister> guhl: yeah
09:26:59 <sledges> Mister_Magister: it will be a challenge, you'll see..
09:27:03 <Mister_Magister> sledges: motorola:kinzie and flo
09:27:08 <sledges> Mister_Magister: ok
09:27:43 <Mister_Magister> sledges: asus:flo
09:28:18 <sledges> #action Ask frajo about https://together.jolla.com/question/171114/xperia-xbug-qtwebkit-unusably-slow/
09:28:38 <Jaymzz> so over 20 minutes has passed, I assume there are no active discussions going after this? or shall we make it 30?
09:29:06 <ghosalmartin> there is some odd issue with the browser on X were it just randomly crashes after opening
09:29:14 <ghosalmartin> but this occured on the bullhead port as well
09:29:14 <sledges> #action follow up on https://together.jolla.com/question/169758/xperia-x-camera-autofocus-or-picture-sharpness-seems-non-optimal/ (it's already tracked by Jolla)
09:29:25 <Mister_Magister> ghosalmartin: it's not only xperia x bug
09:29:33 <Mister_Magister> ghosalmartin: on x force it crashes as hell
09:29:42 <sledges> #action action upon https://bugzilla.libsdl.org/show_bug.cgi?id=2943 (could community make a PR to git.m.o?)
09:29:42 <merbot> bugzilla.libsdl.org bug 2943 in video "Support for QtWayland content orientation and window flags via SDL hints" [Normal,Resolved: fixed]
09:29:44 <ghosalmartin> Mister_Magister, well there ya go
09:30:25 <sledges> #info community wants SIP!
09:30:34 <Mister_Magister> what is sip?
09:30:37 <tbr> film at 11
09:30:54 <tbr> Session initiation protocol. what he means is: working VoIP calls
09:31:10 <sledges> ghosalmartin: Mister_Magister: got a tjc on that?
09:31:15 <ghosalmartin> sledges, dont think so
09:31:33 <Mister_Magister> i mean sailfish browser was always crashing
09:31:37 <sledges> ghosalmartin: https://together.jolla.com/question/169504/web-browser-crashes-when-starting/
09:31:44 <Mister_Magister> now it's just on browser start too
09:31:49 <Mister_Magister> and more often
09:31:53 <tbr> getting sip calls to work was a topic since before SbJ launched. So, yeah, not much of a priority it seems.
09:31:57 <pvuorela> sdl hints? that was merged already last year?
09:31:59 <ghosalmartin> ah well there ya go :D
09:32:03 <M4rtinK> anyone else noticing speakerphone mode being far too silent ?
09:32:05 <ghosalmartin> sip is to do with tea, you sip hot tea
09:32:12 <ghosalmartin> M4rtinK, yes
09:32:27 * tbr looks at his coffee, takes a sip anyway
09:32:37 <ghosalmartin> hmm maybe it should be for drink :D
09:32:57 <sledges> r0kk3rz: ^^
09:33:06 <nekron_web> So what is about device encryption now that everyone uses a Xperia phone?
09:33:07 <M4rtinK> I'll find the TJC question for that
09:33:19 <sledges> (mal used to cater SDL)
09:34:01 <pvuorela> https://git.merproject.org/mer-core/libsdl/merge_requests/1
09:35:16 <Jaymzz> 30 minutes is over guys
09:35:19 <r0kk3rz> pvuorela: it was? someone was talking about it recently, maybe they didnt realise it was merged :)
09:35:27 <Jaymzz> shall we move on? gimme a +1 :D
09:35:35 <nekron_web> Because of that lovely nag screen "your device has been unlocked" everyone knows that fastbooting a recovery image will give you access to all data partitions where your data has been stored
09:35:39 <M4rtinK> https://together.jolla.com/question/169291/xperia-x-speakerphone-volume-too-low/
09:35:50 <M4rtinK> maybe action that as well ?
09:36:02 <sledges> #info SDL hints have been merged https://together.jolla.com/question/169504/web-browser-crashes-when-starting/ ; please tell if more is needed
09:36:06 <sledges> #undo
09:36:09 <M4rtinK> sledges: ^
09:36:21 <sledges> (only Jaymzz can #undo ;P)
09:36:27 <Jaymzz> #undo
09:36:27 <merbot> Removing item from minutes: <MeetBot.items.Info object at 0xa1125d0>
09:36:32 <sledges> thx ;)
09:36:38 <Jaymzz> no worries
09:36:44 <sledges> #info SDL hints have been merged https://git.merproject.org/mer-core/libsdl/merge_requests/1 ; please tell if more is needed
09:36:47 <Jaymzz> I'll make action for xperia volume
09:36:59 <r0kk3rz> sledges: i'll update the TJC about it
09:37:02 <M4rtinK> Jaymzz: thanks! :)
09:37:16 <sledges> Jaymzz: +1 ;)
09:37:38 <Jaymzz> #action Ask about Xperia speaker volume during calls https://together.jolla.com/question/169291/xperia-x-speakerphone-volume-too-low/
09:37:39 <sledges> r0kk3rz: linky?
09:39:26 <r0kk3rz> sledges: https://together.jolla.com/question/70821/request-support-sdl-landscape-mode/
09:39:52 * sledges smells naphtaline
09:40:00 <Jaymzz> alright this is going way over time guys :) Let's move it on to deciding the next meeting's date
09:40:08 <Jaymzz> lol sledges why :DDD
09:40:08 <r0kk3rz> sledges: careful thats toxic :)
09:40:27 <Jaymzz> #topic Next meeting’s time and date (5 min)
09:40:38 <sledges> r0kk3rz: that was figure speech ;P probably not in english-speaking world
09:41:07 <Jaymzz> 2 weeks from now, November 16th 2017 at 09:00 UTC? shoot those +1s
09:41:10 <r0kk3rz> sledges: interesting lithuanian proverb :)
09:41:14 <Mister_Magister> +1
09:41:29 <sledges> r0kk3rz: it's used as flee killer, and colloquially describes anything ancient ;)
09:41:37 <stephg> fine by me
09:42:03 <r0kk3rz> sledges: aye, it does have the stench of history about it
09:42:14 <r0kk3rz> Jaymzz: make it so
09:42:16 <Jaymzz> #info Next meeting will be held on November 16th 2017 at 09:00 UTC
09:42:51 <sledges> SFOS X-Mas dinner will be held Fri 8th December, most probably @ Tas The Cut London
09:42:59 <sledges> everyone's welcome!
09:43:00 <Jaymzz> Alrighty! This was a great meeting guys! thanks for participating. Meeting minutes will be sent shortly
09:43:27 <r0kk3rz> sledges: friday? :(
09:43:37 <sledges> r0kk3rz: ofc, most sought/free eve ;)
09:43:53 <Jaymzz> I'll end the meeting, you guys continue :D
09:43:57 <Jaymzz> #endmeeting