09:00:08 <chriadam_> #startmeeting Sailfish OS CalDAV/CardDAV contributors meeting
09:00:08 <merbot> Meeting started Mon Nov 13 09:00:08 2017 UTC.  The chair is chriadam_. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:00:08 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:00:16 <chriadam_> #link https://sailfishos.org/wiki/CalDAV_and_CardDAV_Community_Contributions#13.2F11.2F2017_Meeting
09:00:22 <chriadam_> #topic Introductions
09:00:32 <chriadam_> Please introduce yourself with #info name/nick
09:00:37 <chriadam_> #info Chris Adams, developer at Jolla
09:01:03 <ljo> #info Leif-Jöran Olsson, community
09:01:06 <dcaliste> #info Damien Caliste, CalDAV plugin user :)
09:02:24 <chriadam_> hi ljo, welcome
09:02:26 <chriadam_> we'll wait another 6 or so minutes in case some people are running a bit late, then we'll continue with the agenda :-)
09:03:04 <ljo> chrisadam_, thx, glad to be back
09:06:26 <chriadam_> ok, let's continue with the agenda :-)
09:06:32 <chriadam_> #topic Follow-up Agenda Items From Last Meeting
09:07:02 <chriadam_> The PR from rubdos was reviewed
09:07:21 <chriadam_> not sure whether that one can be progressed further at this stage, last I saw there were still some outstanding comments on that one
09:07:48 <chriadam_> I raised the issue with Buteo Sync Plugins and translated error messages internally, the response was:
09:08:07 <chriadam_> "untranslated strings belong to journal. we could add custom mechanism for plugins to communicate that a translation file needs to be loaded, or we start maintaining global error enum list that we keep updating with specific errors"
09:08:35 <chriadam_> there were some more details (e.g., sync UI in settings vs recent errors in events view)
09:08:55 <chriadam_> but the basic decision, from what I can tell, is that we need some mechanism to ensure that whatever error message we show to users, must be translated.
09:09:21 <chriadam_> I don't know where that leaves us, with your proposal, dcaliste, my memory is fuzzy on the details
09:09:28 <dcaliste> chriadam_, thanks for discussing it internally. Conclusion is sensible.
09:09:47 <dcaliste> Did you have time to look at my proposition of nemo-qml-plugin-buteo?
09:10:05 <dcaliste> It would help to understand what should be translated.
09:10:57 <chriadam_> I will take a look at that one.  Possibly we could ask the UI to load a particular translation catalogue on demand, if required.
09:11:19 <dcaliste> #link https://git.merproject.org/dcaliste/nemo-qml-plugin-buteo
09:11:20 <chriadam_> #action chriadam to review the nemo-qml-plugin-buteo proposal
09:12:19 <chriadam_> other follow-up items, pvuorela and I did review (and merge) a variety of PRs from dcaliste and mardy, not sure whether some are still outstanding from last month, or whether the ones which are still open are new ones.
09:12:25 <dcaliste> There is an example of UI (not made for UI design but to demonstrate what kind of info we have at hand) in examples/
09:13:03 <ljo> dcaliste Yes, those are nice
09:13:21 <chriadam_> dcaliste: sounds comprehensive, thanks
09:13:40 <chriadam_> were there any other follow up items since last meeting, or shall we continue with the rest of the agenda?
09:14:13 <dcaliste> I think that pending MR are new ones indeed.
09:14:47 <dcaliste> Sorry, one point:
09:15:03 <dcaliste> I've looked at TODO specificities in CalDAV plugin.
09:15:44 <chriadam_> hopefully not too many changes required there?
09:15:49 <dcaliste> It is WIP, you can see in my todos branch: https://git.merproject.org/dcaliste/buteo-sync-plugin-caldav/tree/todos
09:15:55 <dcaliste> Not too many changes indeed.
09:15:59 <chriadam_> great
09:16:04 <dcaliste> One in reader.
09:16:13 <dcaliste> Some in incidencehandler.
09:16:20 <dcaliste> And some in notebooksyncagent.
09:16:45 <dcaliste> It's quite simple indeed, but when working on it I decided to revamp notebooksyncagent.
09:16:56 <dcaliste> The part in reader is done and I've added a test.
09:17:14 <chriadam_> ok, I will ask blam and pvuorela to review also, but hopefully we can get that one in quite soon.
09:17:17 <dcaliste> The parts in incidencehandler and notebooksyncagent are waiting for revamp to be finished.
09:17:38 <chriadam_> thanks
09:17:44 <chriadam_> ok, let's continue with the rest of the agenda:
09:17:53 <chriadam_> #topic MER#1836 - Reminders/alarms for synced all-day events don't work
09:18:01 <chriadam_> dcaliste investigated and provided fixes for this one
09:18:12 <chriadam_> those have been reviewed and merged, and tagged
09:18:23 <chriadam_> however, I realised today that we've internally been having all sorts of CI / infra issues
09:18:35 <chriadam_> so I have absolutely no idea at this point which packages have been promoted and which haven't
09:18:50 <chriadam_> I need to check the repo build metadata
09:18:57 <chriadam_> and potentially retrigger builds
09:19:05 <chriadam_> anyway, thanks to dcaliste for fixing that one!
09:19:14 <chriadam_> #topic MER#1827 - Thunderbird reminders are triggered again after upsync
09:19:20 <chriadam_> this one I believe is still outstanding
09:19:34 <chriadam_> dcaliste: there's a PR in caldav from you, is that the only one required to fix this, or is there also something elsewhere?
09:20:21 <dcaliste> Only https://git.merproject.org/mer-core/buteo-sync-plugin-caldav/merge_requests/31 is useful to fix this (at least I think so).
09:20:44 <chriadam_> ok, I'll review that this week
09:20:48 <dcaliste> I've updated it a bit after pvuorela review.
09:21:01 <chriadam_> great
09:21:04 <dcaliste> If you're fine, I'll squash the review commits.
09:21:26 <chriadam_> it LGTM last time I checked, so assume so
09:21:35 <dcaliste> Ok.
09:21:43 <chriadam_> #topic MER#1714 - isdn field added to phone numbers on upsync
09:22:13 <chriadam_> same as always, this one is a good task for new contributors if you're interested in joining the effort.  get in contact if you'd be interested :-)
09:22:20 <chriadam_> #topic MER#1751 - main issue resolved, but some minor tasks here remain.
09:22:48 <chriadam_> same as always, .eml can be treated as .vcf in some circumstances (if the content type is text/vcard)
09:23:01 <chriadam_> again please get in touch if you'd be interested in helping with this issue
09:23:06 <chriadam_> #topic Any Other Business?
09:23:32 <chriadam_> dcaliste: I guess there are a variety of open PRs from you at the moment, can you list the Mer bug numbers for easy reference?
09:24:09 <dcaliste> There is the new MER#1848, etag is not updated for all exceptions in recurring events.
09:25:19 <dcaliste> there is MER#1835 to allow to retrieve events in a window time, so plugin is not deleting old or far in the future events.
09:25:53 <dcaliste> This one should be discussed because it is adding a new mkcal API https://git.merproject.org/mer-core/mkcal/merge_requests/2
09:26:26 <dcaliste> There is MER#1840, having non-interval schedule not working properly.
09:27:24 <chriadam_> ok, thank you.  I will investigate and review, hopefully this week.
09:27:26 <dcaliste> I would like also to revamp notebooksyncagent. see my tidy branch: https://git.merproject.org/dcaliste/buteo-sync-plugin-caldav/tree/tidy
09:27:50 <chriadam_> I will ask blam to take a look at that too
09:28:10 <dcaliste> For the last one, I'm proposing a new test for the delta function, see https://git.merproject.org/mer-core/buteo-sync-plugin-caldav/merge_requests/32
09:28:18 <dcaliste> blam has seen this one already.
09:28:51 <dcaliste> To propose lmy tidy branch as a MR, I'm waiting for the delta test to enter and also the etag one.
09:29:03 <dcaliste> etag: https://git.merproject.org/mer-core/buteo-sync-plugin-caldav/merge_requests/30
09:29:07 <chriadam_> ok.  I'll merge those this week
09:29:15 <chriadam_> I need to check this ci/infra issue first
09:29:26 <dcaliste> Sure.
09:29:52 <chriadam_> as always, huge thanks for your big efforts on this.
09:30:28 <chriadam_> anything else to discuss from anyone?
09:30:30 <dcaliste> Do you think the current tested package on TJC will enter 2.1.4? Or it has been branched already?
09:30:35 <chriadam_> dcaliste: no idea
09:30:42 <chriadam_> again this comes back to the ci/infra thing
09:30:47 <dcaliste> ;) Infra issue!
09:30:47 <chriadam_> I need to check what got promoted
09:31:07 <dcaliste> One last question:
09:31:45 <dcaliste> I need to check but it seems that my issue of sailfish-updater killing my calendars on restart only trigger if I put interval update.
09:32:11 <dcaliste> In that case, do you think it is using the SyncLog::lastSuccessfulSyncTime() function?
09:32:21 <dcaliste> Like the plugin was doing previously?
09:32:44 <chriadam_> what is sailfish-updater?
09:32:48 <dcaliste> In that case, the erasing make sense, the updater don't find any succesful last sync date so decide to restart.
09:33:15 <chriadam_> is that OS-update thing?
09:33:20 <dcaliste> Yes.
09:33:39 <dcaliste> I'm trying to find the MER bug I filled for this.
09:35:13 <dcaliste> It is MER#1822
09:35:43 <chriadam_> os-update stuff is being rewritten currently.  under the hood it is a jolla-store-client managed set of packagekit transactions
09:35:55 <chriadam_> I don't think it uses buteo at all, however I'm not too familiar with the internals
09:36:34 <dcaliste> Maybe you remember, we discussed at one moment last month. On restart (not only retsrat after update) my calendars are erased may account migrated to a new id.
09:36:50 <dcaliste> It is an issue in sailfish-accounts-tool
09:36:52 <chriadam_> oh right
09:36:55 <chriadam_> the migration thing
09:36:59 <chriadam_> didn't I fix that?
09:37:37 <dcaliste> I can't answer, sorry, because it is closed source part and I don't which version I'm actually on.
09:38:08 <dcaliste> I got erase when updating to 2.1.3.7 by the way.
09:38:24 <chriadam_> I didn't fix it
09:38:28 <chriadam_> I had some notes about it
09:38:33 <chriadam_> but didn't create MR.  dang.
09:39:01 <dcaliste> My point is just maybe to help worrowing reproduction.
09:39:25 <dcaliste> If I don't have a successful last sync date in log, I get erased on any restart.
09:39:35 <chriadam_> whereas if you do, it doesn't erase?
09:39:51 <chriadam_> right
09:40:18 <chriadam_> the core issue is still the migration of the account to a new account id (therefore guaranteeing that there won't be a successful previous sync in the log for that account)
09:40:20 <dcaliste> It seems so. I didn't wanted to reproduce the erasal yet voluntarily to check hat my assumption is right!
09:40:51 <chriadam_> indeed
09:40:55 <dcaliste> But if I have a valid date in log and I restart, everything is fine.
09:41:02 <chriadam_> #action chriadam to investigate MER#1822 again
09:41:14 <chriadam_> I will look into it
09:41:21 <chriadam_> sorry for letting that one slip off my radar
09:41:39 <chriadam_> ok, if nothing else, I guess we can end the meeting :-)  Thanks again to everyone for helping out.
09:41:52 <chriadam_> Before I end, something folks might be interested in: https://github.com/sailfishos/sailfish-secrets
09:42:11 <chriadam_> still heavily in development, expect lots of changes over the next couple of months I guess.
09:42:18 <chriadam_> review/feedback greatly appreciated
09:42:48 <chriadam_> we will be making some changes to the API and implementation to bring us closer to the XDG secrets draft
09:43:07 <dcaliste> Interesting. Can it be used to store passwords ?
09:43:35 <chriadam_> yes, but not just passwords.  any generic data blob.  especially, secret keys / authentication keys.
09:43:46 <chriadam_> anyway, not related to caldav/carddav
09:43:46 <dcaliste> Great for GPG also ;)
09:43:54 <chriadam_> :-)
09:43:56 <ljo> +1
09:44:08 <chriadam_> thanks everyone, closing the meeting in 5
09:44:13 <dcaliste> I'm going to use it for PDF passwords also.
09:44:19 <chriadam_> ...4
09:44:26 <chriadam_> ...3
09:44:32 <dcaliste> A new PR for sailfish-office it has been a long time.
09:44:32 <chriadam_> ...2
09:44:38 <chriadam_> ...1
09:44:49 <chriadam_> dcaliste: oh, ping me or pvuorela if there are outstanding PRs in office
09:44:59 <chriadam_> #endmeeting