09:00:00 <Jaymzz> #startmeeting Sailfish OS, open source, collaboration – November 16th 2017
09:00:00 <merbot> Meeting started Thu Nov 16 09:00:00 2017 UTC.  The chair is Jaymzz. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:00:00 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:00:12 <Jaymzz> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-November/008091.html
09:00:23 <Jaymzz> I am the meeting’s chairperson today and will be doing my best to keep time and order. Please behave, respect the timings and be gentle.
09:00:34 <Jaymzz> #topic Brief introduction (5 min). Please prefix your name/handle with # info
09:00:43 <Venty> 'llo.
09:00:48 <Jaymzz> #info James Noori - Sailor at Jolla
09:01:01 <Mister_Magister> #info Mister_Magister, porter, community
09:01:12 <Mister_Magister> hi James :)
09:01:17 <r0kk3rz> #info Lewis Rockliffe, breaker of chains and king of the north
09:01:22 <Guest14206> #info Venty - Community member
09:01:23 <nekron_web> #info Nekron, community
09:01:25 <leszek> #info Leszek Lesner, Dev & Community
09:01:29 <jenix> #info Jenx Müller, community member
09:01:32 <naytsyrhc> #info naytsyrhc, community
09:01:45 <PeperJohnny> #info peperjohnny, community
09:01:48 <M4rtinK> #info Martin Kolman, modRana developer & community member
09:02:21 <jwalck> #info Jonatan Walck, community
09:02:32 <abranson> #info Andrew Branson, dev @ Jolla
09:02:39 <sledges> #info Simonas Leleiva, sailor @ Jolla
09:02:53 <jpetrell> #info Joona Petrell, sailor @ Jolla
09:03:33 <eekkelund> #info eekkelund
09:03:56 <dcaliste> #info Damien Caliste, community
09:04:12 <tortoisedoc> #info tortoisedoc, developer
09:05:00 <pketo> #info Pami Ketolainen, sailor @ Jolla
09:05:39 <ljo> #info Leif-Jöran Olsson, community
09:06:13 <Jaymzz> #topic: State of USB tethering (10 min) asked by m4rtink
09:06:24 <atlochowski> #info Andrzej Lochowski, community
09:06:25 <Jaymzz> #info some details about the topic: With the WiFi hotspot not yet working on Sailfish X I turned back to USB tethering for the time being. That reminded me that USB tethering still doesn't seem really supported officially and you need to manually install a random package  from the command line to enable it. So I want to ask - what's the actual status of USB tethering ? Is there anything preventing it from being installed by default
09:06:25 <Jaymzz> or at least being available as an addon installable from the Jolla store ?
09:06:36 <Jaymzz> #link http://www.jollausers.com/2015/02/mobile-internet-via-usb-tethering/
09:07:02 <M4rtinK> thanks!
09:07:34 <M4rtinK> yeah, just wondering why something so useful is lingering in obscurity
09:07:45 <Jaymzz> M4rtinK: Thanks for this question/topic. This is something that has been in our plans for a long time but due to higher priority features, it has always been pushed down. However, it will officially happen at some point, no timeframe provided
09:08:07 <M4rtinK> & if it's an oversight or there are technical reasons
09:08:47 <Jaymzz> Also WiFi tethering on Sailfish X is being worked on and shall be released in a near-future update :)
09:08:48 <rainemak_> #info Raine M�kel�inen, sailor @ Jolla
09:09:01 <tortoisedoc> Jaymzz : any timeframe? ;)
09:09:15 <Jaymzz> tortoisedoc: For what? USB or WiFi tethering?
09:09:15 <tortoisedoc> (except SOON(tm), that is)
09:09:23 <tortoisedoc> Wifi Tethering
09:09:26 <jpetrell> currently connectivity special cases (flight mode, mobile data, roaming, error, etc.) are handled in Connection Dialog. USB dialog would need similar capabilities, and we need to check all the places we handle connectivity (Events shortcuts, Settings, connection dialog) to behave gracefully with USB connections
09:09:35 <M4rtinK> anything the community can help with ?
09:09:45 <M4rtinK> for both tetherings
09:09:54 <jpetrell> unfortunately most of the remaining work is in closed UI
09:09:56 <M4rtinK> eq. testing or something
09:09:57 <stephg> sorry I'm late
09:10:21 <tortoisedoc> M4rtinK I guess that'd be CBeta / EA
09:10:50 <Jaymzz> tortoisedoc: Since it's WIP, we can't talk about a timeframe in case it didn't happen as soon as e said it would. But I would say Soon TM would be a suitable answer for now. Sorry for disappointing you :D
09:11:03 <tortoisedoc> :D
09:11:21 <M4rtinK> we hit the closed UI blocking community participation  pretty often, don't we ?  ;-)
09:11:34 <tortoisedoc> it means we are on the right track? ;)
09:11:40 <Jaymzz> #info currently connectivity special cases (flight mode, mobile data, roaming, error, etc.) are handled in Connection Dialog. USB dialog would need similar capabilities, and we need to check all the places we handle connectivity (Events shortcuts, Settings, connection dialog) to behave gracefully with USB connections
09:11:42 <sledges> M4rtinK: community can enable wlan tethering on xperia x to play around/test: https://sailfishos.org/wiki/Sailfish_X_Build_and_Flash#Adaptation_Status
09:12:10 <Jaymzz> #info community won't be able to help that much because most of the work left is in closed UI
09:12:12 <M4rtinK> any progress at all at fixing *that* ? ;-)
09:12:20 <jpetrell> M4rtinK: unfortunately yes :P IMO open sourcing would make sense, but I am not an owner so
09:12:22 <Jaymzz> #link https://sailfishos.org/wiki/Sailfish_X_Build_and_Flash#Adaptation_Status
09:13:36 <Jaymzz> #info community can enable WiFi tethering on Sailfish X with a workaround provided here: https://sailfishos.org/wiki/Sailfish_X_Build_and_Flash#Adaptation_Status
09:13:55 <Jaymzz> M4rtinK: did you get your answer? :)
09:14:11 <M4rtinK> yep, that all from me for this
09:14:27 <Jaymzz> alright thank you, moving on
09:14:31 <M4rtinK> I it is good to know the backgroud
09:14:37 <Jaymzz> #topic: Low speakerphone volume & bad echo cancellation on Sailfish X (15 min) asked by m4rtink
09:15:16 <Jaymzz> According to Sailfish X program manager (Veskuh) this is something we should look into and it is a known issue which we will hopefully be able to fix in future updates.
09:15:37 <M4rtinK> wanted to bring this up here bacause it is pretty annoying
09:15:57 <Jaymzz> #Action Sailfish X team to look into the low speaker volume during calls
09:16:18 <M4rtinK> & seems to be affecting a lot of people according to tjc feedback
09:16:51 <Jaymzz> interestingly I haven't used the speaker phone on my X for phone calls yet :D But yes it seems to be a known issue
09:17:10 <Jaymzz> oh, forgot to paste the link here...
09:17:17 <Jaymzz> #link https://together.jolla.com/question/169291/xperia-x-speakerphone-volume-too-low/
09:17:19 <M4rtinK> maybe add "tracked by Jolla” to the question then ?
09:17:21 <Mister_Magister> working fine for me since always? whole porting is rndis based
09:17:28 <sledges> is anyone running AOSP on their xperia x? ;)
09:17:32 <Mister_Magister> oh duck i didn't scroll
09:17:34 <Mister_Magister> sorry
09:17:35 <Mister_Magister> :D
09:17:41 <jenix> Does this also refer to the possible issue that the volume seems to get resetted to low on every call? I've seen a thread on tjc for this
09:17:49 <M4rtinK> so affected people know it's being worked on
09:18:09 <M4rtinK> jenix: that something else imho
09:18:21 <Jaymzz> M4rtinK: That would be a good idea, yes
09:18:38 <Jaymzz> sledges: I think that's a no :D
09:18:41 <M4rtinK> this is about speakerphone volume being too low
09:18:45 <jenix> k, I also don't know how "legit" that bug report is since there currently are no replies
09:19:11 <M4rtinK> & you can't set it any higher by the buttons during call
09:19:16 <Domo_> I've experienced speakerphone too low (feels like the same as w/o)
09:19:26 <leszek> it is working fine for me. At least the volume is not too low
09:19:44 <Domo_> sailfish x, 2.1.3.7
09:19:47 <sledges> Jaymzz: was worth a shot ;)
09:20:02 <Jaymzz> leszek: yeah apparently it has not affected everyone
09:20:12 <jenix> well, the "right" volume during calls definitely is subjective and depends on your environment :)
09:20:29 <leszek> uff could it be different hardware again? Like the panel options and double tap
09:20:36 <tortoisedoc> does this happen always for you MartinK ?
09:20:55 <M4rtinK> at least in my case it's a big difference from Jolla C/1
09:21:15 <ljo> +1
09:21:26 <M4rtinK> tortoisedoc: always
09:21:30 <jenix> yep, boticed that too on my Xperia X
09:21:37 <jenix> *noticed
09:21:37 <naytsyrhc> I use Xperia X compact and have no problems on 2.1.3.5 with speaker phone.
09:22:09 <M4rtinK> maybe it depends on the other side as well ?
09:22:15 <tortoisedoc> M4rtinK : only during calls? how about sound through speaker?
09:22:42 <Domo_> youtube videos using browser sounds loud and clear
09:22:45 <M4rtinK> this issue is during speakerphonecall
09:22:47 <tortoisedoc> if it's hw related, "normal" sound should be affected as well
09:23:03 <tortoisedoc> so that rules out hw issues
09:23:19 <M4rtinK> eq. hearing the other side of the call through pbone speakers
09:23:26 <jenix> leszek: We could try to compare the model numbers to identify if it is hardware dependend!? though I don't know if / which part of the model number specifies hardware parts
09:23:40 <tortoisedoc> (at least the sound hw)
09:23:48 <M4rtinK> I have no problems with sound volume otherwise
09:23:59 <M4rtinK> eq. music, browser, ringing
09:24:02 <jpetrell> I have had issues with speaker during calls on my f5121 xperia x, there are some open bugs in internal bug tracking system, though some testers there say they couldn't repro
09:24:09 <M4rtinK> plenty loud if needed
09:24:42 <jenix> M4rtinK: maybe the bug is not "volume to low" but "volume control not working during calls" ?
09:24:43 <naytsyrhc> M4rtinK: I had it once, that it seemed, I could not change volume during speakerphonecall but after adjusting volume to lowest value (muted) it somehow triggered a "reset" or however I can call it and afterwards I was able to adjuste the volume and I don't have any problems since then.
09:24:45 <Domo_> f5121, 2.1.3.7. speakerphone volume same as w/o speakerphone
09:24:46 <tortoisedoc> internal bug tracking eh
09:24:46 <sledges> tortoisedoc: some tech inffo: if speakerphone was any louder now, one would get massive echo, as cancellation is not in place (or not fully in place) -- that needs to be addressed first
09:25:14 <tortoisedoc> well that sounds suspicious :P
09:25:30 <Domo_> developer mode set, but now allowing untrusted sw
09:25:31 <M4rtinK> naytsyrhc: I can certainly try that
09:25:42 <jpetrell> sledges: so basically speakerphone is not yet supported on sonys
09:25:49 <Jaymzz> 5 min left
09:26:03 <M4rtinK> sledges: so that confirms my suspicion
09:26:12 <sledges> jpetrell: on AOSP and/or our hw adaptation - needs looked in
09:26:24 <tortoisedoc> sledges is cancellation something community can help with?
09:26:33 <M4rtinK> as the other side does complain about echo some times even now
09:26:51 <M4rtinK> (all mentioned  in the question)
09:26:55 <sledges> tortoisedoc: maybe jusa could point you in the right direction to take some tasks off his table ;)
09:27:25 <tortoisedoc> sledges : I have no xperia yet so cant test /(
09:27:27 <tortoisedoc> :/
09:27:30 <sledges> all i have is this commit/file, but there be dragons: https://github.com/sonyxperiadev/device-sony-suzu/commit/b5efeeece389200899a13368f2e65510d343a446
09:28:08 <abranson> here's another two that might be relevant: https://github.com/sonyxperiadev/device-sony-suzu/commit/d3f13cba0b38b141fcd248710d33e190d1e3333b   https://github.com/sonyxperiadev/device-sony-suzu/commit/59103648114943e6b0a5d5502b93b4ca070073b3
09:28:10 <sledges> if https://cdn-images-1.medium.com/max/455/1*snTXFElFuQLSFDnvZKJ6IA.png ;)
09:28:26 <Jaymzz> #link https://github.com/sonyxperiadev/device-sony-suzu/commit/b5efeeece389200899a13368f2e65510d343a446
09:28:37 <Jaymzz> #link https://github.com/sonyxperiadev/device-sony-suzu/commit/d3f13cba0b38b141fcd248710d33e190d1e3333b
09:28:45 <Jaymzz> #link https://github.com/sonyxperiadev/device-sony-suzu/commit/59103648114943e6b0a5d5502b93b4ca070073b3
09:29:03 <Jaymzz> I'm not gonna # link that meme :D haha
09:29:21 <stephg> shame :D
09:29:22 <sledges> that's just precaution, just like entering about:config in firefox:))
09:29:24 <tortoisedoc> :D
09:29:34 <M4rtinK> I gues we should also info echo cancellation not being used
09:29:50 <jusa> pretty much what sledges and abranson said
09:30:00 <tortoisedoc> hmm hw not working on aosp sounds fishy
09:30:03 <tortoisedoc> (in a bad sense)
09:30:12 <M4rtinK> yeah
09:30:17 <sledges> #info echo cancellation is not (or not fully) in place, which needs to be addressed, and the links above should help ^
09:30:32 <abranson> they'd be really really happy if we fixed something and upstreamed it
09:30:36 <Jaymzz> sledges: beat me to it :D
09:30:59 <jenix> any chance getting support from sony on that one?
09:31:12 <tortoisedoc> abranson you say sony themselves do not know why its not working?
09:31:19 <Jaymzz> time is up for this topic, better wrap it up fast :)
09:31:31 * tortoisedoc gets the ropes
09:31:45 <Jaymzz> M4rtinK: are you done with this one? :)
09:32:01 <M4rtinK> yep, from my side
09:32:21 <Jaymzz> alrighty. we can continue the rest of it during general discussion
09:32:25 <Jaymzz> #topic Harbour/Store: support for paid applications (15 min) asked by naytsyrhc
09:32:34 <Jaymzz> #info some details about the topic: Recently on TJC the question about support for paid apps came up again. There is a very old question about that on TJC, never really answered by Jolla. There are developers out there, that would like to provide apps for Sailfish OS, if they can monetarize them. There is flattr support already implemented, but that's not the same as a "real" support for paid apps. Furthermore a recent discussion on
09:32:34 <Jaymzz> TJC states, that flattr may not be the preferred solution anymore due to acquirance of flattr by some third party with unknown goals. Some users at TJC also see the lack of support for paid apps to be the reason for a poor state of the sailfish ecosystem. So the simple question is "Do you intend to support paid software in any foreseable future, or not. Please give a simple and straightforward answer: YES or NO". If "YES" then when
09:32:34 <Jaymzz> . If "NO" then end of story
09:32:44 <Jaymzz> #link https://together.jolla.com/question/6522/harbourstore-support-for-paid-applications/
09:32:55 <Jaymzz> #link https://together.jolla.com/question/159741/request-replace-flattr-from-jolla-store/
09:33:03 <Jaymzz> #link https://together.jolla.com/question/171977/the-state-of-paid-sailfish-apps-and-app-ecosystem/
09:33:13 <naytsyrhc> Jaymzz: Thanks. Just wanted to enter almost that. :-)
09:34:08 <naytsyrhc> So, that's the question. What's the status about that? The only answer once given by cybette was "Hi there, we are actively working on something but we don't have anything to announce at this point. I know this is not what you want to hear exactly, but that's the best "some words" I can offer right now... cybette (Apr 9 '15)edit"
09:34:23 <naytsyrhc> that's 2 and a half years ago
09:34:31 <Jaymzz> Alright naytsyrhcI'm gonna go ahead and give you the answer you want: Short answer is yes. But it might not be implemented as you and I are used to. I can't comment much more at the moment because this still has a while on it and quite a way to go. But getting to the app ecosystem is very important for us indeed and we will get to it when it's time.
09:34:48 <tortoisedoc> :O wow
09:34:49 <M4rtinK> frankly, the store overall seems just frozen in time in all aspects
09:35:01 <sledges> answer equivalent to cybette (coincidence? i'd say no ;)))
09:35:12 <tortoisedoc> D:
09:35:22 <stephg> cool
09:35:35 <M4rtinK> but given now, in 2017 ;-)
09:35:42 <naytsyrhc> Ok. Thanks. You probably know that the time frame to get some still active developers from Blackberry to port their applications is short. They could change to android.
09:35:45 <sledges> definitely worth staying tuned for this one:)
09:36:14 <tortoisedoc> hopefully the developers will get a head-start when its ready :P
09:36:21 <r0kk3rz> naytsyrhc: surely not being able to buy a device in Canada&US is also a major stumbling block for them
09:36:37 <jenix> So, is it "soon TM" as in "we thought about it" or more "soon TM" like "we started implementing it, but are not done yet"? :)
09:36:50 <sledges> jenix: in between? ;)
09:36:54 <M4rtinK> I guess Jolla setting up for Sailfish X payments might help there
09:36:57 <Jaymzz> naytsyrhc: You see, incidentaly my answer was very similar to cybette's :D but this time it's something completely different that we are working on. For now it is not even close to being implemented into the system so I won't hold my breath for too long
09:37:02 <naytsyrhc> r0kk3rz: I think there are developers apps for blackberry from other countries as well ;-)
09:37:29 <r0kk3rz> jenix: SoonTM - Timespan - Somewhere between next week and heat death of the universe
09:37:33 <eekkelund> Completely different.. cryptos are quite different.. :D
09:37:43 <jenix> sledges: so "we made plans and meetings, but have to code more important stuff"? :)
09:38:11 <naytsyrhc> Jaymzz: thanks again for the answer. I (as a user) just can't understand the challenges and why it will take so long. Shouldn't Jolla be interested to do it to get more money?
09:38:13 <Jaymzz> jenix: Soon TM ;) it is now in the planning phase. It's gonna be a new thing in the mobile world. Let's wait nd see
09:38:24 <sledges> jenix: not quite, we aren't putting this on the back burner, bear with us on that
09:38:37 <sledges> naytsyrhc: it's finnish laws
09:38:47 <jenix> ok, thanks
09:39:13 <tortoisedoc> sledeges : about paying for goods / services vs support money?
09:39:18 <tortoisedoc> (and relative taxation)
09:39:21 <sledges> yes
09:39:35 <naytsyrhc> sledges: but it's not impossible I'd presume. Nokia hat a store as well and is/was a finish company as well. :-D
09:39:47 <naytsyrhc> had ^
09:39:54 <sledges> naytsyrhc: they found a way to tackle that, so shall we
09:39:56 <Jaymzz> naytsyrhc: oh absolutely, everyone wants more money :D as the challenges we faced previously, I honestly don't know about them as I was not in the company back then. But the challenges now are in a different league. As I said, we are planning to bring a new game onto the table which is completely new to the mobile world. That should not only be limited to "paid apps" either. Let's see how it goes...
09:39:56 <tortoisedoc> yeah Jolla could reboot the nokia ovi and rebrand it to jolla ovi :P
09:40:11 <r0kk3rz> Jaymzz: anything to do with carstens new plan?
09:40:29 <PeperJohnny> Don't forget that Nokia was by a magnitude bigger and therefore had a bit more political influence ;)
09:40:50 <naytsyrhc> Ok. And how about cooperating with an existing store like opera store in the meantime?
09:41:07 <Jaymzz> r0kk3rz: I can't comment on what it can be related to honestly, it's in very early stage which means there is always a chance for it "not happening" therefore I reserve it for when we have a more concrete plan :)
09:41:21 <sledges> r0kk3rz: i thought that didn't pan out
09:41:25 <naytsyrhc> just to attract the developers and not loose them to make money on play store/ apple store?
09:41:38 <r0kk3rz> sledges: check the current pivot :)
09:41:46 <sledges> ah good to know!
09:42:20 <tortoisedoc> r0kk3rz : which plan :P
09:42:21 <sledges> naytsyrhc: different nature of apps?
09:42:24 <Jaymzz> naytsyrhc: But opera store isn't Sailfish store, right? :D
09:43:01 <tortoisedoc> that'd suck to have to download SFOS sw from a non-SFOS store (sorry naytsyrhc)
09:43:20 <tortoisedoc> its like meego / Symbian moving to opera
09:43:21 <r0kk3rz> Jaymzz: thanks, sounds cool anyway I had honestly thought jolla had completely given up on the idea
09:43:26 <tortoisedoc> tombstone :|
09:43:51 <jenix> Jaymzz: But they have all the infrstructure needed which maybe can be adapted to SFOS relatively easy... and maybe with residenting in antoher country the legal issues may be easier to tackle?
09:43:59 <Jaymzz> r0kk3rz: No of course not. We understand developers' concerns and they are very much valid concerns we are talking about here.
09:44:05 <jenix> But we will wait and see :)
09:44:10 <naytsyrhc> Jaymzz: that was just the question because "your" solution seems to be some time aways. My concern is: currently there are still developers active for QT based applications like on Meego/Blackberry. If htey have no chance to moneterize their apps on e.g. sailfish in the near future. maybe they switch to android and will probably never come back
09:44:41 <leszek> naytsyrhc: most of them did so already
09:44:55 <Jaymzz> jenix: naytsyrhc I will bring that up internally to see if that could be a possibility :)
09:44:57 <leszek> so no time pressure here
09:45:22 <Jaymzz> and the time for this one is almost over too
09:45:24 <naytsyrhc> So "opera store" cooperation of course should be implemented/integrated within jolla store. But maybe they can handle payment?
09:45:51 <naytsyrhc> leszek: but there are still a few. Would be sad to loose them as well.
09:46:01 <jenix> naytsyrhc: that could also be a separate store for me - the biggest issue probably is the integration into the system
09:46:34 <naytsyrhc> jenix: would probably be ok as an intermediate solution.
09:46:36 <jenix> in that you can purchase, install and update apps easily from within the store app
09:46:43 <Jaymzz> leszek: naytsyrhc: Developers will come back when they see a potential market when monetization is possible :)
09:47:00 <r0kk3rz> yeah... we'll see
09:47:07 <jenix> naytsyrhc: well, it should not be any more than an interim solution
09:47:19 * sledges the number of comebacks i've seen (e.g. from users) .. :)
09:47:31 <leszek> naytsyrhc: for them (I talked to few of them as I am active in the BB community aswell) they don't only need a good store but also a powerful API. The ones I talked about porting things over are dissappointed about the SailfishOS API which is nowhere near what they had in BB10
09:47:36 <PeperJohnny> Also transition from one store to the next one, might not be viable for some developers for such a "small" ecosystem
09:48:09 <Jaymzz> Time's up for this topic
09:48:10 <naytsyrhc> So. Time is probably over. Thank you for openly communicating something. I hope the solution or any intermediate solution will see the light soon.
09:48:20 <sledges> thanks for lots of new ideas!
09:48:30 <tortoisedoc> sledges : blockchain :P
09:48:39 <jenix> Good point, PeperJohnny. But maybe there could be a possibility to migrate the whole store into the new, shiny one when it's ready
09:48:40 <Jaymzz> naytsyrhc: Thanks to you and everyone else for the ideas and this topic :)
09:48:57 <naytsyrhc> Jaymzz You're welcome
09:49:10 <sledges> tortoisedoc: we'll blockchain all your suggested ideas yep, and then see what comes out:D
09:49:11 <Jaymzz> moving on
09:49:13 <Jaymzz> #topic General discussion (20 min)
09:49:32 <sledges> subtopic: actions from last meeting:
09:49:33 <tortoisedoc> sledges : you will block in chains? :P
09:49:34 <r0kk3rz> tortoisedoc: JollaCoin!
09:49:51 <sledges> i'm still working on pinging the right developers, getting to the core: https://together.jolla.com/question/171114/xperia-xbug-qtwebkit-unusably-slow/
09:50:06 <sledges> can be a BRGA RGBA problem (to those in the know)
09:50:07 <jenix> r0kk3rz: mining directly on the phones for better battery life? :p
09:50:14 <sledges> will post on TJC when clearer
09:50:33 <r0kk3rz> jenix: i saw a blockchain project that wanted to do phone based mining :)
09:50:50 <tortoisedoc> question about Jala / SailfishOS expanding; It'd be interesting to get a device-based split view in harbour. that possible?
09:51:16 <r0kk3rz> tortoisedoc: dont he developer side?
09:51:17 <tortoisedoc> (the relative numbers  for example)
09:51:20 <r0kk3rz> *on the
09:51:30 <sledges> tortoisedoc: Alice in Chains, and Chains by the Beatles :D
09:51:31 <tortoisedoc> r0kk3rz : w0t?
09:52:01 <jenix> tortoisedoc: You mean a statistic about how many active SFOS devices (and which models) there are?
09:52:16 <tortoisedoc> sledges : Chains of Sorrow, John Prine :P
09:52:25 <PeperJohnny> So asking as a dumb user. Will the new firefox 57 quantum bring any difficulties to updating the jolla browser?
09:52:34 <tortoisedoc> jenix : installation base per device type yes
09:52:41 <eekkelund> r0kk3rz: one can join to minergate.com with android phone. CPU mining Monero is not bad idea with phone :)
09:52:41 <tortoisedoc> (as in installation split
09:52:42 <tortoisedoc> )
09:52:47 <Mister_Magister> PeperJohnny: sailfish browser is still on 38 or so
09:53:06 <tortoisedoc> jenix : currently we have only total nr of active + installed apps
09:53:09 <leszek> sledges: yeah I also expect BRGA RGBA problem
09:53:13 <PeperJohnny> Mister_Magister: ah ok thanks for the info
09:53:21 <tortoisedoc> would be great to have also per-device split
09:53:26 <tortoisedoc> like
09:53:32 <tortoisedoc> Xperia X : 40000
09:53:35 <tortoisedoc> OTH : 40000
09:53:38 <jenix> tortoisedoc: that would indeed be interesting. But I think we'll have to ask Jaymzz for that
09:53:38 <tortoisedoc> JollaC 1
09:53:39 <tortoisedoc> :p
09:53:48 <tortoisedoc> Jaymzz : ^
09:53:56 <stephg> tortoisedoc: make a question in TJC about it?
09:54:10 <tortoisedoc> id rather discuss it here? :P
09:54:31 <tortoisedoc> a topic in harbour is going backwards imo cause this is jolla action plan
09:54:44 <tortoisedoc> (community cannot and does not mantain harbour)
09:54:50 <Jaymzz> tortoisedoc:  I'm sorry but I am having a hard time understanding what you mean by split...
09:55:00 <leszek> sledges: reason is LLs Video Player I had to make all opacity 0 elements invisible otherwise video would stutter. Which seems to be the same reason. Also when changing the webviews layer properties I can see improvements in speed when disabling the transparent layers. Though that does not qualify as total workaround
09:55:02 <sledges> group by device
09:55:03 <jenix> tortoisedoc: I'm not sure, if Jolla have such data. and if they do, if they want to publish it, as it gives quite some insight into their financial situation
09:55:10 <Jaymzz> sledges: thanks!
09:55:31 <tortoisedoc> jenix : why? its developer-based only
09:55:37 <tortoisedoc> the same you can say of the total nr of installed apps
09:55:51 <pketo> tortoisedoc: in theory it would be possible, but unfortunately we don't have resources to implement it at the moment
09:55:59 <tortoisedoc> there we go :P
09:56:02 <Jaymzz> tortoisedoc: Why would you want that again? :) just trying to understand everything properly
09:56:10 <Mister_Magister> jolla doesn't have resources for anything :D
09:56:15 <tortoisedoc> Jaymzz : clearer view on markets /users?
09:56:15 <sledges> leszek: thanks, from TJC was hard to identify how to reliably reproduce slugishnes, for me jolla email is fast and smooth, only page transitions from list of email to email content (webview) is stuttering - is this the key? (i'll pass this all to our dev)
09:56:24 <jenix> tortoisedoc: well, at least at the moment, you can estimate that most of the xperia x devices have a pruchased license
09:56:55 <Jaymzz> Mister_Magister: Try maintaining 113 million lines of code in an operating system with a team of 40-50 people and let me know if you have resources left over :D
09:57:00 <sledges> Mister_Magister: and yet we have an OS being productised :)
09:57:10 <leszek> sledges: yeah exactly. You can also try out webcat and scrolling around on webpages to see the slugishness. The native UI elements like bookmarks behave normally when scrolling. The webview stutters
09:57:16 <tortoisedoc> pketo : if the data is available, perhaps providing an api to it would be enough
09:57:21 <Mister_Magister> Jaymzz: sledges: i know i know chill guys :D
09:57:28 <SfietKonstantinW> :D
09:57:31 <sledges> Mister_Magister: can't chill, no time xD
09:57:38 <SfietKonstantinW> o/ btw, but just following the meeting with one eye
09:57:39 <sledges> leszek: and transparency is another way to reproduce?
09:57:42 <tortoisedoc> jenix : it's not about the user base, but to know which devices are using my app!
09:57:51 <sledges> o/ SfietKonstantinW SfietKonstantinW :))
09:57:52 <tortoisedoc> its relevant for example for testing
09:57:52 <Mister_Magister> no time for chilling or breathing :D
09:58:03 <Jaymzz> tortoisedoc: I got you. Well, maybe that could be something we could do in the future when we have more time to spend on it and put it as priority item
09:58:13 <Jaymzz> Mister_Magister: no resources for chill XD
09:58:18 <leszek> sledges: at least on LLs video player having an element with opacity 0 on top of the video works on every other device  but the xperia x where it causes a stuttery video
09:58:31 <Mister_Magister> Jaymzz: i like this one xD
09:58:53 <tortoisedoc> Jaymzz : ofc other possiblity is for developer to start collecting imei's
09:58:56 <leszek> sledges: just download the 1.9.4 version of LLs Video Player and try playing back any video it will stutter. Git has this fixed
09:59:23 <jenix> tortoisedoc: ah, so you want additional statistics for app developers in the store which tells you how often an app is installed on the different device models. Then I have totally understood you wrong, I thought you talked about a general statistic of how many active SFOS devices there are
09:59:33 <sledges> leszek: thanks that's very useful, and got you https://github.com/llelectronics/videoPlayer/commit/72d446a9019811cba1f311bc01f7cf7150344012 :)
09:59:36 <tortoisedoc> jenix : exactlu
09:59:40 <tortoisedoc> *exactly
10:00:02 <tortoisedoc> Jaymzz : if the data is available already, I do not believe this to be such a big task to implement - one day?
10:00:12 <jenix> (the later would probably also be interesting never-the-less :D )
10:00:23 <tortoisedoc> one query -> one new section in the home page of harbour -> done? :P
10:01:07 <pketo> tortoisedoc: api would need to be implemented also, and public api also needs to be maintained. so it does not really make things any easier :)
10:01:18 <Jaymzz> pketo: what would you say to tortoisedoc's statement? is the data already available? does it take only a day to implement such a thing?
10:01:26 <Jaymzz> oh you already answered pketo sorry
10:01:39 <tortoisedoc> Jaymzz : he answered my prev question :P
10:01:53 <sledges> it needs to be approved by Jala as well and any other partners, and most companies in this world like to keep their cards close to their chest
10:01:57 <Jaymzz> okay my head's spinning XD
10:02:04 <tortoisedoc> :D
10:02:19 <tortoisedoc> sledges : but this is apps, not installed licenses?
10:02:33 <tortoisedoc> (free apps i'd like to add)
10:02:43 <sledges> tortoisedoc: can't-live-without-apps will aproximate to # of licences
10:03:02 <tortoisedoc> sledges : same can be said already of information available now?
10:03:05 <tortoisedoc> :p
10:03:12 <sledges> but not split by device :P
10:03:16 <tortoisedoc> :D
10:03:42 <tortoisedoc> wheres the difference, sum is even more clear than a split :p
10:03:52 <sledges> more is more ;P
10:03:57 <tortoisedoc> no, less is more :p
10:04:11 <Mister_Magister> what the… ?
10:04:21 <Mister_Magister> bigger is smaller or smaller is bigger?
10:04:22 <tortoisedoc> sorry got derailed
10:04:27 <abranson> so the solution is to write a killer app for each device!
10:04:35 <r0kk3rz> Mister_Magister: its a saying :)
10:04:36 <tortoisedoc> ha
10:04:47 <tortoisedoc> abranson : I wonder, can you actually do that
10:04:58 <sledges> tortoisedoc: still on track ;) sum is what you want to tell your future business partners, not splits ;P
10:05:00 <tortoisedoc> from open repos surely
10:05:17 <jenix> isn't input text prediction the current "killer-app" that's only available for Xperia X devices?
10:05:19 <tortoisedoc> sledges : as said, this is for developers and mainly to know where to focus efforts on?
10:05:22 <r0kk3rz> tortoisedoc: do some sneeky data collection on your own, everyone else is
10:05:23 <tortoisedoc> (see testing for instance)
10:05:37 <sledges> tortoisedoc: but it doesn't prevent anyone checking those numbers
10:05:45 <tortoisedoc> r0kk3rz : im not sneeky I want jolla do to the dirty jon :P
10:05:47 <tortoisedoc> *job
10:06:07 <Jaymzz> 5 min left here
10:06:23 <tortoisedoc> sledges : from harbour? only devs have acces there..
10:06:26 <Mister_Magister> jenix: what?
10:06:27 <tortoisedoc> (to their own apps=
10:06:28 <tortoisedoc> )
10:06:33 <jenix> ah, never mind
10:07:16 <tortoisedoc> sledges I stand my case, your argument makes sense only if one developer would know about the split of all apps on all devices
10:07:17 <sledges> tortoisedoc: i'm talking jolla store sorry misunderstanding, yet still a way of knowing
10:07:48 <inte> sorry i didnt put this on the list but is there any chance to get vowifi/volte working on sailfishx at any point?
10:07:48 <sledges> tortoisedoc: so you are asking for stats only for your ap?
10:07:49 <sledges> ok
10:07:57 <tortoisedoc> yes
10:08:02 <tortoisedoc> :)
10:08:18 <sledges> now we got this clear ;)
10:08:29 <tortoisedoc> app a -> installs on Xperia 40000 Installs on OTH 40000 Installs on JC 1 :P
10:08:35 <jenix> sledges: I was confused by this as well :)
10:08:41 <sledges> other actions from last meeting: no news on camera focus issues, but i'll keep mentioning it ;)
10:08:51 <tortoisedoc> Jaymzz : sledges agrees :P
10:08:53 <tortoisedoc> ^
10:09:07 <Mister_Magister> yeah i didnt get what you all are talking about
10:09:18 <Mister_Magister> now it has sense
10:09:34 <tortoisedoc> pketo : would it be less work to only get data visible in dev harbour?
10:09:36 <Jaymzz> tortoisedoc: honestly it took me a while too to understand the what and why :D
10:09:37 <tortoisedoc> (per app)
10:10:00 <tortoisedoc> Jaymzz : that's my fault, forgot to mention the "per app" part
10:10:02 <M4rtinK_> there are already cases where things don't work well on the Jolla 1
10:10:11 <Jaymzz> tortoisedoc: maybe you would wanna discuss this during the next meeting now that we have a pretty good idea of what is going on
10:10:12 <phlixi_mobile> inte: check log from last(?) meeting?
10:10:18 <pketo> tortoisedoc: not really
10:10:23 <M4rtinK_> due to slow hardware and or old Open GL version (Rinigius hit it recently with Mapbox GL widget porting)
10:10:25 <Jaymzz> time is up, and it's better and more organized if you have your own topic regarding that
10:10:30 <inte> phlixi_mobile: oh ok thanks
10:10:32 <Jaymzz> what do you say tortoisedoc?
10:10:37 <tortoisedoc> Jaymzz ok
10:10:39 <M4rtinK_> so it would be good to know how many users with a Jolla 1 are using an app
10:10:49 <tortoisedoc> also yes
10:10:58 <Jaymzz> tortoisedoc: I think you can dedicate 20 min to your topic so we can milk it properly
10:11:01 <sledges> Jaymzz: tortoisedoc got his answer from pketo
10:11:11 <sledges> it's quite clear now in the end
10:11:12 <tortoisedoc> sledges : i still stand my case :P
10:11:26 <tortoisedoc> one query -> web page result integration
10:11:30 <M4rtinK_> similar way with Jolla (and hopefully Youyouta tablet in the future) - how many tablet users are there ? should I prioritize tablet specific UI improvements ?
10:11:31 <tortoisedoc> (optimal case)
10:11:32 <sledges> #info Jolla has no resources to implement stats for developer to see their app per device installs
10:11:42 <Jaymzz> sledges: okay, understood
10:11:44 <sledges> #info in Harbour
10:12:02 <tortoisedoc> bummer :[
10:12:14 <Jaymzz> anyhow we need to move on as time is up
10:12:20 <sledges> it sounds simple to implement, but it usually isn't ;)
10:12:28 <Mister_Magister> M4rtinK_: me lol
10:12:32 <tortoisedoc> sledges : its not about the complexity here, obviously
10:12:35 <Jaymzz> #topic Next meeting’s time and date (5 min)
10:12:36 <M4rtinK_> sledges: so talking store - what about new comment notifications at least ? ;-)
10:12:53 <Jaymzz> November 30th 2017 at 09:00 UTC. what y'all say?
10:13:01 <M4rtinK_> I still have to manually check my app in the store app to see if there is any feedback/question from users
10:13:03 <Mister_Magister> all good +1
10:13:05 <tortoisedoc> sledges : its understandable you guys are working hard and are busy
10:13:07 <sledges> M4rtinK_: there have been informal talks internally, so keep bringing this up ;)
10:13:15 <ljo> +1
10:13:20 <tortoisedoc> sledges : but still disappointing to see no support whatsover for devs
10:13:28 <M4rtinK_> sledges: well, I guess I can keep doing that...
10:13:34 <tortoisedoc> :)
10:13:38 <sledges> tortoisedoc: and i also know a few examples of implementing simple cases, that turned complex, believe me how many "hysterical reasons" we have in the world of code we work with;)
10:13:51 <Jaymzz> #info Next meeting will be held on November 30th 2017 at 09:00 UTC
10:13:58 <M4rtinK_> yeah, *any* sign of improvements in store would be welcome...
10:14:13 <sledges> M4rtinK_: topic for next meeting (the date of which we're determining now)
10:14:48 <M4rtinK_> sledges: could be, I'll submit it based on my availability
10:14:48 <inte> phlixi_mobile: so in brief - no sip(gui), no volte. i think volte is not plain sip since it requires sim-based auth and handover to csd though
10:14:52 <Jaymzz> Yeah any topics in mind please do not hesitate to create them on the planning page
10:15:19 <inte> volte does not necessarily require a sip-gui though...
10:15:22 <Mister_Magister> if only purple had sip plugin…
10:15:28 <M4rtinK_> so if someone wants to handle that & submit the topic right now (store improvement for devs), go ahead! :)
10:16:24 <Jaymzz> guys all of these can be discussed during the next meeting
10:16:25 <sledges> Jaymzz: meeting date sounds good
10:16:36 <Jaymzz> sledges: thanks, we shall end this meeting now :)
10:16:42 <Jaymzz> thanks everyone for participating
10:16:47 <Jaymzz> see you in 2 weeks
10:16:50 <Jaymzz> #endmeeting