11:00:15 <Jaymzz> #startmeeting Sailfish OS, open source, collaboration – December 21st 2017
11:00:15 <merbot> Meeting started Thu Dec 21 11:00:15 2017 UTC.  The chair is Jaymzz. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
11:00:15 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
11:00:26 <Jaymzz> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-December/008153.html
11:00:35 <Jaymzz> I am the meeting’s chairperson today and will be doing my best to keep time and order. Please behave, respect the timings and be gentle.
11:00:45 <Jaymzz> #topic Brief introduction (5 min). Please prefix your name/handle with # info
11:00:49 <Mister_Magister> #info Mister_Magister, community, mad porter
11:00:57 <Mister_Magister> hi Jaymzz
11:01:00 <peperjohnny> #info peperjohnny, community
11:01:01 <Jaymzz> #info James Noori, sailor @ Jolla
11:01:05 <peperjohnny> hey guys
11:01:12 <Jaymzz> Mister_Magister: o/
11:01:21 <Jaymzz> peperjohnny: \o
11:01:33 <bshah> #info bshah, KDE, Plasma, Community
11:01:47 <peperjohnny> Jaymzz: o/
11:02:10 <pavi[m]> #info pavi, community
11:02:15 <tbr> #info tbr, mer community and such
11:02:29 <M4rtinK_phone_> #info Martin Kolman, modRana & community
11:02:32 <sledges> #info Simonas Leleiva, sailor @ Jolla
11:02:59 <stephg> #info Steph Gosling, community, porter
11:03:27 <dcaliste> #info Damien Caliste, community
11:05:17 <Jaymzz> Not so many today I see, everyone's busy with holidays already or is it the timing this time? Or both.
11:05:31 <peperjohnny> probably both
11:05:40 <tortoisedoc> #info tortoisedoc developer
11:05:40 <Jaymzz> #topic: keyboard to have an optional row with digits above letters (asked by remote – 10 min)
11:05:54 <pasko_> #info pasko sailor
11:05:57 <Jaymzz> #info Asking for implementing an option for keyboard to have an optional row with digits above letters, so one doesn't have to constantly switch back and forth, for those willing to sacrifice some screen estate for convenience.
11:06:05 <tortoisedoc> or the end of the world as we know it? :P
11:06:07 <r0kk3rz> moin
11:06:17 <Jaymzz> tortoisedoc: could be :D
11:06:22 * tbr feels fine
11:06:30 <piggz> #info piggz community porter
11:06:37 <Jaymzz> do we have remote around? I don't see him/her.
11:06:45 <hschmitt> #info hschmitt community
11:07:11 <Mister_Magister> Jaymzz: i think numbers when you hold qwertyuiop keys would be good too. i made that already but that hold menu takes so long to appear
11:07:39 <Jaymzz> Mister_Magister: not a bad idea actually
11:07:54 <Mister_Magister> Jaymzz: just make timing shorter
11:07:54 <Jaymzz> I am unsure if we have anyone who could answer this properly today
11:07:58 <sledges> it's quicker to switch to symbols than wait for a popup
11:08:11 <Mister_Magister> sledges: because popup take so loong
11:08:15 <Mister_Magister> it should be shorter
11:08:31 <Jaymzz> sledges: depending on how quick you are :P but yeah
11:08:31 <piggz> im trying out the presage keyboard atm ... its good, but the layout seems to switch back to normal sometimes
11:08:39 <Mister_Magister> eveni  cant use special polish chars like ąść using popup because it takes so long
11:08:58 <Mister_Magister> i need to pres button for special chars
11:09:03 <sledges> but more to the question point: what should those numbers show when symbol layout is on, and what to do for keyboards that have more or less than 10 keys in the upper row?
11:09:30 <Jaymzz> maybe a configurable time for popup buttons?
11:09:49 <piggz> sledges: they could show the symbols you mormally get on number keys
11:09:59 <piggz> giving more space below for other symbols
11:10:00 <r0kk3rz> sledges: arrow keys?
11:10:07 <Mister_Magister> Jaymzz: sure and option that numbers are in standalone row and on popup cuz some will prefer row
11:10:23 <Mister_Magister> r0kk3rz: tab button
11:10:23 <sledges> piggz: but that would throw muscle memory away
11:10:50 <r0kk3rz> maybe we need a better way to have custom keyboards, since i dont think theres a one size fits all :)
11:10:59 <Jaymzz> sledges what do you think if we make this an # action for now as we don't have a UI person in the grop to answer the topic properly?
11:11:08 <tortoisedoc> custom kb + 1
11:11:15 <tortoisedoc> including swype :)
11:11:22 <Jaymzz> as in like, action for you or me to forward this :)
11:11:25 <sledges> Jaymzz: agreed
11:11:36 <Jaymzz> alright
11:11:58 <Jaymzz> #action jaymzz to forward this request to the UI team and come back with an answer during the next meeting
11:12:04 <Mister_Magister> but that popup would be good and easy to do i think
11:12:07 <Mister_Magister> its like 30 minutes
11:12:09 <Mister_Magister> of work
11:12:16 <Mister_Magister> nothing fancy
11:12:37 <Mister_Magister> (i did that so i know its 30minutes or less)
11:12:38 <dr_gogeta86> #info Fabio Isgrò late as usual
11:12:47 <Mister_Magister> hello doc
11:12:48 <remote_> hi, sorry, I'm late
11:12:51 <Jaymzz> I have all the ideas here (popup + the original idea) I will dicuss it and will get back to you guys. Especially that remote wasn't here to back the question with more ideas I think this is the best course of action
11:12:58 <Jaymzz> oh hai remote :D
11:13:26 <remote_> I'll read the log later then
11:13:40 <Mister_Magister> you just came at the end yof your topic :D
11:13:47 <Jaymzz> remote_: so what do you think? I am going to being this up with the UI team and get back to you during the next meeting
11:13:51 <tortoisedoc> one is never too late :P
11:13:58 <tortoisedoc> (enoug)
11:14:02 <remote_> well I was hoping to see the same keyboard layout as in android on sony
11:14:12 <remote_> usual qwerty plus 1 row with digits above
11:14:25 <Jaymzz> remote_: Will bring it up
11:14:26 <Mister_Magister> like i said :P
11:14:33 <Mister_Magister> some prefers row
11:14:39 <Mister_Magister> some prefers popup
11:14:55 <Mister_Magister> and if you cant choose one make an option (thats my motto while programming ui :D )
11:15:07 <Jaymzz> yeah so in the end it will be a "why not both" situation and we will see if we have the time to implement them
11:15:11 <remote_> screen size on sony X is good, so why not convenient alway-son row
11:15:40 <Jaymzz> good point remote_
11:15:41 <piggz> or, replace keyboard with the one from fingerterm ... full power ;)
11:15:52 <Jaymzz> but we need to move on now as the time is up for this topic.
11:15:58 <dr_gogeta86> fingerterm need a topic ...
11:16:13 <Mister_Magister> yeah fingerterm is like "well its working…"
11:16:24 <Jaymzz> dr_gogeta86: Make a topic for the next meeting, you ar emore than welcome!
11:16:41 <dcaliste> dr_gogeta86: open a TJC question, it's open source, we can adjust what we want.
11:16:44 <Mister_Magister> Jaymzz: 30 minutes is not so many time lets be serious
11:17:05 <Jaymzz> Mister_Magister: sorry what?
11:17:32 <Mister_Magister> nothing move on
11:17:37 <Jaymzz> #topic Upstreaming of mer/sfos specific QtMultimedia patches (asked by bshah – 15 min)
11:17:48 <Jaymzz> I tried to use gst-droid and droidmedia working on top of Qt 5.9 but had a quite a lot struggle as the qtmultimedia patches required are on top of Qt 5.6 and not upstreamed, it would be lovely if original author can upstream those patches where it makes sense.
11:17:52 <pavi[m]> Maybe user setting to choose is a good idea,
11:18:03 <Jaymzz> pavi[m]: Sure :)
11:18:07 <bshah> Hello
11:18:14 <Jaymzz> hi bshah
11:18:15 <r0kk3rz> ahoy bshah
11:18:22 <bshah> So, out of 15 minutes I guess I will just use 5 mins
11:18:23 <bshah> :p
11:18:26 <sledges> #info I tried to use gst-droid and droidmedia working on top of Qt 5.9 but had a quite a lot struggle as the qtmultimedia patches required are on top of Qt 5.6 and not upstreamed, it would be lovely if original author can upstream those patches where it makes sense.
11:18:41 <Jaymzz> sledges: thanks, it slipped :P
11:18:50 <bshah> so essentially I did delta the qtmm fork of mer-core : http://github.com/bhush9/qtmultimedia-patches
11:18:53 <sledges> off the Cpt Hook ;)
11:18:58 <bshah> and asked if it can be upstreamed
11:19:07 <tortoisedoc> Cpt hook?
11:19:09 <bshah> and chrisadm agreed to help me with this
11:19:21 <tortoisedoc> hm is qt5.9 next in line for sfos?
11:19:26 <bshah> so essentially this happened just today : http://merproject.org/logs/%23mer/%23mer.2017-12-21.log.html#t2017-12-21T02:17:20
11:19:32 <tortoisedoc> or, next targeted qt upgrade?
11:20:32 <bshah> In general sfos/mer have lots of patches which needs upstreaming everywhere ... :)
11:20:47 <Jaymzz> #link http://merproject.org/logs/%23mer/%23mer.2017-12-21.log.html#t2017-12-21T02:17:20
11:20:50 <bshah> I think I am done with my topic ;)
11:21:10 <tortoisedoc> so I guess that's a yes to my qt5.9 question ;)
11:21:16 <sledges> #info has been upstreamed by chriadam_, many thanks Chris, great effort!!
11:21:21 <Jaymzz> bshah: cool :D thanks to chriadam_! Moving on then
11:21:24 <M4rtinK> lots of nice stuff and most importantly *fixes* in new Qt
11:21:36 * tortoisedoc cant wait
11:21:41 <Jaymzz> #topic Update of PulseAudio (asked by peperjohnny – 10 min)
11:21:42 <stephg> oo
11:21:51 <Jaymzz> #link https://together.jolla.com/question/176087/update-pulseaudio-to-111/
11:22:03 <Jaymzz> #info I have been playing around with streaming sound from a Jolla phone to devices in my network, but the available ways of e.g. using a PulseAudio sink are not robust enough for daily use. With the update to 11.1 of PulseAudio and the inclusion of avahi some more ways would be possible e.g. RAOP and with it Airplay usage.
11:22:37 <peperjohnny> It was mentioned in the tjc that there are technical reasons against updating
11:22:43 <peperjohnny> are those still in the way?
11:22:51 <piggz> also , PA11 includes a bunch of fixes for eg BT HFP, so would be an advantage for cars
11:23:12 <M4rtinK> also it would be really nice if the general Qt upgrade cycle could be less of an issue in the future - Qt@Android developers can just bundle the newest Qt with their apps while developers for a proper Qt-native platform have to live with an old Qt version - that sucks
11:23:20 <Mister_Magister> jusa: maybe you can say something? if you are there
11:23:25 <sledges> #info From jusa: ">=v10 are breaking FM radio and bluetooth, and these need to be fixed. But I will push 11.1 branch of upgraded pulseaudio, and you can experiment with that proof-of-concept and the modules to see if you have a desired effect."
11:23:39 <tortoisedoc> M4rtinK : but android is not Qt-based :P
11:23:40 <bshah> I suppose droid module needs porting to newer APIs
11:23:50 <piggz> see https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/11.0/
11:23:53 <peperjohnny> sounds good
11:23:58 <jusa> piggz: yep, although it's not that simple, as the HFP (and bluetooth in general) is an interesting mix of android and pulseaudio, and as such just using the PA11 improvements is not possible, they need to be ported for our use case
11:24:07 <Jaymzz> #link https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/11.0/
11:24:08 <tortoisedoc> M4rtinK I guess that's the price you pay for tying up with a specific stack
11:24:17 <M4rtinK> tortoisedoc: I know it's an apples to oranges comparison a bit but it still sucks ;-)
11:24:22 <tortoisedoc> :D
11:24:29 <dr_gogeta86> about pulseaudio
11:24:47 <dr_gogeta86> since 2013 there isn't any hearcandy between alien and sfos
11:24:48 <piggz> jusa: what is easier, porting PA11, or fixing the current setup?
11:25:09 <piggz> and, what is more maintainable in the future?
11:25:54 <hschmitt> jusa: could you additionally configure a OBS build for that 11.1 branch?
11:25:55 <jusa> piggz: personally I want to be as up to date with upstream pulseaudio, but as you know it's not always that simple...
11:26:02 <piggz> sure
11:26:29 <tortoisedoc> M4rtinK : i guess at this point it's fair to say that SFOS developers are free to bundle their own version of Dalvik with the app
11:26:42 <tortoisedoc> (whenever it makes sense, I dont know )
11:26:45 <pvuorela> on that keyboard question, it would be tricky to have extra number row. landscape prediction bar + number row just wouldn't fit. would need to be option and depending on orientation. would double the number of symbol layouts etc.
11:27:03 <jusa> hschmitt: I'm not sure how to do that with mer obs, but I'm sure it would be possible
11:27:18 <tortoisedoc> about the keyboard, wouldnt a fully customizable kb make things easier?
11:27:30 <jusa> sledges: ^ or am I too fast with my promises? :D
11:27:42 <dr_gogeta86> sledges, aren't you a sailor ?
11:27:54 <pvuorela> tortoisedoc: you can already do your own layout files.
11:29:10 <sledges> jusa: hschmitt: we don't have a dedicated repo for such experiments, so anyone in their home project can do that (either jusa or peperjohnny)
11:29:23 <jusa> sledges: yep
11:29:49 <peperjohnny> ok
11:30:03 <hschmitt> sledges: I'll try to figure it out
11:30:05 <sledges> hschmitt: then you can use their repo just like that
11:30:45 <dcaliste> Sorry to be out of topic, I have to quit now and cannot wait for the general discussion. It's a follow-up of last meeting. I did look at the push imap bug. I've logs highlighting the bug, but I cannot figure out where it come from, code is very complex IMHO.
11:30:56 <dcaliste> I can send log to whoever interested.
11:31:17 <dcaliste> I'll continue to look at it and report at next meeting.
11:31:18 <sledges> i think we're done on pa topic? jusa Jaymzz peperjohnny ?
11:31:26 <peperjohnny> yep
11:31:28 <Jaymzz> I think so too
11:31:33 <Jaymzz> alright moving on
11:31:44 <Jaymzz> #topic General discussion (15 min)
11:31:49 <phlixi_o> Are there any plans to fix Camera and WLAN AP? The Xperia X is a strait downgrade for me as both is not working. I dont like it, but i have to stress, this, both are basic features in 2010 already...
11:32:15 <sledges> #info dcaliste: I did look at the push imap bug. I've logs highlighting the bug, but I cannot figure out where it come from, code is very complex IMHO. I can send log to whoever interested.
11:32:23 <Mister_Magister> i think there should be some followup from last meeting but cant remember
11:33:06 <dr_gogeta86> Jaymzz, sledges pvuorela  and other sailors here ... plan for 2018
11:33:07 <tortoisedoc> WLAN AP is not working on XPeria?
11:33:09 <sledges> #info more on that keyboard question by pvuorela: it would be tricky to have extra number row. landscape prediction bar + number row just wouldn't fit. would need to be option and depending on orientation. would double the number of symbol layouts etc.
11:33:15 <ApBBB> sledges: my j1 battery is starting to degrade. can we have a xz compact soonish :D
11:33:19 <dcaliste> Thank you sledges, see you guys next time.
11:33:35 <tortoisedoc> if thats not a "in&out"
11:33:35 <Mister_Magister> ApBBB: why not replace it?
11:33:56 <Jaymzz> dr_gogeta86: There are exciting things being planned for 2018. There will be an "end-of-year" blog post hnting on those + what we accomplished during 2017
11:34:05 <ApBBB> Mister_Magister: i'd like something beter speced :/
11:34:06 <sledges> tortoisedoc: wlan ap was fixed in 2.1.3 iirc
11:34:12 <Mister_Magister> ApBBB: why tho
11:34:13 <M4rtinK> any progress on open sourcing stuff ? basically anything would a a nice Christmas/New Years/Chinese New Years present! ;-)
11:34:17 <phlixi_o> ApBBB i hope not. the xperia is far awy from finished, that is some real aolpha stuff...
11:34:18 <Jaymzz> I can't disclose anything now ofc as it just doesn't work like that :D
11:34:21 <ApBBB> Mister_Magister: camera
11:34:31 <pvuorela> phlixi_o: what is not working?
11:34:32 <tortoisedoc> any news on the harbour stats improvements? :) it'd be really good for testing purpouses!
11:34:59 <tortoisedoc> I know it's work, but could it be in Jolla's best interest as well?
11:35:03 <phlixi_o> pvuorela camera and wlan ap
11:35:05 <Jaymzz> M4rtinK: Unfortunately not for this Xmas. You did howver see that we opened the source of hardware adaptation for Xperia :) consider that a start
11:35:15 <Mister_Magister> ApBBB: ah… dont except good camera on xperia because xperia is no good with cameras
11:35:19 <Mister_Magister> dont wanna swear here
11:35:25 <phlixi_o> pvuorela and lots of other stuff, but i am selfish, i mention those that bug me the most
11:35:40 <Jaymzz> Mister_Magister: Good choice with not swearing.
11:35:42 <M4rtinK> Jaymzz: that's indeed nice & enables all the community ports for variants! :)
11:36:00 <pvuorela> phlixi_o: camera at all? think tethering has been fixed long ago.
11:36:16 <pvuorela> if that's what you mean.
11:36:17 <ApBBB> Mister_Magister: has other benefits like waterproofness and such
11:36:17 <Jaymzz> M4rtinK: Exactly. There ismore where that came from. Hopefully we will have enough time to allocate to some more open sourcing during 2018
11:36:17 <Mister_Magister> Jaymzz: you sound scary D:
11:36:21 <M4rtinK> Jaymzz: but is that actually special ? I would kinda expect this to be the default for the hardware adaptations
11:36:28 <phlixi_o> pvuorela no, tethering is not fixed at all
11:36:36 <M4rtinK> Jaymzz: I really hope so
11:36:40 <Jaymzz> Mister_Magister: Well, swearing will get you kicked out of the meeting so... XD
11:36:40 <pvuorela> phlixi_o: next release perhaps.
11:36:44 <phlixi_o> pvuorela camera impossible to focus.
11:36:45 <Mister_Magister> What about 3 motorolas that i got this month? :D
11:37:04 <pvuorela> phlixi_o: focusing ok myself.
11:37:05 <ApBBB> jpetrell: do you have any UI/UX changes comming our way?
11:37:15 <tortoisedoc> ^ thats a good one +1
11:37:16 <M4rtinK> some of my developer friends started to use Sailfish OS with Sailfish X
11:37:17 <Jaymzz> M4rtinK: It is special because we actually did allocate a lot of resources on it. Just ask sledges
11:37:36 <Jaymzz> Mister_Magister: Good job on the motos mate
11:37:50 <M4rtinK> and they are hitting issues they would be easily able to fix & contribute the fix back, if the respective parts would not be closed source
11:37:55 <Mister_Magister> Jaymzz: they are almost not workign though well x2 is working nice
11:38:16 <phlixi_o> pvuorela so basically the answer is no. no one is fixing it...
11:38:29 <phlixi_o> ?
11:38:32 <Jaymzz> Not sure of jpetrell is online now  on this channel to reply you ApBBB. But there will be exciting stuff in the pipeline for 2018 I'm pretty sure
11:38:38 <Mister_Magister> Christmas is comming my mom will recive moto g2 lte with sailfishos from me :D
11:38:39 <M4rtinK> (some concrete examples: bluetooth pairing UI, volume configuration UI, email client)
11:38:42 <tortoisedoc> phlixi_o : maybe you could gain some tracktion by sharing some logs (if not done so)
11:39:08 <stephg> phlixi_o: what device doesn't focus? everyone of the ones I have does? maybe you have funky hardware?
11:39:10 <tortoisedoc> Mister_Magister : your mom linux user? :P
11:39:25 <remote_> I wanted to report a problem on sony X - sometimes when I receive a sms (X is lying on the desk) the orientation is vertical as it should be, but when I click on notification and sms app opens - orientation changes to horizontal, while I haven't moved a phone
11:39:25 <phlixi_o> stephg xepera x
11:39:26 <Mister_Magister> she will be sfos user :D
11:39:32 <ApBBB> Jaymzz: hopefully they listened to our feedback
11:39:37 <Jaymzz> M4rtinK: Thanks for the feedback and letting us know what could be better done even with details. I will definitely bring those up with high level people in the company
11:39:40 <stephg> phlixi_o: weird, my X is fine
11:39:49 <phlixi_o> tortoisedoc sure, i happily do, how?
11:39:53 <Jaymzz> ApBBB: We always do ;) and will implement where/when feasible
11:39:58 <M4rtinK> Jaymzz: That's definitely encouraging to hear! In the recent years I had the impression this is not being worked on at all due to all the (understandable yet unfortunate) firefighting.
11:40:02 <tortoisedoc> phlixi_o : devel-su -> journalctl ?
11:40:15 <ApBBB> Jaymzz: tell people up the company we need a compact device :D
11:40:16 <tortoisedoc> then post / share relevant parts in irc channel / tj c?
11:40:33 <tortoisedoc> Jaymzz : any news on the harbour stats improvements? :) it'd be really good for testing purpouses!
11:40:35 <sledges> M4rtinK: all things hw related out there, especially on android, are swarmed with closed source. community ports are all opensource, other jolla devices are not due to ties with ODM, but sony adaptation is special because it builds a flashable image, not downloadable zip
11:40:40 <phlixi_o> tortoisedoc that will doisplay something on my display....
11:40:44 <M4rtinK> Jaymzz: thanks! IIRC, there is some poll topic on Together where people vote for open sourcing prioritization, just can't find it now
11:40:49 <Jaymzz> M4rtinK: To be completely honest, it has been pushed back quite a lot due to the limited number of sailors and high amount of work from our customers. But it is never forgotten
11:41:07 <Jaymzz> M4rtinK: We are definitely aware of that
11:41:12 <sledges> M4rtinK: i.e. the way we build devices internally
11:41:14 <tortoisedoc> phlixi_o : network related things especially
11:41:20 <sledges> with factory reset support and other things
11:41:33 <Jaymzz> ApBBB: Compact device, noted ;) not saying any more
11:41:42 <pketo_> tortoisedoc: sorry, no news on the harbour stats
11:42:01 <Jaymzz> thanks pketo_ for the answer
11:42:02 <tortoisedoc> pketo_ : thanks, how big do you estimate the workload to be from 1-5?
11:42:11 <pketo_> 11
11:42:13 <tortoisedoc> (in scrum points :))
11:42:14 <ApBBB> Jaymzz: /me crosses fingers its xz1c
11:42:15 <pketo_> :P
11:42:16 <dr_gogeta86> Jaymzz, did you know the Xperia X isn't avaiable anymore in many countries nowadays ?
11:42:24 <tortoisedoc> pketo_ : seriously kthxz :P
11:42:49 <dr_gogeta86> i've struggled a bit this summer ... now is near impossible
11:42:54 <M4rtinK> Jaymzz: Good to hear that! Yeah, it's certainly not free, but enabling people to contribute really can make the difference.
11:43:09 <Mister_Magister> dr_gogeta86: i got 4yo phone and you cant  get xperia x?
11:43:12 <Jaymzz> ApBBB: /me says nothing and asks the community to wait for a possible compact device ;)
11:43:29 <dr_gogeta86> Mister_Magister, strange but true
11:43:35 <Mister_Magister> lol
11:43:38 <Jaymzz> dr_gogeta86: Yes, I'm / we are aware of that. That's why we won't be sticking to F5121
11:43:49 <tortoisedoc> pketo_ : where do you see the main difficulty in
11:43:52 <dr_gogeta86> in south europe sony as litle market penetration
11:44:10 <Jaymzz> M4rtinK: absolutely true! as I always have said, we are all pro-OSS at Jolla :)
11:44:11 <dr_gogeta86> you can find more xiami's then sonys
11:44:23 <Mister_Magister> buy from poland we got everything :D
11:44:34 <M4rtinK> no major/enterprise distro would get anywhere with just the parent company doing everything and without community contributions
11:44:48 <tortoisedoc> +1 for this ^
11:45:12 <Jaymzz> Certainly M4rtinK :)
11:45:28 <pketo_> tortoisedoc: to be honest, the harbour is a bit hairy piece of software and any kind of changes there are complicated
11:45:41 <Jaymzz> Funnily enough, in Sweden I see millions of Xperia X phones for sale! even the rare lime gold colour
11:45:59 <tortoisedoc> pketo_ : okay so it's frontend issue, not data?
11:46:13 <M4rtinK> pketo_: frankly, I get the same impression from the Harbour interface as an app developer :)
11:46:18 <Mister_Magister> Jaymzz: tons in poland too
11:46:18 <tortoisedoc> (as in all data is / shouold be available)
11:46:20 <pketo_> tortoisedoc: yes mostly frontend
11:46:41 <tortoisedoc> pketo_ : surprising given the "simple" ui :P
11:46:46 <Jaymzz> Mister_Magister: Yeah there are some countries with a ton of them and some countries with literally none. Distribution policies
11:47:01 <Mister_Magister> yeah
11:47:01 <tortoisedoc> pketo_: but the data should already be available?
11:47:14 <M4rtinK> Jaymzz: the lime-gold color is the cheapest Xperia X available here in Czech Republic and you actually have to pay extra to get a proper black one ;-)
11:47:22 <Mister_Magister> you can always buy from another country
11:47:46 <Mister_Magister> like my jolla 1 is from Lithuania :D
11:47:53 <Jaymzz> M4rtinK:  that's just cruel :D
11:48:19 <M4rtinK> pketo_: BTW, for Harbour improvements - what about sending notifications for new comments to app authors ?
11:48:25 <phlixi_o> [2017-12-21 12:35:59] <pvuorela> phlixi_o: camera at all? think tethering has been fixed long ago. <<- i hope this: https://jolla.zendesk.com/hc/en-us/articles/115013777068 is not what you mean with "fixed long ago"
11:48:46 <pketo_> tortoisedoc: yes, more or less ... I don't now remember what information you were after... app instals by device type and such?
11:49:01 <tortoisedoc> pketo_ : yes split by device model/type
11:49:12 <M4rtinK> pketo_: I have to check manually & that really sucks, because if I did not do that I would miss important feedback, questions or bugreports...
11:49:27 <tortoisedoc> pketo_ : +1 on M4rtinK
11:50:08 <tortoisedoc> harbour could have lots of improvements
11:50:10 <Jaymzz> Alright we went to the 20 min teritorry now, we do need to move on as I have some tasks to do before everyone leaves the office XD
11:50:18 <M4rtinK> typing all the replies on the phone(tablet sucks as well, but even just the notifications would help
11:50:38 <Jaymzz> I'll wait for the harbour discussion to be over and will move on
11:50:40 <pketo_> M4rtinK: same applies to that, we would like to have a web interface for developers to read and reply to comments, but a lot of stuff would need fixing before adding features makes much sense
11:50:47 <tortoisedoc> Jaymzz : awesome
11:51:16 <M4rtinK> pketo_: I understand that, which is why I'm trying to itemize :)
11:51:53 <tortoisedoc> it would also give a more professional look to harbour btw :)
11:52:00 <dr_gogeta86> M4rtinK, we need to recall every developer who submit apps
11:52:02 <tortoisedoc> (the device split)
11:52:20 <dr_gogeta86> and I'm not talking about just hourbour
11:52:27 <dr_gogeta86> *harbour
11:52:32 <dr_gogeta86> but also openrepos
11:52:44 <dr_gogeta86> "Forks , Forks are everywhere"
11:52:50 <tortoisedoc> forks?
11:53:02 <M4rtinK> ?
11:53:14 <dr_gogeta86> Even your app have the forked version
11:53:14 <tortoisedoc> dr_gogeta86 : what do you mean
11:53:19 * M4rtinK has modRana in both OpenRepos and Harbour, BTW :)
11:53:21 <pketo_> I will take all this forward in the name of improving the developer offering and hopefully we can spare more resouurces on these things in the future
11:53:29 <M4rtinK> with different feature sets even
11:53:36 <tortoisedoc> pketo_ : appreciated!
11:53:49 <M4rtinK> pketo_: good to hear! :)
11:53:52 <tortoisedoc> I usually use openrepos for "early access" while waiting for q
11:53:53 <tortoisedoc> *qa
11:53:57 <Jaymzz> pketo_: Thanks a lot!
11:54:19 <Jaymzz> Ok now let's move on there's not much time left
11:54:22 <Jaymzz> #topic Next meeting’s time and date (5 min)
11:54:25 <M4rtinK> Jaymzz: BTW, this is the open sourcing priority poll: https://together.jolla.com/question/167645/open-source-roadmap-from-the-community-point-of-view/
11:54:34 <M4rtinK> maybe #info ?
11:54:35 <tortoisedoc> pketo_ if you need support call us and well show up at the doors :D
11:54:36 <Mister_Magister> +1 to whatever
11:54:43 <Jaymzz> 11th of Jan 2018. What y'all say?
11:54:47 <tortoisedoc> sold
11:54:52 <Jaymzz> thank you M4rtinK
11:55:08 <stephg> Jaymzz: +1
11:55:09 <Mister_Magister> Jaymzz: +1 to whatever
11:55:17 <M4rtinK> np :)
11:55:29 <Jaymzz> alrighty thanks!
11:55:46 <Jaymzz> #info next meeting will be held on Jan 11th 2018 at 09:00 UTC
11:55:54 <Jaymzz> we shall end the meeting :)
11:56:03 <Mister_Magister> nooo :(
11:56:06 <Jaymzz> Thank you everyone for participating today
11:56:17 <Jaymzz> what's up Mister_Magister?
11:56:19 <peperjohnny> thank you =)
11:56:25 <tortoisedoc> thank you!
11:56:25 <Mister_Magister> meetings are so nice :D
11:56:40 <bshah> Happy holidays! :)
11:56:40 <Jaymzz> they indeed are! so let's make the next one even nicer!
11:56:52 <Jaymzz> Merry Xmas and happy new year to you all!
11:57:03 <tortoisedoc> Jaymzz same to you, thanks!
11:57:06 <Jaymzz> Meeting minutes will be emailed as usual.
11:57:09 <hschmitt> Merry Xmas and happy new year
11:57:09 <ApBBB> Jaymzz: depends on what new things jolla gives
11:57:11 <ApBBB> :P
11:57:32 <tortoisedoc> lol if JOLLA then CHRISTMAS else BUST
11:57:33 <Mister_Magister> ApBBB: more "someday in the future"
11:57:40 <Jaymzz> ApBBB: ;) fingers crossed everything will go as planned and we will have another fruitful year!
11:57:51 <Jaymzz> haha :D
11:57:55 <Jaymzz> #endmeeting