09:00:25 <sledges> #startmeeting Sailfish OS, open source, collaboration 5th April 2018
09:00:25 <merbot> Meeting started Thu Apr  5 09:00:25 2018 UTC.  The chair is sledges. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:00:25 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:00:48 <sledges> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2018-April/008355.html
09:01:13 <sledges> I am the meeting’s chairperson today and will be doing my best to keep time and order. Please behave, respect the timings and be-have:]
09:01:17 <sledges> #topic Brief introduction (5 min). Please prefix your name/handle with # info
09:01:31 <ljo> #info Leif-Jöran Olsson, community
09:01:41 <M4rtinK_phone_> #info Martin Kolman, modRana developer and community member
09:01:43 <peperjohnny> #info peperjohnny, community
09:01:48 <lbt-> #info David Greaves, sailor and Mer guy
09:01:48 <leszek> #info Leszek Lesner, Community Member & Dev
09:01:52 <chriadam__> #info Chris Adams, developer at Jolla
09:02:03 <au7ogeek> #info au7ogeek, community
09:02:05 <jpetrell> #info Joona Petrell, developer at Jolla
09:02:14 <sledges> #info Simonas Leleiva, sailor and chair
09:02:27 <vgrade> #info vgrade, community
09:02:47 <lolek> #info lolek, just a user?:)
09:02:55 <pketo> #info Pami Ketolainen, sailor @ Jolla
09:02:58 <mal> #info Matti Lehtimäki, community porter etc
09:03:16 <veskuh> #info Vesa-Matti Hartikainen, Program Manager @ Jolla
09:03:40 <Sage__> #info Marko Saukko, sailor @ Jolla
09:06:22 <sledges> #topic: Xperia XA2 support details (10min - asked by au7ogeek)
09:06:29 <sledges> #info Which version of the Xperia XA2 will be supported exactly (model number)? There are many different variations across markets and single/dual-sim types, etc. Will the dual-sim version be supported (initially or maybe eventually)? Single sim versions are already difficult to find (in Sweden) while dual-sim versions are readily available. How about the Xperia XA2 Ultra? This is even more popular an
09:06:36 <sledges> d readily available. It has the same chipset as the XA2 but a different screen size. I feel it is important to clarify such questions now as the devices being supported may be hard to find later on when Sailfish XA2 goes on sale.
09:06:57 <sledges> #info ...and readily available. It has the same chipset as the XA2 but a different screen size. I feel it is important to clarify such questions now as the devices being supported may be hard to find later on when Sailfish XA2 goes on sale.
09:07:26 <sledges> au7ogeek: the stage is yours if there's anything to add
09:08:03 <au7ogeek> Not much to add. Xperia X was difficult to find when Sailfish X went on sale. So I'm trying to avoid a similar situation
09:08:12 <au7ogeek> Ask if you have any questions
09:08:34 <Sage__> Currently we are working with Single SIM (H3113) and Dual SIM (H4113) models, but the final supported models will be annouced later.
09:08:49 <sledges> #info Currently Jolla is working with Single SIM (H3113) and Dual SIM (H4113) models, but the final supported models will be annouced later.
09:09:34 * ApBBB continues to be dissapointed by the HW choice :(
09:09:35 <au7ogeek> Will the dual-sim model be supported initially or will support for it be rolled out later as was in the case of xperia X?
09:10:06 <leszek> why was? The dual sim xperia x isn't supported officially or is it?
09:10:47 <au7ogeek> I'm not sure. But I know the plan is to add support for it at some point.
09:11:07 <Sage__> xperia x dual sim was not supported officially from the start, but the support for that is coming, see https://blog.jolla.com/sailfish-x-whats-next/
09:11:26 <leszek> true. So final supported models will be announced later means -> go on there is nothing more we can say currently
09:11:31 <M4rtinK_phone_> ApBBB: well, it's a slightly less powerful X with USB C and bigger battery
09:12:13 <M4rtinK_phone_> at least the hardware is similar, but some more variety (people have been asking for compact models) would be nice
09:12:16 <leszek> M4rtinK_phone_: its as powerful as the X if not even a tiny bit more powerful
09:12:37 <leszek> the only downside is the missing dual front speakers
09:12:51 <leszek> the rest is basically the X in an improved version
09:12:59 <lolek> M4rtinK_phone_: ++ for compact
09:13:09 <leszek> granted that the front facing camera is not as high resolution
09:13:18 <M4rtinK_phone_> well, I think that debatable - it has more of less advanced cores
09:13:20 <nekron_work> I will jump ship as soon (TM) as the image for XA2 is available from Jolla... I don't like the button layout on the X
09:14:02 <M4rtinK_phone_> I know people getting X comoact with community port just do to the size
09:14:15 <ApBBB> Xc is old
09:14:23 <sledges> 2more mins of hw flaming :)
09:14:30 <nekron_work> :)
09:14:37 <lolek> ApBBB: doesn't matter as long as it works and do it's job
09:14:45 <M4rtinK_phone_> nekron_work: I dont like the pointy edges on XA2 ;-)
09:14:53 <au7ogeek> OK. Final comment from me regarding the HW: can Jolla consider supporting high end models the next time? Since it takes time to adapt Sailfish for the HW, when the new Sailfish version is released, the high end models become mid-range.
09:14:58 <ApBBB> lolek: my hands and pockets are not big enough for this crap
09:15:06 <nekron_work> Ok, so official statement from Jolla is to wait until final HW is announce before buying XA2 single or dual sim?
09:15:14 <physkets> Yes, it is important to me too that Joll announces which of the two versions it will be released for
09:15:21 <au7ogeek> Right now it looks like when sailfish xa2 is released, XA2 might become outdated
09:15:36 <lolek> ApBBB: well yeah of course that's I also prefer the compact but right now there's not much choice and tbh the latest xperia compact is no go because of lack of jack audio
09:15:52 <M4rtinK_phone_> I suppose we dont get any timeline ?
09:15:55 <leszek> Is it planned to ship a final version for the XA2 or a beta release?
09:16:41 <sledges> Sage__: by saying models were you referring to SIM count, or model hw rev variants?
09:16:53 <ApBBB> lolek: other than the audio jack -for which you get a dongle in the box the xz2 is a nice phone.
09:16:58 <lolek> I think the clarification of the word "supported" would be also nice. For example by supported it means : it will allow to make phone calls and send/receive sms
09:17:20 <lolek> ApBBB: yeah just get another adapter.. well maybe they want to be like apple? Adapter for everything :D
09:17:26 <Sage__> sledges: those are the particular models on the devices we are currently working with.
09:17:41 <ApBBB> lolek: at least it has no notch :P
09:17:51 <ApBBB> hope sony adds it to the open devices
09:17:58 <sledges> ok, let us carry on:)
09:18:07 <lolek> ApBBB: :)
09:18:17 <sledges> #topic Community solutions to long standing problems (mapping and text prediction) and how to get them on all phones (10mins - asked by ApBBB)
09:18:24 <sledges> #info The community has developed solutions for both mapping (which sucks) and text prediction (which isn't available to every language). And we need them on the store or integrated in the OS. So how the community can help speed things up and who from jolla has to get things moving.
09:19:24 <sledges> ApBBB: fun question: why should a "sucky" mapping solution be integrated to Jolla Store? :) if you mean Poormaps, they looked quite good; ModRana is already in the Store
09:20:03 <ApBBB> self explenatory i think. WhoMaps is not in the store and jollas solution is either Android or the old here one which is left to rot. Also text prediction which isn't available in all languages
09:20:24 <ApBBB> sledges: sucky is the Here one i have in J1
09:20:38 <M4rtinK_phone_> Osm Scout Server, a Poor Maps, Whogomaps and modRana dependecy (provides all ofline services) is no longer in store
09:20:39 <ApBBB> and i am no fan of android
09:20:42 <sledges> ApBBB: understood, so in brackets you reflected current Jolla's offering
09:20:49 <ApBBB> sledges: yes
09:20:53 <M4rtinK_phone_> due to Harbour restrictions
09:21:25 <ApBBB> we have something better and we can't have it. which is bad because jolla needs quality apps
09:21:33 <mal> M4rtinK_phone_: which restriction is blocking it?
09:21:58 <ApBBB> can't have it easily. its idiotic to have a million different places for apps on a single OS
09:22:07 <leszek> can't whogo trick harbour restrictions like ytplayer does?
09:22:22 <M4rtinK_phone_> mal: https://github.com/sailfishos/sdk-harbour-rpmvalidator/issues/102
09:22:26 <leszek> like importing the "not allowed" stuff via c++
09:22:29 <leszek> instead of using qml
09:22:55 <ApBBB> leszek: the dev said he prefers to develop than try to go round restrictions :/
09:23:08 <ApBBB> so we need an  answer from jolla people
09:23:15 <ApBBB> veskuh ???
09:23:41 <M4rtinK_phone_> yeah, I can't believe we still have these discussions 5 years after SFOS launche
09:23:47 <ljo> We are working on supporting further languages with the open text prediction plugin. This means I am working on  adaptation to language specific settings and also some suggestion selection adaptations. But there is also a lot of work getting ICU-provided functionality integrated for full unicode support which was precursory investigated by rinigus.
09:24:03 <M4rtinK_phone_> it feels like Harbour did not move a meter since then...
09:24:27 <sledges> #info The team responsible for making libsystemd decision and integrating it is currently busy, let us postpone the question to the next meeting
09:24:29 <ApBBB> M4rtinK_phone_: exactly
09:24:31 <sledges> #link https://github.com/sailfishos/sdk-harbour-rpmvalidator/issues/102#issuecomment-367373788
09:24:51 <abranson> M4rtinK_phone_: I think progress has been made: https://github.com/sailfishos/sdk-harbour-rpmvalidator/pulls?q=is%3Apr+is%3Aclosed
09:24:55 <ApBBB> sledges: text prediction??
09:25:31 <sledges> #info Text prediction (presage-based) could be collaborated the same way like community has been submitting the keyboard layouts, but we need to review the working model, as more variables are involved
09:26:05 <ApBBB> sledges: who can we "annoy" for the text predioction?? :P
09:26:13 <ApBBB> the sooner the better.
09:26:15 <sledges> ApBBB: will tell you in two week ;P
09:26:16 <sledges> +s
09:26:20 <M4rtinK_phone_> even if modRana is in store (and don't get me started on all the nasty hacks needed for that), without users installing OSM Scout Server from OpenRepos there will be no offline routing/maps/search at all
09:26:30 <sledges> in the meantime we'll have internal discussion
09:26:55 <sledges> M4rtinK_phone_: my 2p: with EU roaming charges dropped, offline maps is less of an issue nowadays:)
09:26:58 <M4rtinK_phone_> can we info the issue & add an action item for this ?
09:27:18 <M4rtinK_phone_> sledges: there are still privacy implications
09:27:29 <ApBBB> sledges: having stuff like offline maps out of the box adds value to the OS. and will most likely help you sell it better to those that pay.
09:27:34 <sledges> #action discuss libsystemd and presage integration internally
09:28:00 <peperjohnny> sledges: while this is very true it won't help one standing in 2g in an area not preloaded :/
09:28:02 <nekron_work> sledges: It depends if you are on the trail w/out coverage it's very needed to have offline maps
09:28:03 <M4rtinK_phone_> not to mention technical details (road snapping, etc.) not really doable without offline data
09:28:10 <ApBBB> offline is also needed for places with poore reception
09:28:14 <lolek> sledges: sorry, but I don't buy that "offline maps is less of an issue nowadays:)"
09:28:21 <sledges> thank you for your voiced opinions
09:28:23 <sledges> let's move on
09:28:35 <jvd_> sledges: true on europe but I went to Australia and it wass 11e/MB
09:28:36 <jpetrell> if the quality of OSS prediction engine is good I wouldn't mind seeing it integrated to core OS instead of having it in Store, especially for languages not currently covered by our Nuance contract
09:28:40 <sledges> #topic Design UI/UX of Sailfish 3 (15mins - asked by ApBBB)
09:28:42 <jpetrell> we are working contribution agreement template that would allow giving community developer access to the needed private repos, helping develop things like integrating different prediction engines to Sailfish OS keyboard
09:29:12 <jpetrell> we are super busy working on getting 2.2.0 feature complete, the Sailfish 3 work has been put on hold for a moment so not much progress to report
09:29:13 <ljo> sledges: do you info my "info" above too about the textprediction work going on.?
09:29:20 <M4rtinK_phone_> thanks to rinigius and OSM Scout Server is IMHO by far the best platform for navigation *anywhere ever*
09:29:26 <sledges> ljo: in general discussion
09:29:31 <sledges> #info From the MWC video some of the community complains seems to have been fixed, however there are things that are not shown in the video and might be a good time to discuss. Closing multiple apps, tactile and aural feedback, inconsistencies, long reach of some elements, etc etc.
09:29:52 <sledges> #info we at Jolla are super busy working on getting 2.2.0 feature complete, the Sailfish 3 work has been put on hold for a moment so not much progress to report
09:30:00 <M4rtinK_phone_> and this effort should get as much support as possible, not be blocked by trivial trchnical hurdles outside of its control
09:30:39 <ApBBB> being put on hold is not a problem since we discuss design here. so. any info on the topics mentioned in the description
09:30:41 <ApBBB> ?
09:30:49 <leszek> will 2.2 feature some new elements we saw in the MWC videos like swipe down for wifi/bt quick toggles and so on?
09:31:01 <sledges> leszek: that's not SFOS 3 :)
09:31:07 <jpetrell> ApBBB: could you elaborate more, feedback where, what inconsistencies
09:31:17 <sledges> (those were the biggest ui changes)
09:31:19 <leszek> sledges: SFOS3 UI though
09:31:28 <jpetrell> leszek: not yet, will come later in the year
09:32:13 <jpetrell> in Sailfish 3 we are targeting few, selected UX annoyances,  there are plenty of other things we would like to do in the future but need to now start with something
09:32:16 <ApBBB> jpetrell: inconsistency -> open the settings look at the apps and account in the bottom. doesnt blend well with the rest
09:34:04 <ApBBB> jpetrell: tactile and aural feedback is somoehow a more complex matter. to give you an idea i got a switch lately and the UI gives you feedback (aural tactile) when you interact with it. on SFOS is hit or miss
09:34:11 <jpetrell> ApBBB: settings hierarchy is definitely something that should be improved
09:34:50 <leszek> jpetrell: are you performing usability tests with "real" people or planning to do so?
09:35:03 <ApBBB> jpetrell: are there bugs in your internal bug tracker about those issues?
09:35:15 <jpetrell> leszek: we should
09:35:31 <jpetrell> ApBBB: need to double check, but expect so
09:35:44 <jpetrell> wouldn't mind seeing tabs in Phone, Clock, Settings, where you could horizontally swipe between the views (dialer, call log, address book in Phone, alarms, timers and stopwatch in Clock, system, app and account settings in Settings)
09:35:49 * M4rtinK_phone_ still things it should be possible to go to events view and back from an app
09:36:03 * M4rtinK_phone_ not via the task switcher
09:36:18 <ApBBB> jpetrell: also when closing multiple apps (long press etc) the elements move around. and its not the only area where stuff move around as  you tap
09:36:34 <lolek> M4rtinK_phone_: you mean something like BlackBerry HUB?:)
09:36:45 <ApBBB> those -and many others - are annoyances that need to be polished out for SFOS3
09:36:47 <M4rtinK_phone_> this was possible in SFOS 1.0 & BB10 and was really useful
09:36:56 <M4rtinK_phone_> lolek: yep
09:37:02 <lolek> M4rtinK_phone_: well I'd say it's a killer feature
09:37:19 <M4rtinK_phone_> Android has IIRC something similar with top menu
09:37:20 <ApBBB> long reaches also. ie you cant reach the top of the screen easily for a notification
09:38:07 <M4rtinK_phone_> anither pet issue - better way to dissmiss notifications on even screen
09:38:30 <M4rtinK_phone_> long press and then click feels really slow and clumsy
09:38:41 <ApBBB> M4rtinK_phone_: long press > swipe up the notification would be good imo
09:38:47 <jpetrell> ApBBB: feedback definitely could be improved, though audio and haptic feedback is hard to align between different devices
09:38:54 <sledges> #info community's giving feedback on UX usability, please read logs :)
09:38:59 <jpetrell> also would be nice to do refresh to platform transitions
09:39:12 <lolek> M4rtinK_phone_: it's way different. In BB Hub you can do everythig directly from that. BB ported hub to android and ppls complain that now hub just open app to perform desired action instead of doing this directly from the hub
09:39:17 <ApBBB> clicking on a small area is not good
09:39:29 <M4rtinK_phone_> ApBBB: side swipe would be ideal but would likely interfere with the carousel
09:39:41 <jpetrell> there are a lot of things we could improve. initially we are improving multitasking gestures and access to global settings and shortcuts
09:39:44 <ApBBB> M4rtinK_phone_: thats why i said up
09:39:52 <jpetrell> I miss peaking to events from lock screen without unlocking, more intelligent scrolling of long views, quick gesture to switch between keyboard layouts, and so on
09:40:13 <ApBBB> jpetrell:  quick gesture to switch between keyboard??? how?
09:40:38 <ApBBB> this is a problematic area now.
09:40:50 <M4rtinK_phone_> jpetrell: suggestion for easy setting access: pin individual bluetooth devices to the event screen menu
09:40:54 <leszek> ApBBB: swiping on the keyboard horizontally
09:41:08 <lolek> jpetrell: how is with the patents? For example is this a problem to use the same approach as other OS does or you need to always be carefull in that area and if so then abandon the idea or pay for it?
09:41:35 <jpetrell> ApBBB: there are different possibilities, but horizontal flick is one natural choice (doesn't work for handwriting, swipe inputs, etc. though)
09:41:38 <M4rtinK_phone_> jpetrell: I'm using a bluetooth headset a lot lately and have to check the bluetooth page quite often to see if it is connected or to disconnect it
09:41:39 <leszek> lolek: there aren't software patents in the EU
09:41:50 <lolek> leszek: yeah I know, but there are in US
09:41:53 <M4rtinK_phone_> jpetrell: so a shortcut would be ideal
09:42:04 <jpetrell> lolek: there are things we haven't implemented because of patents
09:42:06 <leszek> lolek: no one is interested in the US
09:42:13 <leszek> :P
09:42:16 <lolek> jpetrell: ok
09:42:20 <jpetrell> M4rtinK_phone_: would be cool
09:42:34 <lolek> jpetrell: this is what I was affraid of :(
09:42:42 <sledges> 1min left
09:42:50 <ApBBB> jpetrell: a horizontal swipe from the outside would be good i think. nokia n9 had it like that i think
09:42:50 <lolek> leszek: the horizontal swipe (say from right to left) would be great to delete words
09:42:58 <lolek> right now when I want to delete few words it takes ages
09:43:07 <leszek> lolek: true
09:43:12 <jpetrell> also we made plenty of design mistakes in first versions of the OS that would be nice to fix
09:43:22 <leszek> yep agrred
09:43:27 <leszek> step by step
09:43:29 <jpetrell> e.g. attached pages (accessed from right) in apps
09:43:41 <chriadam__> but time and resources limit what we can promise in a given timeframe.
09:43:55 <jpetrell> yes
09:44:06 <lolek> jpetrell: Imho what's now isn't bad as is usable. Can be fixed later. For me personally the biggest problem is device functionality, security, etc
09:44:07 <sledges> ok to move on fellows?
09:44:29 <mal> jpetrell: what is wrong with attached pages?
09:45:34 <sledges> ok moving on, please turn any burningly unanswered issues into meeting topics for next time
09:45:43 <jpetrell> mal: they are not discoverable. we use them for various things, but one problematic area is category filtering (Email folders, Store categories), people don't realize that after they go open some email folder they need to go forward to right to get back to the main inbox folder
09:45:43 <leszek> I guess they attach to the wrong site:P
09:45:46 <sledges> bear with me while i jump through one topic repetition
09:45:50 <sledges> #topic #info bits from earlier "Community solutions to long standing problems"
09:46:11 <sledges> #info < ljo> We are working on supporting further languages with the open text prediction plugin. This means I am working on  adaptation to language specific settings and also some suggestion selection adaptations. But there is also a lot of work getting ICU-provided functionality integrated for full unicode support which was precursory investigated by rinigus.
09:46:25 <sledges> #info < jpetrell> if the quality of OSS prediction engine is good I wouldn't mind seeing it integrated to core OS instead of having it in Store, especially for languages not currently covered by our Nuance contract
09:46:34 <sledges> #info < jpetrell> we are working contribution agreement template that would allow giving community developer access to the needed private repos, helping develop things like integrating different prediction engines to Sailfish OS keyboard
09:46:54 <sledges> #topic Sailfish security (10mins - asked by lolek)
09:47:10 <sledges> #info It seems that currently the OS is pure simple Linux with only very basic permission structure. There's no SElinux/Apparmor, no application permissions. For example pictures made by the jolla-camera app has got 644 permissions which means every single other app can access it. Based on the fact that Jolla is secure (as of some statement on one of the Jolla webpages) this doesn't look like.
09:47:16 <sledges> #info Also same problem is with the very old web browser which is very dated (Firefox 38?). According to official information, this year we should see system encryption but what with the rest? Unlocked bootloader message is also something not very welcome, but I think this is more related to Sony.
09:47:24 <sledges> #info It would be also great to have some more secure unlock screen. Current one is very fragile for example video recording i.e. someone can record when we input the pw to unlock our phones. Regarding Jolla account I'm missing option to remotely wipe out my phone from account.jolla.com.
09:47:29 <sledges> #info This is somehow a trade of between privacy and security as Jolla would need to have access for my phone but it can be made as opt-in.
09:49:30 <sledges> the stage is for lolek and veskuh :)
09:49:39 <sledges> (or should i say, the boxing ring:D)
09:49:53 <veskuh> Hah, well this is a complex topic.
09:50:14 <lolek> security is never an easy thing ;)
09:51:26 <leszek> I am also interested to what is planned for SFOS3 in that regard. App specific rules. It needs some work to add apparmor profiles for the apps to use
09:51:42 <veskuh> So we are having several things in place, but we continue to work in this area:
09:51:50 <veskuh> Most importantly we don’t track you - all your info stays on your phone.
09:52:10 <veskuh> We continue to provide SW updates to OS even to our first product and in each update we provide several CVE fixes and other security fixes and updates.
09:52:20 <sledges> #info Jolla is having several things in place, but continue to work in this area:
09:52:48 <veskuh> Base of the OS in Open Source and the repositories are open to check what is going on.
09:53:17 <lolek> veskuh: I don't doubt in Sailfish privacy
09:53:22 <veskuh> The Android Runtime has limitations on access and you can disble it completely. Similarly native apps have some limititations (permissions, priviledged).
09:53:27 <lolek> Security in the sense of CVE is not everything
09:53:40 <veskuh> We know that there is room to improve and are working on better security framework to provide better access control for apps, and we are also developing many new security related features.
09:53:54 <sledges> #info Most importantly we don’t track you - all your info stays on your phone.
09:53:59 <sledges> #info We continue to provide SW updates to OS even to our first product and in each update we provide several CVE fixes and other security fixes and updates.
09:54:04 <sledges> #info Base of the OS in Open Source and the repositories are open to check what is going on.
09:54:10 <sledges> #info The Android Runtime has limitations on access and you can disble it completely. Similarly native apps have some limititations (permissions, priviledged).
09:54:17 <sledges> #info We know that there is room to improve and are working on better security framework to provide better access control for apps, and we are also developing many new security related features.
09:54:28 <leszek> oh I can feel the shitstorm coming for the Open Source and Base of the OS statement
09:54:36 <lolek> a real life example. I've got a phone, where I have my mail account setup. When I lost the phone, someone can access the data stored on that phone easily. Once encryption will be introduced (from what I remember - this year) then it will be better
09:54:59 <veskuh> lolek: Yes, encrypted fs in the roadmap
09:55:01 <leszek> veskuh: base of the system is a thing that needs to be defined as I count the wayland compositor as the base of the system aswell and that is closed
09:55:12 <ApBBB> leszek: you have to be a special kind of moron to get annoyed by what is closed in SFOS
09:55:35 <sledges> ApBBB: mind your language
09:55:48 <lolek> veskuh: oh, and how about browser? it's more than dated for this moment
09:55:59 <leszek> ApBBB: nope it is a inherent security issue if the wayland compositor is closed source as it controls basically everything from clipboard to if an app can record the screen and such
09:56:11 <veskuh> leszek: Yes, that’s understandable view, but I guess better for another discussion?
09:56:26 <leszek> yep yep
09:56:44 <lolek> I've read somwhere it's a problem with gecko api mappings if I got it properly but then, maybe webkit could be used instead?
09:56:58 <veskuh> lolek: We have been planning engne update, and there also some other developments going on at the browser area.
09:56:59 <leszek> I am also interested in the browser thingy as I am poking and poking for a more secure qtwebkit but no one is hearing my calls. And Yep Quantum is needed nowadays
09:57:18 <lolek> veskuh: any timeline?
09:57:20 <sledges> #info We have been planning [browser] engine update, and there also some other developments going on at the browser area.
09:58:05 <veskuh> leszek: We are planning on Qt upgrade and that would probably make QtWebEngine also available for developers.
09:58:13 <leszek> veskuh: if its gecko 45 please don't make any big announcement as people will laugh about it
09:58:18 <sledges> #info We are planning on Qt upgrade and that would probably make QtWebEngine also available for developers
09:58:21 <leszek> veskuh: nice
09:58:27 <lolek> that would be good
09:58:31 <piggz> +1
09:58:42 <sledges> we're out of time for topic, any unexhausted aspects still?
10:00:06 <sledges> silence means consent:)
10:00:08 <sledges> #topic General discussion (15 min)
10:00:59 <piggz> Btle? We are trying things as porters, but do Jolla have any insight into how to get le working?
10:02:08 <sledges> please create topic, as no BT sailors are around:)
10:02:20 <ApBBB> who is responsible for pull requests done on stuff like the documents app etc?
10:02:33 <piggz> :/
10:02:45 <ApBBB> damien implemented doc rotation and would be a nice to have feature
10:02:55 <piggz> Ok
10:03:05 <sledges> ApBBB: i'd look into closed PRs whoever commented/merged
10:03:05 <leszek> Anyone thought on selling the cool MWC t-shirts @ jolla. Would be awesome if we could buy those SFOS3 ones
10:03:29 <sledges> leszek: or make some competition?:) as numbers are scarse;)
10:03:41 <leszek> :)
10:05:50 <sledges> e.g. photo contest on twitter; i'll pass it to Jaymzz
10:06:21 <sledges> two more minutes of silence and i'll shorten this 1hour+ meeting ;)
10:07:10 <richrboo> Sorry, late joining. I had the idea, Jolla could make the t-shirt design available for you to download and print your own t-shirt!
10:09:31 <sledges> will see what our t-shirt designer thinks:)
10:09:37 <sledges> ok let's move to the last bit
10:09:40 <ApBBB> sledges: can you look into the internal bug tracker for this > https://together.jolla.com/question/97109/email-imap-idle-doesnt-work-with-both-connections-active/
10:10:48 <sledges> ApBBB: it would say that it's "Tracked by Jolla", I'll see what I can do, but i think it's a slow burner due to hard-to-reproduce
10:10:58 <chriadam__> I think pvuorela is probably the person to look at the docs PR.  but the next couple of weeks probably nobody has time, unfortunately - busy with 2.2.0 finalisation
10:11:14 <ApBBB> sledges: damien provided some feedback
10:11:18 <ApBBB> on the comments
10:11:23 <sledges> ApBBB: yep, and logs
10:11:25 <ApBBB> its a reallt annoying bug
10:12:33 <M4rtinK_phone_> any progress one the wifi/bluetooth interference on Xperia ?
10:12:43 <sledges> chriadam__: and I think it would be blam on BT(le) side of things
10:12:53 <M4rtinK_phone_> eq garbled bt audio when wifi is enabled ?
10:13:06 <M4rtinK_phone_> it's pretty annoying
10:13:14 <chriadam__> or jpoutiai
10:13:41 <sledges> yep, M4rtinK_phone_ call all-hands BT for the next meeting ;)
10:14:09 <sledges> if anyone has time in the community and a hackable Xperia X, can always double-check if BT has problems on vanilla AOSP6 there (as this is what we base off)
10:14:43 <sledges> and time is gracefully up;
10:14:49 <sledges> #topic Next meeting’s time and date (5 min)
10:15:18 <ApBBB> once people are more relaxed?
10:15:19 <sledges> sorry we've goofed about daylight saving time, and had to deprive our sailors from lunch today
10:15:29 <sledges> so next meeting will be 8 UTC
10:15:32 <M4rtinK_phone_> sledges: I'll likely do something like that
10:15:41 <ApBBB> food is bad makes you fat and stuff :P
10:16:00 <sledges> but brain needs food :/ :D
10:16:11 <sledges> let's keep this in two weeks
10:16:29 <Guest84654> your brain is the food
10:16:29 <sledges> Thursday 08:00 UTC 19th April 2018
10:16:48 <sledges> or, "my food is my salad"
10:16:52 <sledges> +1s?
10:17:00 <sledges> *or, "my food eats my salad"
10:17:20 <kimmoli> +1 for whatever
10:17:27 <sledges> one moar?
10:17:41 <au7ogeek> About the daylight savings time: the timeanddate.com link in together.jolla.com doesnt seem to handle daylight savings time properly and shows the wrong local meeting time.
10:17:56 <au7ogeek> +1
10:18:08 <ljo> +1
10:19:23 <sledges> au7ogeek: yep it looks quirky, will pass it to Jaymzz
10:19:28 <sledges> #info Next meeting will be held on Thursday, 08:00 UTC 19th April 2018
10:19:33 <sledges> thanks all!!
10:19:35 <sledges> #endmeeting