#mer-meeting: Sailfish OS, open source, collaboration 19th April 2018

Meeting started by sledges at 08:00:01 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2018-April/008363.html (sledges, 08:00:14)

  1. Brief introduction (5 min). Please prefix your name/handle with # info (sledges, 08:00:25)
    1. Lewis Rockliffe - community (r0kk3rz, 08:01:41)
    2. David Greaves, sailor and Mer guy (lbt-, 08:01:41)
    3. Andrew Branson, Jolla dev (abranson, 08:01:59)
    4. Cedric Heintz, community member (ced117, 08:02:01)
    5. Leif-Jöran Olsson, community (ljo, 08:02:15)
    6. Simonas Leleiva, sailor'n'chair (sledges, 08:02:49)
    7. Pami Ketolainen, sailor @ Jolla (pketo, 08:02:59)
    8. Chris Adams, developer at Jolla (chriadam__, 08:03:05)
    9. Vesa-Matti Hartikainen, Program Manager at Jolla (veskuh, 08:03:35)
    10. eekkelund (eekkelund, 08:04:26)

  2. Sailfish 3 introduction (5min - asked by Sanjeev/snj33v) (sledges, 08:06:14)
    1. can we get deeper preview of new APIs besides the one already mentioned in MWC?, will there be any sandboxing for the applications we develop?, how long we still need to rely on android support in jolla store?, willl keyboard finally support emojis? (sledges, 08:06:45)
    2. New APIs: Location, Camera, WebEngine, VPN, Crypto, Secrets; taken from: (sledges, 08:07:20)
    3. https://jolla.com/sailfish3/ (sledges, 08:07:25)
    4. app sandboxing: We are working on SELinux access control, but that won't land this year. App sandboxing is a bit different story. (sledges, 08:08:09)
    5. Emoji keyboard will already be in 2.2.0; color emojis come when we move to Qt 5.9. (sledges, 08:08:58)
    6. Facebook, Twitter, WhatsApp, etc. won't be making native Sailfish OS apps any time soon. so you will still have to rely on android support, if we understood your question correctly (sledges, 08:10:07)
    7. regarding Secrets+Crypto APIs, it's being fully developed in open, we would greatly appreciate feedback/testing (from developers and particularly crypto experts!) - see https://github.com/sailfishos/sailfish-secrets (sledges, 08:10:48)
    8. https://github.com/sailfishos/sailfish-secrets (sledges, 08:10:54)

  3. Community solutions to long standing problems (mapping and text prediction) and how to get them on all phone (10min - asked by ApBBB) (sledges, 08:13:13)
    1. The community has developed solutions for both mapping (which sucks) and text prediction (which isn't available to every language). And we need them on the store or integrated in the OS. So how the community can help speed things up and who from jolla has to get things moving. (sledges, 08:13:41)
    2. Developer offering will see many improvements in 2018-2019. We are planning to open Qt Location after Qt upgrade 5.9 (sledges, 08:13:56)
    3. regarding WhoGo Maps to jolla store (https://github.com/sailfishos/sdk-harbour-rpmvalidator/issues/102#issuecomment-367373788) -- Some kind of background activity support is high on the list, but there are no exact schedule we could share (sledges, 08:14:32)
    4. Any newer news on "we are working contribution agreement template that would allow giving community developer access to the needed private repos, helping develop things like integrating different prediction engines to Sailfish OS keyboard"? Agreement has been drafted, currently in approval process (sledges, 08:14:50)
    5. to avoid misunderstanding in the orig topic info: The community has developed solutions for both mapping ([to replace Jolla's offering] which sucks) and text prediction ([to replace Jolla's offering] which isn't available to every language) (sledges, 08:17:15)
    6. WhoGo Maps is a continuation of Poor Maps (the latter is not actively developed anymore), so everyone's very welcome to test try WhoGo Maps from openrepos (sledges, 08:20:14)
    7. https://openrepos.net/content/otsaloma/whogo-maps (sledges, 08:20:17)
    8. (discussing about allowing socket activated daemons, read full logs for that) (sledges, 08:30:48)
    9. ACTION: Jolla to try and prioritise background services allowance in Harbour a tad more (considering decoupling daemons that feature socket activation) (sledges, 08:43:00)

  4. General discussion (10mins) (sledges, 08:46:28)
    1. if someone in the community wants to arrange an irc meeting about the app/harbour issues then we can spend more time on it (lbt-, 08:49:14)
    2. community to try spinning off harbour background services allowance support group, to be continued on #sailfishos (sledges, 08:57:44)

  5. Next meeting date (sledges, 08:59:36)
    1. Next meeting will be held on Thursday, 08:00 UTC 3rd May 2018 (sledges, 09:03:43)


Meeting ended at 09:03:51 UTC (full logs).

Action items

  1. Jolla to try and prioritise background services allowance in Harbour a tad more (considering decoupling daemons that feature socket activation)


People present (lines said)

  1. sledges (77)
  2. M4rtinK_phone_ (47)
  3. lbt- (41)
  4. r0kk3rz (29)
  5. ApBBB (22)
  6. abranson (19)
  7. ced117 (8)
  8. Mister_Magister (8)
  9. ljo (7)
  10. merbot (3)
  11. pketo (3)
  12. chriadam__ (2)
  13. eekkelund (1)
  14. veskuh (1)


Generated by MeetBot 0.1.4.