#mer-meeting: Sailfish OS, open source, collaboration – 23rd August 2018

Meeting started by sledges at 08:02:20 UTC (full logs).

Meeting summary

    1. meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2018-August/008451.html (sledges, 08:02:45)

  1. Brief introduction (5 min) (sledges, 08:02:52)
    1. Simonas Leleiva – /dev @ Jolla (sledges, 08:04:47)
    2. Rajmond Wildemann - comunity (Raymaen, 08:05:16)
    3. Vincent Knecht - community (vknecht, 08:06:04)
    4. Lewis Rockliffe - community (r0kk3rz, 08:06:08)
    5. David Llewellyn-Jones - dev in the community (flypig, 08:06:09)
    6. Martin Ebnoether - Fanboy (Venty, 08:06:40)

  2. Community contributions to non open-source components (15 min – asked by flypig) (sledges, 08:09:13)
    1. There are a number of oustanding features and bug-fixes that community members have requested in some of the closed-source SFOS components. The message from Jolla is that they are often too busy to focus on them as revenue-generating work must take priority. (sledges, 08:09:32)
    2. However, Jolla apparently have an NDA that would allow community contributors to access internal repositories to help submit code and fixes. The topic is a request for Jolla representatives to give some more info about how this works, and for the community to suggest areas for contributions and how the scheme could be made more visible to others. (sledges, 08:09:40)
    3. Jolla has already put this in practice (testing waters), and to take things further we will propose hot items from TJC or our own backlogs to a willing and experienced community developer to work on under an NDA, have minimal (but relevant) input from us (sledges, 08:11:56)
    4. We would focus on the tasks where required the UX design is relatively clear (sledges, 08:12:00)

  3. general problems with roaming on Sailfish OS (20mins – asked by Raymaen) (sledges, 08:26:27)
    1. There are a lot of questions about this topic on TJC. (sledges, 08:26:48)
    2. https://together.jolla.com/question/177397/xperia-x-roaming-does-not-show-local-operator-and-does-not-show-connection/ (sledges, 08:26:53)
    3. this question is tracked by Jolla, but since the tracking there have been 2 updates without patching this issue. In my opinion it is a huge problem that needs to be fixed as fast as possible, as it is something that makes Sailfish phones unusable as daily driver. (sledges, 08:27:02)
    4. What is the problem and why is it stil present? What can we as comunity do to help solve it? Shouldn't such critical bugs being patched as fast as there is a solution, no matter if it fits the update schedule? (sledges, 08:27:08)
    5. ACTION: Ask monich for an update for the next meeting (sledges, 08:46:18)

  4. Gen. Discussion (20 min) (sledges, 08:46:32)
    1. More on the 1st topic (community contribs to non-oss): we'll have an update during next meeting, i'll raise this during our iteration planning that will happen to happen in between these meetings (sledges, 08:50:42)

  5. Next meeting time & date (5 min) (sledges, 09:07:27)
    1. Next meeting will be held on 13th September 2018 at 08:00 UTC (sledges, 09:11:51)


Meeting ended at 09:12:04 UTC (full logs).

Action items

  1. Ask monich for an update for the next meeting


People present (lines said)

  1. sledges (69)
  2. leszek (24)
  3. flypig (22)
  4. r0kk3rz (18)
  5. Raymaen (17)
  6. vknecht (16)
  7. merbot (4)
  8. Venty (2)
  9. pketo (1)


Generated by MeetBot 0.1.4.