08:00:06 <Jaymzz> #startmeeting Sailfish OS, open source, collaboration – 25th October 2018
08:00:06 <merbot> Meeting started Thu Oct 25 08:00:06 2018 UTC.  The chair is Jaymzz. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
08:00:06 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:07 <HeinrichJolla> sledges: got it :) ... ok, at least it is on your radar now. And do you know the answer about the 99% (althought all strings are translated)
08:00:14 <jlaakkonen> HeinrichJolla: Hi, I remember you asked about the VPN plugin permissions a long time ago. We have the features ready and included in 2.2.1 to change the user, group and supplementary groups per VPN plugin but unfortunately these do not work with ConnMan's internal VPN plugins at the moment. It will work if we start to ship each VPN plugin as separate package (cannot give any estimate as no decision
08:00:17 <Jaymzz> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2018-October/008495.html
08:00:20 <jlaakkonen> regarding this has been done). Sorry about this.
08:00:27 <Jaymzz> I am the meeting’s chairperson today, and will be doing my best to keep time and order. Please behave, respect the timings and be gentle.
08:00:43 <Jaymzz> #topic Brief introduction (5 min). Please prefix your name/handle with # info
08:00:53 <Jaymzz> #info James Noori - sailor @ Jolla
08:01:08 <sledges> #info Simonas Leleiva - --- " ---
08:01:11 <DylanVanAssche> #info Dylan Van Assche, SFOS community member & developer
08:01:12 <lbt> #info David Greaces - sailor and Mer guy o/
08:01:29 <HeinrichJolla> jlaakkonen: I see, Ill be living without it for now
08:01:57 <HeinrichJolla> #info
08:02:40 <BonoNL> Hi BonoNL end user
08:02:41 <HeinrichJolla> #info Bobi Stoyanov, SFOS advanced user
08:02:42 <mattaustin> #info Matt Austin - community/developer
08:02:56 <flypig> #info David Llewellyn-Jones - dev in the community
08:02:57 <BonoNL> #info BonoNL - end user
08:03:14 <tomoshokas> #info tomoshokas - end user
08:03:21 <M4rtinK_phone_> #info Martin Kolman, community & modRana developer
08:03:34 <kimmoli> #info Kimmo Lindholm, community/developer/porting/whatnot
08:03:35 <leszek> #info Leszek Lesner, community & dev
08:03:57 <r0kk3rz> #info Lewis Rockliffe - community
08:04:28 <HeinrichJolla> @sledges: just to finish the topic: Do you know the answer of why the BG translations stays the 99%, althought all strings are translated?
08:05:03 <sledges> HeinrichJolla: it's a bug in pootle, unresearched
08:05:19 <Jaymzz> first topic coming up
08:05:37 <jwalck> #info Jonatan Walck - community
08:05:44 <Jaymzz> HeinrichJolla: If you want to continue with the translation topic, I advise you to wait until general discussion please, thanks!
08:05:47 <Jaymzz> #topic Bluetooth headset media control integration for Android (10 minutes – Asked by lp35 )#link https://together.jolla.com/question/174156/bug-bluetooth-media-control-with-android-apps-and-native-apps/
08:06:18 <Jaymzz> #link https://together.jolla.com/question/174156/bug-bluetooth-media-control-with-android-apps-and-native-apps/
08:07:10 <Jaymzz> So basically the answer to this topic is that currently we do not have any Bluetooth support for Android applications with no plans to change that for the moment. Let's see what the future brings.
08:07:38 <r0kk3rz> on this, theres a little app in bluez5-tools package called mpris-proxy where if you run it, then it works
08:07:50 <leszek> oh interesting
08:08:02 <leszek> so pretty much an easy fix then
08:08:04 <r0kk3rz> what ive never been able to figure out, is if bluez is supposed to do that normally
08:08:12 <r0kk3rz> or can be configured to do so
08:08:21 <Jaymzz> #info official Bluetooth support in Android apps does not exist as of yet with no current plans to change it.
08:08:50 <Jaymzz> r0kk3rz: That's good to have in the logs so people can test it out :) But as of now the official answer is what I # info'ed
08:09:14 <piggz> #info piggz community porter/camera hacker
08:09:18 <r0kk3rz> Jaymzz: yeah you're talking about general bluetoothy android stuff, which is accurate
08:09:18 <Jaymzz> lp35 is not present for this topic either, I just noticed
08:09:34 <Jaymzz> r0kk3rz: yes
08:09:50 <r0kk3rz> but android does pay attention to MPRISv2 messages, which is how it works with the lockscreen
08:10:00 <flypig> So mpris-proxy solves the problem for both Android and native apps?
08:10:19 <flypig> That's not clear from the TJC answer
08:10:44 <r0kk3rz> i spoke with lp35 about this, and they tested it also
08:11:12 <r0kk3rz> ive just got mpris-proxy being started by systemd...
08:12:58 <Jaymzz> r0kk3rz: Thanks for talking to lp35 about this :) great to have it somewhat solved then
08:13:16 <M4rtinK_phone_> sounds like making it start by default will make many people happy
08:13:34 <leszek> yep :)
08:13:54 <M4rtinK_phone_> improving the overall Android emulation experience
08:13:58 <r0kk3rz> im not sure thats the *proper* way to do it
08:14:54 <r0kk3rz> maybe one of the sailors might know better
08:15:03 <Jaymzz> Yeah it does sound like it. I need to take this internally and see if sailors have any comments on the possibilities of enabling the default start up of this feature. But it has to wait 'till after we have released Sailfish 3 as no one will have the time to answer me now
08:15:59 <pketo> it probably should have a toggle in setting. at least I experienced some weird behavior with some devices, though not exactly sure if it was caused by mpris-proxy
08:16:17 <r0kk3rz> pketo: weird behaviour?
08:16:48 <Jaymzz> giving this topic 5 more minutes as pketo joined the discussion :)
08:17:19 <r0kk3rz> tbh it would be nice to trigger it, because it only needs to be running when an AVRCP device is connected
08:18:11 <pketo> at first my car media thingie didn't even get audio out, required several reconnects, haven't had that before
08:18:49 <pketo> but haven't used it so much, it could be some other random issue also
08:19:35 <r0kk3rz> i almost always have to disconnect and reconnect my headphones to get the audio to route properly
08:19:52 <r0kk3rz> but thats a seperate issue i think
08:20:16 <Jaymzz> And time is up for this topic
08:20:22 <lbt> Jaymzz: want to info the takingit internal
08:20:27 <lbt> to follow up :)
08:20:33 <Jaymzz> Let's take the rest of it in general discussion later
08:20:36 <Jaymzz> lbt: yes
08:21:10 <pketo> it would be good if people could test the mprix-proxy can give feedback on how well it behaves
08:21:22 <lbt> pketo: docs?
08:21:28 <Jaymzz> #action Jaymzz to talk to sailors internally about this topic after Sailfish 3 release to see the potential issues and report back.
08:21:40 <pketo> lbt: see the tjc post
08:21:44 <lbt> :)
08:21:52 <Jaymzz> alright moving on
08:22:02 <r0kk3rz> i've been using it for a while, so feel free to chat to me about it :)
08:22:06 <lbt> #info see the tjc post for docs on trying it out
08:22:09 <Jaymzz> #topic Status of QtWebengine/QtWebkit/Gecko/... in SFOS 3 (25 minutes – asked by DylanVanAssche )
08:22:21 <Jaymzz> #info As promised during MWC 2018, SFOS 3 will have a new WebEngine (https://jolla.com/sailfish3/). Until now, no details were given to devs what changes might be coming and when. Some apps like Sailbook, WebCat, ... might need huge changes and we would like to prepared for these changes. Which type of engine will be available for devs? Which version of Gecko/Chromium/... ? Removal of QtWebkit or upgrading to the latest release (by
08:22:21 <Jaymzz> Leszek)?
08:22:28 <Jaymzz> #link https://jolla.com/sailfish3/
08:22:45 <Jaymzz> #info It is unlikely that we will include this in our first Sailfish 3 release, but we can get back to you on the status afterwards, since our engineers are currently too busy with other tasks that have been prioritised for the 3.0.0
08:23:20 <DylanVanAssche> I understand that, just curious about the current status of it: to do, in progress, ...
08:23:56 <r0kk3rz> what of qtwebkit, will it still be around? i think its been more or less abandoned upstream
08:24:05 <leszek> What I think is important is if QtWebkit will be deprecated or not? So for us devs who use it do we need to change anything? Will there be backwards compatibility or will our apps stop running?
08:24:22 <Jaymzz> DylanVanAssche: It really is the case I said above, as I tried to get some top level engineers on board here to chat with you about this but it was simply not possible as there is the Sailfish 3 priority keeping them fully busy at the moment... Otherwise I'd have a more decent answer for you.
08:24:23 <DylanVanAssche> That's the important thing here, how are devs affected
08:24:50 <DylanVanAssche> Jaymzz: No problem :)
08:25:28 <Jaymzz> #info importsant questions by community devs: Will QtWebkit be deprecated or not? So for us devs who use it do we need to change anything? Will there be backwards compatibility or will our apps stop running?
08:25:50 <Jaymzz> #action Jaymzz to try an find an answer to these after Sailfish 3 release
08:26:12 <DylanVanAssche> Jaymzz: Thanks!
08:26:29 <Jaymzz> No problem! Hopefully I'll be back with good news :P
08:26:41 <Jaymzz> Anything else on this topic?
08:26:42 <M4rtinK_phone_> I kinda remember some new activity about qtwebkit upstream, not sure if it is still continuing till noww
08:26:54 <DylanVanAssche> Nope, that's it
08:27:14 <Jaymzz> Okay, short and sweet :) moving on
08:27:16 <r0kk3rz> i guess we'll find out what breaks when the EA drops :D
08:27:27 <Jaymzz> ;)
08:27:34 <leszek> M4rtinK_phone_: QtWebkit 5.212 wasn't updated since january
08:27:43 <Jaymzz> #topic General discussion (15min)
08:28:13 <piggz> quick Q ... as i understand qclipboard doent work in wayland ... how does the sfos clipboard work?
08:28:19 <Jaymzz> I can potentially give up to 10 extra minutes to the General discussion because the previous topic ended faster than we thought
08:28:36 <leszek> piggz: the wayland compositor takes care of it so lipstick
08:28:45 <M4rtinK_phone_> ah, ok (that still does not seem *that* bad)
08:28:45 <BonoNL> Hey @Jaymzz
08:28:50 <BonoNL> Where is my topic
08:28:58 <BonoNL> which I added this morning?
08:29:05 <BonoNL> https://together.jolla.com/question/94810/new-emails-in-subfolders-not-shown/
08:29:06 <leszek> too late maybe :P
08:29:13 <BonoNL> Allright
08:29:23 <BonoNL> Just to mention it
08:29:25 <piggz> leszek: so, can I access that from qclipbaord? asking becuase the kdeconnect clipboard plugin doesnt work atm and would like to add it
08:29:49 <Jaymzz> BonoNL: I didn't notice it when I wrote the email. the deadline was 30 min before the meeting...
08:30:40 <Jaymzz> BonoNL: I still don't see it here: https://together.jolla.com/question/54157/sailfishos-open-source-collaboration-meeting-planning/
08:30:57 <leszek> piggz: yeah should be possible. At least I am sure for the QML part because this is what I used more often. Though yeah I also used qclipboard for copying stuff into the clipboard in webcat as a workaround back in the day when the normal marking of text would not always work
08:31:58 <M4rtinK_phone_> I transferred a Sailfish X license from a broken Xperia X to a friends Jolla accout a while ago (spring) and he has not yet used it, will it work for him once he gets a XA2 or will he need to buy a new license ? :)
08:32:18 <BonoNL> Ok I will wait till next meeting
08:32:22 <r0kk3rz> BonoNL: generally bug reports dont make great meeting topics
08:32:32 <leszek> M4rtinK_phone_: new phone = new license I think
08:32:35 <BonoNL> I think this isn't a bug
08:32:41 <BonoNL> It's a missing feature
08:32:53 <BonoNL> And I think it should be in sailfishOS
08:33:02 <BonoNL> But will bring it up next time
08:33:07 <BonoNL> If I can make it
08:33:25 <leszek> Yeah BonoNL it should be configurable to set IMAP folders to be watched for new mails in some kind of settings
08:33:47 <r0kk3rz> new feature requests is what tjc is for
08:33:53 <leszek> If its true we will get a overhauled email client anyways. Not sure if with the launch of SailfishOS 3 or after
08:34:13 <lbt> M4rtinK_phone_: we're going to get some official info on licenses but it's a discrete device/license
08:34:30 <r0kk3rz> the email client will see some work since its a fairly core business phone thing
08:34:31 <piggz> leszek: i think the issue comes from QGuiApplication::clipboard() returung NULL on wayland
08:34:46 <leszek> So that brings me to my next question. Will SailfishOS 3.0 feature all the announced features or will we see most of the features rolling out throughout the 3.x series?
08:35:10 <r0kk3rz> it'll no doubt be a series of updates
08:35:20 <M4rtinK_phone_> I guess that makes sense, we will see :)
08:35:21 <Jaymzz> leszek: Not all the features will find their way in the first release
08:35:33 <Jaymzz> but a lot of them are included
08:35:54 <M4rtinK_phone_> in any case, I suggest improving the license management ui in Jolla account
08:36:00 <leszek> piggz: see https://github.com/llelectronics/webcat/blob/master/src/myclass.cpp#L275  this is how I use the clipboard in cpp
08:36:08 <r0kk3rz> certainly with 2.2 being rolled into 3.0, its gonna be a big update
08:36:10 <M4rtinK_phone_> it is really really barebones at the moment
08:36:51 <lbt> M4rtinK_phone_: yeah - that is in the plans
08:36:55 <leszek> Jaymzz: hmm... like I feared. Would be nice if that would be made clear before the release maybe. So if Qt 5.9 for example is missing from the 3.0 release it might be a big dissappointment for devs and perhaps even community
08:37:16 <M4rtinK_phone_> the friend can't even see the transferred license anywhere (even thou we have a ticket confirming the transfer), looks like it only shows up once a phone starts using it
08:38:02 <leszek> and when talking to others interested in SailfishOS 3.0 they are also thinking about switching because of the feature list. If only half of it is included in 3.0 they will be dissappointed aswell. A blogpost beforehand explaining the plan for the 3.x release would help I hope
08:38:09 <M4rtinK_phone_> lbt: ok, good to know :)
08:38:20 <Jaymzz> leszek: Why would you fear? :) We announced the features that will be included in Sailfish 3. We never said that it will be 3.0.0! So What you will see on 3.0.0 is a start of what we are going to make available on Sailfish 3.
08:38:40 <leszek> Jaymzz: apparently that is not clear for the majority of people
08:38:53 <M4rtinK_phone_> leszek: agreed - another thing that has been rather quiet is the Android API level upgrade
08:39:13 <r0kk3rz> Jaymzz: the marketing messages out of jolla have been almost incomprehensible for a while now :P
08:39:22 <M4rtinK_phone_> so I suspect that also got bumped to 3.x release
08:39:26 <piggz> leszek: how can line 289 work there??
08:39:32 <piggz> uninitialised pointer?
08:39:34 <leszek> Jaymzz: thats why I mention it. Press will be all over it aswell and if not stated beforehand it might end up in a press desaster or negative press
08:40:07 <leszek> piggz: 289 is a } ?
08:40:18 <M4rtinK_phone_> Jaymzz: I'm afraid most people (including me) don't see it that way
08:40:23 <lbt> M4rtinK_phone_: just FYI I've passed that bug along
08:40:36 <piggz> leszek: 281
08:40:38 <vknecht__> why not 2.9.1, 2.9.2, etc. till it's complete ? :-)
08:41:22 <leszek> piggz: not sure what you mean looks like a valid cpp code for me
08:41:25 <M4rtinK_phone_> in other news modRana will include a star ship navigation system in a future release ;-)
08:41:40 <M4rtinK_phone_> lbt: thanks! :)
08:41:46 <r0kk3rz> vknecht__: because they promised 3 by an arbitrary date :)
08:41:48 <leszek> vknecht__: I doubt you can change it now. So that question is like obsolete
08:41:50 <Jaymzz> Thanks for the feedback guys, I'll definitey take it internally. It's good to look at how people (especially you guys) look at this from your point of view. We would love to have all the features available for you from the get go but that is simply not feasible. A lot of the announced features will be on 3.0.0 however.
08:41:55 <piggz> leszek: its a pointer, but no new(...)
08:41:55 <lbt> vknecht__: don't people know that version X.0 marks a new release and then X.1 X.2 brings in new features and bug fixes
08:42:07 <M4rtinK_phone_> lbt: I can ask the friend to test a fix if needed :)
08:42:15 <lbt> of course we won't have any bugs *grin*
08:42:34 <leszek> piggz: why should it be new. I use it like a QString
08:42:46 <vknecht__> right :)
08:43:15 <piggz> leszek: no, that would be witout the * ... im sure that code shouldnt work :D
08:43:41 <piggz> QClipboard cb; cb. (not ->) etc
08:43:41 <leszek> it works :)
08:43:51 <lbt> Jaymzz: maybe we should feedback that the community would like us to hold off on 3.0 until it's all ready?
08:44:12 <leszek> piggz: I used this bit of code in other code aswell to fix the issue with the clipboard I had in the past. Worked all the time
08:44:25 <leszek> I even did a push request once in lipstick using this to fix the issue with the clipboard
08:44:39 <Jaymzz> lbt: Yeah that would take its time I fear :D
08:45:18 <lbt> We should hold a poll ... "Release 3.0 ASAP or wait until we have more features?"
08:46:31 * M4rtinK_phone_ wonders if pairing XA2 support with a major Sailfish OS was a good idea
08:46:43 <leszek> lbt: nope would be a press desaster not delivering on time
08:46:49 <Jaymzz> lbt: I doubt that would work out really, because everything is planned on our side
08:47:10 <leszek> with the new UI and encryption support and maybe the new Qt version though I have my doubts according to my spies in the c-beta program... :P
08:48:01 <M4rtinK_phone_> I know a couple people waiting for XA2 to be supported (so they can get a new not second hand device)
08:48:11 <leszek> So new UI, encryption + some other quick fixes and such it still deserves the 3.0 release name. Though it should be made clearly that the other features will come in future 3.x releases
08:48:19 <FaerieFly> I'm waiting for XA2 to be supported so I can switch to the XA2 I bought :p
08:48:27 <M4rtinK_phone_> leszek: +1
08:48:39 <lbt> leszek: oh I agree - but I'm glad you do too :)
08:49:00 <Jaymzz> leszek: Good point. I already took your feedback internally and showed my concern.
08:49:10 <DylanVanAssche> The website says: Sailfish 3 updates, not just 1 update :p
08:49:17 <lbt> I think 3.0 and then 3.1 is part of the early/often thing which is what being open is about
08:49:55 <Jaymzz> DylanVanAssche: Yes, but often what the general public sees is what they want to see which is having everything at once :)
08:50:29 <DylanVanAssche> Jaymzz: True! Change it to: Coming up in the next SFOS 3 updates
08:50:35 <DylanVanAssche> Maybe change it to*
08:50:57 <Jaymzz> Yeah let's see where we go with our wording :)
08:51:07 <Jaymzz> But time is up for this as well guys
08:51:18 <Jaymzz> moving on
08:51:26 <Jaymzz> #topic Next meeting's time and date (5 min)
08:52:01 <Jaymzz> 2 weeks from now we have Sailfish 3 day in Helsinki, as you may have seen on our social media, so we would have to postpone this to 3 weeks from now
08:52:39 <Jaymzz> How is November 15th 2018 at 08:00 UTC? It's after the Berlin meetup as well :)
08:53:49 <Jaymzz> I guess everyone is ok with it ;)
08:54:00 <DylanVanAssche> Fine for me :)
08:54:02 <leszek> sounds good
08:54:02 <flypig> Sounds good :)
08:54:09 <Jaymzz> #info next meeting will be held on November 15th 2018 at 08:00 UTC
08:54:17 <Jaymzz> Thanks everyone for participating today!
08:54:21 <vknecht__> beaujolais nouveau day :) +1
08:54:40 <Jaymzz> Minutes will be sent to you later on during today :)
08:54:45 <Jaymzz> #endmeeting