09:00:05 <Jaymzz> #startmeeting Sailfish OS, open source, collaboration – 15th November 2018
09:00:05 <merbot> Meeting started Thu Nov 15 09:00:05 2018 UTC.  The chair is Jaymzz. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:00:05 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:00:09 <Jaymzz> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2018-November/008499.html
09:00:16 <Jaymzz> I am the meeting’s chairperson today, and will be doing my best to keep time and order. Please behave, respect the timings and be gentle.
09:00:26 <Jaymzz> #topic Brief introduction (5 min). Please prefix your name/handle with # info
09:00:33 <Jaymzz> #info James Noori - sailor @ Jolla
09:00:38 <Mister_Magister> #info Mister_Magister - mad porter
09:01:08 <leszek> #info Leszek Lesner - community + dev
09:01:11 <lbt> #info David Greaves - sailor and Mer guy
09:01:21 <DylanVanAssche> #info Dylan Van Assche - community member and app developer
09:01:26 <Krikke> #info Krister Bäckman - sailfish enthusiast
09:01:48 <mattaustin> #info Matt Austin - community / dev
09:01:57 <r0kk3rz> #info maximus decimus meridius - father to a murdered son, husband to a murdered wide, and loyal servant of the true emperor marcus aurelius
09:02:07 <Kopo> #info Lauri Kopo - sailor @ Jolla
09:02:10 <leszek> lol
09:02:18 <Jaymzz> r0kk3rz: dude :D
09:02:41 <mord> #info Aapi Hämäläinen - sailor @ Jolla
09:02:48 <flypig> #info David Llewellyn-Jones - newly engaged sailor @ Jolla
09:02:50 <Mister_Magister> r0kk3rz: lel
09:03:15 <DylanVanAssche> r0kk3rz: hehe
09:03:24 <ljo> #info Leif-Jöran Olsson, community
09:03:44 <birdzhang[m]> #info BirdZhang - community
09:03:59 <Mister_Magister> wew many sailors i never heard about
09:04:05 <abranson> #info Andrew Branson - dev @ Jolla
09:04:13 <sledges> #info Simonas Leleiva - sailor @ Jolla
09:05:10 <Jaymzz> #topic Bluetooth headset media control integration for Android (asked by lp35 – 10 min)
09:05:19 <Jaymzz> #link https://together.jolla.com/question/174156/bug-bluetooth-media-control-with-android-apps-and-native-apps/
09:05:40 <tadzik> #info tadzik – community, app dev
09:06:04 <Jaymzz> #info Alright so lp35 is not here as of now, and also I haven't been able to squeeze and answer for this question yet. So we may have to postpone this again to the next meeting
09:06:06 <Nrde> Nrde, lurker
09:06:38 <Jaymzz> I'll wait a minute or two, if no discussion gets generated on this one, I'll move on to save time and save you from boredom
09:06:59 <r0kk3rz> didnt we discuss this last time anyway?
09:07:26 <Jaymzz> r0kk3rz: Yes, but I was supposed to get an answer for "why isn't this enabled by default?" and I haven't been able to
09:07:46 <r0kk3rz> because it like that, and thats the way it is?
09:07:56 <jwalck> #info Jonatan Walck, community
09:07:56 <Jaymzz> I maybe should have # info'ed that to avoid confusion :D
09:08:10 <spiiroin> #info Simo Piiroinen - dev @ jolla
09:08:13 <Jaymzz> r0kk3rz: well, it might be, but I still don't know :)
09:08:28 <Jaymzz> anyway I think it is better to move on
09:08:42 <physkets> #info physkets - community
09:08:50 <Jaymzz> #topic Status of QtWebengine/QtWebkit/Gecko/ in Sailfish 3 (asked by DylanVanAssche – 25 min)
09:09:02 <Jaymzz> #info Jolla CEO hinted the community to help with the browser. That woulb be possible if the community can get access to the QtWebEngine builds of the customers. The community can build a browser around it and make it easier for Jolla to decide if they keep the Gecko browser or move to a Chromium based one.
09:09:25 <Jaymzz> So first of all:
09:09:31 <Jaymzz> #info Sailfish Browser is fully open source, any contribution is welcome and all Jolla's work on the browser and browser engines are happening openly. We haven't announced any change in our browser engine strategy, and plan to maintain Gecko for the time being. We are open to alternatives such as QtWebEngine, but building a new browser would be a big effort. QtWebEngine is also open source and any volunteer can look up building a br
09:09:31 <Jaymzz> owser on it. We will be upgrading our Qt version soon too.
09:10:02 <ApBBB> we basically need firefox :/
09:10:04 <Jaymzz> now that you have that from our side, let's discuss! DylanVanAssche the stage is yours for about 25 minutes or less :)
09:10:12 <leszek> In all honesty I am dissappointed by Jolla here
09:10:22 <leszek> no strategy at all for a stable browser
09:10:23 <r0kk3rz> Jaymzz: is there a build/packaging on gmo or mobs?
09:10:34 <DylanVanAssche> Jaymzz: does that mean that QtWebEngine is coming to SFOS? It's already in Qt 5.6 but we don't have it in the repos yet.
09:10:39 <leszek> just put some effort in at least maintaining a browser engine that is integrated in the system
09:10:55 <leszek> and up2date
09:11:03 <Mister_Magister> at least update gecko to latest
09:11:18 <leszek> it doesn't matter if gecko which wasn't updated in ages and is a big security nightmare for all SailfishOS versions
09:11:21 <Jaymzz> r0kk3rz: DylanVanAssche: I'lllet my more capable colleagues take those questions, as I'm not as knowledgable in browser stuff :)
09:11:22 <r0kk3rz> updating gecko is probably not trivial
09:11:45 <leszek> true it isn't but not caring at all is not going to help either
09:12:28 <r0kk3rz> yeah its always good to see 'please upgrade your browser' on every site :)
09:12:44 <ApBBB> what was missing to be able to build FF on SFOS??
09:12:50 <ApBBB> gcc??
09:12:53 <Mister_Magister> exploiting sfos browser should be a kid play
09:13:04 <r0kk3rz> ApBBB: i got part of the way, we need a wayland update
09:13:17 <DylanVanAssche> updating Gecko is a big job, maybe by publishing a build of QtWebEngine for SFOS we can build a browser on top of it. If Jolla wants to maintain Gecko in the future, they can. In the meantime we can provide a better engine for SFOS without a lot of work of adapting each update to the engines.
09:13:36 <leszek> As for QtWebEngine I as a webcat developer am not willing to put any effort in the browser engine at all. From my point of view Jolla has to provide a nice QML Api for it that can be used by all apps in SailfishOS. SailfishOS is a plattform and that needs an infrastructure for webbrowsing. If its qtwebengine fine by me. Probably easier to handle than Gecko. Though Jolla needs to provide an usable API
09:13:36 <Mister_Magister> yep
09:13:38 <leszek> otherwise no more browser updates from my side thats for sure
09:13:41 <ApBBB> r0kk3rz: have you tried updating it?? i mean wayland is ready since a long time and an update won't make a difference i think
09:13:43 <Mister_Magister> i agree with DylanVanAssche
09:14:05 <Mister_Magister> jolla since 5 years didnt do so advanced functionality as history
09:14:06 <ApBBB> r0kk3rz: the protocol
09:14:21 <DylanVanAssche> leszek: I checked the QML API of QtWebEngine again and compared it with WebCat features. They are almost all already there :)
09:14:39 <leszek> For the reference I put effort in QtWebkit 5.212 and did PRs and had promises after promises that someone from Jolla will take a look at it but that never happened. I am fed up with this and won't do anything in that matter anymore
09:14:56 <DylanVanAssche> leszek: I completely understand!
09:15:13 <r0kk3rz> ApBBB: obviously :P
09:15:26 <r0kk3rz> #link https://git.merproject.org/adenexter/qtwebengine/tree/jb38821/5.9.5+git0
09:15:34 <r0kk3rz> i presume thats the source
09:15:52 <mal> r0kk3rz: it looks like wayland update might be blocked by Qt upgrade, everything else works except sdl apps, based on my investigation there might be some race condition between sdl and qtwayland
09:16:12 <ApBBB> r0kk3rz: so. if wayland is updated FF will work?
09:16:14 <DylanVanAssche> Yeah that should be the source, Jolla should push this to the repos and the SDK.
09:16:19 <r0kk3rz> ApBBB: no idea
09:16:39 <mal> r0kk3rz: I have been running updated wayland on fp2 for months
09:16:44 <r0kk3rz> that was likely the first of several hurdles
09:16:50 <Mister_Magister> mal: you hacka :P
09:16:56 <ApBBB> r0kk3rz: ok.
09:17:07 <Mister_Magister> but SDL is needed
09:17:33 <mal> I know which exact line in SDL code causes the crash
09:17:49 <DylanVanAssche> @jolla is there anything else required for QtWebEngine? I remember when I tried to build it, it required a Chromium build first.
09:17:51 <Mister_Magister> you think qt update will fix that?
09:17:58 <r0kk3rz> but if we can get qtwebengine built on merobs, i can try porting the ubuntu touch browser
09:18:21 <mal> the related code in QtWayland was mostly rewritten in 5.9 so might help
09:18:37 <DylanVanAssche> r0kk3rz: That would be awesome and that's basically my idea. Even Github doesn't function properly anymore in Gecko 38
09:18:45 <leszek> did someone at jolla build qtwebengine together with test builds of 5.9 already? It is not so trivial and needs a lot of attention to go right
09:18:55 <Mister_Magister> qtwebengine should open the gate for real browser
09:19:10 <r0kk3rz> DylanVanAssche: if i do the building you wanna do the app hacking?
09:19:11 <DylanVanAssche> leszek: +1
09:19:18 <r0kk3rz> im -ETOOMANYPROJECTS as it is
09:19:25 <DylanVanAssche> r0kk3rz: I can try to create a POC
09:19:31 <r0kk3rz> cool cool
09:19:35 <leszek> The problem I see even with qtwebengine that if Jolla does not care we end up with an outdated engine again. As QtWebEngine from 5.9 is outdated already in terms of blink engine it provides
09:19:59 <leszek> so there needs to be at least one developer responsible for updating that browser engine or backport security fixes
09:20:08 <Mister_Magister> leszek: true and i guess they won't care
09:20:12 <r0kk3rz> leszek: it is somewhat surprising that one of the marketed items for SFOS3 jolla has just gone 'sorry no time, you guys deal with it'
09:20:27 <leszek> otherwise next year we will sit here and discuss the same topic again but in this case with an outdated security monster called blink/qtwebengine
09:20:28 <DylanVanAssche> leszek: As soon as we have a QtWebengine of Qt 5.9 ready, maybe we can back port the one from Qt 5.12
09:20:31 <Mister_Magister> r0kk3rz: its not really
09:21:04 <DylanVanAssche> r0kk3rz: +1
09:21:08 <leszek> DylanVanAssche: Qt officially from 5.12 will be providing QtWebEngine updates outside of normal Qt releases as they also noticed that issue
09:21:33 <Mister_Magister> qt 5.9 was release almost 2 years ago so its pretty old already
09:21:41 <leszek> r0kk3rz: from my view it looks like jolla is shooting itself in the foot
09:21:43 <Jaymzz> DylanVanAssche: 10 minutes left :)
09:21:50 <DylanVanAssche> leszek: hmmm I didn't that know, makes it more interesting.
09:22:00 <DylanVanAssche> Jaymzz: check :)
09:22:18 <ApBBB> leszek: they have a history of overpromising :P.
09:22:18 <leszek> you can't market SailfishOS as a plattform without caring about a browser or at least an up to date browser engine
09:22:22 <DylanVanAssche> Jaymzz: Some input from Jolla would be appreciated though
09:22:44 <Piggz> please also test any new engine with zippie!
09:22:58 <Mister_Magister> ApBBB: jolla new motto would be breaking promises
09:23:01 <r0kk3rz> pwa support would be really nice there...
09:23:06 <leszek> honestly whoever deciced that @ jolla I want to slap some sense into him
09:23:25 <DylanVanAssche> Piggz: I almost forgot that, Zippie requires an up-to-date browser engine
09:23:25 <ApBBB> Mister_Magister: i can't blame them TBH. they are small
09:23:42 <Jaymzz> DylanVanAssche: working on it
09:23:43 <Mister_Magister> ApBBB: dont promise something you wont do then
09:23:51 <Piggz> it does, and progressive web app suppport
09:23:55 <DylanVanAssche> Jaymzz: +1
09:24:19 <ApBBB> Mister_Magister: things can go wrong. i am not getting pissed on stuff like that
09:24:21 <DylanVanAssche> r0kk3rz: https://git.merproject.org/adenexter/qtwebengine/tree/jb38821/5.9.5+git0/examples this should be doable, running such an example on SFOS
09:24:26 <r0kk3rz> pwa support isnt 'required' its just nice to have
09:26:20 <DylanVanAssche> r0kk3rz: https://git.merproject.org/adenexter/qtwebengine-chromium/tree/jb38821 this seems to be the Chromium build
09:26:32 <r0kk3rz> DylanVanAssche: yes i found that also
09:27:52 <DylanVanAssche> r0kk3rz: So basically, if you get the whole thing build on OBS, I will try to create a simple POC and if that works, write some docs to get other devs started with it
09:28:10 <DylanVanAssche> r0kk3rz: Sounds good?
09:29:21 <ljo> +1
09:29:36 <r0kk3rz> yeah will see how far i get
09:29:40 <Mister_Magister> DylanVanAssche: i could do something myself
09:29:49 <Mister_Magister> -ETOOMANYPROJECTS overloaded
09:30:09 <DylanVanAssche> Mister_Magister: The more hands the better, I'm pretty busy myself with my thesis too
09:30:42 <Mister_Magister> i think topic has ended
09:31:33 <DylanVanAssche> Yeah it is
09:31:44 <Mister_Magister> Jaymzz: do your thingy
09:31:49 <leszek> Maybe we need someone to talk some sense in the russian shareholders to convince them to pay jolla for getting a decent browser engine. Thats plan b :)
09:32:03 <Krikke> that always works
09:32:05 <DylanVanAssche> Hahah :p
09:32:26 <Jaymzz> DylanVanAssche: Unfortunately the time is up, and so far from our side, the #info that I provided up there is all we can comment. But you can certainly reopen this discussion if you like for the next meeting
09:32:49 <DylanVanAssche> Jaymzz: Okay fine :) we have something to start with
09:32:50 <Jaymzz> Moving on
09:32:55 <Jaymzz> DylanVanAssche: indeed
09:33:08 <Jaymzz> #topic USB Tethering (asked by krikke – 10 min)
09:33:18 <Jaymzz> #link  https://together.jolla.com/question/191787/3005-usb-tethering-not-working-anymore/
09:33:29 <Krikke> ok so it'
09:33:31 <Jaymzz> #info https://together.jolla.com/question/3798/usb-tethering/?answer=61513#post-id-61513 The documented unofficial method does not work after upgrading to Sailfish 3.
09:33:43 <Jaymzz> #link https://together.jolla.com/question/3798/usb-tethering/?answer=61513#post-id-61513
09:34:25 <Jaymzz> Krikke: Give me a second, I'll answer the topic
09:34:28 <Krikke> it's my first time in this meeting, just wanted to bring to attention this, I conjured up a fix that should probably be incorporated to usb-moded-connection-sharing-android-config and usb-moded-connection-sharing-android-connman-config packages
09:35:04 <Krikke> also I was told to brind this up here so tell me if I'm wrong :)
09:35:22 <Jaymzz> #info We don't officially support this functionality, but according  to some internal testing this should be working. In the next lines, I'll paste an instruction we just tested and worked on an Xperia X:
09:35:34 <Jaymzz> Krikke: you are not wrong! Just give me a sec ;)
09:35:39 <tortoisedoc> arf
09:35:43 <tortoisedoc> did I just miss the browser discusison
09:35:47 <tortoisedoc> *discussoin
09:35:51 <Krikke> tortoisedoc: yes
09:35:51 <tortoisedoc> *discussion too :P
09:35:56 <tortoisedoc> awesome
09:36:16 <Jaymzz> So the instructions go something like this:
09:36:37 <Jaymzz> (you do this in terminal, of course)
09:36:41 <Jaymzz> 1. zypper ref
09:36:47 <Jaymzz> 2. zypper in usb-moded-connection-sharing-android-connman-config
09:36:53 <Jaymzz> 3. systemctl restart usb-moded
09:37:02 <Jaymzz> 4. connect to pc with usb cable
09:37:09 <Jaymzz> 5. select internet sharing
09:37:13 <Jaymzz> 6. enjoy!
09:37:29 <Mister_Magister> Jaymzz: you just did very wrong thing in irc but ill let you pass
09:37:32 <Krikke> that was the first thing I tried and it didn't work
09:37:57 <Krikke> anyway it's working for me right now but would be nice if it would work for everyone
09:38:06 <Krikke> I documented the process in the link
09:38:07 <Jaymzz> Krikke: this has worked in our internal testings. Maybe you can try resetting your phone to see if it fixes the issue?
09:38:19 <Jaymzz> Krikke: as said above, this is not an officially supported feature...
09:38:25 <Krikke> I'm not going to do that
09:38:27 <abranson> Krikke: what's your fix?
09:38:35 <Krikke> https://together.jolla.com/question/191787/3005-usb-tethering-not-working-anymore/
09:38:43 <Krikke> the first answer
09:39:15 <Krikke> the problem with "Internet sharing"-mode is it's not bringin up the rndis0 device. Which developer mode does
09:39:20 <ApBBB> any reasons why this is not officially supported?
09:39:37 <Krikke> should be an easy fix to just match the config from developer mode into the other packages
09:39:54 <abranson> Krikke: so you're saying that it doesn't work without developer mode enabled?
09:40:01 <Krikke> not for me at least
09:40:06 <Krikke> tried it on X and C
09:40:14 <Krikke> and the documented fix works on both
09:40:31 <Jaymzz> Apologies for the hiccup, I got disconnected for a minute there...
09:40:38 <Krikke> ah
09:40:47 <abranson> ok, that's an important detail. most people using that will have dev mode enabled. not least because it's quite hard to install usb tethering support without it!
09:40:48 <Krikke> should I re paste
09:41:09 <Jaymzz> Krikke: If you want me to read what you wrote :P
09:41:12 <spiiroin> ApBBB: to start with: it pays no attention to data call limitations one might have set elsewhere
09:41:17 <Krikke> the problem with "Internet sharing"-mode is it's not bringin up the rndis0 device. Which developer mode does
09:41:20 <Krikke> should be an easy fix to just match the config from developer mode into the other packages
09:42:17 <Coolgeek> zypper : command not found
09:42:19 <Krikke> I can even make that config for you if you can give me an contact who can put it in the repo
09:42:32 <Krikke> since I'm already familiar with how it works
09:43:34 <Jaymzz> Krikke: I think we can start by my email. Just email me at james.noori@jolla.com and we shall see if this is something doable from our side. Since we don't exactly support this feature, I would imagine some blockers in front of us trying to pass the fix into the repo.
09:43:46 <Jaymzz> But we'll do our best :)
09:44:03 <Krikke> okay
09:44:05 <flypig> Coolgeek: you have to install zypper first. "su-devel pkcon install zypper" I think.
09:44:37 <Jaymzz> #action jaymzz to take on the task of passing the fix for this topic to responsible sailors that can put it in repo
09:44:39 <Krikke> Jaymzz: I'll try to make the fix into the config and see if we can get this through
09:44:44 <mal> pkcon install can be used to replace zypper in
09:44:53 <Jaymzz> Krikke: thanks
09:44:58 <Jaymzz> moving on then :)
09:45:01 <Krikke> thanks
09:45:21 <Jaymzz> #topic The 3 year old email/connection bug (asked by ApBBB – 15 min)
09:45:31 <Jaymzz> #info https://together.jolla.com/question/97109/email-imap-idle-doesnt-work-with-both-connections-active/ this is an old and ultra annoyin bug that has been brought up a few times and noone has fixed it thus far.
09:45:42 <Jaymzz> #link https://together.jolla.com/question/97109/email-imap-idle-doesnt-work-with-both-connections-active/
09:46:13 <Jaymzz> #info from rainemak__: Some mentioned that when creating gmail account imap idle push works. So, this could be an error in the generic account. Messaging framework getting confused when there are multiple active connection feels a bit different issue. Let's see what can be done here. We're tracking the issue.
09:47:15 <Jaymzz> ApBBB: do you have anything to add on top of that?
09:47:17 <ApBBB> damien caliste and others researched a bit and posted their findings in the cinnebts
09:47:21 <ApBBB> comments
09:47:35 <ApBBB> Jaymzz: i just want this fixed tbh
09:47:37 <Mister_Magister> This topic is funny itself
09:47:45 <Mister_Magister> like in the name
09:47:45 <ApBBB> Mister_Magister: ????
09:47:56 <Mister_Magister> "The 3 year old email/connection bug"
09:48:04 <Jaymzz> Mister_Magister: please stop the unneccesary comments man. It wastes time
09:48:08 <ApBBB> well its exactly this.
09:48:10 <Mister_Magister> Jaymzz: ah sorry
09:48:46 <ApBBB> email is importand and its not fun to have to use flight mode every time i go in and out of my appartment
09:49:10 <ApBBB> Jaymzz: if you could give me an ETA of some sort it would be great
09:49:30 <leszek> lol
09:49:42 <ApBBB> and tell me if it is in the internal bug tracker
09:49:46 <Jaymzz> ApBBB: I certainly can't. I'm trying to track down Raine to discuss this with you but I think he's in another meeting internally...
09:49:57 <ApBBB> ok.
09:50:20 <ApBBB> we can move on then.
09:51:10 <Jaymzz> 1 sec, let me see if I can get hold of him...
09:52:41 <sledges> ApBBB: TJC says it's "Tracked by Jolla", meaning it's in the internal bugtracker
09:53:53 <tortoisedoc> sledges : does it also mean it will get fixed?
09:53:54 <Jaymzz> ApBBB: He can't comment here for some reason, the bot is giving him a hard time
09:53:55 <Jaymzz> but
09:54:12 <Jaymzz> This is what he said:  "I'll give a look and check what can be done"
09:54:14 <ApBBB> sledges: its been there for quite a while now :/
09:54:46 <ApBBB> Jaymzz: tell him to comment at the TJC thread if he finds something. Also tell him there are info there that might help him
09:54:47 <leszek> Thats normal. Take a look at the KDE Bug tracker. There are bugs there for decades
09:54:54 <Jaymzz> ApBBB: that's understood :) it'll be looked at as you brought it up to our attention. There is a chance that multiple bugs are lurking underneath there.
09:54:59 <leszek> I know why Jolla does not want to show their bug tracker :)
09:55:02 <Jaymzz> Sure will do ApBBB
09:55:11 <ApBBB> Jaymzz: ok. we can move on
09:55:37 <Jaymzz> #topic general discussion (15 min)
09:56:19 <leszek> as general discussion anyone noticed that XA2 drains battery like crazy?
09:56:55 <Piggz> ok, i have a Q/request ... can the new app switching functions  in 3 (available under a setting atm) be invokable via dbus...would be nice for my appswitching app
09:57:03 <mal> leszek: yes, battery life is not good on that yet
09:57:06 <ApBBB> One thing that i noticed with light ambiances is that the app icons don't look that good on a white background
09:57:06 <PAMPKIN> Yes i do. XA2 drains battery in 1 day
09:57:13 <Nrde> In my case it's always related to ofonod
09:57:16 <ApBBB> i like the light theme though
09:57:45 <leszek> mal: PAMPKIN ah ok. So its not me alone and I don't have a faulty device
09:57:46 <jol> @leszek: on Android I lost about 5% battery over night, on SF 3 it's around 20% on XA2+
09:58:08 <ApBBB> Jaymzz: there were some xz2 compact related stuff in the 3 changelog. are you testing it?
09:58:10 <leszek> jol: wow thats much. I guess on screen off it does not go into sleep mode
09:58:22 <Nrde> xperia x. If the bug is not triggered I get 48 quite easily. If not it takes 2 hours.
09:58:34 <Nrde> not/is
09:58:49 <Jaymzz> ApBBB: Not the XZ2 compact, not at the moment at least.
09:59:02 <PAMPKIN> leszesk In my case it's similar or little worst
09:59:26 <ApBBB> Jaymzz: i just hope my j1 doesn't fail untill you release something that will fit my hand
09:59:29 <ApBBB> and pockets
09:59:33 <jol> leszek: well, haven't observed it precisely, just a guest, could also be 10 or 15%
09:59:47 <Mister_Magister> light ambiances are like inverted colors on all os
09:59:56 <leszek> yeah hopefully a fix is found before the battery suffers from it
10:00:00 <Jaymzz> ApBBB: any particular issues with your J1 so far? like screen etc?
10:00:23 <Jaymzz> Mister_Magister: it's MUCH more than that though...
10:01:27 <ApBBB> Jaymzz: after 4 years the battery doesn't last as much as it used to. and the vibration works sometimes only.
10:01:58 <Piggz> jaymzz^^
10:02:07 <ApBBB> Jaymzz: it loses network some times -needs restart- but i believe that is a SFOS bug and not the device
10:02:09 <M4rtinK> are we sure the Hunger Meter data can be trusted on X/XA2 ?
10:02:35 <Jaymzz> ApBBB: Understood. Make sure to send me a PM after the meeting.
10:02:47 <M4rtinK> during short testing on my Xperie X the data seemed weird/too high to me
10:04:08 <Jaymzz> 5 min left on this
10:04:20 <tortoisedoc> leszek : as a general discussion, how do you see integrating servo?
10:04:35 <tortoisedoc> servo "should" be better candidate thank firfefox no?
10:04:44 <ApBBB> servo = newer fiorefox
10:04:57 <DylanVanAssche> ApBBB: indeed
10:04:58 <r0kk3rz> just build ff
10:05:07 <tortoisedoc> r0kk3rz : on gcc6?
10:05:10 <tortoisedoc> or on gcc4?
10:05:20 <leszek> tortoisedoc: harder to maintain than QtWebEngine / Blink
10:05:37 <r0kk3rz> probably gcc6, might have to build gcc8
10:05:39 <tortoisedoc> leszek : due to rolling release?
10:05:53 <tortoisedoc> gcc8 :O
10:06:00 <leszek> yeah that aswell
10:06:01 <M4rtinK> also, what about using Flatpak for native app distribution ? it looks like it could solve most of the problems native apps have at the moment
10:06:27 <leszek> M4rtinK: its the technology of the future. So nothing for now
10:06:46 <r0kk3rz> M4rtinK: Hi, can i have a moment of you time to talk about our lord and saviour FlatPak
10:06:49 <leszek> xdg-portals is still not ready for smartphone usage
10:06:59 * M4rtinK recently started playing with it on desktop and was impressed how well it works these days
10:07:14 <leszek> M4rtinK: mostly because sandbox isn't really used
10:07:21 <tortoisedoc> hmm a browser in flatpac - browser inception?
10:07:30 <Jaymzz> 3 min left
10:07:37 <M4rtinK> r0kk3rz: sure, let's share the *true* work wide and high!
10:07:57 <M4rtinK> leszek, r0kk3rz: I know about that
10:08:15 <M4rtinK> I see it mostly as a way to fix the API mess for the time being
10:08:27 <r0kk3rz> flatpak or no, the thing still needs to be built and working
10:08:32 <akaWolf> does someone have a problems with mobile internet at X? sometimes I need to reenable «cellular data»... without it it just doesnt working
10:08:33 <tortoisedoc> it seems chromium-based solution might be better choice then for a browser
10:08:35 <ApBBB> people i trust told me that flatpacks make app size unnessesary big. and this sounds problematic on mobile
10:08:37 <M4rtinK> the native apps have zero sandboxing anyway at the moment
10:08:51 <tortoisedoc> or at least easier to mantain?
10:09:20 <jkonecny> ApBBB, FlatPaks apps use ostree which is something like hardlink farm to deduplicate things
10:09:22 <tortoisedoc> M4rtinK: yea sandboxing is AWOL on sfos anyways
10:09:24 <M4rtinK> ApBBB: there should be pretty good deduplication for all installed apps
10:09:34 <Jaymzz> wrap it up guys, 1 min left and I'm moving on after that. Need to get to other tasks :)
10:09:35 <DylanVanAssche> QtWebengine doesn't need separately maintaining, it's maintained by Qt
10:09:44 <jkonecny> ApBBB, so it is not that easy to tell what the space consumption will be
10:09:45 <Piggz> taskswitching - dbus, any takers?
10:10:15 <M4rtinK> but unless you want to keep apps and system in lockstep API wise (has not worked very well so far with SFOS & apps are submitted in binary form in store)
10:10:26 <leszek> DylanVanAssche: if qt maintains it just as good as qtwebkit it needs a maintainer from jolla
10:10:38 <jkonecny> ApBBB, for extensive usage you can have even better results than with normal applications (not tested thought)
10:10:40 <M4rtinK> so you will get some sort of duplication if you want to decouple the system/app API
10:10:47 <DylanVanAssche> leszek: qtwebkit isn't maintained anymore by Qt?
10:11:01 <leszek> DylanVanAssche: on paper yes
10:11:24 <Jaymzz> Alright, guys, I need to move on from general discussion now. I have a strict timebox here and got to get to other stuff.
10:11:30 <Jaymzz> #topic next meeting time and date
10:11:34 <Jaymzz> #topic next meeting time and date
10:11:42 <Jaymzz> #info Next meeting will be held on November 29th at 09:00 UTC
10:12:43 <Jaymzz> Thanks everyone for your contribution today. DylanVanAssche, keep it up, it's a good start! ;)
10:13:22 <Jaymzz> I talk to you all in 2 weeks. Keep up the great discussions and topics!
10:13:28 <ljo> thanks, bye
10:13:29 <Jaymzz> #endmeeting