09:00:19 <Jaymzz> #startmeeting Sailfish OS, open source, collaboration – 29th November 2018
09:00:19 <merbot> Meeting started Thu Nov 29 09:00:19 2018 UTC.  The chair is Jaymzz. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:00:19 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:00:29 <Jaymzz> #info Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2018-November/008502.html
09:00:37 <Jaymzz> I am the meeting’s chairperson today, and will be doing my best to keep time and order. Please behave, respect the timings and be gentle.
09:00:47 <Jaymzz> #topic Brief introduction (5 min). Please prefix your name/handle with # info
09:00:57 <Jaymzz> #info James Noori - sailor @ Jolla
09:01:17 <Mister_Magister> #info Mister_Magister - sailor @ VerdandiTeam
09:01:27 <nekron_remote> #info Nekron, SailfishOS fanboy
09:01:42 <martonmiklos> #info martonmiklos community member
09:01:46 <DylanVanAssche> #info DylanVanAssche - Community & developer
09:02:33 <kimmoli> #info Kimmo Lindholm - whatnot
09:03:34 <sledges> #info Simonas Leleiva @ Jolla
09:03:45 <flypig> #info David Llewellyn-Jones - sailor @ jolla
09:03:49 <mattaustin> #info Matt Austin, Community & developer
09:04:27 <schmittlauch[m]> #info schmittlauch, Community (cycling right now)
09:04:54 <lbt> #info David Greaves, Mer guy and sailor
09:07:09 <flypig> I think we lost Jaymzz :(
09:07:25 <Jaymzz1> sorry guys I have connection issues today. Do you see this message?
09:07:30 <sledges> yes
09:07:32 <martonmiklos> yes
09:07:32 <flypig> Yes
09:07:41 <nekron_remote> yep
09:07:42 <Jaymzz1> Ok thanks! let's continue.
09:07:57 <Jaymzz1> #topic Harbour and it's place in the strategy of jolla (w/r to individual markets) (20 min – asked by tortiosedoc )
09:08:09 <Jaymzz1> oh damn merbot doesn't listen to Jaymzz1 :(
09:08:36 <Jaymzz1> I guess it gets registered anyway? or am I mistaken?
09:08:53 <kimmoli> change your nick?
09:09:28 <Jaymzz1> kimmoli: it doesn't let me... I'm using my hotspot as my home internet is gone for some reason, maybe that's the reason?
09:10:03 <urjaman> identify and then change your nick :P (or maybe you tried before the timeout? the old one is gone now...)
09:10:04 <kimmoli> talk to nickserv, regain
09:10:16 <Jaymzz1> ok one second
09:12:09 <abranson> I'd heard such great things about swedish internet :P
09:12:20 <nekron_remote> :)
09:12:24 <Anidel> :)
09:12:57 <Jaymzz> This should work now
09:13:15 <Jaymzz> #topic Harbour and it's place in the strategy of jolla (w/r to individual markets) (20 min – asked by tortiosedoc )
09:13:19 <Jaymzz> YES! :D
09:13:24 <martonmiklos> cool
09:13:35 <Jaymzz> but
09:13:39 <Jaymzz> #info Unfortunately this topic needs to be postponed due to lack of available time to answer or discuss it this week. It is a very interesting topic and we would like to have proper answers for it before beforehand. Sorry for this caused any inconvenience.
09:13:51 <Jaymzz> #action Jaymzz to keep this topic on the topics page for the next meeting.
09:14:08 <Anidel> Ok
09:14:34 <Jaymzz> Seems like tortiosedoc isn't here either, but hopefully by next time he will be, and we will have answers for him :)
09:14:38 <Jaymzz> moving on...
09:14:42 <kimmoli> tortiosedoc tortoisedoc
09:15:07 <Jaymzz> #topic Transfer engine plugin translations not loaded correctly (25 min – asked by martonmiklos )
09:15:18 <martonmiklos> 'kay
09:15:22 <Jaymzz> #info The transfer engine plugins translations not loading correctly. Since there are quite a few plugins out there (SMS, QR, Android share, etc.) it would be great if this issue would be fixed. It is not clear for me that which component loads the translations wrong. It looks like that the problematic component is closed source (at least translation loading is not present in the open source mer transfer-engine). If this is correct
09:15:22 <Jaymzz> could it be problematic component open sourced to give ability to the community (ie. me) to fix this bug?
09:15:44 <martonmiklos> so I have developed a sharing plugin for sharing contacts via SMS
09:15:52 <martonmiklos> and ran to trouble with the localisation
09:16:01 <pvuorela> i think in this case the problematic components are already open-sourced :)
09:16:11 <pvuorela> i.e. the plugin themselves.
09:16:36 <martonmiklos> could you please point to this component which loads the translation for the plugin?
09:16:58 <martonmiklos> I have checked transfer engine in mer core
09:17:00 <pvuorela> qml modules should commonly load translations themselves.
09:17:11 <martonmiklos> hmm
09:17:16 <martonmiklos> https://together.jolla.com/question/193895/transfer-engine-localisation-problem/
09:17:24 <martonmiklos> if you check that strace output
09:17:34 <Jaymzz> #link https://together.jolla.com/question/193895/transfer-engine-localisation-problem/
09:17:42 <martonmiklos> all the *.qm files got loaded
09:17:55 <martonmiklos> from the translation folder
09:18:07 <martonmiklos> and the last one got used
09:18:38 <dcaliste> #info Damien Caliste, community
09:19:07 <martonmiklos> pvuorela: so you are saying that this behaviour caused by the Qt itself?
09:19:23 <pvuorela> martonmiklos: i'll need to check the sources too.
09:19:38 <martonmiklos> if this is the case I am under an impression that the plugin does not know it's locale correctly
09:20:11 <martonmiklos> pvuorela: thanks in advance
09:20:34 <martonmiklos> if you can confirm that no other closed source components involved in the transferengine plugin loading
09:20:38 <martonmiklos> that would be great
09:20:52 <pvuorela> martonmiklos: don't think there should be.
09:20:58 <Jaymzz> #info pvuorela: the problematic components are open-sourced
09:20:58 <martonmiklos> ok thanks
09:21:18 <Jaymzz> #action pvuorela to check the sources and get back to martonmiklos
09:21:54 <Jaymzz> martonmiklos: anything else? :)
09:22:21 <martonmiklos> if no obvious problem found
09:22:55 <martonmiklos> I will try to determine what locale passed to the plugin
09:23:17 <martonmiklos> Jaymzz: that's all from my side
09:23:24 <Jaymzz> #action martonmiklos to try and determine what locale passed to the plugin
09:23:36 <martonmiklos> pvuorela: thank you for the help in advance
09:24:03 <Jaymzz> martonmiklos: so I assume you'll come back with the topic at a later IRC meeting?
09:24:26 <martonmiklos> yes I will contact with Pekka about my findigns
09:24:57 <Jaymzz> okay, moving on then :)
09:25:12 <martonmiklos> I need to leave now
09:25:17 <Jaymzz> #topic general discussion (30 min)
09:25:18 <martonmiklos> thank you for your time and help
09:25:20 <martonmiklos> \o
09:25:28 <Jaymzz> martonmiklos: thanks :) cheers!
09:25:41 <tortoisedoc> hellO!
09:25:42 <DylanVanAssche> Any news about SFOS on FOSDEM 2019?
09:25:43 <tortoisedoc> sorry im late
09:25:44 <tortoisedoc> :)
09:25:55 <DylanVanAssche> tortoisedoc: hi
09:25:56 <tortoisedoc> I guess my topic was skipped
09:26:00 <Jaymzz> #changed the length for general discussion to 30 min instead since the 1t topic was cancelled and second one was cut short
09:26:21 <Jaymzz> tortoisedoc: this is what we said: Unfortunately this topic needs to be postponed due to lack of available time to answer or discuss it this week. It is a very interesting topic and we would like to have proper answers for it before beforehand. Sorry for this caused any inconvenience.
09:26:51 <tortoisedoc> Jaymzz : okay great, is the next meeting a good time?
09:27:13 <Mister_Magister> whats up Jaymzz? getting ready for 2.0.1?
09:27:30 <Jaymzz> tortoisedoc: absolutely
09:27:44 <Jaymzz> Mister_Magister: Are we downgrading now? ;)
09:27:56 <Mister_Magister> Jaymzz: 3.0.1
09:27:59 <Mister_Magister> boi im so old xD
09:28:04 <tortoisedoc> Jaymzz : I might not be able to attend to it, but im fine with you guys to write down the answers
09:28:11 <tortoisedoc> and then get them from the log
09:28:14 <Jaymzz> Yeah we are getting ready for that!
09:28:27 <Mister_Magister> Jaymzz: any leak on what features will it have?
09:28:31 <schmittlauch[m]> Jaymzz: can you give me the public IRC nick of jlaakkonen? I sadly forgot that one, but you have access to jollamobile wiki
09:28:46 <Mister_Magister> probably not window switching gesture cause its unstable in 3.0.0
09:29:17 <Jaymzz> tortoisedoc: In case you wanna be involved too, let me know and I'll arrange for the topic to be mentioned whenever you are available. If you're fine like this, then we just go with the next meeting
09:29:27 <Jaymzz> Mister_Magister: No leaks! ;)
09:29:44 <Mister_Magister> Jaymzz: GIB VOLTE SAR PLZ
09:29:46 <Jaymzz> schmittlauch[m]: I need to take a look, will get back to you
09:29:58 <schmittlauch[m]> the windoe changer issues are quite funny, I don't remember the first protype to have issues with browser, so these were introduced at a later point
09:30:20 <Mister_Magister> wew
09:30:31 <jlaakkonen> schmittlauch[m]: I'm here. I know what you are after for. I forgot the whole thing, sorry. I'll try to clean the document before 6.12 and send it to you.
09:30:42 <schmittlauch[m]> Jaymzz: sure
09:30:59 <Mister_Magister> schmittlauch[m]: you pinged wrong person
09:31:08 <jlaakkonen> schmittlauch[m]: -ETOOMUCHTODO
09:31:50 <Mister_Magister> Jaymzz: how is winter in finland
09:32:04 <schmittlauch[m]> jlaakkonen: It's not that important (that's why I also didn't care), I'd rather have a nice direct-message chat  abot $things (:
09:32:17 <Jaymzz> Mister_Magister: I live in Sweden, but it's snowing here as we speak
09:32:28 <nekron_remote> Regarding XA2 ODM services I am wondering what Sony is doing with "/odm/bin/tftpd_server" running on the phone? It's not listening to any ports right now, but why it is needed? Who has more infos about this?
09:32:33 <Mister_Magister> Jaymzz: my city temp reached -7*C
09:32:35 <mal> Mister_Magister: not enough snow
09:32:40 <Mister_Magister> mal: i feel same
09:32:53 <Mister_Magister> there was some but not enough
09:32:53 <nekron_remote> TFTPD = unauthenticated FTP services...
09:33:02 <Mister_Magister> mal: whats temp at your place?
09:33:40 <Jaymzz> it was -11 here last night :)
09:33:42 <nekron_remote> back in the days of old M$ IIS there was a bug using TFTP to transfer trojans to your sever running IIS 5.x
09:33:43 <sledges> nekron_remote: you can try https://talk.sonymobile.com/t5/Open-Devices/ct-p/OpenDevices
09:33:50 <Mister_Magister> btw mal debugging got hard since network sharing over usb doesnt work in 3.0 ootb
09:34:01 <Mister_Magister> Jaymzz: whew
09:34:08 <abranson> nekron_remote: i remember that one. that was prime windows worm time!
09:34:15 <schmittlauch[m]> regarding "leaks": I heard there shall be a roadmap again. I guss you notify us when it's published at $some_point?
09:34:45 <jlaakkonen> schmittlauch[m]: ah ok, sure :) Maybe after this week I have some time.
09:34:47 <Mister_Magister> jolla kindof fullfilled their last roadmap… kindof
09:34:55 <Jaymzz> schmittlauch[m]: That is being worked on actually. There will be a roadmap pretty soon on the blog
09:35:31 <Mister_Magister> Jaymzz: verdanditeam stopped carrying about ports xd
09:35:43 * Mister_Magister should be working
09:36:09 <schmittlauch[m]> Also, I hereby want to state an interest in anything related to further open-sourcing or updates on GPLv3 usage. I remember there were some developments at the beginning of this year.
09:37:12 <schmittlauch[m]> Mister_Magister: What even is Verdandi Team?
09:37:19 <Mister_Magister> nothing
09:37:23 <Jaymzz> Mister_Magister: so I've heard :) good that you still are porting though. Even if it's not the team anymore
09:37:32 * schmittlauch[m] is apparently uninformed
09:37:46 <Jaymzz> schmittlauch[m]: Noted. We'll get back to you on that one too :)
09:37:53 <schmittlauch[m]> \0/
09:37:53 <Mister_Magister> Jaymzz: yeee but i won't care this much xd
09:37:55 <Jaymzz> ...when we have more news
09:38:23 <Jaymzz> Mister_Magister: That's understood.
09:38:49 <Coolgeek> I have some trouble with MTP, like not being able to transfert some huge file (17G for the one I tested) on a SDCARD with ext4 filesystems
09:38:57 <Coolgeek> is there some known issue ?
09:39:05 <schmittlauch[m]> Coolgeek: which OS?
09:39:13 <Coolgeek> was fine through scp with developer mode
09:39:19 <Coolgeek> xperia x
09:39:21 <Coolgeek> last version
09:40:03 <spiiroin> Coolgeek: buteo-mtp does not support >= 4GB transfers (or was it 2GB)
09:40:24 <Coolgeek> too bad :(
09:40:28 <schmittlauch[m]> well, that's interesting
09:40:48 <Mister_Magister> Jaymzz: can't wait untill i do notchfish
09:41:29 <Jaymzz> Mister_Magister: I'm not the biggest notch fan, but it'd be cool at some point to have it done :)
09:41:31 <Coolgeek> I assume that buteo-mtp is the part on sfos handling mtp ?
09:42:02 <Mister_Magister> Jaymzz: im not either but im fan of sfos on snapdragon 845 with 6GB ram
09:42:18 <Mister_Magister> and 18.9:9 pixel ratio
09:42:31 <Jaymzz> that'd be cool!
09:43:10 <Mister_Magister> (and fingerprint only if fingerprint support in sfos was opensource)
09:43:43 <spiiroin> Coolgeek: yes, and the limitation comes from ptp frame size - which is 32 bit value; there is documented way to exceed that but that is not implemented in buteo-mtp
09:44:34 <Coolgeek> hmm OK, will keep that in mind
09:44:53 <Coolgeek> is there any plan to update that part ?
09:45:02 <schmittlauch[m]> quick survey: Am I the only one around who still cares about XMPP and telepathy?
09:45:15 <schmittlauch[m]> And is Kaffeine still working for OMP?
09:45:33 <nekron_remote_> schmittlauch[m]: Nope! I use XMPP daily...
09:46:02 <Jaymzz> schmittlauch[m]: There are more people than you of course :) but it isn't as popular as - say - when N900 was out anymore.
09:46:16 <Coolgeek> I use a bit XMPP for hangout via the SMS app
09:46:45 <schmittlauch[m]> Because there are 2 things that might make me switch to the OS I won't mention the name of: The ancient browser and the horrible state of XMPP integration
09:46:50 <nekron_remote_> Adding of contacts via GUI would help a lot
09:47:18 <schmittlauch[m]> nekron_remote_: that was the first issue I opened on TJC back in 2013
09:47:45 <nekron_remote_> As of today you habve to use two different XMPP clients... one for adding contacts, one for chatting (the SFOS native)
09:48:17 <schmittlauch[m]> we just need an opening up of the messages app. It's worth nothing that the middleware/ backend is open, if we can't anitegrate any of the features into the frontend
09:49:13 <spiiroin> Coolgeek: there is task about it, but it is not exactly something considered a priority item.  ref: https://together.jolla.com/question/189851/very-large-files-fails-to-write-over-mtp/
09:49:25 <Jaymzz> 5 minutes left guys :)
09:49:32 <schmittlauch[m]> One further thing: Last year I once asked about QML-testing, but I guess chriadam hasn't found time to look into that since. (I haven't either)
09:49:33 <abranson> schmittlauch[m]: i don't think that's true. if everything's implemented in the middle/backend, then making another OSS frontend isn't too much work
09:49:41 <Mister_Magister> Jaymzz: shhhh let them be
09:49:43 <abranson> see the camera app that piggz did recently
09:50:06 <schmittlauch[m]> abranson: ok, I change the "nothing" to "not that much"
09:50:56 <dcaliste> schmittlauch[m]: remind me what you wanted to know about qml testing?
09:51:02 <schmittlauch[m]> abranson: but you see that if people can't get into the combined default messaging app, they stop caring alltogether and just make an app for their new messaging backend only
09:51:11 <abranson> that frontend has already led to new stuff being added in the middleware, with the intent that the foss app can use it immediately, while the jolla app will hopefully catch up later
09:51:22 <Coolgeek> thx spiiroin :)
09:51:24 <Mister_Magister> schmittlauch[m]: sfos has their own unique features that you can't use paradoxically
09:52:12 <schmittlauch[m]> dcaliste: I strrugled with writing unit tests for QML-only apps and wondered whether to use qmltestrunner or the C++ harnish, how to best supply test data (db) and how to do subpackaging
09:52:28 <abranson> schmittlauch[m]: people can do that anyway. there's not a lot of contribution to the browser.
09:52:41 <schmittlauch[m]> but that reminds me that I still have a sample directory layout laying around
09:53:41 <schmittlauch[m]> abranson: I don't want to blame anyone – browser is indeed quite hard. But on the user-side it's also just the way it is.
09:53:53 <dcaliste> schmittlauch[m]: I've done some work adding qml testing via qmltestrunner for the sailfish-office app, but I didn't need test data.
09:54:11 <schmittlauch[m]> dcaliste: https://gist.github.com/schmittlauch/172c39a9e669ece1e5a080a0869e7a87
09:54:19 <abranson> schmittlauch[m]: just trying to think of ways to advance the situation.
09:54:31 <Mr_Doge> when we can expect VoLTE ? many user are pinging me on XDA
09:54:44 <sledges> abranson: so community's opensource [sailfish-messages] app would support xmpp, then it will be easy for jolla-messages to cherry pick the GUI enablers (minimal work)?
09:54:44 <Mister_Magister> gib volte sar plz
09:54:57 <Mr_Doge> Mister_Magister, exactly
09:55:56 <schmittlauch[m]> dcaliste: I think the wiki could use some documentation on handling unit tests from someone experienced. The instructions I found were unclear and contradictory
09:56:29 <dcaliste> schnittlauch[m]: thanks for the page, I'll give a better look next days and comment there.
09:56:32 <abranson> sledges: yeah. i think there's also mileage in the ability of apps to use the same message store as the jolla apps. you can do your own view ofnthe same messages.
09:56:53 <Jaymzz> I'm giving this a few more minutes
09:57:20 <sledges> abranson: that's a really nice approach, i think community should give this more attention (piggz OSS camera app already has taken first steps!)
09:58:07 <schmittlauch[m]> abranson, sledges : although as long as we have no permission management system, giving 3rd party apps acess to the message store also is a tough decision
09:58:17 <dcaliste> schmittlauch[m]: about packaging, currently in Mer, most repos are creating separated RPM for test with data and so on.
09:58:38 <abranson> schmittlauch[m]: one problem at a time :)
09:58:42 <sledges> schmittlauch[m]: don't do a full-blown sms/messages app, just an xmpp chat client, but with all main implementation being in mw
09:59:08 <schmittlauch[m]> dcaliste: some points I raised were also about app-SDK integration
09:59:10 <sledges> people will use two apps, this gives incentive for jolla-messages to catch up
09:59:29 <Mister_Magister> sledges: i have created one xmpp client xd
09:59:35 <schmittlauch[m]> abranson: luckily I know there's work being done on the latter \0/
09:59:59 <nekron_remote_> schmittlauch[m]: +1
10:01:08 <sledges> Mister_Magister: i think community had something more direct in mind than telepathy/libpurple
10:01:11 <schmittlauch[m]> regarding middleware: sadly telepathy is also a struggling framework
10:01:19 <Mister_Magister> sledges: meh :P
10:01:38 <schmittlauch[m]> for the love of god, please no libpurple!
10:01:45 <Mister_Magister> schmittlauch[m]: y not
10:02:14 <Mister_Magister> Jaymzz: i think you could end meeting and people would still talk :P
10:02:47 <Jaymzz> no. giving 5 more mins
10:02:52 <schmittlauch[m]> Mister_Magister: many people claim libpurple is just a framework for remote-code execution, which accidentally also does IM
10:02:58 <schmittlauch[m]> Jaymzz: 1 last thing
10:03:05 <abranson> haha
10:03:12 <Jaymzz> go for it
10:03:12 <Mister_Magister> schmittlauch[m]: well their code is also terrible
10:03:21 <Mister_Magister> over 10k lines in one file
10:03:50 <abranson> IM has really been taken over by the cloud service though, and they largely refuse to participate in multiprotocol clients
10:04:02 <schmittlauch[m]> I don't know how Jolla's funding looks, but it might be worth to take a look whether someone can be payd to rework the whole telepathy API (telepathy-next branch on github)
10:04:29 <schmittlauch[m]> that might give it some traction again, after collabora went out of the project
10:04:32 <schmittlauch[m]> that's it from me
10:05:10 * schmittlauch[m] participates using matrix.org right now
10:05:23 <Mister_Magister> schmittlauch[m]: we know
10:06:20 <Jaymzz> schmittlauch[m]: alrighty
10:06:41 <Jaymzz> #topic next meeting time and date
10:07:02 <Jaymzz> December 13 2018 at 09:00 UTC :)
10:07:48 <Jaymzz> #One thing to everyone, I'll mention this on my emails as well: Let's have our topics read at least 3 days before the meeting so that we can have enough time to answer them beforehand
10:07:53 <Jaymzz> oops
10:08:00 <Jaymzz> #info One thing to everyone, I'll mention this on my emails as well: Let's have our topics read at least 3 days before the meeting so that we can have enough time to answer them beforehand
10:08:07 <sledges> *ready
10:08:32 <Jaymzz> XD yes. (was on the phone for a sec, sorry)
10:08:33 <r0kk3rz> idk, we have several IM apps for different services, which is the norm elsewhere these days
10:09:17 <Jaymzz> #info next meeting will be held on Thursday, December 13th 2018 at 09:00 UTC
10:09:31 <Jaymzz> Thanks all for participating this time, see you in 2 weeks!
10:09:35 <Jaymzz> #endmeeting