#mer-meeting: Sailfish OS, open source, collaboration – 16th May 2019

Meeting started by Jaymzz at 08:00:18 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2019-May/008601.html (Jaymzz, 08:00:28)

  1. Brief introduction (5 min). Please prefix your name/handle with # info (Jaymzz, 08:00:45)
    1. James Noori - sailor @ Jolla (Jaymzz, 08:00:53)
    2. David Llewellyn-Jones - also Sailing @ Jolla (flypig, 08:01:44)
    3. Ville Nummela - sailor @ Jolla (ViGe, 08:01:47)
    4. David Greaves - Mer guy and sailor (lbt, 08:01:57)
    5. Simonas Leleiva - privateer 4 Jolla (sledges, 08:02:04)
    6. Walter Justen, community member (runvgn, 08:02:18)
    7. Cedric Heintz, community member (ced117, 08:02:27)
    8. Simon Brown, community (zotan, 08:02:41)
    9. Martin Kolman, modRana developer & community member (M4rtinK, 08:02:49)

  2. Do you plan to migrate projects from github/sailfishos to git.sailfishos.org ? (20 min - Asked by dcaliste) (Jaymzz, 08:06:32)
    1. dcaliste had to leave and can’t attend the meeting with us today, but we will anyway answer the topic so he can read the logs later. (Jaymzz, 08:06:43)
    2. As for github/nemomobile which was migrated to git.merproject.org when the latter was setup, do you plan to migrate github/sailfishos to the new git.sailfishos.org ? As Mer was only for middleware and lower levels, this will bring higher level stack (like sailfish secrets) and even applications (like office viewer or browser) into the sailfishos open source repositories. Will they land into mer-core there ? Or to a new group ? (Jaymzz, 08:06:53)
    3. The nemomobile migration was also about a consolidation into a single mer-core - there isn't really a similar architectural drive here. Nor are there issues with the service (lbt, 08:08:27)
    4. Overall I think this specific move is not a high priority right now (lbt, 08:08:44)

  3. : Fragmentation between open repos and the Jolla store and effort to bring more apps in the store. (20 min – asked by ApB) (Jaymzz, 08:15:48)
    1. Lets face it the store isn't in a great state shape when it comes to apps while openrepos seems to have much better days and some extremely useful and well made apps (hint mapping). Its been discussed in the past that some steps need to be taken to get more of them in the store -lifting limitations etc-. So. What is the status of it, what needs to be done and who at jolla can help solve this and not continue to have two "app s (Jaymzz, 08:15:59)
    2. So far the allowed API list has been limited those APIs which are considered stable. That means that we have enough faith that we will not break the APIs in future versions, i.e. apps built for APIs which are approved today will keep on working in the future Sailfish OS versions. We have always had the plan of allowing more APIs, but the progress has been slow. As we move forward, we have basically two options: either stabiliz (Jaymzz, 08:16:46)
    3. Anyway, main unstable api usage pain points: - OBS targets are published late (after stable release), nobway to publish two versions, one for older SFOS (due to port not yet updated to latest). (M4rtinK, 08:29:19)
    4. ACTION: 1) evaluate possibility to mark apps as experimental 2) evaluate possibility to allow systemd socket activation. (Jaymzz, 08:48:27)

  4. general discussion (15 min) (Jaymzz, 08:50:17)
  5. next meeting time and date (Jaymzz, 09:03:59)
    1. Next meeting will be held on May 30th 2019 at 08:00 UTC (Jaymzz, 09:04:29)


Meeting ended at 09:06:14 UTC (full logs).

Action items

  1. 1) evaluate possibility to mark apps as experimental 2) evaluate possibility to allow systemd socket activation.


People present (lines said)

  1. M4rtinK (41)
  2. lbt (40)
  3. Jaymzz (40)
  4. ApBBB (32)
  5. flypig (24)
  6. ViGe (7)
  7. pvuorela (5)
  8. abranson (5)
  9. merbot (3)
  10. runvgn (1)
  11. ced117 (1)
  12. sledges (1)
  13. zotan (1)


Generated by MeetBot 0.1.4.