#sailfishos-meeting: Sailfish OS, open source, collaboration – August 21st 2020

Meeting started by Jaymzz at 10:00:20 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: https://forum.sailfishos.org/t/community-meeting-on-irc-21st-aug-2020/1596 (Jaymzz, 10:00:30)

  1. Brief introduction (5 min). Please prefix your name/handle with # info (Jaymzz, 10:01:03)
    1. James Noori - Community (Jaymzz, 10:01:20)
    2. Andrew Branson - sailor @ Jolla (abranson, 10:01:33)
    3. Sefriol - Community (Sefriol, 10:01:41)
    4. Leszek Lesner - Community + Dev (leszek3, 10:02:01)
    5. fridlmue - Community (fridlmue, 10:02:06)
    6. Jussi Maaniitty - sailor @ Jolla (maajussi, 10:02:23)
    7. Karry - Community, developer (karry, 10:02:36)
    8. David Llewellyn-Jones - sailor @ Jolla (flypig, 10:02:48)
    9. nekron - DevOp (nekron_home, 10:03:01)
    10. Pami Ketolainen - sailor @ Jolla (pketo, 10:03:17)
    11. Björn Bidar - sailor @ Jolla (Thaodan, 10:03:23)
    12. Santhosh - Community (Santhosh, 10:03:40)

  2. AOSP10 based ports (20 min by rinigus) (Jaymzz, 10:05:48)
    1. From looking at https://github.com/libhybris/libhybris 4 and Android Q PR specifically, it seems that there is not much activity on development of Android 10 support. I wonder what is the current status of AOSP10 support (in case if it is not all published). If work has not started on it by Jolla developers, whether it is planned and, if it is, when do you plan to work on it. (Jaymzz, 10:05:59)
    2. https://github.com/libhybris/libhybris (Jaymzz, 10:06:04)
    3. Leif-Jöran Olsson, community member (ljo_, 10:06:22)
    4. Android 10 support is on the roadmap, but there is no schedule available that we could commit to at this point. (Jaymzz, 10:07:32)

  3. E2E testing in Sailfish (by sefriol – 10 min) (Jaymzz, 10:21:15)
    1. E2E testing is one of the key aspects to make reliable and tested software, most popular (or atleast user friendly) webapp testers being Cypress.io 1. There seems to be little to no E2E testing capabilities provided as a base line or atleast the documentation is very limited. I stumbled upon https://www.researchgate.net/publication/320649391_Method_and_tools_for_automated_end-to-end_testing_of_applications_for_sailfish_ (Jaymzz, 10:27:17)
    2. https://www.researchgate.net/publication/320649391_Method_and_tools_for_automated_end-to-end_testing_of_applications_for_sailfish_OS (Jaymzz, 10:27:26)
    3. https://bitbucket.org/yarfruct/sailfish-os-qml-test-runner/src/default/ (Jaymzz, 10:27:34)
    4. We are using internally qmltestrunner for testing QML components. That tool is available for all (https://git.sailfishos.org/mer-core/qtdeclarative/tree/mer-5.6/tools/qmltestrunner and qt5-qtdeclarative-devel-tools package in our repositories) and community can use it for testing own applications. For HW testing we are using CSD tools and porters should use that for verifying functionality of different HW features. (Jaymzz, 10:27:52)
    5. https://git.sailfishos.org/mer-core/qtdeclarative/tree/mer-5.6/tools/qmltestrunner (Jaymzz, 10:27:59)
    6. https://bitbucket.org/yarfruct/sailfish-os-qml-test-runner is not public (birdzhang, 10:28:55)

  4. Native Banking Apps for SailfishOS (by sefriol – 10 min) (Jaymzz, 10:36:38)
    1. Currently, you are pretty much required to have a second device if your bank only allows SafetyNet passing devices to run as credential client. VTB24 seems to have an closed source banking app for AuroraOS 2. Any insight from Jolla’s side if there is any posssible progress in bringing native banking apps to Sailfish. https://together.jolla.com/question/11734/mobilebanking/ (Jaymzz, 10:36:46)
    2. https://together.jolla.com/question/11734/mobilebanking/ (Jaymzz, 10:36:55)
    3. It would be valuable to understand if there are particular enabling technologies that banks require and which should be provided at OS level - without which banking apps won't work. If the enablers (API) are public, the community could provide apps for individual banks/countries. (Jaymzz, 10:37:07)
    4. https://crosskey.io/stores/s-pankki/apis (Thaodan, 10:43:18)

  5. Separating QML components from closed source and publishing them to git (by sefriol – 5 min) (Jaymzz, 10:49:43)
    1. This has come up before. Currently, if community sees a bug or wants to propose a change in core app’s UI, the source is only available within the phone / emulator / SDK. Is there a problem with separating these components from the closed source repositories and publishing them in gitso that community could do pull requests on them? (Jaymzz, 10:49:51)
    2. This is something that could be made possible, by for example mirroring the QML code in git. We would need to alter the licence and hold the copyright for all contributions, but the possibility to do this exists. Action taken to study this further. (Jaymzz, 10:50:01)
    3. ACTION: maajussi is going to dig more on this topic and get back to the community (Jaymzz, 10:55:59)

  6. Multiple 2+ cameras support (by Mister_Magister – 15 min) (Jaymzz, 10:59:33)
    1. Lately i’ve successfully created initial support of multi-camera. On some devices auxiliary cameras are provided same way as other 2 but sfos is based around front and back camera while we need to support camera id 2 and higher. My initial changes are nowhere near merging, but it’s something jolla should start think about regarding jolla-camera ui. (Jaymzz, 10:59:43)
    2. It seems multiple cameras are in common place for the device category we have been supporting in co-operation with Sony Open Devices. It is likely that we will support this in future. (Jaymzz, 11:00:00)
    3. https://git.sailfishos.org/mer-core/qtmultimedia/merge_requests/34 (flypig, 11:10:06)
    4. https://github.com/sailfishos/gst-droid/pull/56 (flypig, 11:10:12)

  7. general discussion (15 min) (Jaymzz, 11:11:35)
  8. next meeting time and date (5 min) (Jaymzz, 11:32:46)
    1. Next meeting will be held on September 3rd 2020 at 08:00 UTC (Jaymzz, 11:33:19)


Meeting ended at 11:34:15 UTC (full logs).

Action items

  1. maajussi is going to dig more on this topic and get back to the community


Action items, by person

  1. maajussi
    1. maajussi is going to dig more on this topic and get back to the community


People present (lines said)

  1. Jaymzz (61)
  2. flypig (43)
  3. leszek3 (33)
  4. Mister_Magister (27)
  5. Sefriol (26)
  6. rinigus (19)
  7. Thaodan (17)
  8. ApBBB (16)
  9. maajussi (10)
  10. TheKit (7)
  11. Wunderfitz (6)
  12. mal (6)
  13. Kabouik_ (5)
  14. fridlmue (3)
  15. sailbot_ (2)
  16. abranson (2)
  17. PeperJohnny (2)
  18. karry (1)
  19. nekron_home (1)
  20. pketo (1)
  21. Santhosh (1)
  22. ljo_ (1)
  23. birdzhang (1)


Generated by MeetBot 0.1.4.