#sailfishos-meeting: Sailfish OS, open source, collaboration -- 29th October 2020

Meeting started by sledges at 08:00:01 UTC (full logs).

Meeting summary

    1. Meeting information and agenda can be found here: (sledges, 08:00:16)
    2. https://forum.sailfishos.org/t/community-meeting-on-irc-29th-oct-2020/2899 (sledges, 08:00:20)

  1. Brief introduction (5 min). Please prefix your name/handle with #info (sledges, 08:00:28)
    1. Simonas Leleiva - privateer for Jolla (sledges, 08:00:32)
    2. Chris Adams - privateer for Jolla (chriadam, 08:00:51)
    3. ggabriel - community (ggabriel, 08:01:06)
    4. Ville Nummela - sailor @ Jolla (ViGe, 08:01:08)
    5. Florian Leeber - member of BoD UBports Foundation (Ubuntu Touch) (Flohack, 08:01:15)
    6. gmc - community (gmc, 08:01:15)
    7. Björn Bidar - sailor @ Jolla (Thaodan, 08:01:26)
    8. David Llewellyn-Jones sailor @ Jolla (flypig, 08:01:31)
    9. Lukas Karas - developer, community member (karry_, 08:01:49)
    10. Leif-Jöran Olsson, community member (ljo_, 08:02:06)
    11. Thilo, community (thigg[m], 08:02:28)
    12. fridl, community (fridl, 08:02:49)
    13. Andrew Branson, sailing @ Jolla (abranson, 08:03:07)
    14. Chris, community (ahappyhuman, 08:03:51)

  2. That Qt update question again (5 min -- asked by rinigus) (sledges, 08:05:39)
    1. <rinigus> Any progress regarding Qt update? (sledges, 08:05:43)
    2. <rinigus> While it is old topic and nobody probably has high hopes regarding it, I would like to raise it to stimulate the internal discussion at Jolla. (sledges, 08:05:49)
    3. <rinigus> Ancient Qt does hinder SFOS progress and makes it impossible to collaborate with other mobile Linux platforms (Plasma Mobile in particular) on the development of applications. (sledges, 08:05:58)
    4. <Jolla> As stated also before, this is something we constantly evaluate. The current plan is still to proceed step by step, but we are not announcing any schedule for the update. (sledges, 08:06:18)

  3. strategy regarding the other linux phone OS’s (10 min -- thigg) (sledges, 08:14:03)
    1. <thigg> The other linux phone os’s which are gathering around the pinephone have some attention and see development (manjaro, postmarket, ubports). Is any kind of collaboration with these platforms planned? (sledges, 08:14:13)
    2. <thigg> Is jolla having plans to encourage app developers to create apps which run on sailfishos and these platforms? How is the strategy regarding the pinephone. Is supporting it officially a priority of jolla? (sledges, 08:14:28)
    3. <Jolla> There are lot of mutual interests with this group, therefore it is evident that we are open for collaboration for defined targets that benefit the parties involved - and of course also the users of the platforms. (sledges, 08:14:56)
    4. <Jolla> We do keep close contact with members of these groups in all levels of process, from SW development to business development. (sledges, 08:15:13)
    5. Chatting about what UBports is using, discussing frameworks' portability like Kirigami (read full logs) (sledges, 08:27:59)
    6. appportingguide across platforms would be nice, but while doc may take a while to write (and read), here's some platform.* dirs to look at (sledges, 08:32:02)
    7. https://github.com/rinigus/pure-maps/tree/master/qml (sledges, 08:32:05)
    8. and related issue: (sledges, 08:32:52)
    9. https://github.com/rinigus/pure-maps/issues/330 (sledges, 08:32:54)

  4. storing app credentials on sailfish os (10 min -- asked by gmc) (sledges, 08:33:18)
    1. <gmc> Apps may use credentials to log in to external services, and need to do so in a secure way - the sailfish-secrets library / daemon provides a solution, however it is not allowed to use it when publishing an app to the jolla store. (sledges, 08:33:25)
    2. <gmc> What is the recommended way for an app to securely store credentials and be publishable in the jolla store? Are there plans to allow the sailfishsecrets service to the list of allowed packages to depend on? Sailfishsecrets seems to be pretty stable (according to the commit history): (sledges, 08:33:45)
    3. https://github.com/sailfishos/sailfish-secrets/commits/master (sledges, 08:33:52)
    4. <Jolla> Even though it is an extensible framework in a source and binary compatible way, we may still alter other aspects, which might break stored data consistency. Hence why it's still not in the Harbour. (sledges, 08:34:29)
    5. ACTION: gmc to rally some crypto-nerds to do security audit on sailfish-secrets framework, if and when they have time (sledges, 08:54:30)

  5. General Discussion (30 min) (sledges, 08:54:46)
    1. https://forum.sailfishos.org/t/community-meeting-on-irc-29th-oct-2020/2899/7 (sledges, 08:55:10)
    2. forgotten bit from thigg's topic earlier: (sledges, 09:14:13)
    3. <thigg> Sidenote: the UBPorts forum is publishing the results of their Q&A streams to the blog, which looks quite good, because you get some biweekly information there. Maybe it would be a good idea to publich the minutes of the community meetings in a separate section in the blog? (sledges, 09:14:14)
    4. <Jolla> the current primary community communications platform is the forum, where these minutes can be found easily in the first (Announcements) section; more visibility would be to promote forum in general (sledges, 09:15:48)

  6. Next meeting time and date (5 min) (sledges, 09:29:05)
    1. Next meeting will be held on Thursday 12th November 2020 at 8:00am UTC: 2020-11-12T08Z (sledges, 09:31:00)


Meeting ended at 09:31:09 UTC (full logs).

Action items

  1. gmc to rally some crypto-nerds to do security audit on sailfish-secrets framework, if and when they have time


Action items, by person

  1. gmc
    1. gmc to rally some crypto-nerds to do security audit on sailfish-secrets framework, if and when they have time


People present (lines said)

  1. sledges (89)
  2. rinigus1 (32)
  3. gmc (31)
  4. chriadam (28)
  5. thigg[m] (24)
  6. Flohack (23)
  7. ApBBB (22)
  8. flypig (21)
  9. Thaodan (19)
  10. KeeperoftheKeys (19)
  11. ahappyhuman (11)
  12. ggabriel (8)
  13. dcaliste (5)
  14. fridl (4)
  15. Venemo (4)
  16. sailbot (3)
  17. ViGe (3)
  18. abranson (3)
  19. Nico[m] (2)
  20. karry_ (1)
  21. ljo_ (1)


Generated by MeetBot 0.1.4.